cde2c7ceef
update pkgconfig, udev, man-utf8->man-encoding, epson-expression800, docs-utf8 patches remove hal conditional
167 lines
6.4 KiB
Diff
167 lines
6.4 KiB
Diff
diff -up sane-backends-1.0.21/backend/Makefile.in.automake sane-backends-1.0.21/backend/Makefile.in
|
|
--- sane-backends-1.0.21/backend/Makefile.in.automake 2010-05-05 13:27:58.924821528 +0200
|
|
+++ sane-backends-1.0.21/backend/Makefile.in 2010-05-05 13:28:43.237080981 +0200
|
|
@@ -4720,7 +4720,8 @@ install-firmware-path:
|
|
done
|
|
|
|
install-lockpath:
|
|
- $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir)
|
|
+ $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir) || \
|
|
+ $(mkinstalldirs) -m 775 $(DESTDIR)$(locksanedir)
|
|
|
|
uninstall-hook:
|
|
rm -rf $(DESTDIR)$(libdir)/sane $(DESTDIR)$(configdir) $(DESTDIR)$(locksanedir)
|
|
diff -up sane-backends-1.0.21/tools/Makefile.in.automake sane-backends-1.0.21/tools/Makefile.in
|
|
--- sane-backends-1.0.21/tools/Makefile.in.automake 2010-05-05 13:28:20.439822508 +0200
|
|
+++ sane-backends-1.0.21/tools/Makefile.in 2010-05-05 13:28:43.886070205 +0200
|
|
@@ -16,6 +16,7 @@
|
|
@SET_MAKE@
|
|
|
|
|
|
+
|
|
VPATH = @srcdir@
|
|
pkgdatadir = $(datadir)/@PACKAGE@
|
|
pkgincludedir = $(includedir)/@PACKAGE@
|
|
@@ -50,7 +51,8 @@ mkinstalldirs = $(SHELL) $(top_srcdir)/m
|
|
CONFIG_HEADER = $(top_builddir)/include/sane/config.h
|
|
CONFIG_CLEAN_FILES = sane-config sane-backends.pc
|
|
CONFIG_CLEAN_VPATH_FILES =
|
|
-am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)"
|
|
+am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" \
|
|
+ "$(DESTDIR)$(pkgconfigdir)"
|
|
PROGRAMS = $(bin_PROGRAMS) $(noinst_PROGRAMS)
|
|
am_gamma4scanimage_OBJECTS = gamma4scanimage.$(OBJEXT)
|
|
gamma4scanimage_OBJECTS = $(am_gamma4scanimage_OBJECTS)
|
|
@@ -105,6 +107,7 @@ SOURCES = $(gamma4scanimage_SOURCES) $(s
|
|
$(sane_find_scanner_SOURCES) $(umax_pp_SOURCES)
|
|
DIST_SOURCES = $(gamma4scanimage_SOURCES) $(sane_desc_SOURCES) \
|
|
$(sane_find_scanner_SOURCES) $(umax_pp_SOURCES)
|
|
+DATA = $(pkgconfig_DATA)
|
|
ETAGS = etags
|
|
CTAGS = ctags
|
|
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
|
@@ -274,6 +277,8 @@ top_srcdir = @top_srcdir@
|
|
AM_CPPFLAGS = -I. -I$(srcdir) -I$(top_builddir)/include \
|
|
-I$(top_srcdir)/include
|
|
|
|
+SUFFIXES = .pc.in .pc
|
|
+pkgconfigdir = ${libdir}/pkgconfig
|
|
@CROSS_COMPILING_FALSE@HOTPLUG = hal/libsane.fdi hotplug/libsane.usermap hotplug-ng/libsane.db \
|
|
@CROSS_COMPILING_FALSE@ udev/libsane.rules
|
|
|
|
@@ -286,9 +291,10 @@ bin_SCRIPTS = sane-config
|
|
noinst_SCRIPTS = $(HOTPLUG)
|
|
BUILT_SOURCES = $(HOTPLUG_DIR)
|
|
CLEANFILES = $(bin_SCRIPTS) $(dist_noinst_SCRIPTS)
|
|
+pkgconfig_DATA = sane-backends.pc
|
|
EXTRA_DIST = check-po.awk libtool-get-dll-ext mustek600iin-off.c \
|
|
- RenSaneDlls.cmd README xerox hotplug/README \
|
|
- hotplug/libusbscanner hotplug-ng/README \
|
|
+ RenSaneDlls.cmd README xerox sane-backends.pc.in \
|
|
+ hotplug/README hotplug/libusbscanner hotplug-ng/README \
|
|
hotplug-ng/libsane.hotplug openbsd/attach openbsd/detach
|
|
sane_find_scanner_SOURCES = sane-find-scanner.c check-usb-chip.c \
|
|
../backend/sane_strstatus.c
|
|
@@ -307,7 +313,7 @@ all: $(BUILT_SOURCES)
|
|
$(MAKE) $(AM_MAKEFLAGS) all-am
|
|
|
|
.SUFFIXES:
|
|
-.SUFFIXES: .c .lo .o .obj
|
|
+.SUFFIXES: .pc.in .pc .c .lo .o .obj
|
|
$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__configure_deps)
|
|
@for dep in $?; do \
|
|
case '$(am__configure_deps)' in \
|
|
@@ -523,6 +529,26 @@ mostlyclean-libtool:
|
|
|
|
clean-libtool:
|
|
-rm -rf .libs _libs
|
|
+install-pkgconfigDATA: $(pkgconfig_DATA)
|
|
+ @$(NORMAL_INSTALL)
|
|
+ test -z "$(pkgconfigdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgconfigdir)"
|
|
+ @list='$(pkgconfig_DATA)'; test -n "$(pkgconfigdir)" || list=; \
|
|
+ for p in $$list; do \
|
|
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
+ echo "$$d$$p"; \
|
|
+ done | $(am__base_list) | \
|
|
+ while read files; do \
|
|
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgconfigdir)'"; \
|
|
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgconfigdir)" || exit $$?; \
|
|
+ done
|
|
+
|
|
+uninstall-pkgconfigDATA:
|
|
+ @$(NORMAL_UNINSTALL)
|
|
+ @list='$(pkgconfig_DATA)'; test -n "$(pkgconfigdir)" || list=; \
|
|
+ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
|
|
+ test -n "$$files" || exit 0; \
|
|
+ echo " ( cd '$(DESTDIR)$(pkgconfigdir)' && rm -f" $$files ")"; \
|
|
+ cd "$(DESTDIR)$(pkgconfigdir)" && rm -f $$files
|
|
|
|
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
|
|
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
|
|
@@ -609,9 +635,9 @@ distdir: $(DISTFILES)
|
|
check-am: all-am
|
|
check: $(BUILT_SOURCES)
|
|
$(MAKE) $(AM_MAKEFLAGS) check-am
|
|
-all-am: Makefile $(PROGRAMS) $(SCRIPTS)
|
|
+all-am: Makefile $(PROGRAMS) $(SCRIPTS) $(DATA)
|
|
installdirs:
|
|
- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)"; do \
|
|
+ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgconfigdir)"; do \
|
|
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
|
done
|
|
install: $(BUILT_SOURCES)
|
|
@@ -665,7 +691,7 @@ info: info-am
|
|
|
|
info-am:
|
|
|
|
-install-data-am:
|
|
+install-data-am: install-pkgconfigDATA
|
|
|
|
install-dvi: install-dvi-am
|
|
|
|
@@ -711,7 +737,8 @@ ps: ps-am
|
|
|
|
ps-am:
|
|
|
|
-uninstall-am: uninstall-binPROGRAMS uninstall-binSCRIPTS
|
|
+uninstall-am: uninstall-binPROGRAMS uninstall-binSCRIPTS \
|
|
+ uninstall-pkgconfigDATA
|
|
|
|
.MAKE: all check install install-am install-strip
|
|
|
|
@@ -723,14 +750,19 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
install-binSCRIPTS install-data install-data-am install-dvi \
|
|
install-dvi-am install-exec install-exec-am install-html \
|
|
install-html-am install-info install-info-am install-man \
|
|
- install-pdf install-pdf-am install-ps install-ps-am \
|
|
- install-strip installcheck installcheck-am installdirs \
|
|
- maintainer-clean maintainer-clean-generic mostlyclean \
|
|
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
|
|
- pdf pdf-am ps ps-am tags uninstall uninstall-am \
|
|
- uninstall-binPROGRAMS uninstall-binSCRIPTS
|
|
+ install-pdf install-pdf-am install-pkgconfigDATA install-ps \
|
|
+ install-ps-am install-strip installcheck installcheck-am \
|
|
+ installdirs maintainer-clean maintainer-clean-generic \
|
|
+ mostlyclean mostlyclean-compile mostlyclean-generic \
|
|
+ mostlyclean-libtool pdf pdf-am ps ps-am tags uninstall \
|
|
+ uninstall-am uninstall-binPROGRAMS uninstall-binSCRIPTS \
|
|
+ uninstall-pkgconfigDATA
|
|
|
|
|
|
+.pc.in.pc:
|
|
+ cd $(top_builddir) \
|
|
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
|
+
|
|
# When build directory is not same as source directory then any
|
|
# subdirectories that targets use must be manually created (under
|
|
# the build directory that is).
|
|
@@ -755,6 +787,8 @@ hal/libsane.fdi: $(wildcard ${top_srcdir
|
|
@./sane-desc -m hal -s ${top_srcdir}/doc/descriptions:${top_srcdir}/doc/descriptions-external \
|
|
-d 0 > $@
|
|
|
|
+sane-backends.pc: $(top_builddir)/config.status
|
|
+
|
|
clean-local:
|
|
rm -f $(HOTPLUG)
|
|
|