fix pkgconfig file (#598401)
This commit is contained in:
parent
a962963591
commit
f6ef728ae7
@ -1,10 +1,16 @@
|
|||||||
From de99bb00b0084e8a1862398270278a14e099b22b Mon Sep 17 00:00:00 2001
|
From 99d33809f7c02e4ace528edc4b8b6e2bb7e762aa Mon Sep 17 00:00:00 2001
|
||||||
From: Nils Philippsen <nils@redhat.com>
|
From: Nils Philippsen <nils@redhat.com>
|
||||||
Date: Wed, 5 May 2010 13:23:40 +0200
|
Date: Wed, 2 Jun 2010 14:16:56 +0200
|
||||||
Subject: [PATCH] patch: pkgconfig
|
Subject: [PATCH] patch: pkgconfig
|
||||||
|
|
||||||
Squashed commit of the following:
|
Squashed commit of the following:
|
||||||
|
|
||||||
|
commit 248577ef557e36b9a326d93fd143e5e376f1a0f1
|
||||||
|
Author: Nils Philippsen <nils@redhat.com>
|
||||||
|
Date: Wed Jun 2 14:14:53 2010 +0200
|
||||||
|
|
||||||
|
use ${...} instead of $(...) (#598401)
|
||||||
|
|
||||||
commit d615848c499842c5923c3274370d2536dc650916
|
commit d615848c499842c5923c3274370d2536dc650916
|
||||||
Author: Nils Philippsen <nils@redhat.com>
|
Author: Nils Philippsen <nils@redhat.com>
|
||||||
Date: Fri Feb 26 17:51:14 2010 +0100
|
Date: Fri Feb 26 17:51:14 2010 +0100
|
||||||
@ -29,9 +35,10 @@ Date: Wed May 5 10:22:15 2010 +0200
|
|||||||
|
|
||||||
use pkg-config in sane-config
|
use pkg-config in sane-config
|
||||||
---
|
---
|
||||||
tools/Makefile.am | 14 ++++++++++-
|
tools/Makefile.am | 14 +++++++++-
|
||||||
tools/sane-config.in | 66 ++++++++++++++++++++++++++++++++++++++-----------
|
tools/sane-backends.pc.in | 6 ++--
|
||||||
2 files changed, 64 insertions(+), 16 deletions(-)
|
tools/sane-config.in | 66 ++++++++++++++++++++++++++++++++++----------
|
||||||
|
3 files changed, 67 insertions(+), 19 deletions(-)
|
||||||
|
|
||||||
diff --git a/tools/Makefile.am b/tools/Makefile.am
|
diff --git a/tools/Makefile.am b/tools/Makefile.am
|
||||||
index f52a39a..ab4e1b7 100644
|
index f52a39a..ab4e1b7 100644
|
||||||
@ -72,6 +79,20 @@ index f52a39a..ab4e1b7 100644
|
|||||||
+
|
+
|
||||||
clean-local:
|
clean-local:
|
||||||
rm -f $(HOTPLUG)
|
rm -f $(HOTPLUG)
|
||||||
|
diff --git a/tools/sane-backends.pc.in b/tools/sane-backends.pc.in
|
||||||
|
index 5781121..b4d9731 100644
|
||||||
|
--- a/tools/sane-backends.pc.in
|
||||||
|
+++ b/tools/sane-backends.pc.in
|
||||||
|
@@ -9,6 +9,6 @@ Name: SANE Backends
|
||||||
|
Description: Backends for SANE, the universal scanner interface
|
||||||
|
Version: @VERSION@
|
||||||
|
Requires:
|
||||||
|
-Libs: -L$(libdir) -lsane
|
||||||
|
-Libs.private: $(ldflags) $(libs)
|
||||||
|
-Cflags: -I$(includedir)
|
||||||
|
+Libs: -L${libdir} -lsane
|
||||||
|
+Libs.private: ${ldflags} ${libs}
|
||||||
|
+Cflags: -I${includedir}
|
||||||
diff --git a/tools/sane-config.in b/tools/sane-config.in
|
diff --git a/tools/sane-config.in b/tools/sane-config.in
|
||||||
index 22c02b5..a9ce6fb 100644
|
index 22c02b5..a9ce6fb 100644
|
||||||
--- a/tools/sane-config.in
|
--- a/tools/sane-config.in
|
||||||
@ -178,5 +199,5 @@ index 22c02b5..a9ce6fb 100644
|
|||||||
--prefix)
|
--prefix)
|
||||||
echo ${prefix}
|
echo ${prefix}
|
||||||
--
|
--
|
||||||
1.6.6.1
|
1.7.0.1
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Scanner access software
|
Summary: Scanner access software
|
||||||
Name: sane-backends
|
Name: sane-backends
|
||||||
Version: 1.0.21
|
Version: 1.0.21
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
# lib/ is LGPLv2+, backends are GPLv2+ with exceptions
|
# lib/ is LGPLv2+, backends are GPLv2+ with exceptions
|
||||||
# Tools are GPLv2+, docs are public domain
|
# Tools are GPLv2+, docs are public domain
|
||||||
# see LICENSE for details
|
# see LICENSE for details
|
||||||
@ -158,6 +158,9 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/pkgconfig/sane-backends.pc
|
%{_libdir}/pkgconfig/sane-backends.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 02 2010 Nils Philippsen <nils@redhat.com> - 1.0.21-2
|
||||||
|
- fix pkgconfig file (#598401)
|
||||||
|
|
||||||
* Wed May 05 2010 Nils Philippsen <nils@redhat.com> - 1.0.21-1
|
* Wed May 05 2010 Nils Philippsen <nils@redhat.com> - 1.0.21-1
|
||||||
- version 1.0.21
|
- version 1.0.21
|
||||||
- remove obsolete rpath, hal, genesys-gl841-registers patches
|
- remove obsolete rpath, hal, genesys-gl841-registers patches
|
||||||
|
Loading…
Reference in New Issue
Block a user