remove obsolete lockdir, automake patches
This commit is contained in:
parent
4c4b8135b8
commit
c61644cd90
@ -1,30 +0,0 @@
|
||||
commit 1e12605eac293b12809ca2933622acc54515c237
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Dec 28 17:00:25 2009 +0100
|
||||
|
||||
patch: lockdir
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 7d26ebc2c0c0c8a8e3254834a700951b49648eeb
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Dec 28 16:58:36 2009 +0100
|
||||
|
||||
improve install-lockpath target
|
||||
|
||||
make robust against problems with setting group on sane lock dir
|
||||
|
||||
diff --git a/backend/Makefile.am b/backend/Makefile.am
|
||||
index 5165423..3c22cd4 100644
|
||||
--- a/backend/Makefile.am
|
||||
+++ b/backend/Makefile.am
|
||||
@@ -137,7 +137,8 @@ install-firmware-path:
|
||||
done
|
||||
|
||||
install-lockpath:
|
||||
- $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir)
|
||||
+ $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir) || \
|
||||
+ $(mkinstalldirs) -m 775 $(DESTDIR)$(locksanedir)
|
||||
|
||||
uninstall-hook:
|
||||
rm -rf $(DESTDIR)$(libdir)/sane $(DESTDIR)$(configdir) $(DESTDIR)$(locksanedir)
|
@ -1,13 +0,0 @@
|
||||
diff -up sane-backends-1.0.22/backend/Makefile.in.automake sane-backends-1.0.22/backend/Makefile.in
|
||||
--- sane-backends-1.0.22/backend/Makefile.in.automake 2011-01-30 19:50:55.000000000 +0100
|
||||
+++ sane-backends-1.0.22/backend/Makefile.in 2011-03-14 15:46:47.946422433 +0100
|
||||
@@ -4881,7 +4881,8 @@ install-firmware-path:
|
||||
done
|
||||
|
||||
install-lockpath:
|
||||
- $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir)
|
||||
+ $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir) || \
|
||||
+ $(mkinstalldirs) -m 775 $(DESTDIR)$(locksanedir)
|
||||
|
||||
uninstall-hook:
|
||||
rm -rf $(DESTDIR)$(libdir)/sane $(DESTDIR)$(configdir) $(DESTDIR)$(locksanedir)
|
@ -1,7 +1,7 @@
|
||||
Summary: Scanner access software
|
||||
Name: sane-backends
|
||||
Version: 1.0.22
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# lib/ is LGPLv2+, backends are GPLv2+ with exceptions
|
||||
# Tools are GPLv2+, docs are public domain
|
||||
# see LICENSE for details
|
||||
@ -17,16 +17,12 @@ Patch1: sane-backends-1.0.22-udev.patch
|
||||
Patch2: sane-backends-1.0.22-man-encoding.patch
|
||||
# Upstreamed at: https://alioth.debian.org/tracker/index.php?func=detail&aid=313040
|
||||
Patch3: sane-backends-1.0.21-epson-expression800.patch
|
||||
# Upstreamed at: https://alioth.debian.org/tracker/index.php?func=detail&aid=313041
|
||||
Patch4: sane-backends-1.0.20-lockdir.patch
|
||||
# Upstreamed at: https://alioth.debian.org/tracker/index.php?func=detail&aid=313042
|
||||
Patch5: sane-backends-1.0.22-docs-utf8.patch
|
||||
Patch4: sane-backends-1.0.22-docs-utf8.patch
|
||||
# Upstreamed at: https://alioth.debian.org/tracker/index.php?func=detail&aid=313043
|
||||
Patch6: sane-backends-1.0.21-SCX4500W.patch
|
||||
Patch5: sane-backends-1.0.21-SCX4500W.patch
|
||||
# backported from upstream c5ca46c2d1be78c651afb843cc834cf2b5b24953
|
||||
Patch7: sane-backends-1.0.22-v4l.patch
|
||||
# may need rebuilding if one of the above changes:
|
||||
Patch100: sane-backends-1.0.22-automake.patch
|
||||
Patch6: sane-backends-1.0.22-v4l.patch
|
||||
URL: http://www.sane-project.org
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%__id_u -n)
|
||||
BuildRequires: tetex-latex
|
||||
@ -91,12 +87,9 @@ want to access digital cameras.
|
||||
%patch1 -p1 -b .udev
|
||||
%patch2 -p1 -b .man-encoding
|
||||
%patch3 -p1 -b .epson-expression800
|
||||
%patch4 -p1 -b .lockdir
|
||||
%patch5 -p1 -b .docs-utf8
|
||||
%patch6 -p1 -b .SCX4500W
|
||||
%patch7 -p1 -b .v4l
|
||||
|
||||
%patch100 -p1 -b .automake
|
||||
%patch4 -p1 -b .docs-utf8
|
||||
%patch5 -p1 -b .SCX4500W
|
||||
%patch6 -p1 -b .v4l
|
||||
|
||||
%build
|
||||
# use PIC/PIE because SANE-enabled software is likely to deal with data coming
|
||||
@ -175,6 +168,9 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/pkgconfig/sane-backends.pc
|
||||
|
||||
%changelog
|
||||
* Tue Apr 19 2011 Nils Philippsen <nils@redhat.com> - 1.0.22-2
|
||||
- remove obsolete lockdir, automake patches
|
||||
|
||||
* Wed Mar 16 2011 Nils Philippsen <nils@redhat.com> - 1.0.22-1
|
||||
- version 1.0.22
|
||||
- remove obsolete i18n, xerox-mfp-color-mode, epson2-fixes, open-macro patches
|
||||
|
Loading…
Reference in New Issue
Block a user