fix autoconf macro bug add exec_prefix to .pc file

This commit is contained in:
Nils Philippsen 2006-05-16 16:40:51 +00:00
parent 20e2dab44e
commit c3cf35892e

View File

@ -1,5 +1,5 @@
--- sane-backends-1.0.17/ChangeLog.pkgconfig 2005-12-18 15:41:09.000000000 +0100 --- sane-backends-1.0.17/ChangeLog.pkgconfig 2005-12-18 15:41:09.000000000 +0100
+++ sane-backends-1.0.17/ChangeLog 2006-05-16 18:22:07.000000000 +0200 +++ sane-backends-1.0.17/ChangeLog 2006-05-16 18:31:17.000000000 +0200
@@ -0,0 +1,7 @@ @@ -0,0 +1,7 @@
+2006-05-16 Nils Philippsen <nphilipp@redhat.com> +2006-05-16 Nils Philippsen <nphilipp@redhat.com>
+ +
@ -8,8 +8,8 @@
+ re-write sane-config to use pkg-config to avoid multilib problems with + re-write sane-config to use pkg-config to avoid multilib problems with
+ conflicting sane-config scripts + conflicting sane-config scripts
+ +
--- sane-backends-1.0.17/acinclude.m4.pkgconfig 2006-05-15 17:05:18.000000000 +0200 --- sane-backends-1.0.17/acinclude.m4.pkgconfig 2006-05-16 18:38:02.000000000 +0200
+++ sane-backends-1.0.17/acinclude.m4 2006-05-16 17:31:37.000000000 +0200 +++ sane-backends-1.0.17/acinclude.m4 2006-05-16 18:31:18.000000000 +0200
@@ -194,6 +194,7 @@ @@ -194,6 +194,7 @@
# Checks for ieee1284 library, needed for canon_pp backend. # Checks for ieee1284 library, needed for canon_pp backend.
AC_DEFUN([SANE_CHECK_IEEE1284], AC_DEFUN([SANE_CHECK_IEEE1284],
@ -55,7 +55,7 @@
#endif #endif
],[sane_cv_use_libjpeg="yes"; LIBS="${LIBS} -ljpeg"; ],[sane_cv_use_libjpeg="yes"; LIBS="${LIBS} -ljpeg";
- AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)]) - AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)])
+ AC_SUBST(JPEG_LIBS, "-ljpeg"); AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)]) + AC_SUBST(JPEG_LIBS, "-ljpeg") AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)])
],) ],)
],) ],)
]) ])
@ -76,7 +76,7 @@
saved_LIBS="${LIBS}" saved_LIBS="${LIBS}"
LIBS="${LIBS} ${GPHOTO2_LIBS}" LIBS="${LIBS} ${GPHOTO2_LIBS}"
--- sane-backends-1.0.17/configure.in.pkgconfig 2005-12-18 14:15:15.000000000 +0100 --- sane-backends-1.0.17/configure.in.pkgconfig 2005-12-18 14:15:15.000000000 +0100
+++ sane-backends-1.0.17/configure.in 2006-05-16 17:43:53.000000000 +0200 +++ sane-backends-1.0.17/configure.in 2006-05-16 18:31:17.000000000 +0200
@@ -52,6 +52,7 @@ @@ -52,6 +52,7 @@
AC_PROG_MAKE_SET AC_PROG_MAKE_SET
AC_PROG_CPP AC_PROG_CPP
@ -154,8 +154,8 @@
AC_OUTPUT AC_OUTPUT
dnl *********************************************************************** dnl ***********************************************************************
--- sane-backends-1.0.17/tools/sane-config.in.pkgconfig 2006-05-15 17:05:17.000000000 +0200 --- sane-backends-1.0.17/tools/sane-config.in.pkgconfig 2006-05-16 18:31:17.000000000 +0200
+++ sane-backends-1.0.17/tools/sane-config.in 2006-05-16 18:14:26.000000000 +0200 +++ sane-backends-1.0.17/tools/sane-config.in 2006-05-16 18:31:17.000000000 +0200
@@ -7,30 +7,10 @@ @@ -7,30 +7,10 @@
PACKAGE="@PACKAGE@" PACKAGE="@PACKAGE@"
scriptname="sane-config" scriptname="sane-config"
@ -218,10 +218,11 @@
;; ;;
--prefix) --prefix)
echo ${prefix} echo ${prefix}
--- sane-backends-1.0.17/tools/sane-backends.pc.in.pkgconfig 2006-05-15 17:37:54.000000000 +0200 --- /dev/null 2006-05-15 11:22:36.323023750 +0200
+++ sane-backends-1.0.17/tools/sane-backends.pc.in 2006-05-16 17:44:05.000000000 +0200 +++ sane-backends-1.0.17/tools/sane-backends.pc.in 2006-05-16 18:33:43.000000000 +0200
@@ -0,0 +1,13 @@ @@ -0,0 +1,14 @@
+prefix=@prefix@ +prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@ +libdir=@libdir@
+includedir=@includedir@ +includedir=@includedir@
+ +
@ -235,7 +236,7 @@
+Libs: -L${libdir} -lsane ${pc_libs} +Libs: -L${libdir} -lsane ${pc_libs}
+Cflags: +Cflags:
--- sane-backends-1.0.17/tools/Makefile.in.pkgconfig 2005-10-29 16:41:09.000000000 +0200 --- sane-backends-1.0.17/tools/Makefile.in.pkgconfig 2005-10-29 16:41:09.000000000 +0200
+++ sane-backends-1.0.17/tools/Makefile.in 2006-05-16 17:46:46.000000000 +0200 +++ sane-backends-1.0.17/tools/Makefile.in 2006-05-16 18:31:17.000000000 +0200
@@ -25,6 +25,7 @@ @@ -25,6 +25,7 @@
includedir = @includedir@ includedir = @includedir@
oldincludedir = /usr/include oldincludedir = /usr/include