genesys_gl841: always send registers before trying to acquire a line
(#527935) build v4l backend (#550119) don't use lockdir, fix make install
This commit is contained in:
parent
82a29d5338
commit
91a7a55212
@ -1,2 +1,3 @@
|
||||
sane-backends-1.0.20.tar.gz
|
||||
sane-backends-1.0.20-autoreconf.patch.bz2
|
||||
sane-backends-1.0.20-11-autoreconf.patch.bz2
|
||||
|
42
sane-backends-1.0.20-genesys-gl841-registers.patch
Normal file
42
sane-backends-1.0.20-genesys-gl841-registers.patch
Normal file
@ -0,0 +1,42 @@
|
||||
commit 4d9d166a3ae830c62bb7341efe886c99e614199a
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Tue Dec 29 11:43:24 2009 +0100
|
||||
|
||||
patch: genesys-gl841-registers
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 8bb82ba231bec01377e28a4f7f635dca61c34fbb
|
||||
Author: Pierre Willenbrock <pierre@pirsoft.dnsalias.org>
|
||||
Date: Wed Jun 3 00:16:16 2009 +0200
|
||||
|
||||
Always send registers before trying to acquire a line
|
||||
(cherry picked from commit a0ea955e91837156d2112c0ffd12c8afebe86efa)
|
||||
|
||||
Signed-off-by: Nils Philippsen <nils@redhat.com>
|
||||
Resolves: rhbz#527935
|
||||
|
||||
diff --git a/backend/genesys_gl841.c b/backend/genesys_gl841.c
|
||||
index 2810865..c9facc4 100644
|
||||
--- a/backend/genesys_gl841.c
|
||||
+++ b/backend/genesys_gl841.c
|
||||
@@ -4948,9 +4948,6 @@ gl841_offset_calibration (Genesys_Device * dev)
|
||||
return status;
|
||||
}
|
||||
|
||||
- RIE (gl841_bulk_write_register
|
||||
- (dev, dev->calib_reg, GENESYS_GL841_MAX_REGS));
|
||||
-
|
||||
used_res = dev->current_setup.xres;
|
||||
num_pixels = dev->current_setup.pixels;
|
||||
|
||||
@@ -4999,6 +4996,9 @@ gl841_offset_calibration (Genesys_Device * dev)
|
||||
|
||||
do {
|
||||
|
||||
+ RIE (gl841_bulk_write_register
|
||||
+ (dev, dev->calib_reg, GENESYS_GL841_MAX_REGS));
|
||||
+
|
||||
for (j=0; j < channels; j++) {
|
||||
off[j] = (offh[j]+offl[j])/2;
|
||||
dev->frontend.offset[j] = off[j];
|
30
sane-backends-1.0.20-lockdir.patch
Normal file
30
sane-backends-1.0.20-lockdir.patch
Normal file
@ -0,0 +1,30 @@
|
||||
commit 1e12605eac293b12809ca2933622acc54515c237
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Dec 28 17:00:25 2009 +0100
|
||||
|
||||
patch: lockdir
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 7d26ebc2c0c0c8a8e3254834a700951b49648eeb
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Dec 28 16:58:36 2009 +0100
|
||||
|
||||
improve install-lockpath target
|
||||
|
||||
make robust against problems with setting group on sane lock dir
|
||||
|
||||
diff --git a/backend/Makefile.am b/backend/Makefile.am
|
||||
index 5165423..3c22cd4 100644
|
||||
--- a/backend/Makefile.am
|
||||
+++ b/backend/Makefile.am
|
||||
@@ -137,7 +137,8 @@ install-firmware-path:
|
||||
done
|
||||
|
||||
install-lockpath:
|
||||
- $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir)
|
||||
+ $(mkinstalldirs) -m 775 -g $(LOCKPATH_GROUP) $(DESTDIR)$(locksanedir) || \
|
||||
+ $(mkinstalldirs) -m 775 $(DESTDIR)$(locksanedir)
|
||||
|
||||
uninstall-hook:
|
||||
rm -rf $(DESTDIR)$(libdir)/sane $(DESTDIR)$(configdir) $(DESTDIR)$(locksanedir)
|
@ -15,7 +15,7 @@
|
||||
Summary: Scanner access software
|
||||
Name: sane-backends
|
||||
Version: 1.0.20
|
||||
Release: 10%{?dist}
|
||||
Release: 11%{?dist}
|
||||
# lib/ is LGPLv2+, backends are GPLv2+ with exceptions
|
||||
# Tools are GPLv2+, docs are public domain
|
||||
# see LICENSE for details
|
||||
@ -31,7 +31,9 @@ Patch3: sane-backends-1.0.20-hal.patch
|
||||
Patch4: sane-backends-1.0.20-udev.patch
|
||||
Patch5: sane-backends-1.0.20-man-utf8.patch
|
||||
Patch6: sane-backends-1.0.20-epson-expression800.patch
|
||||
Patch10: sane-backends-1.0.20-autoreconf.patch.bz2
|
||||
Patch7: sane-backends-1.0.20-lockdir.patch
|
||||
Patch8: sane-backends-1.0.20-genesys-gl841-registers.patch
|
||||
Patch10: sane-backends-1.0.20-11-autoreconf.patch.bz2
|
||||
URL: http://www.sane-project.org
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%__id_u -n)
|
||||
BuildRequires: tetex-latex
|
||||
@ -39,6 +41,7 @@ BuildRequires: libusb-devel
|
||||
BuildRequires: libieee1284-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libv4l-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: gphoto2-devel
|
||||
%if %{with udev}
|
||||
@ -102,13 +105,15 @@ want to access digital cameras.
|
||||
%patch4 -p1 -b .udev
|
||||
%patch5 -p1 -b .man-utf8
|
||||
%patch6 -p1 -b .epson-expression800
|
||||
%patch7 -p1 -b .lockdir
|
||||
%patch8 -p1 -b .genesys-gl841-registers
|
||||
%patch10 -p1 -b .autoreconf
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-gphoto2=%{_prefix} \
|
||||
--with-docdir=%{_docdir}/%{name}-%{version} \
|
||||
--disable-rpath
|
||||
--disable-locking --disable-rpath
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
@ -189,6 +194,14 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/pkgconfig/sane-backends.pc
|
||||
|
||||
%changelog
|
||||
* Tue Dec 29 2009 Nils Philippsen <nils@redhat.com> - 1.0.20-11
|
||||
- genesys_gl841: always send registers before trying to acquire a line
|
||||
(#527935)
|
||||
|
||||
* Mon Dec 28 2009 Nils Philippsen <nils@redhat.com>
|
||||
- build v4l backend (#550119)
|
||||
- don't use lockdir, fix make install
|
||||
|
||||
* Thu Oct 22 2009 Nils Philippsen <nils@redhat.com> - 1.0.20-10
|
||||
- don't set owner, group or mode as this may interfere with setting ACLs
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user