- rebased to 2.26.0
This commit is contained in:
parent
9e98b44d8b
commit
d6f3723e10
@ -1,4 +1,4 @@
|
||||
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
||||
From b2daaa34776ba6afec879e362378f6f7563590a6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
||||
return n;
|
||||
|
||||
--
|
||||
2.37.3
|
||||
2.39.2
|
||||
|
||||
|
||||
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
||||
From 692e70bcfc32a05e30146bd7077c41e0eaceff03 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||
@ -213,7 +213,7 @@ Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||
index 64eabe4..7043005 100644
|
||||
index cab5655..7ec215d 100644
|
||||
--- a/zipl/src/Makefile
|
||||
+++ b/zipl/src/Makefile
|
||||
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||
@ -223,7 +223,7 @@ index 64eabe4..7043005 100644
|
||||
+ -lrpmio -lrpm
|
||||
|
||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
||||
bootmap_header.o envblk.o install.o zipl.o
|
||||
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
|
||||
index 9352f76..3327e2d 100644
|
||||
--- a/zipl/src/scan.c
|
||||
@ -344,5 +344,5 @@ index 9352f76..3327e2d 100644
|
||||
static int
|
||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||
--
|
||||
2.37.3
|
||||
2.39.2
|
||||
|
||||
|
@ -1,77 +0,0 @@
|
||||
From d721eb018973842a432869f6f9efd5752b2e7f19 Mon Sep 17 00:00:00 2001
|
||||
From: Marc Hartmayer <mhartmay@linux.ibm.com>
|
||||
Date: Mon, 19 Dec 2022 09:51:51 +0000
|
||||
Subject: [PATCH 1/2] zgetdump/Makefile: don't use `.check_dep_zgetdump` as
|
||||
linker input
|
||||
|
||||
The `.check_dep_zgetdump` file is used to cache the result of the
|
||||
dependency checks and should not be used as input for linking or
|
||||
anything else. Let's add it as dependency for the objects file. This
|
||||
shouldn't cause any problems since the Makefile rule for object files is
|
||||
defined in `common.mak` as follows:
|
||||
|
||||
%.o: %.c
|
||||
$(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -c $< -o $@
|
||||
|
||||
Fixes: https://github.com/ibm-s390-linux/s390-tools/issues/147
|
||||
Fixes: 8d8d5e9746a4 ("zdump: Fix Makefile dependencies")
|
||||
Signed-off-by: Marc Hartmayer <mhartmay@linux.ibm.com>
|
||||
Reviewed-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
||||
Signed-off-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
||||
---
|
||||
zdump/Makefile | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/zdump/Makefile b/zdump/Makefile
|
||||
index ca8aadc..934dc47 100644
|
||||
--- a/zdump/Makefile
|
||||
+++ b/zdump/Makefile
|
||||
@@ -119,7 +119,9 @@ libs = $(rootdir)/libutil/libutil.a $(LIBPV)
|
||||
|
||||
all: $(BUILD_TARGETS)
|
||||
|
||||
-zgetdump: .check_dep_zgetdump $(OBJECTS) $(libs)
|
||||
+$(OBJECTS): .check_dep_zgetdump
|
||||
+
|
||||
+zgetdump: $(OBJECTS) $(libs)
|
||||
|
||||
skip-zgetdump:
|
||||
echo " SKIP zgetdump due to unresolved dependencies"
|
||||
--
|
||||
2.39.1
|
||||
|
||||
|
||||
From d9f54f76e2e6f17e0b5bafdc0d09ff0e72edd474 Mon Sep 17 00:00:00 2001
|
||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Date: Fri, 20 Jan 2023 11:04:18 +0100
|
||||
Subject: [PATCH 2/2] zkey: Support EP11 host library version 4
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Try to load libep11.so.4 if available, but fallback to older
|
||||
library versions if not.
|
||||
|
||||
Reviewed-by: Jörg Schmidbauer <jschmidb@de.ibm.com>
|
||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||
---
|
||||
zkey/ep11.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/zkey/ep11.c b/zkey/ep11.c
|
||||
index 58dc3c5..8359929 100644
|
||||
--- a/zkey/ep11.c
|
||||
+++ b/zkey/ep11.c
|
||||
@@ -35,7 +35,7 @@
|
||||
* Definitions for the EP11 library
|
||||
*/
|
||||
#define EP11_LIBRARY_NAME "libep11.so"
|
||||
-#define EP11_LIBRARY_VERSION 3
|
||||
+#define EP11_LIBRARY_VERSION 4
|
||||
#define EP11_WEB_PAGE "http://www.ibm.com/security/cryptocards"
|
||||
|
||||
/**
|
||||
--
|
||||
2.39.1
|
||||
|
115
s390utils-2.26.0-fedora.patch
Normal file
115
s390utils-2.26.0-fedora.patch
Normal file
@ -0,0 +1,115 @@
|
||||
From a12dfc9ee92722c3fdf9f9fbd358023bef7a6ed9 Mon Sep 17 00:00:00 2001
|
||||
From: Steffen Eiden <seiden@linux.ibm.com>
|
||||
Date: Fri, 17 Feb 2023 15:12:46 +0100
|
||||
Subject: [PATCH] Make -Werror optional
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Enforcing `-Werror` can cause problems when compiling with newer
|
||||
compilers that have additional warnings on by default.
|
||||
|
||||
By default `-Werror` is turned off and can be turned on via
|
||||
`ENABLE_WERROR=1`.
|
||||
|
||||
Fixes: https://github.com/ibm-s390-linux/s390-tools/issues/148
|
||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||
Reviewed-by: Jan Höppner <hoeppner@linux.ibm.com>
|
||||
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
||||
(cherry picked from commit d3a3b26d16efdc4e9f896e616b5c8b7cac1b1a63)
|
||||
---
|
||||
common.mak | 17 +++++++++++------
|
||||
genprotimg/boot/Makefile | 2 +-
|
||||
genprotimg/src/Makefile | 2 +-
|
||||
libpv/Makefile | 1 -
|
||||
pvattest/src/Makefile | 1 -
|
||||
5 files changed, 13 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/common.mak b/common.mak
|
||||
index dbd1ebb..1d5e1a2 100644
|
||||
--- a/common.mak
|
||||
+++ b/common.mak
|
||||
@@ -101,6 +101,10 @@ else
|
||||
DEFAULT_CFLAGS += -O3
|
||||
endif
|
||||
|
||||
+ifeq ("${ENABLE_WERROR}", "1")
|
||||
+ DEFAULT_CFLAGS += -Werror
|
||||
+endif
|
||||
+
|
||||
DEFAULT_CPPFLAGS = -D_GNU_SOURCE
|
||||
DEFAULT_LDFLAGS = -rdynamic
|
||||
|
||||
@@ -302,12 +306,13 @@ help:
|
||||
@echo ' clean Delete all generated files'
|
||||
@echo ''
|
||||
@echo 'OPTIONS'
|
||||
- @echo ' D=1 Build with debugging option "-Og"'
|
||||
- @echo ' C=1 Build with check tool defined with "CHECK=" (default=sparse)'
|
||||
- @echo ' G=1 Build with gcov to collect code coverage data'
|
||||
- @echo ' V=1 Generate verbose build output'
|
||||
- @echo ' W=1 Build with higher warning level'
|
||||
- @echo ' ASAN=1 Build with address sanitizer'
|
||||
+ @echo ' D=1 Build with debugging option "-Og"'
|
||||
+ @echo ' C=1 Build with check tool defined with "CHECK=" (default=sparse)'
|
||||
+ @echo ' G=1 Build with gcov to collect code coverage data'
|
||||
+ @echo ' V=1 Generate verbose build output'
|
||||
+ @echo ' W=1 Build with higher warning level'
|
||||
+ @echo ' ASAN=1 Build with address sanitizer'
|
||||
+ @echo ' ENABLE_WERROR=1 Build with -Werror'
|
||||
@echo ''
|
||||
@echo 'EXAMPLES'
|
||||
@echo ' # make clean all D=1 W=1 -j'
|
||||
diff --git a/genprotimg/boot/Makefile b/genprotimg/boot/Makefile
|
||||
index b1b1421..6f3ae5c 100644
|
||||
--- a/genprotimg/boot/Makefile
|
||||
+++ b/genprotimg/boot/Makefile
|
||||
@@ -15,7 +15,7 @@ ALL_CFLAGS := $(NO_PIE_CFLAGS) -Os -g \
|
||||
-fno-delete-null-pointer-checks -fno-stack-protector \
|
||||
-fexec-charset=IBM1047 -m64 -mpacked-stack \
|
||||
-mstack-size=4096 -mstack-guard=128 -msoft-float \
|
||||
- -Wall -Wformat-security -Wextra -Werror \
|
||||
+ -Wall -Wformat-security -Wextra \
|
||||
-Wno-array-bounds
|
||||
|
||||
FILES := stage3a.bin stage3b.bin stage3b_reloc.bin
|
||||
diff --git a/genprotimg/src/Makefile b/genprotimg/src/Makefile
|
||||
index 0e811d6..6c80ed2 100644
|
||||
--- a/genprotimg/src/Makefile
|
||||
+++ b/genprotimg/src/Makefile
|
||||
@@ -17,7 +17,7 @@ WARNINGS := -Wall -Wextra -Wshadow \
|
||||
-Wcast-align -Wwrite-strings -Wmissing-prototypes \
|
||||
-Wmissing-declarations -Wredundant-decls -Wnested-externs \
|
||||
-Wno-long-long -Wuninitialized -Wconversion -Wstrict-prototypes \
|
||||
- -Wpointer-arith -Werror -Wno-error=inline \
|
||||
+ -Wpointer-arith -Wno-error=inline \
|
||||
$(NULL)
|
||||
|
||||
$(bin_PROGRAM)_SRCS := $(bin_PROGRAM).c pv/pv_stage3.c pv/pv_image.c \
|
||||
diff --git a/libpv/Makefile b/libpv/Makefile
|
||||
index d9a1cff..5b518c7 100644
|
||||
--- a/libpv/Makefile
|
||||
+++ b/libpv/Makefile
|
||||
@@ -28,7 +28,6 @@ WARNINGS := -Wall -Wextra -Wshadow \
|
||||
-Wno-long-long -Wuninitialized -Wconversion -Wstrict-prototypes \
|
||||
-Wpointer-arith -Wno-error=inline \
|
||||
-Wno-unused-function -Wno-unused-parameter -Wno-unused-variable \
|
||||
- -Werror \
|
||||
$(NULL)
|
||||
|
||||
ALL_CFLAGS += -std=gnu11 \
|
||||
diff --git a/pvattest/src/Makefile b/pvattest/src/Makefile
|
||||
index a1f0e1a..cd56af0 100644
|
||||
--- a/pvattest/src/Makefile
|
||||
+++ b/pvattest/src/Makefile
|
||||
@@ -17,7 +17,6 @@ WARNINGS := -Wall -Wextra -Wshadow \
|
||||
-Wno-long-long -Wuninitialized -Wconversion -Wstrict-prototypes \
|
||||
-Wpointer-arith -Wno-error=inline \
|
||||
-Wno-unused-function -Wno-unused-parameter -Wno-unused-variable \
|
||||
- -Werror \
|
||||
$(NULL)
|
||||
|
||||
PVATTEST_SRCS := $(wildcard *.c) \
|
||||
--
|
||||
2.39.2
|
||||
|
@ -9,8 +9,8 @@
|
||||
|
||||
Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Version: 2.25.0
|
||||
Release: 4%{?dist}
|
||||
Version: 2.26.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
@ -69,9 +69,6 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
||||
# upstream fixes/updates
|
||||
%patch100 -p1
|
||||
|
||||
# drop -Werror from genprotimg to allow building with GCC 12
|
||||
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
||||
|
||||
# remove --strip from install
|
||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||
|
||||
@ -340,11 +337,6 @@ s390 base tools. This collection provides the following utilities:
|
||||
* tunedasd:
|
||||
Adjust tunable parameters on DASD devices.
|
||||
|
||||
* vmconvert:
|
||||
Convert system dumps created by the z/VM VMDUMP command into dumps with
|
||||
LKCD format. These LKCD dumps can then be analyzed with the dump analysis
|
||||
tool lcrash.
|
||||
|
||||
* vmcp:
|
||||
Allows Linux users to send commands to the z/VM control program (CP).
|
||||
The normal usage is to invoke vmcp with the command you want to
|
||||
@ -478,7 +470,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_bindir}/mk-s390image
|
||||
%{_bindir}/pvattest
|
||||
%{_bindir}/pvextract-hdr
|
||||
%{_bindir}/vmconvert
|
||||
%{_bindir}/zkey
|
||||
%{_bindir}/zkey-cryptsetup
|
||||
%{_unitdir}/dumpconf.service
|
||||
@ -507,7 +498,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_mandir}/man1/pvattest-create.1*
|
||||
%{_mandir}/man1/pvattest-perform.1*
|
||||
%{_mandir}/man1/pvattest-verify.1*
|
||||
%{_mandir}/man1/vmconvert.1*
|
||||
%{_mandir}/man1/zkey.1*
|
||||
%{_mandir}/man1/zkey-cryptsetup.1*
|
||||
%{_mandir}/man1/zkey-ekmfweb.1*
|
||||
@ -907,6 +897,9 @@ User-space development files for the s390/s390x architecture.
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 03 2023 Dan Horák <dan[at]danny.cz> - 2:2.26.0-1
|
||||
- rebased to 2.26.0
|
||||
|
||||
* Tue Jan 31 2023 Dan Horák <dan[at]danny.cz> - 2:2.25.0-4
|
||||
- add post GA fixes
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (s390-tools-2.25.0.tar.gz) = 1c766a4bd19c957596c741a80141712acf150591c0ff1a47caf1aa8a17f7153c1441560f05aef78bb3f05bd35c1fef431569cabd7e7d6b003bd74beedb7213d9
|
||||
SHA512 (s390-tools-2.26.0.tar.gz) = 83cd717553f5bb7b9faac8beadfe9d88b211b2e86942c763778825ef840ed398201e1fe4e085f8eafdc3dc6ab0e231b22cb51277aae23106a964e5a14f2997fc
|
||||
|
Loading…
Reference in New Issue
Block a user