import CS s390utils-2.29.0-3.el8
This commit is contained in:
parent
d305c2983a
commit
d33bf2736c
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
SOURCES/cmsfs-1.1.8c.tar.gz
|
||||
SOURCES/s390-tools-2.27.0.tar.gz
|
||||
SOURCES/s390-tools-2.29.0-rust-vendor.tar.xz
|
||||
SOURCES/s390-tools-2.29.0.tar.gz
|
||||
SOURCES/src_vipa-2.1.0.tar.gz
|
||||
|
@ -1,3 +1,4 @@
|
||||
9c9a4e89bddb2b4e6e09ef6fc7c2e6f2ad6316de SOURCES/cmsfs-1.1.8c.tar.gz
|
||||
ebfc228d39c55586d6b5af08682896adda6b0068 SOURCES/s390-tools-2.27.0.tar.gz
|
||||
1dcae3e55c2d4d945d0b5c61a12671468aa5f7ef SOURCES/s390-tools-2.29.0-rust-vendor.tar.xz
|
||||
e10ffbde7f3fcf4438fdfdd83051ad68518e7be5 SOURCES/s390-tools-2.29.0.tar.gz
|
||||
8ed8592a0a9370ce8422df9231ccb17f6cf49bed SOURCES/src_vipa-2.1.0.tar.gz
|
||||
|
@ -6,7 +6,7 @@ diff -urN cmsfs-1.1.8/cmsfssed.sh cmsfs-1.1.8_/cmsfssed.sh
|
||||
MODULES_DIRECTORY="/lib/modules/`uname -r`/fs"
|
||||
;;
|
||||
- 2.4*|2.5*)
|
||||
+ 2.4*|2.5*|2.6*|3.*|4.*|5.*)
|
||||
+ 2.4*|2.5*|2.6*|3.*|4.*)
|
||||
LINUX_RELEASE="2.4"
|
||||
# ln -s cmsfs24x.c cmsfsvfs.c
|
||||
INCLUDES="-I/lib/modules/`uname -r`/build/include"
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
||||
From b2daaa34776ba6afec879e362378f6f7563590a6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
||||
return n;
|
||||
|
||||
--
|
||||
2.38.1
|
||||
2.39.2
|
||||
|
||||
|
||||
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
||||
From 692e70bcfc32a05e30146bd7077c41e0eaceff03 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||
@ -213,7 +213,7 @@ Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||
index 64eabe4..7043005 100644
|
||||
index cab5655..7ec215d 100644
|
||||
--- a/zipl/src/Makefile
|
||||
+++ b/zipl/src/Makefile
|
||||
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||
@ -344,5 +344,5 @@ index 9352f76..3327e2d 100644
|
||||
static int
|
||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||
--
|
||||
2.38.1
|
||||
2.39.2
|
||||
|
||||
|
File diff suppressed because it is too large
Load Diff
5719
SOURCES/s390utils-2.29.0-rhel.patch
Normal file
5719
SOURCES/s390utils-2.29.0-rhel.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -3,23 +3,32 @@
|
||||
|
||||
# secure boot support is for RHEL only
|
||||
%if 0%{?rhel} >= 8
|
||||
%global signzipl 1
|
||||
%bcond_without signzipl
|
||||
%else
|
||||
%bcond_with signzipl
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%global with_pandoc 1
|
||||
%bcond_without pandoc
|
||||
%else
|
||||
%bcond_with pandoc
|
||||
%endif
|
||||
%bcond_without rust
|
||||
|
||||
Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Version: 2.27.0
|
||||
Release: 3%{?dist}.alma.1
|
||||
Version: 2.29.0
|
||||
Release: 3%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
#URL: http://www.ibm.com/developerworks/linux/linux390/s390-tools.html
|
||||
URL: https://github.com/ibm-s390-tools/s390-tools
|
||||
Source0: https://github.com/ibm-s390-tools/s390-tools/archive/v%{version}.tar.gz#/s390-tools-%{version}.tar.gz
|
||||
# To create the vendor tarball:
|
||||
# tar xf s390-tools-%%{version}.tar.gz ; pushd s390-tools-%%{version}/rust/pvsecret ; \
|
||||
# rm -f Cargo.lock && cargo vendor && \
|
||||
# tar Jvcf ../../../s390-tools-%%{version}-rust-vendor.tar.xz vendor/ ; popd
|
||||
Source1: s390-tools-%{version}-rust-vendor.tar.xz
|
||||
Source4: http://www.linuxvm.org/Patches/S390/cmsfs-%{cmsfsver}.tar.gz
|
||||
Source5: zfcpconf.sh
|
||||
# http://www.ibm.com/developerworks/linux/linux390/src_vipa-%%{vipaver}.html
|
||||
@ -38,7 +47,7 @@ Source24: 20-zipl-kernel.install
|
||||
Source25: 52-zipl-rescue.install
|
||||
Source26: 91-zipl.install
|
||||
|
||||
%if 0%{?signzipl}
|
||||
%if %{with signzipl}
|
||||
%define pesign_name redhatsecureboot302
|
||||
%endif
|
||||
|
||||
@ -56,6 +65,13 @@ Patch1003: cmsfs-1.1.8-args.patch
|
||||
|
||||
Patch2000: src_vipa-2.1.0-deprecate.patch
|
||||
|
||||
# https://fedoraproject.org/wiki/Changes/EncourageI686LeafRemoval
|
||||
ExcludeArch: %{ix86}
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native package structure
|
||||
#
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||
@ -64,8 +80,46 @@ Requires: s390utils-mon_statd = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-iucvterm = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-ziomon = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-cmsfs = %{epoch}:%{version}-%{release}
|
||||
%else
|
||||
#
|
||||
# multiarch package structure
|
||||
#
|
||||
Requires: s390utils-se-data = %{epoch}:%{version}-%{release}
|
||||
%endif
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: glib2-devel
|
||||
%if %{with rust}
|
||||
%if 0%{?rhel}
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: rust-toolset
|
||||
%else
|
||||
BuildRequires: crate(anstream)
|
||||
BuildRequires: crate(anstyle-query)
|
||||
BuildRequires: crate(anyhow)
|
||||
BuildRequires: crate(byteorder)
|
||||
BuildRequires: crate(cfg-if)
|
||||
BuildRequires: crate(clap)
|
||||
BuildRequires: crate(clap_complete)
|
||||
BuildRequires: crate(clap_derive)
|
||||
BuildRequires: crate(colorchoice)
|
||||
BuildRequires: crate(curl)
|
||||
BuildRequires: crate(is-terminal)
|
||||
BuildRequires: crate(libc)
|
||||
BuildRequires: crate(log)
|
||||
BuildRequires: crate(openssl)
|
||||
BuildRequires: crate(openssl-probe)
|
||||
BuildRequires: crate(serde)
|
||||
BuildRequires: crate(serde_derive)
|
||||
BuildRequires: crate(serde_yaml)
|
||||
BuildRequires: crate(strsim)
|
||||
BuildRequires: crate(terminal_size)
|
||||
BuildRequires: crate(thiserror)
|
||||
BuildRequires: crate(zerocopy)
|
||||
BuildRequires: rust-packaging
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%description
|
||||
This is a meta package for installing the default s390-tools sub packages.
|
||||
@ -113,6 +167,17 @@ popd
|
||||
# remove --strip from install
|
||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||
|
||||
%if %{with rust}
|
||||
%if 0%{?rhel}
|
||||
pushd rust
|
||||
%cargo_prep -V 1
|
||||
popd
|
||||
%else
|
||||
%cargo_prep
|
||||
%endif
|
||||
rm -rf ./rust/Cargo.lock
|
||||
%endif
|
||||
|
||||
pushd cmsfs-%{cmsfsver}
|
||||
# cmdfs: fix encoding
|
||||
iconv -f ISO8859-1 -t UTF-8 -o README.new README
|
||||
@ -127,8 +192,11 @@ popd
|
||||
%build
|
||||
make \
|
||||
CFLAGS="%{build_cflags}" CXXFLAGS="%{build_cxxflags}" LDFLAGS="%{build_ldflags}" \
|
||||
%if %{without rust}
|
||||
HAVE_CARGO=0 \
|
||||
%endif
|
||||
HAVE_DRACUT=1 \
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
ENABLE_DOC=1 \
|
||||
%endif
|
||||
NO_PIE_LDFLAGS="" \
|
||||
@ -136,6 +204,10 @@ make \
|
||||
DISTRELEASE=%{release} \
|
||||
V=1
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native specific %%build section
|
||||
#
|
||||
pushd cmsfs-%{cmsfsver}
|
||||
./configure
|
||||
make CC="gcc %{build_cflags} -fno-strict-aliasing %{build_ldflags}"
|
||||
@ -144,12 +216,16 @@ popd
|
||||
pushd src_vipa-%{vipaver}
|
||||
make CC_FLAGS="%{build_cflags} -fPIC" LD_FLAGS="%{build_ldflags} -shared" LIBDIR=%{_libdir}
|
||||
popd
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
make install \
|
||||
%if %{without rust}
|
||||
HAVE_CARGO=0 \
|
||||
%endif
|
||||
HAVE_DRACUT=1 \
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
ENABLE_DOC=1 \
|
||||
%endif
|
||||
DESTDIR=%{buildroot} \
|
||||
@ -158,8 +234,12 @@ make install \
|
||||
DISTRELEASE=%{release} \
|
||||
V=1
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native specific %%install section
|
||||
#
|
||||
# sign the stage3 bootloader
|
||||
%if 0%{?signzipl}
|
||||
%if %{with signzipl}
|
||||
if [ -x /usr/bin/rpm-sign ]; then
|
||||
pushd %{buildroot}/lib/s390-tools/
|
||||
rpm-sign --key "%{pesign_name}" --lkmsign stage3.bin --output stage3.signed
|
||||
@ -229,11 +309,63 @@ install -p -m 644 %{SOURCE17} %{buildroot}%{_udevrulesdir}/81-ccw.rules
|
||||
|
||||
# zipl.conf to be ghosted
|
||||
touch %{buildroot}%{_sysconfdir}/zipl.conf
|
||||
%endif
|
||||
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native main %%files section
|
||||
#
|
||||
%files
|
||||
%doc README.md
|
||||
|
||||
%else
|
||||
#
|
||||
# multiarch %%files section
|
||||
#
|
||||
|
||||
%files
|
||||
%doc README.md
|
||||
%license LICENSE
|
||||
%{_bindir}/genprotimg
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvapconfig
|
||||
%endif
|
||||
%{_bindir}/pvattest
|
||||
%{_bindir}/pvextract-hdr
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvsecret
|
||||
%endif
|
||||
%{_mandir}/man1/genprotimg.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvapconfig.1*
|
||||
%endif
|
||||
%{_mandir}/man1/pvattest.1*
|
||||
%{_mandir}/man1/pvattest-create.1*
|
||||
%{_mandir}/man1/pvattest-perform.1*
|
||||
%{_mandir}/man1/pvattest-verify.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvsecret-add.1*
|
||||
%{_mandir}/man1/pvsecret-create-association.1*
|
||||
%{_mandir}/man1/pvsecret-create-meta.1*
|
||||
%{_mandir}/man1/pvsecret-create.1*
|
||||
%{_mandir}/man1/pvsecret-list.1*
|
||||
%{_mandir}/man1/pvsecret-lock.1*
|
||||
%{_mandir}/man1/pvsecret-version.1*
|
||||
%{_mandir}/man1/pvsecret.1*
|
||||
%endif
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
|
||||
#
|
||||
# enf of multi-arch section
|
||||
#
|
||||
%endif
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x specific sub-packages
|
||||
#
|
||||
#
|
||||
# ************************* s390-tools core package *************************
|
||||
#
|
||||
%package core
|
||||
@ -344,6 +476,7 @@ Requires: ethtool
|
||||
Requires: tar
|
||||
Requires: file
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-se-data = %{epoch}:%{version}-%{release}
|
||||
%{?systemd_requires}
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: ncurses-devel
|
||||
@ -351,7 +484,6 @@ BuildRequires: glibc-static
|
||||
BuildRequires: cryptsetup-devel >= 2.0.3
|
||||
BuildRequires: json-c-devel
|
||||
BuildRequires: rpm-devel
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libxml2-devel
|
||||
|
||||
|
||||
@ -548,8 +680,14 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_bindir}/dump2tar
|
||||
%{_bindir}/genprotimg
|
||||
%{_bindir}/mk-s390image
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvapconfig
|
||||
%endif
|
||||
%{_bindir}/pvattest
|
||||
%{_bindir}/pvextract-hdr
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvsecret
|
||||
%endif
|
||||
%{_bindir}/zkey
|
||||
%{_bindir}/zkey-cryptsetup
|
||||
%{_unitdir}/dumpconf.service
|
||||
@ -574,10 +712,23 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_libdir}/zkey/zkey-kmip.so
|
||||
%{_mandir}/man1/dump2tar.1*
|
||||
%{_mandir}/man1/genprotimg.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvapconfig.1*
|
||||
%endif
|
||||
%{_mandir}/man1/pvattest.1*
|
||||
%{_mandir}/man1/pvattest-create.1*
|
||||
%{_mandir}/man1/pvattest-perform.1*
|
||||
%{_mandir}/man1/pvattest-verify.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvsecret-add.1*
|
||||
%{_mandir}/man1/pvsecret-create-association.1*
|
||||
%{_mandir}/man1/pvsecret-create-meta.1*
|
||||
%{_mandir}/man1/pvsecret-create.1*
|
||||
%{_mandir}/man1/pvsecret-list.1*
|
||||
%{_mandir}/man1/pvsecret-lock.1*
|
||||
%{_mandir}/man1/pvsecret-version.1*
|
||||
%{_mandir}/man1/pvsecret.1*
|
||||
%endif
|
||||
%{_mandir}/man1/zkey.1*
|
||||
%{_mandir}/man1/zkey-cryptsetup.1*
|
||||
%{_mandir}/man1/zkey-ekmfweb.1*
|
||||
@ -628,7 +779,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_mandir}/man8/znetconf.8*
|
||||
%{_mandir}/man8/zpcictl.8*
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
%{_datadir}/s390-tools/netboot/
|
||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
|
||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/kmip
|
||||
@ -645,6 +795,18 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_libdir}/src_vipa.so
|
||||
%{_mandir}/man8/src_vipa.8*
|
||||
|
||||
%package se-data
|
||||
License: MIT
|
||||
Summary: Data for Secure Execution
|
||||
BuildArch: noarch
|
||||
|
||||
%description se-data
|
||||
%{summary}.
|
||||
|
||||
%files se-data
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
|
||||
#
|
||||
# *********************** s390-tools osasnmpd package ***********************
|
||||
#
|
||||
@ -949,7 +1111,7 @@ Summary: Use multipath information for re-IPL path failover
|
||||
BuildRequires: make
|
||||
BuildRequires: bash
|
||||
BuildRequires: coreutils
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
BuildRequires: pandoc
|
||||
%endif
|
||||
BuildRequires: gawk
|
||||
@ -970,7 +1132,7 @@ reconfigures the FCP re-IPL settings to use an operational path.
|
||||
|
||||
%files chreipl-fcp-mpath
|
||||
%doc chreipl-fcp-mpath/README.md
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
%doc chreipl-fcp-mpath/README.html
|
||||
%endif
|
||||
%dir %{_prefix}/lib/chreipl-fcp-mpath/
|
||||
@ -1002,10 +1164,52 @@ User-space development files for the s390/s390x architecture.
|
||||
%{_libdir}/libekmfweb.so
|
||||
%{_libdir}/libkmipclient.so
|
||||
|
||||
#
|
||||
# end of s390x specific sub-packages
|
||||
#
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Nov 01 2023 Eduard Abdullin <eabdullin@almalinux.org> - 2:2.27.0-3.alma.1
|
||||
- Update to 2.27.0
|
||||
* Mon Jan 29 2024 Dan Horák <dhorak@redhat.com> - 2:2.29.0-3
|
||||
- add s390utils-se-data as a noarch subpackage with Secure Execution data files
|
||||
- Resolves: RHEL-10568
|
||||
|
||||
* Fri Jan 19 2024 Dan Horák <dhorak@redhat.com> - 2:2.29.0-2
|
||||
- SE: Secure guest tool to bind and associate APQNs (RHEL-10575)
|
||||
- Resolves: RHEL-10575
|
||||
|
||||
* Mon Dec 04 2023 Dan Horák <dhorak@redhat.com> - 2:2.29.0-1
|
||||
- rebased to 2.29.0 (RHEL-11409)
|
||||
- KVM: Support AP Bindings in SE Header (RHEL-10573)
|
||||
- KVM: Userspace Tool for IBK Request Generation and Insertion (RHEL-10579)
|
||||
- zkey: support for key type PKEY_TYPE_EP11_AES (RHEL-11441)
|
||||
- vmur: fix handling of option -t (RHEL-11479)
|
||||
- dbginfo.sh: global original Input Field Separator (IFS) (RHEL-16526)
|
||||
- enable multi-arch build (RHEL-10568)
|
||||
- Resolves: RHEL-11409 RHEL-10573 RHEL-10579 RHEL-11441 RHEL-11479 RHEL-16526 RHEL-10568
|
||||
|
||||
* Mon Aug 07 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-3
|
||||
- zdev/dracut: fix kdump build to integrate with site support (#2229178)
|
||||
- Resolves: #2229178
|
||||
|
||||
* Fri Jul 21 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-2
|
||||
- Secure Execution APQN binding and IBK association (#2110510)
|
||||
- Resolves: #2110510
|
||||
|
||||
* Tue Jun 06 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-1.1
|
||||
- rebuild
|
||||
- Related: #2159698
|
||||
|
||||
* Mon Jun 05 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-1
|
||||
- rebased to 2.27.0 (#2159698)
|
||||
- lszcrypt fails when querying a specific domain (#2177613)
|
||||
- DASD autoquiesce support (#2196510)
|
||||
- zcrypt DD: AP command filtering (#2170362)
|
||||
- vmconvert and zgetdump consolidation (#2173925)
|
||||
- Support for List-Directed dump from ECKD DASD (#2159694)
|
||||
- Support for List-Directed IPL and re-IPL from ECKD DASD (#2159691)
|
||||
- Resolves: #2159698 #2177613 #2196510 #2170362 #2173925 #2159694 #2159691
|
||||
|
||||
* Fri Feb 03 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-2
|
||||
- zkey: Support EP11 host library version 4 (#2165811)
|
||||
|
Loading…
Reference in New Issue
Block a user