- rebased to 2.17.0
This commit is contained in:
parent
e4da637a53
commit
ce7722eab4
20
.gitignore
vendored
20
.gitignore
vendored
@ -5,22 +5,4 @@ src_vipa-2.0.4.tar.gz
|
|||||||
/lib-zfcp-hbaapi-2.1.tar.gz
|
/lib-zfcp-hbaapi-2.1.tar.gz
|
||||||
/src_vipa-2.1.0.tar.gz
|
/src_vipa-2.1.0.tar.gz
|
||||||
/s390-tools-*.tar.bz2
|
/s390-tools-*.tar.bz2
|
||||||
/s390-tools-2.0.0.tar.gz
|
/s390-tools-*.tar.gz
|
||||||
/s390-tools-2.1.0.tar.gz
|
|
||||||
/s390-tools-2.2.0.tar.gz
|
|
||||||
/s390-tools-2.3.0.tar.gz
|
|
||||||
/s390-tools-2.4.0.tar.gz
|
|
||||||
/s390-tools-2.5.0.tar.gz
|
|
||||||
/s390-tools-2.6.0.tar.gz
|
|
||||||
/s390-tools-2.7.0.tar.gz
|
|
||||||
/s390-tools-2.7.1.tar.gz
|
|
||||||
/s390-tools-2.8.0.tar.gz
|
|
||||||
/s390-tools-2.9.0.tar.gz
|
|
||||||
/s390-tools-2.10.0.tar.gz
|
|
||||||
/s390-tools-2.11.0.tar.gz
|
|
||||||
/s390-tools-2.12.0.tar.gz
|
|
||||||
/s390-tools-2.13.0.tar.gz
|
|
||||||
/s390-tools-2.14.0.tar.gz
|
|
||||||
/s390-tools-2.15.0.tar.gz
|
|
||||||
/s390-tools-2.15.1.tar.gz
|
|
||||||
/s390-tools-2.16.0.tar.gz
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,50 +0,0 @@
|
|||||||
From 3f3f063c98278f53ad3b34e68b70fca62eaea8fb Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Date: Tue, 23 Feb 2021 08:52:26 +0100
|
|
||||||
Subject: [PATCH] zkey: Fix build error when the compiler flags are overridden
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
When the compiler flags are overridden, the build of zkey may fail with:
|
|
||||||
|
|
||||||
kms.c:44:2: error: #error KMS_PLUGIN_LOCATION must be defined
|
|
||||||
44 | #error KMS_PLUGIN_LOCATION must be defined
|
|
||||||
| ^~~~~
|
|
||||||
|
|
||||||
The Makefile uses CFLAGS variable for defining the KMS_PLUGIN_LOCATION,
|
|
||||||
but it should rather use ALL_CFLAGS.
|
|
||||||
|
|
||||||
Also use ALL_CPPFLAGS for defining HAVE_LUKS2_SUPPORT.
|
|
||||||
|
|
||||||
Fixes: https://github.com/ibm-s390-linux/s390-tools/issues/108
|
|
||||||
|
|
||||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Reviewed-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
|
||||||
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
|
||||||
---
|
|
||||||
zkey/Makefile | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/zkey/Makefile b/zkey/Makefile
|
|
||||||
index 41129bcf..f74e2091 100644
|
|
||||||
--- a/zkey/Makefile
|
|
||||||
+++ b/zkey/Makefile
|
|
||||||
@@ -18,7 +18,7 @@ ifneq (${HAVE_CRYPTSETUP2},0)
|
|
||||||
ifneq (${HAVE_OPENSSL},0)
|
|
||||||
BUILD_TARGETS += zkey-cryptsetup
|
|
||||||
INSTALL_TARGETS += install-zkey-cryptsetup
|
|
||||||
- CPPFLAGS += -DHAVE_LUKS2_SUPPORT
|
|
||||||
+ ALL_CPPFLAGS += -DHAVE_LUKS2_SUPPORT
|
|
||||||
else
|
|
||||||
BUILD_TARGETS += zkey-cryptsetup-skip-openssl
|
|
||||||
INSTALL_TARGETS += zkey-cryptsetup-skip-openssl
|
|
||||||
@@ -34,7 +34,7 @@ endif
|
|
||||||
|
|
||||||
libs = $(rootdir)/libutil/libutil.a
|
|
||||||
|
|
||||||
-CFLAGS += -DKMS_PLUGIN_LOCATION=\"$(ZKEYKMSPLUGINDIR)\"
|
|
||||||
+ALL_CFLAGS += -DKMS_PLUGIN_LOCATION=\"$(ZKEYKMSPLUGINDIR)\"
|
|
||||||
|
|
||||||
detect-libcryptsetup.dep:
|
|
||||||
echo "#include <libcryptsetup.h>" > detect-libcryptsetup.dep
|
|
@ -5,14 +5,13 @@
|
|||||||
|
|
||||||
Name: s390utils
|
Name: s390utils
|
||||||
Summary: Utilities and daemons for IBM z Systems
|
Summary: Utilities and daemons for IBM z Systems
|
||||||
Version: 2.16.0
|
Version: 2.17.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: MIT
|
License: MIT
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
#URL: http://www.ibm.com/developerworks/linux/linux390/s390-tools.html
|
URL: https://github.com/ibm-s390-linux/s390-tools
|
||||||
URL: https://github.com/ibm-s390-tools/s390-tools
|
Source0: https://github.com/ibm-s390-linux/s390-tools/archive/v%{version}.tar.gz#/s390-tools-%{version}.tar.gz
|
||||||
Source0: https://github.com/ibm-s390-tools/s390-tools/archive/v%{version}.tar.gz#/s390-tools-%{version}.tar.gz
|
|
||||||
Source5: zfcpconf.sh
|
Source5: zfcpconf.sh
|
||||||
Source7: zfcp.udev
|
Source7: zfcp.udev
|
||||||
# files for DASD initialization
|
# files for DASD initialization
|
||||||
@ -35,12 +34,6 @@ Source25: 91-zipl.install
|
|||||||
Patch0: s390-tools-zipl-invert-script-options.patch
|
Patch0: s390-tools-zipl-invert-script-options.patch
|
||||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||||
|
|
||||||
# upstream fixes
|
|
||||||
# https://github.com/ibm-s390-linux/s390-tools/commit/3f3f063c98278f53ad3b34e68b70fca62eaea8fb
|
|
||||||
Patch100: s390-tools-2.16.0-zkey.patch
|
|
||||||
# https://github.com/ibm-s390-linux/s390-tools/commit/b6bdd7744aba06d82f30b0c84012f0b06ccb01de
|
|
||||||
Patch101: s390-tools-2.16.0-genprotimg.patch
|
|
||||||
|
|
||||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||||
@ -49,7 +42,7 @@ Requires: s390utils-mon_statd = %{epoch}:%{version}-%{release}
|
|||||||
Requires: s390utils-iucvterm = %{epoch}:%{version}-%{release}
|
Requires: s390utils-iucvterm = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-ziomon = %{epoch}:%{version}-%{release}
|
Requires: s390utils-ziomon = %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -67,10 +60,6 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
%patch0 -p1 -b .zipl-invert-script-options
|
%patch0 -p1 -b .zipl-invert-script-options
|
||||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||||
|
|
||||||
# upstream fixes
|
|
||||||
%patch100 -p1
|
|
||||||
%patch101 -p1
|
|
||||||
|
|
||||||
# remove --strip from install
|
# remove --strip from install
|
||||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||||
|
|
||||||
@ -259,6 +248,7 @@ BuildRequires: cryptsetup-devel >= 2.0.3
|
|||||||
BuildRequires: json-c-devel
|
BuildRequires: json-c-devel
|
||||||
BuildRequires: rpm-devel
|
BuildRequires: rpm-devel
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
|
||||||
|
|
||||||
%description base
|
%description base
|
||||||
@ -418,6 +408,7 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_sbindir}/dasdstat
|
%{_sbindir}/dasdstat
|
||||||
%{_sbindir}/dasdview
|
%{_sbindir}/dasdview
|
||||||
%{_sbindir}/dbginfo.sh
|
%{_sbindir}/dbginfo.sh
|
||||||
|
%{_sbindir}/hsavmcore
|
||||||
%{_sbindir}/hsci
|
%{_sbindir}/hsci
|
||||||
%{_sbindir}/hyptop
|
%{_sbindir}/hyptop
|
||||||
%{_sbindir}/ip_watcher.pl
|
%{_sbindir}/ip_watcher.pl
|
||||||
@ -425,6 +416,7 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_sbindir}/lscpumf
|
%{_sbindir}/lscpumf
|
||||||
%{_sbindir}/lscss
|
%{_sbindir}/lscss
|
||||||
%{_sbindir}/lsdasd
|
%{_sbindir}/lsdasd
|
||||||
|
%{_sbindir}/lshwc
|
||||||
%{_sbindir}/lsqeth
|
%{_sbindir}/lsqeth
|
||||||
%{_sbindir}/lsluns
|
%{_sbindir}/lsluns
|
||||||
%{_sbindir}/lsreipl
|
%{_sbindir}/lsreipl
|
||||||
@ -468,17 +460,22 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
/lib/s390-tools/zfcpdump/zfcpdump-initrd
|
/lib/s390-tools/zfcpdump/zfcpdump-initrd
|
||||||
/lib/s390-tools/znetcontrolunits
|
/lib/s390-tools/znetcontrolunits
|
||||||
%{_libdir}/libekmfweb.so.*
|
%{_libdir}/libekmfweb.so.*
|
||||||
|
%{_libdir}/libkmipclient.so.*
|
||||||
%{_libdir}/zkey/zkey-ekmfweb.so
|
%{_libdir}/zkey/zkey-ekmfweb.so
|
||||||
|
%{_libdir}/zkey/zkey-kmip.so
|
||||||
%{_mandir}/man1/dbginfo.sh.1*
|
%{_mandir}/man1/dbginfo.sh.1*
|
||||||
%{_mandir}/man1/dump2tar.1*
|
%{_mandir}/man1/dump2tar.1*
|
||||||
%{_mandir}/man1/lscpumf.1*
|
%{_mandir}/man1/lscpumf.1*
|
||||||
|
%{_mandir}/man1/lshwc.1*
|
||||||
%{_mandir}/man1/vmconvert.1*
|
%{_mandir}/man1/vmconvert.1*
|
||||||
%{_mandir}/man1/zfcpdbf.1*
|
%{_mandir}/man1/zfcpdbf.1*
|
||||||
%{_mandir}/man1/zipl-switch-to-blscfg.1*
|
%{_mandir}/man1/zipl-switch-to-blscfg.1*
|
||||||
%{_mandir}/man1/zkey.1*
|
%{_mandir}/man1/zkey.1*
|
||||||
%{_mandir}/man1/zkey-cryptsetup.1*
|
%{_mandir}/man1/zkey-cryptsetup.1*
|
||||||
%{_mandir}/man1/zkey-ekmfweb.1*
|
%{_mandir}/man1/zkey-ekmfweb.1*
|
||||||
|
%{_mandir}/man1/zkey-kmip.1*
|
||||||
%{_mandir}/man4/prandom.4*
|
%{_mandir}/man4/prandom.4*
|
||||||
|
%{_mandir}/man5/hsavmcore.conf.5*
|
||||||
%{_mandir}/man8/chccwdev.8*
|
%{_mandir}/man8/chccwdev.8*
|
||||||
%{_mandir}/man8/chchp.8*
|
%{_mandir}/man8/chchp.8*
|
||||||
%{_mandir}/man8/chcpumf.8*
|
%{_mandir}/man8/chcpumf.8*
|
||||||
@ -488,6 +485,7 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_mandir}/man8/dasdview.8*
|
%{_mandir}/man8/dasdview.8*
|
||||||
%{_mandir}/man8/dumpconf.8*
|
%{_mandir}/man8/dumpconf.8*
|
||||||
%{_mandir}/man8/genprotimg.8.*
|
%{_mandir}/man8/genprotimg.8.*
|
||||||
|
%{_mandir}/man8/hsavmcore.8*
|
||||||
%{_mandir}/man8/hsci.8*
|
%{_mandir}/man8/hsci.8*
|
||||||
%{_mandir}/man8/hyptop.8*
|
%{_mandir}/man8/hyptop.8*
|
||||||
%{_mandir}/man8/lschp.8*
|
%{_mandir}/man8/lschp.8*
|
||||||
@ -520,6 +518,9 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_datadir}/s390-tools/genprotimg/
|
%{_datadir}/s390-tools/genprotimg/
|
||||||
%{_datadir}/s390-tools/netboot/
|
%{_datadir}/s390-tools/netboot/
|
||||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
|
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
|
||||||
|
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/kmip
|
||||||
|
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/kmip/profiles
|
||||||
|
%config(noreplace) %attr(0660,root,zkeyadm)%{_sysconfdir}/zkey/kmip/profiles/*.profile
|
||||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/repository
|
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/repository
|
||||||
%config(noreplace) %attr(0660,root,zkeyadm)%{_sysconfdir}/zkey/kms-plugins.conf
|
%config(noreplace) %attr(0660,root,zkeyadm)%{_sysconfdir}/zkey/kms-plugins.conf
|
||||||
|
|
||||||
@ -813,10 +814,18 @@ User-space development files for the s390/s390x architecture.
|
|||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/%{name}/
|
%{_includedir}/%{name}/
|
||||||
%{_includedir}/ekmfweb/
|
%{_includedir}/ekmfweb/
|
||||||
|
%{_includedir}/kmipclient/
|
||||||
%{_libdir}/libekmfweb.so
|
%{_libdir}/libekmfweb.so
|
||||||
|
%{_libdir}/libkmipclient.so
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 07 2021 Dan Horák <dan[at]danny.cz> - 2:2.17.0-1
|
||||||
|
- rebased to 2.17.0
|
||||||
|
- zfcpconf: set exit code explicitly (#1977434)
|
||||||
|
- mk-s390image script requires file (#1973239)
|
||||||
|
- drop obsolete setting from device_cio_free.service (#1972449)
|
||||||
|
|
||||||
* Mon Mar 01 2021 Dan Horák <dan[at]danny.cz> - 2:2.16.0-2
|
* Mon Mar 01 2021 Dan Horák <dan[at]danny.cz> - 2:2.16.0-2
|
||||||
- drop superfluous Require from s390utils-base
|
- drop superfluous Require from s390utils-base
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (s390-tools-2.16.0.tar.gz) = d0866e2f372ba2938ccab264846d6cfe3db1b760cff6645fbefcd33a8ce8e7d971e442ccefda7e8e4d59818293147caa57fa593a3e66cd77e1e661928336793c
|
SHA512 (s390-tools-2.17.0.tar.gz) = 57d1c90e2a270c380fd7b4ac8efdd301299d9e8671a7ff10747557135b27a06e8124a49f50b8729b450550ced61599f392606bcbe5e499c5bd488b9e207945da
|
||||||
|
Loading…
Reference in New Issue
Block a user