- move vmcp to core (#1931287)
- rebased to 2.18.0 (#2011434) - Resolves: #2011434 #1931287
This commit is contained in:
parent
7c28ad9960
commit
caf9e5ac94
@ -8,8 +8,8 @@ diff -up s390-tools-2.9.0/zipl/src/Makefile.blscfg-rpm-nvr-sort s390-tools-2.9.0
|
|||||||
-libs = $(rootdir)/libutil/libutil.a
|
-libs = $(rootdir)/libutil/libutil.a
|
||||||
+libs = $(rootdir)/libutil/libutil.a -lrpmio -lrpm
|
+libs = $(rootdir)/libutil/libutil.a -lrpmio -lrpm
|
||||||
|
|
||||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o disk.o \
|
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||||
install.o zipl.o $(rootdir)/zipl/boot/data.o
|
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
||||||
diff -up s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort s390-tools-2.9.0/zipl/src/scan.c
|
diff -up s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort s390-tools-2.9.0/zipl/src/scan.c
|
||||||
--- s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort 2019-05-21 09:13:36.000000000 -0400
|
--- s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort 2019-05-21 09:13:36.000000000 -0400
|
||||||
+++ s390-tools-2.9.0/zipl/src/scan.c 2019-05-22 08:16:17.317273801 -0400
|
+++ s390-tools-2.9.0/zipl/src/scan.c 2019-05-22 08:16:17.317273801 -0400
|
||||||
|
@ -1,110 +0,0 @@
|
|||||||
From 66cca7c6765be5a5207315a8df6de599bba306cb Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexander Egorenkov <egorenar@linux.ibm.com>
|
|
||||||
Date: Wed, 21 Jul 2021 17:22:29 +0200
|
|
||||||
Subject: [PATCH 1/2] hsavmcore: Avoid recompilation of overlay during install
|
|
||||||
step
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
overlay.o was being recompiled during the install step because
|
|
||||||
it depended on the target check-dep-fuse which is phony and,
|
|
||||||
therefore, always outdated. The solution is to create an empty file
|
|
||||||
for the target check-dep-fuse after its successful completion. This
|
|
||||||
prevents make from rebuilding overlay.o during installation.
|
|
||||||
|
|
||||||
Closes: https://github.com/ibm-s390-linux/s390-tools/pull/118
|
|
||||||
Fixes: 5a7d2a58c8b3 ("hsavmcore: Fix fuse dependency checking")
|
|
||||||
Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com>
|
|
||||||
Suggested-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
|
||||||
(cherry picked from commit 80cb1553a30d7804d1521691e9b178c7613eaa8c)
|
|
||||||
---
|
|
||||||
hsavmcore/Makefile | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/hsavmcore/Makefile b/hsavmcore/Makefile
|
|
||||||
index 7c1d4fd..82e6abc 100644
|
|
||||||
--- a/hsavmcore/Makefile
|
|
||||||
+++ b/hsavmcore/Makefile
|
|
||||||
@@ -69,6 +69,7 @@ check-dep-fuse:
|
|
||||||
"fuse.h", \
|
|
||||||
"fuse-devel or libfuse-dev", \
|
|
||||||
"HAVE_FUSE=0")
|
|
||||||
+ touch check-dep-fuse
|
|
||||||
|
|
||||||
install: all
|
|
||||||
$(INSTALL) -g $(GROUP) -o $(OWNER) -m 755 hsavmcore \
|
|
||||||
@@ -81,6 +82,6 @@ install: all
|
|
||||||
endif # HAVE_FUSE
|
|
||||||
|
|
||||||
clean:
|
|
||||||
- rm -f hsavmcore $(objects)
|
|
||||||
+ rm -f hsavmcore $(objects) check-dep-fuse
|
|
||||||
|
|
||||||
.PHONY: all install clean
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
||||||
|
|
||||||
From f6f24d191ed29a1c6d49c1339e09f21fe7d24c19 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Date: Mon, 12 Jul 2021 13:20:52 +0200
|
|
||||||
Subject: [PATCH 2/2] libkmipclient: Fix parsing of hex values for XML and JSON
|
|
||||||
encoding (#1870700)
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
KMIP values of type BYTE-STRING are represented as hex values when XML
|
|
||||||
or JSON encoding is used. Do not drop any leading zero bytes, if the
|
|
||||||
value has them.
|
|
||||||
|
|
||||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
|
||||||
(cherry picked from commit d2a4a8b0f3f24a19bd0363b5a4f264b50ac4a885)
|
|
||||||
---
|
|
||||||
libkmipclient/utils.c | 12 +++++++-----
|
|
||||||
1 file changed, 7 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libkmipclient/utils.c b/libkmipclient/utils.c
|
|
||||||
index 4a88d0c..dbd03fd 100644
|
|
||||||
--- a/libkmipclient/utils.c
|
|
||||||
+++ b/libkmipclient/utils.c
|
|
||||||
@@ -125,7 +125,7 @@ int kmip_parse_hex(const char *str, bool has_prefix, unsigned char **val,
|
|
||||||
{
|
|
||||||
unsigned char *buf;
|
|
||||||
BIGNUM *b = NULL;
|
|
||||||
- int len, rc;
|
|
||||||
+ int len;
|
|
||||||
|
|
||||||
if (str == NULL)
|
|
||||||
return -EINVAL;
|
|
||||||
@@ -133,18 +133,20 @@ int kmip_parse_hex(const char *str, bool has_prefix, unsigned char **val,
|
|
||||||
if (has_prefix && strncmp(str, "0x", 2) != 0)
|
|
||||||
return -EBADMSG;
|
|
||||||
|
|
||||||
- rc = BN_hex2bn(&b, str + (has_prefix ? 2 : 0));
|
|
||||||
- if (rc <= 0)
|
|
||||||
+ len = BN_hex2bn(&b, str + (has_prefix ? 2 : 0));
|
|
||||||
+ if (len <= 0)
|
|
||||||
+ return -EBADMSG;
|
|
||||||
+ if (len < (int)strlen(str) - (has_prefix ? 2 : 0))
|
|
||||||
return -EBADMSG;
|
|
||||||
|
|
||||||
- len = BN_num_bytes(b);
|
|
||||||
+ len = len / 2 + (len % 2 > 0 ? 1 : 0);
|
|
||||||
buf = calloc(1, len);
|
|
||||||
if (buf == NULL) {
|
|
||||||
BN_free(b);
|
|
||||||
return -ENOMEM;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (BN_bn2bin(b, buf) != len) {
|
|
||||||
+ if (BN_bn2binpad(b, buf, len) != len) {
|
|
||||||
BN_free(b);
|
|
||||||
free(buf);
|
|
||||||
return -EIO;
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
0
s390utils-2.18.0-rhel.patch
Normal file
0
s390utils-2.18.0-rhel.patch
Normal file
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Name: s390utils
|
Name: s390utils
|
||||||
Summary: Utilities and daemons for IBM z Systems
|
Summary: Utilities and daemons for IBM z Systems
|
||||||
Version: 2.17.0
|
Version: 2.18.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: MIT
|
License: MIT
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
@ -34,7 +34,7 @@ Patch0: s390-tools-zipl-invert-script-options.patch
|
|||||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||||
|
|
||||||
# backported fixes
|
# backported fixes
|
||||||
Patch100: s390utils-2.17.0-rhel.patch
|
Patch100: s390utils-2.18.0-rhel.patch
|
||||||
|
|
||||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
@ -185,11 +185,14 @@ This package provides minimal set of tools needed to system to boot.
|
|||||||
%{_sbindir}/dasdinfo
|
%{_sbindir}/dasdinfo
|
||||||
%{_sbindir}/fdasd
|
%{_sbindir}/fdasd
|
||||||
%{_sbindir}/lszdev
|
%{_sbindir}/lszdev
|
||||||
|
%{_sbindir}/vmcp
|
||||||
%{_sbindir}/zipl
|
%{_sbindir}/zipl
|
||||||
|
%{_sbindir}/zipl-editenv
|
||||||
%dir /lib/s390-tools
|
%dir /lib/s390-tools
|
||||||
/lib/s390-tools/{zipl,chreipl}_helper.*
|
/lib/s390-tools/{zipl,chreipl}_helper.*
|
||||||
/lib/s390-tools/cpictl
|
/lib/s390-tools/cpictl
|
||||||
/lib/s390-tools/stage3.bin
|
/lib/s390-tools/stage3.bin
|
||||||
|
/lib/s390-tools/zdev_id
|
||||||
/lib/s390-tools/zdev-root-update
|
/lib/s390-tools/zdev-root-update
|
||||||
/lib/s390-tools/zipl.conf
|
/lib/s390-tools/zipl.conf
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/zipl.conf
|
%ghost %config(noreplace) %{_sysconfdir}/zipl.conf
|
||||||
@ -204,7 +207,9 @@ This package provides minimal set of tools needed to system to boot.
|
|||||||
%{_mandir}/man8/dasdinfo.8*
|
%{_mandir}/man8/dasdinfo.8*
|
||||||
%{_mandir}/man8/fdasd.8*
|
%{_mandir}/man8/fdasd.8*
|
||||||
%{_mandir}/man8/lszdev.8*
|
%{_mandir}/man8/lszdev.8*
|
||||||
|
%{_mandir}/man8/vmcp.8*
|
||||||
%{_mandir}/man8/zipl.8*
|
%{_mandir}/man8/zipl.8*
|
||||||
|
%{_mandir}/man8/zipl-editenv.8*
|
||||||
|
|
||||||
# Additional Fedora/RHEL specific stuff
|
# Additional Fedora/RHEL specific stuff
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/dasd.conf
|
%ghost %config(noreplace) %{_sysconfdir}/dasd.conf
|
||||||
@ -224,6 +229,7 @@ This package provides minimal set of tools needed to system to boot.
|
|||||||
%{_udevrulesdir}/59-dasd.rules
|
%{_udevrulesdir}/59-dasd.rules
|
||||||
%{_udevrulesdir}/60-readahead.rules
|
%{_udevrulesdir}/60-readahead.rules
|
||||||
%{_udevrulesdir}/81-ccw.rules
|
%{_udevrulesdir}/81-ccw.rules
|
||||||
|
%{_udevrulesdir}/81-dpm.rules
|
||||||
%{_udevrulesdir}/90-cpi.rules
|
%{_udevrulesdir}/90-cpi.rules
|
||||||
%{_sysconfdir}/kernel/install.d/20-grubby.install
|
%{_sysconfdir}/kernel/install.d/20-grubby.install
|
||||||
%{_prefix}/lib/kernel/install.d/10-zfcpdump.install
|
%{_prefix}/lib/kernel/install.d/10-zfcpdump.install
|
||||||
@ -435,12 +441,12 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_sbindir}/qethconf
|
%{_sbindir}/qethconf
|
||||||
%{_sbindir}/qethqoat
|
%{_sbindir}/qethqoat
|
||||||
%{_sbindir}/scsi_logging_level
|
%{_sbindir}/scsi_logging_level
|
||||||
|
%{_sbindir}/sclpdbf
|
||||||
%{_sbindir}/start_hsnc.sh
|
%{_sbindir}/start_hsnc.sh
|
||||||
%{_sbindir}/tape390_crypt
|
%{_sbindir}/tape390_crypt
|
||||||
%{_sbindir}/tape390_display
|
%{_sbindir}/tape390_display
|
||||||
%{_sbindir}/ttyrun
|
%{_sbindir}/ttyrun
|
||||||
%{_sbindir}/tunedasd
|
%{_sbindir}/tunedasd
|
||||||
%{_sbindir}/vmcp
|
|
||||||
%{_sbindir}/vmur
|
%{_sbindir}/vmur
|
||||||
%{_sbindir}/xcec-bridge
|
%{_sbindir}/xcec-bridge
|
||||||
%{_sbindir}/zcryptctl
|
%{_sbindir}/zcryptctl
|
||||||
@ -513,7 +519,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_mandir}/man8/tape390_display.8*
|
%{_mandir}/man8/tape390_display.8*
|
||||||
%{_mandir}/man8/ttyrun.8*
|
%{_mandir}/man8/ttyrun.8*
|
||||||
%{_mandir}/man8/tunedasd.8*
|
%{_mandir}/man8/tunedasd.8*
|
||||||
%{_mandir}/man8/vmcp.8*
|
|
||||||
%{_mandir}/man8/vmur.8*
|
%{_mandir}/man8/vmur.8*
|
||||||
%{_mandir}/man8/zcryptctl.8*
|
%{_mandir}/man8/zcryptctl.8*
|
||||||
%{_mandir}/man8/zcryptstats.8*
|
%{_mandir}/man8/zcryptstats.8*
|
||||||
@ -826,6 +831,11 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 05 2021 Dan Horák <dan[at]danny.cz> - 2:2.18.0-1
|
||||||
|
- move vmcp to core (#1931287)
|
||||||
|
- rebased to 2.18.0 (#2011434)
|
||||||
|
- Resolves: #2011434 #1931287
|
||||||
|
|
||||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2:2.17.0-4
|
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2:2.17.0-4
|
||||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
Related: rhbz#1991688
|
Related: rhbz#1991688
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (s390-tools-2.17.0.tar.gz) = 57d1c90e2a270c380fd7b4ac8efdd301299d9e8671a7ff10747557135b27a06e8124a49f50b8729b450550ced61599f392606bcbe5e499c5bd488b9e207945da
|
SHA512 (s390-tools-2.18.0.tar.gz) = 498cbc55d7d84f72e9ec0f625267a26377a80f7be3bd967ec380531b6430d5ea0a192d92024ccd1f70acfe4a1c5aeaa9004110a158830972ca0a0204e7b9d328
|
||||||
|
Loading…
Reference in New Issue
Block a user