include fixed ccw_init and updated device_cio_free
This commit is contained in:
parent
36d50ba5f4
commit
ca07d6e6f0
@ -1,12 +0,0 @@
|
|||||||
diff -up s390-tools-1.8.2/ziomon/Makefile.linker s390-tools-1.8.2/ziomon/Makefile
|
|
||||||
--- s390-tools-1.8.2/ziomon/Makefile.linker 2010-06-10 08:54:55.000000000 +0200
|
|
||||||
+++ s390-tools-1.8.2/ziomon/Makefile 2010-06-10 08:55:48.000000000 +0200
|
|
||||||
@@ -21,7 +21,7 @@ ziomon_util: ziomon_util_main.o ziomon_t
|
|
||||||
ziomon_zfcpdd_main.o: ziomon_zfcpdd.c ziomon_zfcpdd.h
|
|
||||||
$(CC) -DWITH_MAIN $(CFLAGS) $(CPPFLAGS) -c $< -o $@
|
|
||||||
ziomon_zfcpdd: ziomon_zfcpdd_main.o ziomon_tools.o
|
|
||||||
- $(LINK) $^ -o $@ -lm -lrt
|
|
||||||
+ $(LINK) $^ -o $@ -lm -lrt -lpthread
|
|
||||||
|
|
||||||
ziorep_traffic: ziorep_traffic.o ziorep_framer.o ziorep_frameset.o \
|
|
||||||
ziorep_printers.o ziomon_dacc.o ziomon_util.o \
|
|
2
ccw_init
2
ccw_init
@ -88,7 +88,7 @@ if [ -n "$PORTNAME" ]; then
|
|||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
if [ "$NETTYPE" = "ctc" -a -n "$CTCPROT" ]; then
|
if [ "$NETTYPE" = "ctc" -a -n "$CTCPROT" ]; then
|
||||||
OPTIONS="$OPTIONS protocol=$CTCPROTO"
|
OPTIONS="$OPTIONS protocol=$CTCPROT"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# SUBCHANNELS is only set on mainframe ccwgroup devices
|
# SUBCHANNELS is only set on mainframe ccwgroup devices
|
||||||
|
@ -26,6 +26,7 @@ DASDCONFIG=/etc/dasd.conf
|
|||||||
ZFCPCONFIG=/etc/zfcp.conf
|
ZFCPCONFIG=/etc/zfcp.conf
|
||||||
ZNETCONFIG=/etc/ccw.conf
|
ZNETCONFIG=/etc/ccw.conf
|
||||||
BLACKLIST=/proc/cio_ignore
|
BLACKLIST=/proc/cio_ignore
|
||||||
|
CIO_SETTLE=/proc/cio_settle
|
||||||
VERBOSE=
|
VERBOSE=
|
||||||
PATH=/bin:/sbin
|
PATH=/bin:/sbin
|
||||||
DEVICE= # list of devices given on command line
|
DEVICE= # list of devices given on command line
|
||||||
@ -302,4 +303,9 @@ fi
|
|||||||
|
|
||||||
[ -z "$ALL_DEVICES" ] && exit 0
|
[ -z "$ALL_DEVICES" ] && exit 0
|
||||||
|
|
||||||
wait_on_devices
|
if [ -w $CIO_SETTLE ]; then
|
||||||
|
[ $VERBOSE ] && echo "Waiting until all pending CIO requests are processed"
|
||||||
|
echo 1 > $CIO_SETTLE
|
||||||
|
else
|
||||||
|
wait_on_devices
|
||||||
|
fi
|
||||||
|
@ -8,7 +8,7 @@ Name: s390utils
|
|||||||
Summary: Utilities and daemons for IBM System/z
|
Summary: Utilities and daemons for IBM System/z
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Version: 1.16.0
|
Version: 1.16.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: GPLv2 and GPLv2+ and CPL
|
License: GPLv2 and GPLv2+ and CPL
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -40,18 +40,16 @@ Source19: mon_statd.initd
|
|||||||
|
|
||||||
Patch1: s390-tools-1.14.0-fedora.patch
|
Patch1: s390-tools-1.14.0-fedora.patch
|
||||||
|
|
||||||
Patch1000: 1000-ziomon-linker.patch
|
Patch1000: cmsfs-1.1.8-warnings.patch
|
||||||
|
Patch1001: cmsfs-1.1.8-kernel26.patch
|
||||||
|
Patch1002: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
|
||||||
|
|
||||||
Patch100: cmsfs-1.1.8-warnings.patch
|
Patch2000: src_vipa-2.0.4-locations.patch
|
||||||
Patch101: cmsfs-1.1.8-kernel26.patch
|
|
||||||
Patch102: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
|
|
||||||
|
|
||||||
Patch200: src_vipa-2.0.4-locations.patch
|
Patch3001: lib-zfcp-hbaapi-2.1-module.patch
|
||||||
|
Patch3002: lib-zfcp-hbaapi-2.1-u8.patch
|
||||||
Patch301: lib-zfcp-hbaapi-2.1-module.patch
|
Patch3003: lib-zfcp-hbaapi-2.1-vendorlib.patch
|
||||||
Patch302: lib-zfcp-hbaapi-2.1-u8.patch
|
Patch3004: lib-zfcp-hbaapi-2.1-HBA_FreeLibrary.patch
|
||||||
Patch303: lib-zfcp-hbaapi-2.1-vendorlib.patch
|
|
||||||
Patch304: lib-zfcp-hbaapi-2.1-HBA_FreeLibrary.patch
|
|
||||||
|
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||||
@ -76,22 +74,18 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
# Fedora/RHEL changes
|
# Fedora/RHEL changes
|
||||||
%patch1 -p1 -b .fedora
|
%patch1 -p1 -b .fedora
|
||||||
|
|
||||||
|
|
||||||
# Fix linking with --no-add-needed
|
|
||||||
#%patch1000 -p1 -b .linker
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# cmsfs
|
# cmsfs
|
||||||
#
|
#
|
||||||
pushd cmsfs-%{cmsfsver}
|
pushd cmsfs-%{cmsfsver}
|
||||||
# Patch to fix a couple of code bugs
|
# Patch to fix a couple of code bugs
|
||||||
%patch100 -p1 -b .warnings
|
%patch1000 -p1 -b .warnings
|
||||||
|
|
||||||
# build on kernel-2.6, too
|
# build on kernel-2.6, too
|
||||||
%patch101 -p1 -b .cmsfs26
|
%patch1001 -p1 -b .cmsfs26
|
||||||
|
|
||||||
# use detected filesystem block size (#651012)
|
# use detected filesystem block size (#651012)
|
||||||
%patch102 -p1 -b .use-detected-block-size
|
%patch1002 -p1 -b .use-detected-block-size
|
||||||
popd
|
popd
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -99,7 +93,7 @@ popd
|
|||||||
#
|
#
|
||||||
pushd src_vipa-%{vipaver}
|
pushd src_vipa-%{vipaver}
|
||||||
# fix location of the library
|
# fix location of the library
|
||||||
%patch200 -p1 -b .locations
|
%patch2000 -p1 -b .locations
|
||||||
popd
|
popd
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -107,13 +101,13 @@ popd
|
|||||||
#
|
#
|
||||||
pushd lib-zfcp-hbaapi-%{hbaapiver}
|
pushd lib-zfcp-hbaapi-%{hbaapiver}
|
||||||
# build the library as a module
|
# build the library as a module
|
||||||
%patch301 -p1 -b .module
|
%patch3001 -p1 -b .module
|
||||||
|
|
||||||
# kernel headers need u8 type
|
# kernel headers need u8 type
|
||||||
%patch302 -p1 -b .u8
|
%patch3002 -p1 -b .u8
|
||||||
|
|
||||||
# fix linking of the tools when using vendor library mode
|
# fix linking of the tools when using vendor library mode
|
||||||
%patch303 -p1 -b .vendorlib
|
%patch3003 -p1 -b .vendorlib
|
||||||
popd
|
popd
|
||||||
|
|
||||||
# remove --strip from install
|
# remove --strip from install
|
||||||
@ -860,6 +854,9 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 10 2012 Dan Horák <dan[at]danny.cz> 2:1.16.0-3
|
||||||
|
- include fixed ccw_init and updated device_cio_free
|
||||||
|
|
||||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.16.0-2
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.16.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user