- rebased to 2.25.0
This commit is contained in:
parent
bef2b35dc9
commit
c33643ba10
@ -1,4 +1,4 @@
|
|||||||
From 14119148dabb7f4f633623c00eece44c5771db10 Mon Sep 17 00:00:00 2001
|
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
|||||||
return n;
|
return n;
|
||||||
|
|
||||||
--
|
--
|
||||||
2.36.1
|
2.37.3
|
||||||
|
|
||||||
|
|
||||||
From 661f143bb0b429c732d0ad9756c745dcb8799bc7 Mon Sep 17 00:00:00 2001
|
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Jones <pjones@redhat.com>
|
From: Peter Jones <pjones@redhat.com>
|
||||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||||
@ -208,20 +208,19 @@ Content-Transfer-Encoding: 8bit
|
|||||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||||
Signed-off-by: Dan Horák <dan@danny.cz>
|
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||||
---
|
---
|
||||||
zipl/src/Makefile | 2 +-
|
zipl/src/Makefile | 1 +
|
||||||
zipl/src/scan.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++-
|
zipl/src/scan.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++-
|
||||||
2 files changed, 95 insertions(+), 3 deletions(-)
|
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||||
index 786bb7f..1adc486 100644
|
index 64eabe4..7043005 100644
|
||||||
--- a/zipl/src/Makefile
|
--- a/zipl/src/Makefile
|
||||||
+++ b/zipl/src/Makefile
|
+++ b/zipl/src/Makefile
|
||||||
@@ -7,7 +7,7 @@ ALL_CPPFLAGS += -I../include -I../boot \
|
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||||
-D_FILE_OFFSET_BITS=64 $(NO_PIE_CFLAGS)
|
|
||||||
ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
|
||||||
|
|
||||||
-libs = $(rootdir)/libutil/libutil.a
|
libs = $(rootdir)/libutil/libutil.a \
|
||||||
+libs = $(rootdir)/libutil/libutil.a -lrpmio -lrpm
|
$(rootdir)/libvtoc/libvtoc.a \
|
||||||
|
+ -lrpmio -lrpm
|
||||||
|
|
||||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||||
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
||||||
@ -345,5 +344,5 @@ index 9352f76..3327e2d 100644
|
|||||||
static int
|
static int
|
||||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||||
--
|
--
|
||||||
2.36.1
|
2.37.3
|
||||||
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
0
s390utils-2.25.0-fedora.patch
Normal file
0
s390utils-2.25.0-fedora.patch
Normal file
@ -9,8 +9,8 @@
|
|||||||
|
|
||||||
Name: s390utils
|
Name: s390utils
|
||||||
Summary: Utilities and daemons for IBM z Systems
|
Summary: Utilities and daemons for IBM z Systems
|
||||||
Version: 2.24.0
|
Version: 2.25.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: MIT
|
License: MIT
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
@ -38,7 +38,7 @@ Patch0: s390-tools-zipl-invert-script-options.patch
|
|||||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||||
|
|
||||||
# upstream fixes/updates
|
# upstream fixes/updates
|
||||||
Patch100: s390utils-%{version}-fedora.patch
|
#Patch100: s390utils-%%{version}-fedora.patch
|
||||||
|
|
||||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
@ -67,7 +67,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||||
|
|
||||||
# upstream fixes/updates
|
# upstream fixes/updates
|
||||||
%patch100 -p1
|
#%%patch100 -p1
|
||||||
|
|
||||||
# drop -Werror from genprotimg to allow building with GCC 12
|
# drop -Werror from genprotimg to allow building with GCC 12
|
||||||
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
||||||
@ -486,6 +486,11 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%config(noreplace) %{_sysconfdir}/sysconfig/dumpconf
|
%config(noreplace) %{_sysconfdir}/sysconfig/dumpconf
|
||||||
%{_sysconfdir}/mdevctl.d/*
|
%{_sysconfdir}/mdevctl.d/*
|
||||||
/usr/lib/dracut/modules.d/99ngdump/
|
/usr/lib/dracut/modules.d/99ngdump/
|
||||||
|
# own the mdevctl dirs until new release is available
|
||||||
|
%dir /usr/lib/mdevctl
|
||||||
|
%dir /usr/lib/mdevctl/scripts.d
|
||||||
|
%dir /usr/lib/mdevctl/scripts.d/callouts
|
||||||
|
/usr/lib/mdevctl/scripts.d/callouts/ap-check
|
||||||
/lib/s390-tools/dumpconf
|
/lib/s390-tools/dumpconf
|
||||||
/lib/s390-tools/lsznet.raw
|
/lib/s390-tools/lsznet.raw
|
||||||
%dir /lib/s390-tools/zfcpdump
|
%dir /lib/s390-tools/zfcpdump
|
||||||
@ -902,6 +907,9 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 09 2022 Dan Horák <dan[at]danny.cz> - 2:2.25.0-1
|
||||||
|
- rebased to 2.25.0
|
||||||
|
|
||||||
* Tue Nov 22 2022 Dan Horák <dan[at]danny.cz> - 2:2.24.0-2
|
* Tue Nov 22 2022 Dan Horák <dan[at]danny.cz> - 2:2.24.0-2
|
||||||
- update for Transparent DASD PPRC (Peer-to-Peer Remote Copy) handling
|
- update for Transparent DASD PPRC (Peer-to-Peer Remote Copy) handling
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (s390-tools-2.24.0.tar.gz) = 5c681a031c2bab0ab167623ad08da67bfd236e4892f8a5de813ebfbbc1c60a842f0954bcbca6d2f6ab125ee089b2b5dcbfbb24152bcdde3401810232e21460f4
|
SHA512 (s390-tools-2.25.0.tar.gz) = 1c766a4bd19c957596c741a80141712acf150591c0ff1a47caf1aa8a17f7153c1441560f05aef78bb3f05bd35c1fef431569cabd7e7d6b003bd74beedb7213d9
|
||||||
|
Loading…
Reference in New Issue
Block a user