Import from AlmaLinux stable repository
This commit is contained in:
parent
b9c09cb33d
commit
9a1596e6ac
3
.gitignore
vendored
3
.gitignore
vendored
@ -1 +1,2 @@
|
||||
SOURCES/s390-tools-2.25.0.tar.gz
|
||||
SOURCES/s390-tools-2.29.0-rust-vendor.tar.xz
|
||||
SOURCES/s390-tools-2.29.0.tar.gz
|
||||
|
@ -1 +1,2 @@
|
||||
e8e0d3f651179fd14dc4a40d53a1e4ef6edaae7d SOURCES/s390-tools-2.25.0.tar.gz
|
||||
1dcae3e55c2d4d945d0b5c61a12671468aa5f7ef SOURCES/s390-tools-2.29.0-rust-vendor.tar.xz
|
||||
e10ffbde7f3fcf4438fdfdd83051ad68518e7be5 SOURCES/s390-tools-2.29.0.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
||||
From b2daaa34776ba6afec879e362378f6f7563590a6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
||||
return n;
|
||||
|
||||
--
|
||||
2.37.3
|
||||
2.39.2
|
||||
|
||||
|
||||
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
||||
From 692e70bcfc32a05e30146bd7077c41e0eaceff03 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||
@ -213,7 +213,7 @@ Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||
index 64eabe4..7043005 100644
|
||||
index cab5655..7ec215d 100644
|
||||
--- a/zipl/src/Makefile
|
||||
+++ b/zipl/src/Makefile
|
||||
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||
@ -223,7 +223,7 @@ index 64eabe4..7043005 100644
|
||||
+ -lrpmio -lrpm
|
||||
|
||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
||||
bootmap_header.o envblk.o install.o zipl.o
|
||||
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
|
||||
index 9352f76..3327e2d 100644
|
||||
--- a/zipl/src/scan.c
|
||||
@ -344,5 +344,5 @@ index 9352f76..3327e2d 100644
|
||||
static int
|
||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||
--
|
||||
2.37.3
|
||||
2.39.2
|
||||
|
||||
|
@ -1,35 +0,0 @@
|
||||
From a9fed51fbf159a98fcd4a9dddf4fef243bb433af Mon Sep 17 00:00:00 2001
|
||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Date: Fri, 20 Jan 2023 11:04:18 +0100
|
||||
Subject: [PATCH] zkey: Support EP11 host library version 4 (#2165812)
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Try to load libep11.so.4 if available, but fallback to older
|
||||
library versions if not.
|
||||
|
||||
Reviewed-by: Jörg Schmidbauer <jschmidb@de.ibm.com>
|
||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||
(cherry picked from commit 6222c384958729bc4b5bad61ad38967647cc3248)
|
||||
---
|
||||
zkey/ep11.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/zkey/ep11.c b/zkey/ep11.c
|
||||
index 58dc3c5..8359929 100644
|
||||
--- a/zkey/ep11.c
|
||||
+++ b/zkey/ep11.c
|
||||
@@ -35,7 +35,7 @@
|
||||
* Definitions for the EP11 library
|
||||
*/
|
||||
#define EP11_LIBRARY_NAME "libep11.so"
|
||||
-#define EP11_LIBRARY_VERSION 3
|
||||
+#define EP11_LIBRARY_VERSION 4
|
||||
#define EP11_WEB_PAGE "http://www.ibm.com/security/cryptocards"
|
||||
|
||||
/**
|
||||
--
|
||||
2.39.1
|
||||
|
5719
SOURCES/s390utils-2.29.0-rhel.patch
Normal file
5719
SOURCES/s390utils-2.29.0-rhel.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,21 +1,30 @@
|
||||
# secure boot support is for RHEL only
|
||||
%if 0%{?rhel} >= 8
|
||||
%global signzipl 1
|
||||
%bcond_without signzipl
|
||||
%else
|
||||
%bcond_with signzipl
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%global with_pandoc 1
|
||||
%bcond_without pandoc
|
||||
%else
|
||||
%bcond_with pandoc
|
||||
%endif
|
||||
%bcond_without rust
|
||||
|
||||
Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Version: 2.25.0
|
||||
Release: 4%{?dist}
|
||||
Version: 2.29.0
|
||||
Release: 3%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
URL: https://github.com/ibm-s390-linux/s390-tools
|
||||
Source0: https://github.com/ibm-s390-linux/s390-tools/archive/v%{version}.tar.gz#/s390-tools-%{version}.tar.gz
|
||||
# To create the vendor tarball:
|
||||
# tar xf s390-tools-%%{version}.tar.gz ; pushd s390-tools-%%{version}/rust/pvsecret ; \
|
||||
# rm -f Cargo.lock && cargo vendor && \
|
||||
# tar Jvcf ../../../s390-tools-%%{version}-rust-vendor.tar.xz vendor/ ; popd
|
||||
Source1: s390-tools-%{version}-rust-vendor.tar.xz
|
||||
Source5: https://fedorapeople.org/cgit/sharkcz/public_git/utils.git/tree/zfcpconf.sh
|
||||
Source7: https://fedorapeople.org/cgit/sharkcz/public_git/utils.git/tree/zfcp.udev
|
||||
Source12: https://fedorapeople.org/cgit/sharkcz/public_git/utils.git/tree/dasd.udev
|
||||
@ -29,7 +38,7 @@ Source23: 20-zipl-kernel.install
|
||||
Source24: 52-zipl-rescue.install
|
||||
Source25: 91-zipl.install
|
||||
|
||||
%if 0%{?signzipl}
|
||||
%if %{with signzipl}
|
||||
%define pesign_name redhatsecureboot302
|
||||
%endif
|
||||
|
||||
@ -38,8 +47,15 @@ Patch0: s390-tools-zipl-invert-script-options.patch
|
||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||
|
||||
# upstream fixes/updates
|
||||
Patch100: s390utils-%%{version}-rhel.patch
|
||||
Patch100: s390utils-%{version}-rhel.patch
|
||||
|
||||
# https://fedoraproject.org/wiki/Changes/EncourageI686LeafRemoval
|
||||
ExcludeArch: %{ix86}
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native package structure
|
||||
#
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||
@ -47,9 +63,47 @@ Requires: s390utils-cpuplugd = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-mon_statd = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-iucvterm = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-ziomon = %{epoch}:%{version}-%{release}
|
||||
%else
|
||||
#
|
||||
# multiarch package structure
|
||||
#
|
||||
Requires: s390utils-se-data = %{epoch}:%{version}-%{release}
|
||||
%endif
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: glib2-devel
|
||||
%if %{with rust}
|
||||
%if 0%{?rhel}
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: rust-toolset
|
||||
%else
|
||||
BuildRequires: crate(anstream)
|
||||
BuildRequires: crate(anstyle-query)
|
||||
BuildRequires: crate(anyhow)
|
||||
BuildRequires: crate(byteorder)
|
||||
BuildRequires: crate(cfg-if)
|
||||
BuildRequires: crate(clap)
|
||||
BuildRequires: crate(clap_complete)
|
||||
BuildRequires: crate(clap_derive)
|
||||
BuildRequires: crate(colorchoice)
|
||||
BuildRequires: crate(curl)
|
||||
BuildRequires: crate(is-terminal)
|
||||
BuildRequires: crate(libc)
|
||||
BuildRequires: crate(log)
|
||||
BuildRequires: crate(openssl)
|
||||
BuildRequires: crate(openssl-probe)
|
||||
BuildRequires: crate(serde)
|
||||
BuildRequires: crate(serde_derive)
|
||||
BuildRequires: crate(serde_yaml)
|
||||
BuildRequires: crate(strsim)
|
||||
BuildRequires: crate(terminal_size)
|
||||
BuildRequires: crate(thiserror)
|
||||
BuildRequires: crate(zerocopy)
|
||||
BuildRequires: rust-packaging
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%description
|
||||
This is a meta package for installing the default s390-tools sub packages.
|
||||
@ -69,18 +123,29 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
||||
# upstream fixes/updates
|
||||
%patch100 -p1
|
||||
|
||||
# drop -Werror from genprotimg to allow building with GCC 12
|
||||
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
||||
|
||||
# remove --strip from install
|
||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||
|
||||
%if %{with rust}
|
||||
%if 0%{?rhel}
|
||||
pushd rust
|
||||
%cargo_prep -V 1
|
||||
popd
|
||||
%else
|
||||
%cargo_prep
|
||||
%endif
|
||||
rm -rf ./rust/Cargo.lock
|
||||
%endif
|
||||
|
||||
|
||||
%build
|
||||
make \
|
||||
CFLAGS="%{build_cflags}" CXXFLAGS="%{build_cxxflags}" LDFLAGS="%{build_ldflags}" \
|
||||
%if %{without rust}
|
||||
HAVE_CARGO=0 \
|
||||
%endif
|
||||
HAVE_DRACUT=1 \
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
ENABLE_DOC=1 \
|
||||
%endif
|
||||
NO_PIE_LDFLAGS="" \
|
||||
@ -91,8 +156,11 @@ make \
|
||||
|
||||
%install
|
||||
make install \
|
||||
%if %{without rust}
|
||||
HAVE_CARGO=0 \
|
||||
%endif
|
||||
HAVE_DRACUT=1 \
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
ENABLE_DOC=1 \
|
||||
%endif
|
||||
DESTDIR=%{buildroot} \
|
||||
@ -101,8 +169,12 @@ make install \
|
||||
DISTRELEASE=%{release} \
|
||||
V=1
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native specific %%install section
|
||||
#
|
||||
# sign the stage3 bootloader
|
||||
%if 0%{?signzipl}
|
||||
%if %{with signzipl}
|
||||
if [ -x /usr/bin/rpm-sign ]; then
|
||||
pushd %{buildroot}/lib/s390-tools/
|
||||
rpm-sign --key "%{pesign_name}" --lkmsign stage3.bin --output stage3.signed
|
||||
@ -160,11 +232,62 @@ install -p -m 644 %{SOURCE17} %{buildroot}%{_udevrulesdir}/81-ccw.rules
|
||||
|
||||
# zipl.conf to be ghosted
|
||||
touch %{buildroot}%{_sysconfdir}/zipl.conf
|
||||
%endif
|
||||
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native main %%files section
|
||||
#
|
||||
%files
|
||||
%doc README.md
|
||||
|
||||
%else
|
||||
#
|
||||
# multiarch %%files section
|
||||
#
|
||||
|
||||
%files
|
||||
%doc README.md
|
||||
%license LICENSE
|
||||
%{_bindir}/genprotimg
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvapconfig
|
||||
%endif
|
||||
%{_bindir}/pvattest
|
||||
%{_bindir}/pvextract-hdr
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvsecret
|
||||
%endif
|
||||
%{_mandir}/man1/genprotimg.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvapconfig.1*
|
||||
%endif
|
||||
%{_mandir}/man1/pvattest.1*
|
||||
%{_mandir}/man1/pvattest-create.1*
|
||||
%{_mandir}/man1/pvattest-perform.1*
|
||||
%{_mandir}/man1/pvattest-verify.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvsecret-add.1*
|
||||
%{_mandir}/man1/pvsecret-create-association.1*
|
||||
%{_mandir}/man1/pvsecret-create-meta.1*
|
||||
%{_mandir}/man1/pvsecret-create.1*
|
||||
%{_mandir}/man1/pvsecret-list.1*
|
||||
%{_mandir}/man1/pvsecret-lock.1*
|
||||
%{_mandir}/man1/pvsecret-version.1*
|
||||
%{_mandir}/man1/pvsecret.1*
|
||||
%endif
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
|
||||
#
|
||||
# enf of multi-arch section
|
||||
#
|
||||
%endif
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x specific sub-packages
|
||||
#
|
||||
#
|
||||
# ************************* s390-tools core package *************************
|
||||
#
|
||||
@ -215,6 +338,7 @@ This package provides minimal set of tools needed to system to boot.
|
||||
%{_unitdir}/cpi.service
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
|
||||
/usr/lib/dracut/modules.d/95zdev/
|
||||
/usr/lib/dracut/modules.d/95zdev-kdump/
|
||||
%{_mandir}/man5/zipl.conf.5*
|
||||
%{_mandir}/man8/chreipl.8*
|
||||
%{_mandir}/man8/chzdev.8*
|
||||
@ -267,6 +391,7 @@ Requires: ethtool
|
||||
Requires: tar
|
||||
Requires: file
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-se-data = %{epoch}:%{version}-%{release}
|
||||
%{?systemd_requires}
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: ncurses-devel
|
||||
@ -274,7 +399,6 @@ BuildRequires: glibc-static
|
||||
BuildRequires: cryptsetup-devel >= 2.0.3
|
||||
BuildRequires: json-c-devel
|
||||
BuildRequires: rpm-devel
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libxml2-devel
|
||||
|
||||
|
||||
@ -340,11 +464,6 @@ s390 base tools. This collection provides the following utilities:
|
||||
* tunedasd:
|
||||
Adjust tunable parameters on DASD devices.
|
||||
|
||||
* vmconvert:
|
||||
Convert system dumps created by the z/VM VMDUMP command into dumps with
|
||||
LKCD format. These LKCD dumps can then be analyzed with the dump analysis
|
||||
tool lcrash.
|
||||
|
||||
* vmcp:
|
||||
Allows Linux users to send commands to the z/VM control program (CP).
|
||||
The normal usage is to invoke vmcp with the command you want to
|
||||
@ -476,9 +595,14 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_bindir}/dump2tar
|
||||
%{_bindir}/genprotimg
|
||||
%{_bindir}/mk-s390image
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvapconfig
|
||||
%endif
|
||||
%{_bindir}/pvattest
|
||||
%{_bindir}/pvextract-hdr
|
||||
%{_bindir}/vmconvert
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvsecret
|
||||
%endif
|
||||
%{_bindir}/zkey
|
||||
%{_bindir}/zkey-cryptsetup
|
||||
%{_unitdir}/dumpconf.service
|
||||
@ -503,11 +627,23 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_libdir}/zkey/zkey-kmip.so
|
||||
%{_mandir}/man1/dump2tar.1*
|
||||
%{_mandir}/man1/genprotimg.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvapconfig.1*
|
||||
%endif
|
||||
%{_mandir}/man1/pvattest.1*
|
||||
%{_mandir}/man1/pvattest-create.1*
|
||||
%{_mandir}/man1/pvattest-perform.1*
|
||||
%{_mandir}/man1/pvattest-verify.1*
|
||||
%{_mandir}/man1/vmconvert.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvsecret-add.1*
|
||||
%{_mandir}/man1/pvsecret-create-association.1*
|
||||
%{_mandir}/man1/pvsecret-create-meta.1*
|
||||
%{_mandir}/man1/pvsecret-create.1*
|
||||
%{_mandir}/man1/pvsecret-list.1*
|
||||
%{_mandir}/man1/pvsecret-lock.1*
|
||||
%{_mandir}/man1/pvsecret-version.1*
|
||||
%{_mandir}/man1/pvsecret.1*
|
||||
%endif
|
||||
%{_mandir}/man1/zkey.1*
|
||||
%{_mandir}/man1/zkey-cryptsetup.1*
|
||||
%{_mandir}/man1/zkey-ekmfweb.1*
|
||||
@ -557,7 +693,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_mandir}/man8/znetconf.8*
|
||||
%{_mandir}/man8/zpcictl.8*
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
%{_datadir}/s390-tools/netboot/
|
||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
|
||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/kmip
|
||||
@ -569,6 +704,18 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
# Additional Fedora/RHEL specific stuff
|
||||
/boot/tape0
|
||||
|
||||
%package se-data
|
||||
License: MIT
|
||||
Summary: Data for Secure Execution
|
||||
BuildArch: noarch
|
||||
|
||||
%description se-data
|
||||
%{summary}.
|
||||
|
||||
%files se-data
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
|
||||
#
|
||||
# *********************** s390-tools osasnmpd package ***********************
|
||||
#
|
||||
@ -852,7 +999,7 @@ Summary: Use multipath information for re-IPL path failover
|
||||
BuildRequires: make
|
||||
BuildRequires: bash
|
||||
BuildRequires: coreutils
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
BuildRequires: pandoc
|
||||
%endif
|
||||
BuildRequires: gawk
|
||||
@ -873,7 +1020,7 @@ reconfigures the FCP re-IPL settings to use an operational path.
|
||||
|
||||
%files chreipl-fcp-mpath
|
||||
%doc chreipl-fcp-mpath/README.md
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
%doc chreipl-fcp-mpath/README.html
|
||||
%endif
|
||||
%dir %{_prefix}/lib/chreipl-fcp-mpath/
|
||||
@ -905,8 +1052,54 @@ User-space development files for the s390/s390x architecture.
|
||||
%{_libdir}/libekmfweb.so
|
||||
%{_libdir}/libkmipclient.so
|
||||
|
||||
#
|
||||
# end of s390x specific sub-packages
|
||||
#
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 29 2024 Dan Horák <dhorak@redhat.com> - 2:2.29.0-3
|
||||
- add s390utils-se-data as a noarch subpackage with Secure Execution data files
|
||||
- Resolves: RHEL-10567
|
||||
|
||||
* Fri Jan 19 2024 Dan Horák <dhorak@redhat.com> - 2:2.29.0-2
|
||||
- SE: Secure guest tool to bind and associate APQNs (RHEL-10574)
|
||||
- Resolves: RHEL-10574
|
||||
|
||||
* Fri Nov 24 2023 Dan Horák <dhorak@redhat.com> - 2:2.29.0-1
|
||||
- rebased to 2.29.0 (RHEL-11408)
|
||||
- KVM: Support AP Bindings in SE Header (RHEL-10572)
|
||||
- KVM: Userspace Tool for IBK Request Generation and Insertion (RHEL-10578)
|
||||
- zkey: support for key type PKEY_TYPE_EP11_AES (RHEL-11440)
|
||||
- vmur: fix handling of option -t (RHEL-11480)
|
||||
- dbginfo.sh: global original Input Field Separator (IFS) (RHEL-16527)
|
||||
- enable multi-arch build (RHEL-10567)
|
||||
- Resolves: RHEL-11408 RHEL-10572 RHEL-10578 RHEL-11440 RHEL-11480 RHEL-16527 RHEL-10567
|
||||
|
||||
* Mon Aug 7 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-4
|
||||
- zdev/dracut: fix kdump build to integrate with site support (#2229177)
|
||||
- Resolves: #2229177
|
||||
|
||||
* Thu Jul 20 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-3
|
||||
- Secure Execution APQN binding and IBK association (#2110521)
|
||||
- Resolves: #2110521
|
||||
|
||||
* Mon Jul 17 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-2
|
||||
- zdev: cleanup patches to fix warnings (#2223304)
|
||||
- zdev: add missing label in the udev-rules (#2222900)
|
||||
- Resolves: #2223304 #2222900
|
||||
|
||||
* Wed May 31 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-1
|
||||
- rebased to 2.27.0 (#2160062)
|
||||
- lszcrypt fails when querying a specific domain (#2177612)
|
||||
- DASD autoquiesce support (#2196517)
|
||||
- zcrypt DD: AP command filtering (#2170360)
|
||||
- vmconvert and zgetdump consolidation (#2173924)
|
||||
- Support for List-Directed dump from ECKD DASD (#2160052)
|
||||
- Support for List-Directed IPL and re-IPL from ECKD DASD (#2160040)
|
||||
- Resolves: #2160062 #2177612 #2196517 #2170360 #2173924 #2160052 #2160040
|
||||
|
||||
* Thu Feb 02 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-4
|
||||
- zkey: Support EP11 host library version 4 (#2165812)
|
||||
- Resolves: #2165812
|
||||
|
Loading…
Reference in New Issue
Block a user