import s390utils-2.15.1-5.el8

This commit is contained in:
CentOS Sources 2021-05-18 02:36:01 -04:00 committed by Stepan Oksanichenko
parent 2c679ceae4
commit 86ad0bb7cb
9 changed files with 3820 additions and 44925 deletions

2
.gitignore vendored
View File

@ -1,3 +1,3 @@
SOURCES/cmsfs-1.1.8c.tar.gz
SOURCES/s390-tools-2.6.0.tar.gz
SOURCES/s390-tools-2.15.1.tar.gz
SOURCES/src_vipa-2.1.0.tar.gz

View File

@ -1,3 +1,3 @@
9c9a4e89bddb2b4e6e09ef6fc7c2e6f2ad6316de SOURCES/cmsfs-1.1.8c.tar.gz
46a09493030c3c80987b7710e34a33462e4b90f4 SOURCES/s390-tools-2.6.0.tar.gz
9a169518bf1074f3c087f97a32fd85c35ac216ee SOURCES/s390-tools-2.15.1.tar.gz
8ed8592a0a9370ce8422df9231ccb17f6cf49bed SOURCES/src_vipa-2.1.0.tar.gz

View File

@ -0,0 +1,12 @@
diff -up cmsfs-1.1.8c/cmsfslst.c.orig cmsfs-1.1.8c/cmsfslst.c
--- cmsfs-1.1.8c/cmsfslst.c.orig 2020-08-19 09:47:36.459063820 +0000
+++ cmsfs-1.1.8c/cmsfslst.c 2020-08-19 09:47:45.619063820 +0000
@@ -49,7 +49,7 @@ int main(int argc,unsigned char *argv[])
}
/* sanity check */
- if (*devname == 0x00)
+ if ((devname == NULL) || (*devname == 0x00))
{
(void) fprintf(stderr,"Please specify a CMS volume.\n");
(void) fprintf(stderr,USAGE,argv[0]);

File diff suppressed because it is too large Load Diff

View File

@ -1,146 +0,0 @@
From ecf5a4ecb909bfd91306678d0c460ab2f2837a33 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 18 Nov 2019 04:10:06 -0500
Subject: [PATCH 1/3] zipl: drop redundant string duplication
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Dan Horák <dan@danny.cz>
---
zipl/src/scan.c | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
index 38fa5454..0ea37efa 100644
--- a/zipl/src/scan.c
+++ b/zipl/src/scan.c
@@ -1575,7 +1575,6 @@ scan_check_bls(struct scan_token *scan)
int i, rc;
char *target_value = NULL;
char *img_value = NULL;
- char *buffer = NULL;
/*
* In the BLS case, each BLS section heading inherits a keyword
* assignment target= from zipl.conf, and they are all the same.
@@ -1609,14 +1608,8 @@ scan_check_bls(struct scan_token *scan)
scan[i].content.keyword.value);
return rc;
}
- buffer = (char *)
- misc_malloc(strlen(img_value) + 1);
- if (buffer == NULL)
- return -1;
- memcpy(buffer, img_value, strlen(img_value));
- buffer[strlen(img_value)] = 0;
free(scan[i].content.keyword.value);
- scan[i].content.keyword.value = buffer;
+ scan[i].content.keyword.value = img_value;
}
}
}
From 05f83569960e2774e819fe0942da1f92d0cce35b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 18 Nov 2019 04:29:04 -0500
Subject: [PATCH 2/3] zipl: set reason not text for failed check
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Dan Horák <dan@danny.cz>
---
zipl/src/scan.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
index 0ea37efa..0f01cac9 100644
--- a/zipl/src/scan.c
+++ b/zipl/src/scan.c
@@ -1603,7 +1603,7 @@ scan_check_bls(struct scan_token *scan)
scan[i].content.keyword.value);
rc = misc_check_readable_file(img_value);
if (rc) {
- error_text(
+ error_reason(
"Image file '%s' is not accessible",
scan[i].content.keyword.value);
return rc;
From 8ab552b430f109d80966d0c56bed0d204d917d30 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 18 Nov 2019 11:45:50 -0500
Subject: [PATCH 3/3] zipl: fix handling of values with load address in BLS
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Various keywords (like image or ramdisk) allow specifying a load address
as an optional argument. Adapt the logic for checking the presence of
the files to take this into the account.
Fixes: https://github.com/ibm-s390-tools/s390-tools/commit/d71628326d80e623fc9f008fe4ea93edb5592b2e
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1772054
Signed-off-by: Dan Horák <dan@danny.cz>
---
zipl/src/scan.c | 32 ++++++++++++++++++++++++++------
1 file changed, 26 insertions(+), 6 deletions(-)
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
index 0f01cac9..a34edf62 100644
--- a/zipl/src/scan.c
+++ b/zipl/src/scan.c
@@ -1575,6 +1575,8 @@ scan_check_bls(struct scan_token *scan)
int i, rc;
char *target_value = NULL;
char *img_value = NULL;
+ char *file = NULL;
+ char *tmp, *value;
/*
* In the BLS case, each BLS section heading inherits a keyword
* assignment target= from zipl.conf, and they are all the same.
@@ -1595,19 +1597,37 @@ scan_check_bls(struct scan_token *scan)
if (scan[i].content.keyword.keyword == scan_keyword_image ||
scan[i].content.keyword.keyword == scan_keyword_ramdisk) {
- rc = misc_check_readable_file(
- scan[i].content.keyword.value);
+ value = scan[i].content.keyword.value;
+ /*
+ * put the filename only into the file var before
+ * checking its presence
+ */
+ if (contains_address(value)) {
+ tmp = strrchr(value, ',');
+ file = strndup(value, tmp - value);
+ } else {
+ file = value;
+ }
+ rc = misc_check_readable_file(file);
if (rc) {
misc_asprintf(&img_value, "%s%s",
- target_value,
- scan[i].content.keyword.value);
+ target_value, file);
rc = misc_check_readable_file(img_value);
if (rc) {
error_reason(
- "Image file '%s' is not accessible",
- scan[i].content.keyword.value);
+ "File '%s' not accessible", file);
return rc;
}
+ /*
+ * when file has stripped the load address part,
+ * do generate a prefixed value
+ */
+ if (file != value) {
+ free(file);
+ free(img_value);
+ misc_asprintf(&img_value, "%s%s",
+ target_value, value);
+ }
free(scan[i].content.keyword.value);
scan[i].content.keyword.value = img_value;
}

View File

@ -1,18 +1,18 @@
From 8ec7b75204f3c7bf691e14b89c73c5dd28d2a824 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 15 Oct 2018 13:54:16 -0400
Subject: [PATCH] blscfg: sort like rpm nvr, not like a single version
Signed-off-by: Peter Jones <pjones@redhat.com>
---
zipl/src/scan.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++-
zipl/src/Makefile | 3 +-
2 files changed, 96 insertions(+), 3 deletions(-)
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
index fe72e9ab13d..63186222783 100644
--- a/zipl/src/scan.c
+++ b/zipl/src/scan.c
diff -up s390-tools-2.9.0/zipl/src/Makefile.blscfg-rpm-nvr-sort s390-tools-2.9.0/zipl/src/Makefile
--- s390-tools-2.9.0/zipl/src/Makefile.blscfg-rpm-nvr-sort 2019-05-22 08:16:17.317273801 -0400
+++ s390-tools-2.9.0/zipl/src/Makefile 2019-05-22 08:18:02.947273801 -0400
@@ -7,7 +7,7 @@ ALL_CPPFLAGS += -I../include -I../boot \
-D_FILE_OFFSET_BITS=64 $(NO_PIE_CFLAGS)
ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
-libs = $(rootdir)/libutil/libutil.a
+libs = $(rootdir)/libutil/libutil.a -lrpm
objects = misc.o error.o scan.o job.o boot.o bootmap.o disk.o \
install.o zipl.o $(rootdir)/zipl/boot/data.o
diff -up s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort s390-tools-2.9.0/zipl/src/scan.c
--- s390-tools-2.9.0/zipl/src/scan.c.blscfg-rpm-nvr-sort 2019-05-21 09:13:36.000000000 -0400
+++ s390-tools-2.9.0/zipl/src/scan.c 2019-05-22 08:16:17.317273801 -0400
@@ -33,6 +33,8 @@
#include "lib/util_base.h"
@ -22,7 +22,7 @@ index fe72e9ab13d..63186222783 100644
#include "boot.h"
#include "error.h"
#include "misc.h"
@@ -652,14 +654,104 @@ bls_filter(const struct dirent *ent)
@@ -653,13 +655,103 @@ bls_filter(const struct dirent *ent)
return strncmp(ent->d_name + offset, ".conf", strlen(".conf")) == 0;
}
@ -63,8 +63,9 @@ index fe72e9ab13d..63186222783 100644
+ *release = NULL;
+ }
+}
+
+static int
static int
-bls_sort(const struct dirent **ent_a, const struct dirent **ent_b)
+split_cmp(char *nvr0, char *nvr1, int has_name)
+{
+ int ret = 0;
@ -95,7 +96,8 @@ index fe72e9ab13d..63186222783 100644
+/* 0: filename0 and filename1 are the same version */
+/* -1: filename1 is newer than filename0 */
+static int bls_cmp(const char *filename0, const char *filename1)
+{
{
- return strverscmp((*ent_a)->d_name, (*ent_b)->d_name);
+ char *id0, *id1;
+ int l, r;
+
@ -116,32 +118,13 @@ index fe72e9ab13d..63186222783 100644
+ free(id1);
+
+ return r;
}
+static int
+bls_sort(const struct dirent **ent_a, const struct dirent **ent_b)
+{
+ return bls_cmp((*ent_a)->d_name, (*ent_b)->d_name);
+}
static int
bls_sort(const struct dirent **ent_a, const struct dirent **ent_b)
{
- return strverscmp((*ent_a)->d_name, (*ent_b)->d_name);
+ return bls_cmp((*ent_a)->d_name, (*ent_b)->d_name);
}
-
static int
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
static int
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
index 1634c0d5121..bc797990652 100644
--- a/zipl/src/Makefile
+++ b/zipl/src/Makefile
@@ -7,7 +7,7 @@ ALL_CPPFLAGS += -I../include -I../boot \
-D_FILE_OFFSET_BITS=64 $(NO_PIE_CFLAGS)
ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
-libs = $(rootdir)/libutil/libutil.a
+libs = $(rootdir)/libutil/libutil.a -lrpm
objects = misc.o error.o scan.o job.o boot.o bootmap.o disk.o \
install.o zipl.o $(rootdir)/zipl/boot/data.o
--
2.17.1

File diff suppressed because it is too large Load Diff

View File

@ -2,10 +2,12 @@
# config file syntax:
# deviceno WWPN FCPLUN
# deviceno # allowed when auto LUN scan is enabled and port is in NPIV mode
#
# Example:
# 0.0.4000 0x5005076300C213e9 0x5022000000000000
# 0.0.4001 0x5005076300c213e9 0x5023000000000000
# 0.0.5000
#
#
# manual setup:
@ -21,6 +23,14 @@
CONFIG=/etc/zfcp.conf
PATH=/bin:/sbin
set_online()
{
DEVICE=$1
[ `cat /sys/bus/ccw/drivers/zfcp/${DEVICE}/online` = "0" ] \
&& echo 1 > /sys/bus/ccw/drivers/zfcp/${DEVICE}/online
}
if [ -f "$CONFIG" ]; then
if [ ! -d /sys/bus/ccw/drivers/zfcp ]; then
modprobe zfcp
@ -34,6 +44,17 @@ if [ -f "$CONFIG" ]; then
*)
[ -z "$line" ] && continue
set $line
if [ $# -eq 1 ]; then
DEVICE=${1##*0x}
if [ `cat /sys/module/zfcp/parameters/allow_lun_scan` = "Y" ]; then
set_online ${DEVICE}
grep -q NPIV /sys/bus/ccw/devices/${DEVICE}/host*/fc_host/host*/port_type || \
echo "Error: Only device ID (${DEVICE}) given, but port not in NPIV mode"
else
echo "Error: Only device ID (${DEVICE}) given, but LUN scan is disabled for the zfcp module"
fi
continue
fi
if [ $# -eq 5 ]; then
DEVICE=$1
SCSIID=$2
@ -46,8 +67,7 @@ if [ -f "$CONFIG" ]; then
WWPN=$2
FCPLUN=$3
fi
[ `cat /sys/bus/ccw/drivers/zfcp/${DEVICE}/online` = "0" ] \
&& echo 1 > /sys/bus/ccw/drivers/zfcp/${DEVICE}/online
set_online ${DEVICE}
[ ! -d /sys/bus/ccw/drivers/zfcp/${DEVICE}/${WWPN}/${FCPLUN} ] \
&& echo $FCPLUN > /sys/bus/ccw/drivers/zfcp/${DEVICE}/${WWPN}/unit_add
;;

View File

@ -1,15 +1,15 @@
%define cmsfsver 1.1.8c
%define vipaver 2.1.0
# secure boot support is for RHEL only
%if 0%{?rhel} >= 8
%global signzipl 1
%endif
Name: s390utils
Summary: Utilities and daemons for IBM z Systems
Group: System Environment/Base
Version: 2.6.0
Release: 33%{?dist}.2
Version: 2.15.1
Release: 5%{?dist}
Epoch: 2
License: MIT
ExclusiveArch: s390 s390x
@ -29,32 +29,30 @@ Source15: device_cio_free.service
Source16: ccw_init
Source17: ccw.udev
Source21: normalize_dasd_arg
Source22: 00-zipl-prepare.install
Source23: 20-zipl-kernel.install
Source24: 52-zipl-rescue.install
Source25: 91-zipl.install
Source23: 00-zipl-prepare.install
Source24: 20-zipl-kernel.install
Source25: 52-zipl-rescue.install
Source26: 91-zipl.install
# for secure boot
%if 0%{?signzipl}
%define pesign_name redhatsecureboot302
%endif
# backported stuff for RHEL
Patch0: s390-tools-rhel.patch
# BLS support in zipl
# change the defaults to match Fedora environment
Patch100: s390-tools-zipl-invert-script-options.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1640968
Patch102: s390-tools-zipl-sort-like-rpm.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1772054
Patch103: s390-tools-zipl-bls-loadaddr.patch
Patch0: s390-tools-zipl-invert-script-options.patch
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
# backported fixes
Patch100: s390utils-2.15.1-rhel.patch
Patch1000: cmsfs-1.1.8-warnings.patch
Patch1001: cmsfs-1.1.8-kernel26.patch
Patch1002: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
Patch1003: cmsfs-1.1.8-args.patch
Patch2000: src_vipa-2.1.0-deprecate.patch
Requires: s390utils-core = %{epoch}:%{version}-%{release}
Requires: s390utils-base = %{epoch}:%{version}-%{release}
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
Requires: s390utils-cpuplugd = %{epoch}:%{version}-%{release}
@ -64,7 +62,6 @@ Requires: s390utils-ziomon = %{epoch}:%{version}-%{release}
Requires: s390utils-cmsfs = %{epoch}:%{version}-%{release}
BuildRequires: gcc-c++
BuildRequires: rpm-devel
%description
This is a meta package for installing the default s390-tools sub packages.
@ -77,13 +74,11 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
%prep
%setup -q -n s390-tools-%{version} -a 4 -a 6
# Backported stuff for RHEL
%patch0 -p1
# Fedora/RHEL changes
%patch0 -p1 -b .zipl-invert-script-options
%patch1 -p1 -b .blscfg-rpm-nvr-sort
# BLS support in zipl
%patch100 -p1 -b .zipl-invert-script-options
%patch102 -p1 -b .zipl-sort-like-rpm
%patch103 -p1 -b .zipl-bls-loadaddr
%patch100 -p1
#
# cmsfs
@ -97,6 +92,9 @@ pushd cmsfs-%{cmsfsver}
# use detected filesystem block size (#651012)
%patch1002 -p1 -b .use-detected-block-size
# fix args processing (#1866872)
%patch1003 -p1 -b .args
popd
#
@ -141,7 +139,7 @@ popd
%install
make install \
HAVE_DRACUT=1 \
DESTDIR=$RPM_BUILD_ROOT \
DESTDIR=%{buildroot} \
BINDIR=/usr/sbin \
SYSTEMDSYSTEMUNITDIR=%{_unitdir} \
DISTRELEASE=%{release} \
@ -159,67 +157,155 @@ else
fi
%endif
mkdir -p $RPM_BUILD_ROOT{/boot,%{_udevrulesdir},%{_sysconfdir}/{profile.d,sysconfig},%{_prefix}/lib/modules-load.d}
install -p -m 644 zipl/boot/tape0.bin $RPM_BUILD_ROOT/boot/tape0
install -p -m 755 %{SOURCE5} $RPM_BUILD_ROOT%{_sbindir}
install -p -m 755 %{SOURCE13} $RPM_BUILD_ROOT%{_sbindir}
install -p -m 755 %{SOURCE21} $RPM_BUILD_ROOT%{_sbindir}
install -p -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_udevrulesdir}/56-zfcp.rules
install -p -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{_udevrulesdir}/56-dasd.rules
# move tools to searchable dir
mv %{buildroot}%{_datadir}/s390-tools/netboot/mk-s390image %{buildroot}%{_bindir}
touch $RPM_BUILD_ROOT%{_sysconfdir}/{zfcp.conf,dasd.conf}
mkdir -p %{buildroot}{/boot,%{_udevrulesdir},%{_sysconfdir}/{profile.d,sysconfig},%{_prefix}/lib/modules-load.d}
install -p -m 644 zipl/boot/tape0.bin %{buildroot}/boot/tape0
install -p -m 755 %{SOURCE5} %{buildroot}%{_sbindir}
install -p -m 755 %{SOURCE13} %{buildroot}%{_sbindir}
install -p -m 755 %{SOURCE21} %{buildroot}%{_sbindir}
install -p -m 644 %{SOURCE7} %{buildroot}%{_udevrulesdir}/56-zfcp.rules
install -p -m 644 %{SOURCE12} %{buildroot}%{_udevrulesdir}/56-dasd.rules
touch %{buildroot}%{_sysconfdir}/{zfcp.conf,dasd.conf}
# upstream udev rules
install -Dp -m 644 etc/udev/rules.d/*.rules $RPM_BUILD_ROOT%{_udevrulesdir}
install -Dp -m 644 etc/udev/rules.d/*.rules %{buildroot}%{_udevrulesdir}
# upstream modules config
install -Dp -m 644 etc/modules-load.d/*.conf $RPM_BUILD_ROOT%{_prefix}/lib/modules-load.d
install -Dp -m 644 etc/modules-load.d/*.conf %{buildroot}%{_prefix}/lib/modules-load.d
# Install kernel-install scripts
install -d -m 0755 %{buildroot}%{_prefix}/lib/kernel/install.d/
install -D -m 0755 -t %{buildroot}%{_prefix}/lib/kernel/install.d/ %{SOURCE22}
install -D -m 0755 -t %{buildroot}%{_prefix}/lib/kernel/install.d/ zfcpdump/10-zfcpdump.install
install -D -m 0755 -t %{buildroot}%{_prefix}/lib/kernel/install.d/ %{SOURCE23}
install -D -m 0755 -t %{buildroot}%{_prefix}/lib/kernel/install.d/ %{SOURCE24}
install -D -m 0755 -t %{buildroot}%{_prefix}/lib/kernel/install.d/ %{SOURCE25}
install -D -m 0755 -t %{buildroot}%{_prefix}/lib/kernel/install.d/ %{SOURCE26}
install -d -m 0755 %{buildroot}%{_sysconfdir}/kernel/install.d/
install -m 0644 /dev/null %{buildroot}%{_sysconfdir}/kernel/install.d/20-grubby.install
# cmsfs tools must be available in /sbin
for f in cat lst vol cp ck; do
install -p -m 755 cmsfs-%{cmsfsver}/cmsfs${f} $RPM_BUILD_ROOT%{_sbindir}
install -p -m 644 cmsfs-%{cmsfsver}/cmsfs${f}.8 $RPM_BUILD_ROOT%{_mandir}/man8
install -p -m 755 cmsfs-%{cmsfsver}/cmsfs${f} %{buildroot}%{_sbindir}
install -p -m 644 cmsfs-%{cmsfsver}/cmsfs${f}.8 %{buildroot}%{_mandir}/man8
done
# src_vipa
pushd src_vipa-%{vipaver}
make install LIBDIR=%{_libdir} SBINDIR=%{_bindir} INSTROOT=$RPM_BUILD_ROOT LDCONFIG=/bin/true
make install LIBDIR=%{_libdir} SBINDIR=%{_bindir} INSTROOT=%{buildroot} LDCONFIG=/bin/true
popd
# install usefull headers for devel subpackage
mkdir -p $RPM_BUILD_ROOT%{_includedir}/%{name}
install -p -m 644 include/lib/vtoc.h $RPM_BUILD_ROOT%{_includedir}/%{name}
mkdir -p %{buildroot}%{_includedir}/%{name}
install -p -m 644 include/lib/vtoc.h %{buildroot}%{_includedir}/%{name}
# device_cio_free
install -p -m 755 %{SOURCE14} $RPM_BUILD_ROOT%{_sbindir}
pushd $RPM_BUILD_ROOT%{_sbindir}
install -p -m 755 %{SOURCE14} %{buildroot}%{_sbindir}
pushd %{buildroot}%{_sbindir}
for lnk in dasd zfcp znet; do
ln -sf device_cio_free ${lnk}_cio_free
done
popd
install -p -m 644 %{SOURCE15} $RPM_BUILD_ROOT%{_unitdir}
install -p -m 644 %{SOURCE15} %{buildroot}%{_unitdir}
# ccw
install -p -m 755 %{SOURCE16} $RPM_BUILD_ROOT/usr/lib/udev/ccw_init
install -p -m 644 %{SOURCE17} $RPM_BUILD_ROOT%{_udevrulesdir}/81-ccw.rules
install -p -m 755 %{SOURCE16} %{buildroot}/usr/lib/udev/ccw_init
install -p -m 644 %{SOURCE17} %{buildroot}%{_udevrulesdir}/81-ccw.rules
# zipl.conf to be ghosted
touch $RPM_BUILD_ROOT%{_sysconfdir}/zipl.conf
touch %{buildroot}%{_sysconfdir}/zipl.conf
%files
%doc README.md
# ************************* s390-tools core package *************************
#
%package core
License: MIT
Summary: S390 core tools
Requires: coreutils
%{?systemd_requires}
# BRs are covered via the base package
%description core
This package provides minimal set of tools needed to system to boot.
%post core
%if 0
# enable in F-31
%systemd_post device_cio_free.service
%else
# explicit enable for upgrade patch from s390utils-base < 2.6.0-4
systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%endif
%systemd_post cpi.service
%preun core
%systemd_preun device_cio_free.service
%systemd_preun cpi.service
%postun core
%systemd_postun_with_restart cpi.service
%files core
%doc README.md zdev/src/chzdev_usage.txt
%doc LICENSE
%{_sbindir}/chreipl
%{_sbindir}/chzdev
%{_sbindir}/cio_ignore
%{_sbindir}/dasdfmt
%{_sbindir}/dasdinfo
%{_sbindir}/zipl
%dir /lib/s390-tools/
/lib/s390-tools/{zipl,chreipl}_helper.*
/lib/s390-tools/cpictl
/lib/s390-tools/stage3.bin
/lib/s390-tools/zdev-root-update
/lib/s390-tools/zipl.conf
%ghost %config(noreplace) %{_sysconfdir}/zipl.conf
%{_unitdir}/cpi.service
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
/usr/lib/dracut/modules.d/95zdev/
%{_mandir}/man5/zipl.conf.5*
%{_mandir}/man8/chreipl.8*
%{_mandir}/man8/chzdev.8*
%{_mandir}/man8/cio_ignore.8*
%{_mandir}/man8/dasdfmt.8*
%{_mandir}/man8/dasdinfo.8*
%{_mandir}/man8/zipl.8*
# Additional Fedora/RHEL specific stuff
%ghost %config(noreplace) %{_sysconfdir}/dasd.conf
%ghost %config(noreplace) %{_sysconfdir}/zfcp.conf
%{_sbindir}/dasdconf.sh
%{_sbindir}/normalize_dasd_arg
%{_sbindir}/zfcpconf.sh
%{_sbindir}/device_cio_free
%{_sbindir}/dasd_cio_free
%{_sbindir}/zfcp_cio_free
%{_sbindir}/znet_cio_free
%{_unitdir}/device_cio_free.service
/usr/lib/udev/ccw_init
%{_udevrulesdir}/40-z90crypt.rules
%{_udevrulesdir}/56-dasd.rules
%{_udevrulesdir}/56-zfcp.rules
%{_udevrulesdir}/59-dasd.rules
%{_udevrulesdir}/60-readahead.rules
%{_udevrulesdir}/81-ccw.rules
%{_udevrulesdir}/90-cpi.rules
%{_sysconfdir}/kernel/install.d/20-grubby.install
%{_prefix}/lib/kernel/install.d/00-zipl-prepare.install
%{_prefix}/lib/kernel/install.d/10-zfcpdump.install
%{_prefix}/lib/kernel/install.d/20-zipl-kernel.install
%{_prefix}/lib/kernel/install.d/52-zipl-rescue.install
%{_prefix}/lib/kernel/install.d/91-zipl.install
%{_prefix}/lib/modules-load.d/s390-pkey.conf
#
# ************************* s390-tools base package *************************
#
@ -227,17 +313,19 @@ touch $RPM_BUILD_ROOT%{_sysconfdir}/zipl.conf
# src_vipa is CPL
License: MIT and CPL
Summary: S390 base tools
Group: System Environment/Base
Requires: gawk sed coreutils
Requires: sysfsutils
Requires: sg3_utils
Requires: ethtool
Requires: tar
Requires: s390utils-core = %{epoch}:%{version}-%{release}
%{?systemd_requires}
BuildRequires: perl-generators
BuildRequires: ncurses-devel
BuildRequires: glibc-static
BuildRequires: cryptsetup-devel >= 2.0.3
BuildRequires: json-c-devel
BuildRequires: rpm-devel
BuildRequires: glib2-devel
@ -380,45 +468,30 @@ For more information refer to the following publications:
getent group zkeyadm > /dev/null || groupadd -r zkeyadm
%post base
%systemd_post cpi.service
%if 0
# enable in F-31
%systemd_post device_cio_free.service
%else
# explicit enable for upgrade patch from s390utils-base < 2.6.0-4
systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%endif
%systemd_post dumpconf.service
%preun base
%systemd_preun cpi.service
%systemd_preun device_cio_free.service
%systemd_preun dumpconf.service
%postun base
%systemd_postun_with_restart cpi.service
%systemd_postun_with_restart dumpconf.service
%files base
%doc README.md zdev/src/*.txt
%doc LICENSE
%doc README.md zdev/src/lszdev_usage.txt
%{_sbindir}/chccwdev
%{_sbindir}/chchp
%{_sbindir}/chcpumf
%{_sbindir}/chreipl
%{_sbindir}/chshut
%{_sbindir}/chzcrypt
%{_sbindir}/chzdev
%{_sbindir}/cio_ignore
%{_sbindir}/dasdfmt
%{_sbindir}/dasdinfo
%{_sbindir}/dasdstat
%{_sbindir}/dasdview
%{_sbindir}/dbginfo.sh
%{_sbindir}/fdasd
%{_sbindir}/hsci
%{_sbindir}/hyptop
%{_sbindir}/ip_watcher.pl
%{_sbindir}/lschp
%{_sbindir}/lscpumf
%{_sbindir}/lscss
%{_sbindir}/lsdasd
%{_sbindir}/lsqeth
@ -426,6 +499,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_sbindir}/lsreipl
%{_sbindir}/lsscm
%{_sbindir}/lsshut
%{_sbindir}/lsstp
%{_sbindir}/lstape
%{_sbindir}/lszcrypt
%{_sbindir}/lszdev
@ -446,23 +520,25 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_sbindir}/zcryptstats
%{_sbindir}/zfcpdbf
%{_sbindir}/zgetdump
%{_sbindir}/zipl
%{_sbindir}/zipl-switch-to-blscfg
%{_sbindir}/znetconf
%{_sbindir}/zpcictl
%{_bindir}/lscpumf
%{_bindir}/dump2tar
%{_bindir}/genprotimg
%{_bindir}/mk-s390image
%{_bindir}/vmconvert
%{_bindir}/zkey
%{_bindir}/zkey-cryptsetup
%{_unitdir}/cpi.service
%{_unitdir}/dumpconf.service
%ghost %config(noreplace) %{_sysconfdir}/zipl.conf
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
%config(noreplace) %{_sysconfdir}/sysconfig/dumpconf
/lib/s390-tools/
/usr/lib/dracut/modules.d/95zdev/
/lib/s390-tools/dumpconf
/lib/s390-tools/lsznet.raw
%dir /lib/s390-tools/zfcpdump
/lib/s390-tools/zfcpdump/zfcpdump-initrd
/lib/s390-tools/znetcontrolunits
%{_libdir}/libekmfweb.so.*
%{_libdir}/zkey/zkey-ekmfweb.so
%{_mandir}/man1/dbginfo.sh.1*
%{_mandir}/man1/dump2tar.1*
%{_mandir}/man1/lscpumf.1*
@ -471,23 +547,20 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_mandir}/man1/zipl-switch-to-blscfg.1*
%{_mandir}/man1/zkey.1*
%{_mandir}/man1/zkey-cryptsetup.1*
%{_mandir}/man1/zkey-ekmfweb.1*
%{_mandir}/man4/prandom.4*
%{_mandir}/man5/zipl.conf.5*
%{_mandir}/man8/chccwdev.8*
%{_mandir}/man8/chchp.8*
%{_mandir}/man8/chcpumf.8*
%{_mandir}/man8/chreipl.8*
%{_mandir}/man8/chshut.8*
%{_mandir}/man8/chzcrypt.8*
%{_mandir}/man8/chzdev.8*
%{_mandir}/man8/cio_ignore.8*
%{_mandir}/man8/dasdfmt.8*
%{_mandir}/man8/dasdinfo.8*
%{_mandir}/man8/dasdstat.8*
%{_mandir}/man8/dasdview.8*
%{_mandir}/man8/dumpconf.8*
%{_mandir}/man8/fdasd.8*
%{_mandir}/man8/genprotimg.8.*
%{_mandir}/man8/hsci.8*
%{_mandir}/man8/hyptop.8*
%{_mandir}/man8/lschp.8*
%{_mandir}/man8/lscss.8*
@ -497,6 +570,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_mandir}/man8/lsreipl.8*
%{_mandir}/man8/lsscm.8*
%{_mandir}/man8/lsshut.8*
%{_mandir}/man8/lsstp.8*
%{_mandir}/man8/lstape.8*
%{_mandir}/man8/lszcrypt.8*
%{_mandir}/man8/lszdev.8*
@ -513,43 +587,17 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_mandir}/man8/zcryptctl.8*
%{_mandir}/man8/zcryptstats.8*
%{_mandir}/man8/zgetdump.8*
%{_mandir}/man8/zipl.8*
%{_mandir}/man8/znetconf.8*
%{_mandir}/man8/zpcictl.8*
%dir %{_datadir}/s390-tools/
%{_datadir}/s390-tools/cpumf/
%{_datadir}/s390-tools/genprotimg/
%{_datadir}/s390-tools/netboot/
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/repository
%config(noreplace) %attr(0660,root,zkeyadm)%{_sysconfdir}/zkey/kms-plugins.conf
# Additional Redhat specific stuff
# Additional Fedora/RHEL specific stuff
/boot/tape0
%ghost %config(noreplace) %{_sysconfdir}/dasd.conf
%ghost %config(noreplace) %{_sysconfdir}/zfcp.conf
%{_sbindir}/dasdconf.sh
%{_sbindir}/zfcpconf.sh
%{_sbindir}/dasd_cio_free
%{_sbindir}/device_cio_free
%{_sbindir}/zfcp_cio_free
%{_sbindir}/znet_cio_free
%{_sbindir}/normalize_dasd_arg
%{_unitdir}/device_cio_free.service
/usr/lib/udev/ccw_init
%{_udevrulesdir}/40-z90crypt.rules
%{_udevrulesdir}/56-zfcp.rules
%{_udevrulesdir}/56-dasd.rules
%{_udevrulesdir}/59-dasd.rules
%{_udevrulesdir}/60-readahead.rules
%{_udevrulesdir}/81-ccw.rules
%{_udevrulesdir}/90-cpi.rules
%{_sysconfdir}/kernel/install.d/20-grubby.install
%{_prefix}/lib/kernel/install.d/00-zipl-prepare.install
%{_prefix}/lib/kernel/install.d/10-zfcpdump.install
%{_prefix}/lib/kernel/install.d/20-zipl-kernel.install
%{_prefix}/lib/kernel/install.d/52-zipl-rescue.install
%{_prefix}/lib/kernel/install.d/91-zipl.install
%{_prefix}/lib/modules-load.d/s390-pkey.conf
# src_vipa
%{_bindir}/src_vipa.sh
@ -561,7 +609,6 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
#
%package osasnmpd
Summary: SNMP sub-agent for OSA-Express cards
Group: System Environment/Daemons
Requires: net-snmp
Requires: psmisc
BuildRequires: net-snmp-devel
@ -581,7 +628,6 @@ ATM Ethernet LAN Emulation in QDIO mode.
#
%package mon_statd
Summary: Monitoring daemons for Linux in z/VM
Group: System Environment/Daemons
Requires: coreutils
%{?systemd_requires}
@ -621,7 +667,6 @@ Monitoring daemons for Linux in z/VM:
#
%package cpuplugd
Summary: Daemon that manages CPU and memory resources
Group: System Environment/Daemons
%{?systemd_requires}
BuildRequires: systemd
@ -651,7 +696,6 @@ memory can be increased or decreased exploiting the CMM1 feature.
#
%package ziomon
Summary: S390 ziomon tools
Group: Applications/System
Requires: blktrace
Requires: coreutils
Requires: device-mapper-multipath
@ -690,7 +734,6 @@ Tool set to collect data for zfcp performance analysis and report.
#
%package iucvterm
Summary: z/VM IUCV terminal applications
Group: Applications/System
Requires(pre): shadow-utils
Requires(post): grep
Requires(postun): grep
@ -753,7 +796,6 @@ fi
%package cmsfs
License: GPLv2
Summary: CMS file system tools
Group: System Environment/Base
URL: http://www.casita.net/pub/cmsfs/cmsfs.html
# Requires:
@ -777,7 +819,6 @@ This package contains the CMS file system tools.
#
%package cmsfs-fuse
Summary: CMS file system based on FUSE
Group: System Environment/Base
BuildRequires: fuse-devel
Requires: fuse
@ -795,8 +836,8 @@ This package contains the CMS file system based on FUSE.
#
%package zdsfs
Summary: z/OS data set access based on FUSE
Group: System Environment/Base
BuildRequires: fuse-devel
BuildRequires: libcurl-devel
Requires: fuse
%description zdsfs
@ -811,7 +852,6 @@ This package contains the z/OS data set access based on FUSE.
#
%package hmcdrvfs
Summary: HMC drive file system based on FUSE
Group: System Environment/Base
BuildRequires: fuse-devel
Requires: fuse
@ -830,7 +870,6 @@ to list files and directories.
#
%package cpacfstatsd
Summary: Monitor and maintain CPACF activity counters
Group: System Environment/Base
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
@ -865,26 +904,46 @@ getent group cpacfstats >/dev/null || groupadd -r cpacfstats
#
%package devel
Summary: Development files
Group: Development/Libraries
Requires: %{name}-base%{?_isa} = %{epoch}:%{version}-%{release}
%description devel
User-space development files for the s390/s390x architecture.
%files devel
%{_includedir}/%{name}
%{_includedir}/%{name}/
%{_includedir}/ekmfweb/
%{_libdir}/libekmfweb.so
%changelog
* Thu Feb 04 2021 Dan Horák <dhorak@redhat.com> - 2:2.6.0-33.2
- bump and rebuild
- Related: #1905085 #1912479 #1917853 #1917854
* Fri Mar 12 2021 Dan Horák <dhorak@redhat.com> - 2:2.15.1-5
- fdasd: Use increased retry count for dasd_reread_partition_table (#1933766)
- zipl: fix reading 4k disk's geometry (#1933235)
- Resolves: #1933235 #1933766
* Tue Jan 26 2021 Dan Horák <dhorak@redhat.com> - 2:2.6.0-33.1
- lscpumf: adjust output for raw event number (#1917854)
- dasdfmt: Fix bad file descriptor error when running on symlinks (#1917853)
- zcryptstats: Fix handling of partial results with many domains (#1912479)
- libdasd: Fix dasd_get_host_access_count() (#1905085)
- Resolves: #1905085 #1912479 #1917853 #1917854
* Mon Dec 07 2020 Dan Horák <dhorak@redhat.com> - 2:2.15.1-4
- zkey: Fix KMS plugin configuration to store APQNs correctly. (#1901968)
- dasdfmt: Fix bad file descriptor error when running on symlinks (#1901963)
- zcryptstats: Fix handling of partial results with many domains (#1901962)
- s390-tools: add hsci tool (#1847434)
- genprotimg: add host-key document verification support (#1845925)
- genprotimg: require argument for 'ramdisk' and 'parmfile' options (#1845925)
- genprotimg: fix two memory leaks (#1845925)
- genprotimg: abort if one of the recursive targets is failing (#1845925)
- zdev/lsdasd: Add FC Endpoint Security information (#1723844)
- Resolves: #1723844 #1845925 #1847434 #1901962 #1901963 #1901968
* Fri Nov 27 2020 Javier Martinez Canillas <javierm@redhat.com> - 2:2.15.1-2
- add again the 00-zipl-prepare.install script that got dropped (#1902273)
Resolves: #1902273
* Wed Nov 04 2020 Dan Horák <dhorak@redhat.com> - 2:2.15.1-2
- rebased to 2.15.1 (#1851111)
- implement improved auto LUN scan (#1552697)
- fix crash when device is missing in cmsfslst (#1866872)
- introduce s390utils-core to avoid dependency on Perl (#1886201)
- Resolves: #1851111 #1552697 #1866872 #1886201
* Fri Jul 31 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-33
- cpacfstats: Bugfix to remove libpfm from cpacfstats (#1861779)