import s390utils-2.6.0-33.el8

This commit is contained in:
CentOS Sources 2020-11-03 06:49:39 -05:00 committed by Stepan Oksanichenko
parent 7533564948
commit 7e9fc5e5b8
4 changed files with 19923 additions and 102 deletions

View File

@ -132,8 +132,12 @@ case "$COMMAND" in
fi
fi
if [ -n "$NEWDEFAULT" ]; then
sed -i -e "s,^default=.*,default=${NEWDEFAULT}," "${ZIPLCFG}"
if [ -n "$NEWDEFAULT" ] && [ -f "${ZIPLCFG}" ]; then
if grep -q "^default=" "${ZIPLCFG}"; then
sed -i -e "s,^default=.*,default=${NEWDEFAULT}," "${ZIPLCFG}"
else
echo "default=${NEWDEFAULT}" >> "${ZIPLCFG}"
fi
fi
exit 0
@ -151,8 +155,10 @@ case "$COMMAND" in
BLS_TARGET="${BLS_DIR}/${MACHINE_ID}-${KERNEL_VERSION}.conf"
BLS_DEBUG="$(echo ${BLS_TARGET} | sed -e "s/${KERNEL_VERSION}/${KERNEL_VERSION}~debug/")"
TITLE="$(grep '^title[ \t]' "${BLS_TARGET}" | sed -e 's/^title[ \t]*//')"
sed -i -e "/^default=${TITLE}/d" "${ZIPLCFG}"
if [ -f "${BLS_TARGET}" ] && [ -f "${ZIPLCFG}" ]; then
TITLE="$(grep '^title[ \t]' "${BLS_TARGET}" | sed -e 's/^title[ \t]*//')"
sed -i -e "/^default=${TITLE}/d" "${ZIPLCFG}"
fi
if [[ -f "${BLS_DEBUG}" ]]; then
TITLE="$(grep '^title[ \t]' "${BLS_DEBUG}" | sed -e 's/^title[ \t]*//')"

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,12 @@
diff -up s390-tools-2.2.0/src_vipa-2.1.0/Makefile.orig s390-tools-2.2.0/src_vipa-2.1.0/Makefile
--- s390-tools-2.2.0/src_vipa-2.1.0/Makefile.orig 2020-02-21 13:51:23.502305796 +0100
+++ s390-tools-2.2.0/src_vipa-2.1.0/Makefile 2020-02-21 13:53:51.353817181 +0100
@@ -44,6 +44,8 @@ src_vipa.sh:
echo '#!/bin/bash' > src_vipa.sh
echo 'export LD_LIBRARY_PATH=$(LIBDIR):$$LD_LIBRARY_PATH' >> src_vipa.sh
echo 'export LD_PRELOAD=$(LIBDIR)/src_vipa.so' >> src_vipa.sh
+ echo 'echo "WARNING: The src_vipa (flexible source address selection) feature is DEPRECATED"' >> src_vipa.sh
+ echo 'echo "WARNING: It will be removed in the future."' >> src_vipa.sh
echo 'exec $$@' >> src_vipa.sh
chmod 755 src_vipa.sh

View File

@ -9,7 +9,7 @@ Name: s390utils
Summary: Utilities and daemons for IBM z Systems
Group: System Environment/Base
Version: 2.6.0
Release: 28%{?dist}.2
Release: 33%{?dist}
Epoch: 2
License: MIT
ExclusiveArch: s390 s390x
@ -53,6 +53,8 @@ Patch1000: cmsfs-1.1.8-warnings.patch
Patch1001: cmsfs-1.1.8-kernel26.patch
Patch1002: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
Patch2000: src_vipa-2.1.0-deprecate.patch
Requires: s390utils-base = %{epoch}:%{version}-%{release}
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
Requires: s390utils-cpuplugd = %{epoch}:%{version}-%{release}
@ -97,6 +99,13 @@ pushd cmsfs-%{cmsfsver}
%patch1002 -p1 -b .use-detected-block-size
popd
#
# src_vipa
#
pushd src_vipa-%{vipaver}
# mark as deprecated
%patch2000 -p2
popd
# remove --strip from install
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
@ -226,10 +235,10 @@ Requires: ethtool
%{?systemd_requires}
BuildRequires: perl-generators
BuildRequires: ncurses-devel
BuildRequires: libpfm-devel
BuildRequires: glibc-static
BuildRequires: cryptsetup-devel >= 2.0.3
BuildRequires: json-c-devel
BuildRequires: glib2-devel
%description base
@ -355,6 +364,13 @@ s390 base tools. This collection provides the following utilities:
Allows to set the system and sysplex names from the Linux guest to
the HMC/SE using the Control Program Identification feature.
* genprotimg:
Tool for the creation of PV images. The image consists of a concatenation of
a plain text boot loader, the encrypted components for kernel, initrd, and
cmdline, and the integrity-protected PV header, containing metadata necessary for
running the guest in PV mode. Protected VMs (PVM) are KVM VMs, where KVM can't
access the VM's state like guest memory and guest registers anymore.
For more information refer to the following publications:
* "Device Drivers, Features, and Commands" chapter "Useful Linux commands"
* "Using the dump tools"
@ -436,6 +452,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_sbindir}/zpcictl
%{_bindir}/lscpumf
%{_bindir}/dump2tar
%{_bindir}/genprotimg
%{_bindir}/vmconvert
%{_bindir}/zkey
%{_bindir}/zkey-cryptsetup
@ -470,6 +487,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_mandir}/man8/dasdview.8*
%{_mandir}/man8/dumpconf.8*
%{_mandir}/man8/fdasd.8*
%{_mandir}/man8/genprotimg.8.*
%{_mandir}/man8/hyptop.8*
%{_mandir}/man8/lschp.8*
%{_mandir}/man8/lscss.8*
@ -500,6 +518,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_mandir}/man8/zpcictl.8*
%dir %{_datadir}/s390-tools/
%{_datadir}/s390-tools/cpumf/
%{_datadir}/s390-tools/genprotimg/
%{_datadir}/s390-tools/netboot/
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/repository
@ -856,13 +875,39 @@ User-space development files for the s390/s390x architecture.
%changelog
* Tue Jul 07 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-28.2
- avoid dependency on network-scripts (#1852525)
- Resolves: #1852525
* Fri Jul 31 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-33
- cpacfstats: Bugfix to remove libpfm from cpacfstats (#1861779)
- Resolves: (#1861779)
* Thu Jun 25 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-28.1
- zipl/libc: Fix potential buffer overflow in printf (#1847536)
- Resolves: #1847536
* Fri Jul 24 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-32
- vmcp: Change sequence of failed exit (#1858839)
- zipl: Fix KVM IPL without bootindex (#1858842, #1846960)
- Resolves: #1858839, #1846960
* Fri Jul 03 2020 Javier Martinez Canillas <javierm@redhat.com> - 2:2.6.0-31
- add a default entry in zipl.conf if there isn't one present (#1698363)
- Resolves: #1698363
* Mon Jun 22 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-30
- avoid dependency on network-scripts (#1847388)
- Resolves: #1847388
* Thu May 28 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-29
- zkey: Add support for EP11 secure keys (#1723845)
- ipl-tools: Add nvme device support to zipl, lsreipl/chreipl (#1525178)
- zipl: Rebase to 2.13.0 (#1821250)
- ipl_tools: support clear attribute for FCP and CCW re-IPL (#1812983)
- lscpumf: New z15 CPU-MF counters not available (#1821591)
- dbginfo.sh: Extend data collection (#1814323)
- zpcictl: Initiate recover after reset (#1814303)
- zipl: fix secure boot config handling (#1814322)
- zkey: Fix display of clear key size for CCA-AESCIPHER keys (#1808492)
- zkey: Fix display of XTS attribute for validate command (#1808494)
- dasdview: Fix exit status in error cases (#1783288)
- zipl/libc: Fix potential buffer overflow in printf (#1807973)
- src_vipa feature is deprecated (#1780648)
- zdev: report FC Endpoint Security of zfcp device (#1723843)
- Resolves: #1723845 #1525178 #1821250 #1812983 #1821591 #1814323 #1814303 #1814322 #1808492 #1808494 #1783288 #1807973 #1780648 #1723843
* Mon Jan 27 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-28
- zkey: Fix listing of keys on file systems reporting DT_UNKNOWN (#1792957)