import s390utils-2.25.0-4.el9
This commit is contained in:
parent
874fdd8a2c
commit
5e24e18e30
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/s390-tools-2.22.0.tar.gz
|
SOURCES/s390-tools-2.25.0.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
7023dd992d5cb418cb522a62c6f8550bf3d4ec37 SOURCES/s390-tools-2.22.0.tar.gz
|
e8e0d3f651179fd14dc4a40d53a1e4ef6edaae7d SOURCES/s390-tools-2.25.0.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 14119148dabb7f4f633623c00eece44c5771db10 Mon Sep 17 00:00:00 2001
|
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
|||||||
return n;
|
return n;
|
||||||
|
|
||||||
--
|
--
|
||||||
2.36.1
|
2.37.3
|
||||||
|
|
||||||
|
|
||||||
From 661f143bb0b429c732d0ad9756c745dcb8799bc7 Mon Sep 17 00:00:00 2001
|
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Jones <pjones@redhat.com>
|
From: Peter Jones <pjones@redhat.com>
|
||||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||||
@ -208,20 +208,19 @@ Content-Transfer-Encoding: 8bit
|
|||||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||||
Signed-off-by: Dan Horák <dan@danny.cz>
|
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||||
---
|
---
|
||||||
zipl/src/Makefile | 2 +-
|
zipl/src/Makefile | 1 +
|
||||||
zipl/src/scan.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++-
|
zipl/src/scan.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++-
|
||||||
2 files changed, 95 insertions(+), 3 deletions(-)
|
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||||
index 786bb7f..1adc486 100644
|
index 64eabe4..7043005 100644
|
||||||
--- a/zipl/src/Makefile
|
--- a/zipl/src/Makefile
|
||||||
+++ b/zipl/src/Makefile
|
+++ b/zipl/src/Makefile
|
||||||
@@ -7,7 +7,7 @@ ALL_CPPFLAGS += -I../include -I../boot \
|
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||||
-D_FILE_OFFSET_BITS=64 $(NO_PIE_CFLAGS)
|
|
||||||
ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
|
||||||
|
|
||||||
-libs = $(rootdir)/libutil/libutil.a
|
libs = $(rootdir)/libutil/libutil.a \
|
||||||
+libs = $(rootdir)/libutil/libutil.a -lrpmio -lrpm
|
$(rootdir)/libvtoc/libvtoc.a \
|
||||||
|
+ -lrpmio -lrpm
|
||||||
|
|
||||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||||
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
||||||
@ -345,5 +344,5 @@ index 9352f76..3327e2d 100644
|
|||||||
static int
|
static int
|
||||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||||
--
|
--
|
||||||
2.36.1
|
2.37.3
|
||||||
|
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
From 2844d07e4bba2301fef66f56574c92054bac7cac Mon Sep 17 00:00:00 2001
|
|
||||||
From: Steffen Eiden <seiden@linux.ibm.com>
|
|
||||||
Date: Mon, 25 Jul 2022 12:57:53 +0200
|
|
||||||
Subject: [PATCH] zipl: Add missing check for a nullpointer.
|
|
||||||
|
|
||||||
Fixes a bug that leads to a segmentation fault when no parmline is
|
|
||||||
provided.
|
|
||||||
|
|
||||||
Fixes: 11b401b5 ("zipl: move and make check for maximum command line length dynamic")
|
|
||||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
|
||||||
Reviewed-by: Marc Hartmayer <mhartmay@linux.ibm.com>
|
|
||||||
Reviewed-by: Stefan Haberland <sth@linux.ibm.com>
|
|
||||||
---
|
|
||||||
zipl/src/job.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/zipl/src/job.c b/zipl/src/job.c
|
|
||||||
index ffdc297..b5bf5b2 100644
|
|
||||||
--- a/zipl/src/job.c
|
|
||||||
+++ b/zipl/src/job.c
|
|
||||||
@@ -790,7 +790,7 @@ check_common_ipl_data(struct job_common_ipl_data *common, const char *section,
|
|
||||||
if (!max_parm_size)
|
|
||||||
max_parm_size = LEGACY_MAXIMUM_PARMLINE_SIZE;
|
|
||||||
|
|
||||||
- len = strlen(common->parmline);
|
|
||||||
+ len = common->parmline ? strlen(common->parmline) : 0;
|
|
||||||
if (len > max_parm_size) {
|
|
||||||
error_text("The length of the parameters line "
|
|
||||||
"(%d bytes) exceeds the allowed maximum "
|
|
||||||
--
|
|
||||||
2.37.1
|
|
||||||
|
|
35
SOURCES/s390utils-2.25.0-rhel.patch
Normal file
35
SOURCES/s390utils-2.25.0-rhel.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From a9fed51fbf159a98fcd4a9dddf4fef243bb433af Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||||
|
Date: Fri, 20 Jan 2023 11:04:18 +0100
|
||||||
|
Subject: [PATCH] zkey: Support EP11 host library version 4 (#2165812)
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Try to load libep11.so.4 if available, but fallback to older
|
||||||
|
library versions if not.
|
||||||
|
|
||||||
|
Reviewed-by: Jörg Schmidbauer <jschmidb@de.ibm.com>
|
||||||
|
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||||
|
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||||
|
(cherry picked from commit 6222c384958729bc4b5bad61ad38967647cc3248)
|
||||||
|
---
|
||||||
|
zkey/ep11.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/zkey/ep11.c b/zkey/ep11.c
|
||||||
|
index 58dc3c5..8359929 100644
|
||||||
|
--- a/zkey/ep11.c
|
||||||
|
+++ b/zkey/ep11.c
|
||||||
|
@@ -35,7 +35,7 @@
|
||||||
|
* Definitions for the EP11 library
|
||||||
|
*/
|
||||||
|
#define EP11_LIBRARY_NAME "libep11.so"
|
||||||
|
-#define EP11_LIBRARY_VERSION 3
|
||||||
|
+#define EP11_LIBRARY_VERSION 4
|
||||||
|
#define EP11_WEB_PAGE "http://www.ibm.com/security/cryptocards"
|
||||||
|
|
||||||
|
/**
|
||||||
|
--
|
||||||
|
2.39.1
|
||||||
|
|
@ -9,8 +9,8 @@
|
|||||||
|
|
||||||
Name: s390utils
|
Name: s390utils
|
||||||
Summary: Utilities and daemons for IBM z Systems
|
Summary: Utilities and daemons for IBM z Systems
|
||||||
Version: 2.22.0
|
Version: 2.25.0
|
||||||
Release: 2%{?dist}
|
Release: 4%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: MIT
|
License: MIT
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
@ -37,8 +37,8 @@ Source25: 91-zipl.install
|
|||||||
Patch0: s390-tools-zipl-invert-script-options.patch
|
Patch0: s390-tools-zipl-invert-script-options.patch
|
||||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||||
|
|
||||||
# backported fixes
|
# upstream fixes/updates
|
||||||
Patch100: s390utils-%{version}-rhel.patch
|
Patch100: s390utils-%%{version}-rhel.patch
|
||||||
|
|
||||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
@ -66,6 +66,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
%patch0 -p1 -b .zipl-invert-script-options
|
%patch0 -p1 -b .zipl-invert-script-options
|
||||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||||
|
|
||||||
|
# upstream fixes/updates
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
|
|
||||||
# drop -Werror from genprotimg to allow building with GCC 12
|
# drop -Werror from genprotimg to allow building with GCC 12
|
||||||
@ -84,7 +85,6 @@ make \
|
|||||||
%endif
|
%endif
|
||||||
NO_PIE_LDFLAGS="" \
|
NO_PIE_LDFLAGS="" \
|
||||||
BINDIR=/usr/sbin \
|
BINDIR=/usr/sbin \
|
||||||
UDEVRUNDIR=/run/udev \
|
|
||||||
DISTRELEASE=%{release} \
|
DISTRELEASE=%{release} \
|
||||||
V=1
|
V=1
|
||||||
|
|
||||||
@ -98,7 +98,6 @@ make install \
|
|||||||
DESTDIR=%{buildroot} \
|
DESTDIR=%{buildroot} \
|
||||||
BINDIR=/usr/sbin \
|
BINDIR=/usr/sbin \
|
||||||
SYSTEMDSYSTEMUNITDIR=%{_unitdir} \
|
SYSTEMDSYSTEMUNITDIR=%{_unitdir} \
|
||||||
UDEVRUNDIR=/run/udev \
|
|
||||||
DISTRELEASE=%{release} \
|
DISTRELEASE=%{release} \
|
||||||
V=1
|
V=1
|
||||||
|
|
||||||
@ -277,7 +276,6 @@ BuildRequires: json-c-devel
|
|||||||
BuildRequires: rpm-devel
|
BuildRequires: rpm-devel
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: liblockfile-devel
|
|
||||||
|
|
||||||
|
|
||||||
%description base
|
%description base
|
||||||
@ -488,6 +486,11 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%config(noreplace) %{_sysconfdir}/sysconfig/dumpconf
|
%config(noreplace) %{_sysconfdir}/sysconfig/dumpconf
|
||||||
%{_sysconfdir}/mdevctl.d/*
|
%{_sysconfdir}/mdevctl.d/*
|
||||||
/usr/lib/dracut/modules.d/99ngdump/
|
/usr/lib/dracut/modules.d/99ngdump/
|
||||||
|
# own the mdevctl dirs until new release is available
|
||||||
|
%dir /usr/lib/mdevctl
|
||||||
|
%dir /usr/lib/mdevctl/scripts.d
|
||||||
|
%dir /usr/lib/mdevctl/scripts.d/callouts
|
||||||
|
/usr/lib/mdevctl/scripts.d/callouts/ap-check
|
||||||
/lib/s390-tools/dumpconf
|
/lib/s390-tools/dumpconf
|
||||||
/lib/s390-tools/lsznet.raw
|
/lib/s390-tools/lsznet.raw
|
||||||
%dir /lib/s390-tools/zfcpdump
|
%dir /lib/s390-tools/zfcpdump
|
||||||
@ -816,6 +819,7 @@ Requires(preun): systemd
|
|||||||
Requires(postun): systemd
|
Requires(postun): systemd
|
||||||
Requires(pre): shadow-utils
|
Requires(pre): shadow-utils
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
|
BuildRequires: systemd-devel
|
||||||
|
|
||||||
%description cpacfstatsd
|
%description cpacfstatsd
|
||||||
The cpacfstats tools provide a client/server application set to monitor
|
The cpacfstats tools provide a client/server application set to monitor
|
||||||
@ -903,6 +907,34 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 02 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-4
|
||||||
|
- zkey: Support EP11 host library version 4 (#2165812)
|
||||||
|
- Resolves: #2165812
|
||||||
|
|
||||||
|
* Wed Jan 25 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-3
|
||||||
|
- revert the last change
|
||||||
|
- Related: #2161740
|
||||||
|
|
||||||
|
* Thu Jan 19 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-2
|
||||||
|
- update kernel install script to write /etc/kernel/cmdline (#2161740)
|
||||||
|
- Resolves: #2161740
|
||||||
|
|
||||||
|
* Tue Dec 13 2022 Dan Horák <dhorak@redhat.com> - 2:2.25.0-1
|
||||||
|
- rebased to 2.25.0 (#2110310)
|
||||||
|
- zipl: Support for Secure Boot IPL and Dump from ECKD DASD (#2044200)
|
||||||
|
- zipl: Add secure boot trailer (#2142883)
|
||||||
|
- Resolves: #2110310 #2044200 #2142883
|
||||||
|
|
||||||
|
* Thu Nov 24 2022 Dan Horák <dhorak@redhat.com> - 2:2.24.0-1
|
||||||
|
- rebased to 2.24.0 (#2110310)
|
||||||
|
- KVM: Tool to process encrypted Secure Execution guest dumps (#2044198)
|
||||||
|
- zdev: Site-aware device configuration (#2044202)
|
||||||
|
- Support IBM z16 Processor-Activity-Instrumentation Facility (#2110298)
|
||||||
|
- Transparent DASD PPRC (Peer-to-Peer Remote Copy) handling (#2126617)
|
||||||
|
- Support IBM z16 Processor Activity Instrumentation Extension 1 (#2127435)
|
||||||
|
- Display Processor Activity Instrumentation CPACF counters (#2111012)
|
||||||
|
- Resolves: #2110310 #2044198 #2044202 #2110298 #2126617 #2127435 #2111012
|
||||||
|
|
||||||
* Thu Aug 04 2022 Dan Horák <dhorak@redhat.com> - 2:2.22.0-2
|
* Thu Aug 04 2022 Dan Horák <dhorak@redhat.com> - 2:2.22.0-2
|
||||||
- zipl: Add missing check for a nullpointer (#2113884)
|
- zipl: Add missing check for a nullpointer (#2113884)
|
||||||
- Resolves: #2113884
|
- Resolves: #2113884
|
||||||
|
Loading…
Reference in New Issue
Block a user