- rebased to 2.25.0 (#2110310)

- zipl: Support for Secure Boot IPL and Dump from ECKD DASD (#2044200)
- zipl: Add secure boot trailer (#2142883)
- Resolves: #2110310 #2044200 #2142883
This commit is contained in:
Dan Horák 2022-12-13 10:42:38 +01:00
parent c5faed242e
commit 5df5172a29
5 changed files with 30 additions and 1683 deletions

View File

@ -1,4 +1,4 @@
From 14119148dabb7f4f633623c00eece44c5771db10 Mon Sep 17 00:00:00 2001
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 20 Jun 2022 17:43:05 +0200
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
return n;
--
2.36.1
2.37.3
From 661f143bb0b429c732d0ad9756c745dcb8799bc7 Mon Sep 17 00:00:00 2001
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 20 Jun 2022 17:46:59 +0200
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
@ -208,20 +208,19 @@ Content-Transfer-Encoding: 8bit
Signed-off-by: Peter Jones <pjones@redhat.com>
Signed-off-by: Dan Horák <dan@danny.cz>
---
zipl/src/Makefile | 2 +-
zipl/src/Makefile | 1 +
zipl/src/scan.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++-
2 files changed, 95 insertions(+), 3 deletions(-)
2 files changed, 95 insertions(+), 2 deletions(-)
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
index 786bb7f..1adc486 100644
index 64eabe4..7043005 100644
--- a/zipl/src/Makefile
+++ b/zipl/src/Makefile
@@ -7,7 +7,7 @@ ALL_CPPFLAGS += -I../include -I../boot \
-D_FILE_OFFSET_BITS=64 $(NO_PIE_CFLAGS)
ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
-libs = $(rootdir)/libutil/libutil.a
+libs = $(rootdir)/libutil/libutil.a -lrpmio -lrpm
libs = $(rootdir)/libutil/libutil.a \
$(rootdir)/libvtoc/libvtoc.a \
+ -lrpmio -lrpm
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
@ -345,5 +344,5 @@ index 9352f76..3327e2d 100644
static int
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
--
2.36.1
2.37.3

File diff suppressed because it is too large Load Diff

View File

View File

@ -9,7 +9,7 @@
Name: s390utils
Summary: Utilities and daemons for IBM z Systems
Version: 2.24.0
Version: 2.25.0
Release: 1%{?dist}
Epoch: 2
License: MIT
@ -37,8 +37,8 @@ Source25: 91-zipl.install
Patch0: s390-tools-zipl-invert-script-options.patch
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
# backported fixes
Patch100: s390utils-%{version}-rhel.patch
# upstream fixes/updates
#Patch100: s390utils-%%{version}-rhel.patch
Requires: s390utils-core = %{epoch}:%{version}-%{release}
Requires: s390utils-base = %{epoch}:%{version}-%{release}
@ -66,7 +66,8 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
%patch0 -p1 -b .zipl-invert-script-options
%patch1 -p1 -b .blscfg-rpm-nvr-sort
%patch100 -p1
# upstream fixes/updates
#%%patch100 -p1
# drop -Werror from genprotimg to allow building with GCC 12
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
@ -485,6 +486,11 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
%config(noreplace) %{_sysconfdir}/sysconfig/dumpconf
%{_sysconfdir}/mdevctl.d/*
/usr/lib/dracut/modules.d/99ngdump/
# own the mdevctl dirs until new release is available
%dir /usr/lib/mdevctl
%dir /usr/lib/mdevctl/scripts.d
%dir /usr/lib/mdevctl/scripts.d/callouts
/usr/lib/mdevctl/scripts.d/callouts/ap-check
/lib/s390-tools/dumpconf
/lib/s390-tools/lsznet.raw
%dir /lib/s390-tools/zfcpdump
@ -901,6 +907,12 @@ User-space development files for the s390/s390x architecture.
%changelog
* Tue Dec 13 2022 Dan Horák <dhorak@redhat.com> - 2:2.25.0-1
- rebased to 2.25.0 (#2110310)
- zipl: Support for Secure Boot IPL and Dump from ECKD DASD (#2044200)
- zipl: Add secure boot trailer (#2142883)
- Resolves: #2110310 #2044200 #2142883
* Thu Nov 24 2022 Dan Horák <dhorak@redhat.com> - 2:2.24.0-1
- rebased to 2.24.0 (#2110310)
- KVM: Tool to process encrypted Secure Execution guest dumps (#2044198)
@ -908,7 +920,8 @@ User-space development files for the s390/s390x architecture.
- Support IBM z16 Processor-Activity-Instrumentation Facility (#2110298)
- Transparent DASD PPRC (Peer-to-Peer Remote Copy) handling (#2126617)
- Support IBM z16 Processor Activity Instrumentation Extension 1 (#2127435)
- Resolves: #2110310 #2044198 #2044202 #2110298 #2126617 #2127435
- Display Processor Activity Instrumentation CPACF counters (#2111012)
- Resolves: #2110310 #2044198 #2044202 #2110298 #2126617 #2127435 #2111012
* Thu Aug 04 2022 Dan Horák <dhorak@redhat.com> - 2:2.22.0-2
- zipl: Add missing check for a nullpointer (#2113884)

View File

@ -1 +1 @@
SHA512 (s390-tools-2.24.0.tar.gz) = 5c681a031c2bab0ab167623ad08da67bfd236e4892f8a5de813ebfbbc1c60a842f0954bcbca6d2f6ab125ee089b2b5dcbfbb24152bcdde3401810232e21460f4
SHA512 (s390-tools-2.25.0.tar.gz) = 1c766a4bd19c957596c741a80141712acf150591c0ff1a47caf1aa8a17f7153c1441560f05aef78bb3f05bd35c1fef431569cabd7e7d6b003bd74beedb7213d9