import CS s390utils-2.27.0-4.el9
This commit is contained in:
parent
5e24e18e30
commit
541e8e05c0
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/s390-tools-2.25.0.tar.gz
|
SOURCES/s390-tools-2.27.0.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
e8e0d3f651179fd14dc4a40d53a1e4ef6edaae7d SOURCES/s390-tools-2.25.0.tar.gz
|
ebfc228d39c55586d6b5af08682896adda6b0068 SOURCES/s390-tools-2.27.0.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
From b2daaa34776ba6afec879e362378f6f7563590a6 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
|||||||
return n;
|
return n;
|
||||||
|
|
||||||
--
|
--
|
||||||
2.37.3
|
2.39.2
|
||||||
|
|
||||||
|
|
||||||
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
From 692e70bcfc32a05e30146bd7077c41e0eaceff03 Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Jones <pjones@redhat.com>
|
From: Peter Jones <pjones@redhat.com>
|
||||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||||
@ -213,7 +213,7 @@ Signed-off-by: Dan Horák <dan@danny.cz>
|
|||||||
2 files changed, 95 insertions(+), 2 deletions(-)
|
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||||
index 64eabe4..7043005 100644
|
index cab5655..7ec215d 100644
|
||||||
--- a/zipl/src/Makefile
|
--- a/zipl/src/Makefile
|
||||||
+++ b/zipl/src/Makefile
|
+++ b/zipl/src/Makefile
|
||||||
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||||
@ -223,7 +223,7 @@ index 64eabe4..7043005 100644
|
|||||||
+ -lrpmio -lrpm
|
+ -lrpmio -lrpm
|
||||||
|
|
||||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||||
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
bootmap_header.o envblk.o install.o zipl.o
|
||||||
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
|
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
|
||||||
index 9352f76..3327e2d 100644
|
index 9352f76..3327e2d 100644
|
||||||
--- a/zipl/src/scan.c
|
--- a/zipl/src/scan.c
|
||||||
@ -344,5 +344,5 @@ index 9352f76..3327e2d 100644
|
|||||||
static int
|
static int
|
||||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||||
--
|
--
|
||||||
2.37.3
|
2.39.2
|
||||||
|
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
From a9fed51fbf159a98fcd4a9dddf4fef243bb433af Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Date: Fri, 20 Jan 2023 11:04:18 +0100
|
|
||||||
Subject: [PATCH] zkey: Support EP11 host library version 4 (#2165812)
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Try to load libep11.so.4 if available, but fallback to older
|
|
||||||
library versions if not.
|
|
||||||
|
|
||||||
Reviewed-by: Jörg Schmidbauer <jschmidb@de.ibm.com>
|
|
||||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
|
||||||
(cherry picked from commit 6222c384958729bc4b5bad61ad38967647cc3248)
|
|
||||||
---
|
|
||||||
zkey/ep11.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/zkey/ep11.c b/zkey/ep11.c
|
|
||||||
index 58dc3c5..8359929 100644
|
|
||||||
--- a/zkey/ep11.c
|
|
||||||
+++ b/zkey/ep11.c
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
* Definitions for the EP11 library
|
|
||||||
*/
|
|
||||||
#define EP11_LIBRARY_NAME "libep11.so"
|
|
||||||
-#define EP11_LIBRARY_VERSION 3
|
|
||||||
+#define EP11_LIBRARY_VERSION 4
|
|
||||||
#define EP11_WEB_PAGE "http://www.ibm.com/security/cryptocards"
|
|
||||||
|
|
||||||
/**
|
|
||||||
--
|
|
||||||
2.39.1
|
|
||||||
|
|
1578
SOURCES/s390utils-2.27.0-rhel.patch
Normal file
1578
SOURCES/s390utils-2.27.0-rhel.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -9,7 +9,7 @@
|
|||||||
|
|
||||||
Name: s390utils
|
Name: s390utils
|
||||||
Summary: Utilities and daemons for IBM z Systems
|
Summary: Utilities and daemons for IBM z Systems
|
||||||
Version: 2.25.0
|
Version: 2.27.0
|
||||||
Release: 4%{?dist}
|
Release: 4%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -38,7 +38,7 @@ Patch0: s390-tools-zipl-invert-script-options.patch
|
|||||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||||
|
|
||||||
# upstream fixes/updates
|
# upstream fixes/updates
|
||||||
Patch100: s390utils-%%{version}-rhel.patch
|
Patch100: s390utils-%{version}-rhel.patch
|
||||||
|
|
||||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
@ -69,9 +69,6 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
# upstream fixes/updates
|
# upstream fixes/updates
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
|
|
||||||
# drop -Werror from genprotimg to allow building with GCC 12
|
|
||||||
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
|
||||||
|
|
||||||
# remove --strip from install
|
# remove --strip from install
|
||||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||||
|
|
||||||
@ -215,6 +212,7 @@ This package provides minimal set of tools needed to system to boot.
|
|||||||
%{_unitdir}/cpi.service
|
%{_unitdir}/cpi.service
|
||||||
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
|
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
|
||||||
/usr/lib/dracut/modules.d/95zdev/
|
/usr/lib/dracut/modules.d/95zdev/
|
||||||
|
/usr/lib/dracut/modules.d/95zdev-kdump/
|
||||||
%{_mandir}/man5/zipl.conf.5*
|
%{_mandir}/man5/zipl.conf.5*
|
||||||
%{_mandir}/man8/chreipl.8*
|
%{_mandir}/man8/chreipl.8*
|
||||||
%{_mandir}/man8/chzdev.8*
|
%{_mandir}/man8/chzdev.8*
|
||||||
@ -340,11 +338,6 @@ s390 base tools. This collection provides the following utilities:
|
|||||||
* tunedasd:
|
* tunedasd:
|
||||||
Adjust tunable parameters on DASD devices.
|
Adjust tunable parameters on DASD devices.
|
||||||
|
|
||||||
* vmconvert:
|
|
||||||
Convert system dumps created by the z/VM VMDUMP command into dumps with
|
|
||||||
LKCD format. These LKCD dumps can then be analyzed with the dump analysis
|
|
||||||
tool lcrash.
|
|
||||||
|
|
||||||
* vmcp:
|
* vmcp:
|
||||||
Allows Linux users to send commands to the z/VM control program (CP).
|
Allows Linux users to send commands to the z/VM control program (CP).
|
||||||
The normal usage is to invoke vmcp with the command you want to
|
The normal usage is to invoke vmcp with the command you want to
|
||||||
@ -478,7 +471,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_bindir}/mk-s390image
|
%{_bindir}/mk-s390image
|
||||||
%{_bindir}/pvattest
|
%{_bindir}/pvattest
|
||||||
%{_bindir}/pvextract-hdr
|
%{_bindir}/pvextract-hdr
|
||||||
%{_bindir}/vmconvert
|
|
||||||
%{_bindir}/zkey
|
%{_bindir}/zkey
|
||||||
%{_bindir}/zkey-cryptsetup
|
%{_bindir}/zkey-cryptsetup
|
||||||
%{_unitdir}/dumpconf.service
|
%{_unitdir}/dumpconf.service
|
||||||
@ -507,7 +499,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_mandir}/man1/pvattest-create.1*
|
%{_mandir}/man1/pvattest-create.1*
|
||||||
%{_mandir}/man1/pvattest-perform.1*
|
%{_mandir}/man1/pvattest-perform.1*
|
||||||
%{_mandir}/man1/pvattest-verify.1*
|
%{_mandir}/man1/pvattest-verify.1*
|
||||||
%{_mandir}/man1/vmconvert.1*
|
|
||||||
%{_mandir}/man1/zkey.1*
|
%{_mandir}/man1/zkey.1*
|
||||||
%{_mandir}/man1/zkey-cryptsetup.1*
|
%{_mandir}/man1/zkey-cryptsetup.1*
|
||||||
%{_mandir}/man1/zkey-ekmfweb.1*
|
%{_mandir}/man1/zkey-ekmfweb.1*
|
||||||
@ -907,6 +898,29 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 7 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-4
|
||||||
|
- zdev/dracut: fix kdump build to integrate with site support (#2229177)
|
||||||
|
- Resolves: #2229177
|
||||||
|
|
||||||
|
* Thu Jul 20 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-3
|
||||||
|
- Secure Execution APQN binding and IBK association (#2110521)
|
||||||
|
- Resolves: #2110521
|
||||||
|
|
||||||
|
* Mon Jul 17 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-2
|
||||||
|
- zdev: cleanup patches to fix warnings (#2223304)
|
||||||
|
- zdev: add missing label in the udev-rules (#2222900)
|
||||||
|
- Resolves: #2223304 #2222900
|
||||||
|
|
||||||
|
* Wed May 31 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-1
|
||||||
|
- rebased to 2.27.0 (#2160062)
|
||||||
|
- lszcrypt fails when querying a specific domain (#2177612)
|
||||||
|
- DASD autoquiesce support (#2196517)
|
||||||
|
- zcrypt DD: AP command filtering (#2170360)
|
||||||
|
- vmconvert and zgetdump consolidation (#2173924)
|
||||||
|
- Support for List-Directed dump from ECKD DASD (#2160052)
|
||||||
|
- Support for List-Directed IPL and re-IPL from ECKD DASD (#2160040)
|
||||||
|
- Resolves: #2160062 #2177612 #2196517 #2170360 #2173924 #2160052 #2160040
|
||||||
|
|
||||||
* Thu Feb 02 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-4
|
* Thu Feb 02 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-4
|
||||||
- zkey: Support EP11 host library version 4 (#2165812)
|
- zkey: Support EP11 host library version 4 (#2165812)
|
||||||
- Resolves: #2165812
|
- Resolves: #2165812
|
||||||
|
Loading…
Reference in New Issue
Block a user