- rebased to 2.16.0
This commit is contained in:
parent
d792b32be1
commit
3d1d949272
1
.gitignore
vendored
1
.gitignore
vendored
@ -23,3 +23,4 @@ src_vipa-2.0.4.tar.gz
|
||||
/s390-tools-2.14.0.tar.gz
|
||||
/s390-tools-2.15.0.tar.gz
|
||||
/s390-tools-2.15.1.tar.gz
|
||||
/s390-tools-2.16.0.tar.gz
|
||||
|
1021
s390-tools-2.16.0-genprotimg.patch
Normal file
1021
s390-tools-2.16.0-genprotimg.patch
Normal file
File diff suppressed because it is too large
Load Diff
50
s390-tools-2.16.0-zkey.patch
Normal file
50
s390-tools-2.16.0-zkey.patch
Normal file
@ -0,0 +1,50 @@
|
||||
From 3f3f063c98278f53ad3b34e68b70fca62eaea8fb Mon Sep 17 00:00:00 2001
|
||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Date: Tue, 23 Feb 2021 08:52:26 +0100
|
||||
Subject: [PATCH] zkey: Fix build error when the compiler flags are overridden
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
When the compiler flags are overridden, the build of zkey may fail with:
|
||||
|
||||
kms.c:44:2: error: #error KMS_PLUGIN_LOCATION must be defined
|
||||
44 | #error KMS_PLUGIN_LOCATION must be defined
|
||||
| ^~~~~
|
||||
|
||||
The Makefile uses CFLAGS variable for defining the KMS_PLUGIN_LOCATION,
|
||||
but it should rather use ALL_CFLAGS.
|
||||
|
||||
Also use ALL_CPPFLAGS for defining HAVE_LUKS2_SUPPORT.
|
||||
|
||||
Fixes: https://github.com/ibm-s390-linux/s390-tools/issues/108
|
||||
|
||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Reviewed-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
||||
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
||||
---
|
||||
zkey/Makefile | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/zkey/Makefile b/zkey/Makefile
|
||||
index 41129bcf..f74e2091 100644
|
||||
--- a/zkey/Makefile
|
||||
+++ b/zkey/Makefile
|
||||
@@ -18,7 +18,7 @@ ifneq (${HAVE_CRYPTSETUP2},0)
|
||||
ifneq (${HAVE_OPENSSL},0)
|
||||
BUILD_TARGETS += zkey-cryptsetup
|
||||
INSTALL_TARGETS += install-zkey-cryptsetup
|
||||
- CPPFLAGS += -DHAVE_LUKS2_SUPPORT
|
||||
+ ALL_CPPFLAGS += -DHAVE_LUKS2_SUPPORT
|
||||
else
|
||||
BUILD_TARGETS += zkey-cryptsetup-skip-openssl
|
||||
INSTALL_TARGETS += zkey-cryptsetup-skip-openssl
|
||||
@@ -34,7 +34,7 @@ endif
|
||||
|
||||
libs = $(rootdir)/libutil/libutil.a
|
||||
|
||||
-CFLAGS += -DKMS_PLUGIN_LOCATION=\"$(ZKEYKMSPLUGINDIR)\"
|
||||
+ALL_CFLAGS += -DKMS_PLUGIN_LOCATION=\"$(ZKEYKMSPLUGINDIR)\"
|
||||
|
||||
detect-libcryptsetup.dep:
|
||||
echo "#include <libcryptsetup.h>" > detect-libcryptsetup.dep
|
@ -5,8 +5,8 @@
|
||||
|
||||
Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Version: 2.15.1
|
||||
Release: 5%{?dist}
|
||||
Version: 2.16.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
@ -35,6 +35,12 @@ Source25: 91-zipl.install
|
||||
Patch0: s390-tools-zipl-invert-script-options.patch
|
||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||
|
||||
# upstream fixes
|
||||
# https://github.com/ibm-s390-linux/s390-tools/commit/3f3f063c98278f53ad3b34e68b70fca62eaea8fb
|
||||
Patch100: s390-tools-2.16.0-zkey.patch
|
||||
# https://github.com/ibm-s390-linux/s390-tools/commit/b6bdd7744aba06d82f30b0c84012f0b06ccb01de
|
||||
Patch101: s390-tools-2.16.0-genprotimg.patch
|
||||
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||
@ -61,6 +67,10 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
||||
%patch0 -p1 -b .zipl-invert-script-options
|
||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||
|
||||
# upstream fixes
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
|
||||
# remove --strip from install
|
||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||
|
||||
@ -408,6 +418,7 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_sbindir}/dasdstat
|
||||
%{_sbindir}/dasdview
|
||||
%{_sbindir}/dbginfo.sh
|
||||
%{_sbindir}/hsci
|
||||
%{_sbindir}/hyptop
|
||||
%{_sbindir}/ip_watcher.pl
|
||||
%{_sbindir}/lschp
|
||||
@ -477,6 +488,7 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_mandir}/man8/dasdview.8*
|
||||
%{_mandir}/man8/dumpconf.8*
|
||||
%{_mandir}/man8/genprotimg.8.*
|
||||
%{_mandir}/man8/hsci.8*
|
||||
%{_mandir}/man8/hyptop.8*
|
||||
%{_mandir}/man8/lschp.8*
|
||||
%{_mandir}/man8/lscss.8*
|
||||
@ -805,6 +817,9 @@ User-space development files for the s390/s390x architecture.
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 24 2021 Dan Horák <dan[at]danny.cz> - 2:2.16.0-1
|
||||
- rebased to 2.16.0
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2:2.15.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (s390-tools-2.15.1.tar.gz) = a62ab491bac153b78161b7b1fb80ef1aa5ddb8657a9329f5ad9f8a16f106a9a9af1a37ceb328ed34eb44adb406207faec12ed0fb6648b5198498bf2fd411f0cf
|
||||
SHA512 (s390-tools-2.16.0.tar.gz) = d0866e2f372ba2938ccab264846d6cfe3db1b760cff6645fbefcd33a8ce8e7d971e442ccefda7e8e4d59818293147caa57fa593a3e66cd77e1e661928336793c
|
||||
|
Loading…
Reference in New Issue
Block a user