- rebased to 2.27.0 (#2160062)
- lszcrypt fails when querying a specific domain (#2177612) - DASD autoquiesce support (#2196517) - zcrypt DD: AP command filtering (#2170360) - vmconvert and zgetdump consolidation (#2173924) - Support for List-Directed dump from ECKD DASD (#2160052) - Support for List-Directed IPL and re-IPL from ECKD DASD (#2160040) - Resolves: #2160062 #2177612 #2196517 #2170360 #2173924 #2160052 #2160040
This commit is contained in:
parent
45ea441edc
commit
37d592e2f0
@ -1,4 +1,4 @@
|
|||||||
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
From b2daaa34776ba6afec879e362378f6f7563590a6 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
|||||||
return n;
|
return n;
|
||||||
|
|
||||||
--
|
--
|
||||||
2.37.3
|
2.39.2
|
||||||
|
|
||||||
|
|
||||||
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
From 692e70bcfc32a05e30146bd7077c41e0eaceff03 Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Jones <pjones@redhat.com>
|
From: Peter Jones <pjones@redhat.com>
|
||||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||||
@ -213,7 +213,7 @@ Signed-off-by: Dan Horák <dan@danny.cz>
|
|||||||
2 files changed, 95 insertions(+), 2 deletions(-)
|
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||||
index 64eabe4..7043005 100644
|
index cab5655..7ec215d 100644
|
||||||
--- a/zipl/src/Makefile
|
--- a/zipl/src/Makefile
|
||||||
+++ b/zipl/src/Makefile
|
+++ b/zipl/src/Makefile
|
||||||
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||||
@ -223,7 +223,7 @@ index 64eabe4..7043005 100644
|
|||||||
+ -lrpmio -lrpm
|
+ -lrpmio -lrpm
|
||||||
|
|
||||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||||
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
bootmap_header.o envblk.o install.o zipl.o
|
||||||
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
|
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
|
||||||
index 9352f76..3327e2d 100644
|
index 9352f76..3327e2d 100644
|
||||||
--- a/zipl/src/scan.c
|
--- a/zipl/src/scan.c
|
||||||
@ -344,5 +344,5 @@ index 9352f76..3327e2d 100644
|
|||||||
static int
|
static int
|
||||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||||
--
|
--
|
||||||
2.37.3
|
2.39.2
|
||||||
|
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
From a9fed51fbf159a98fcd4a9dddf4fef243bb433af Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Date: Fri, 20 Jan 2023 11:04:18 +0100
|
|
||||||
Subject: [PATCH] zkey: Support EP11 host library version 4 (#2165812)
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Try to load libep11.so.4 if available, but fallback to older
|
|
||||||
library versions if not.
|
|
||||||
|
|
||||||
Reviewed-by: Jörg Schmidbauer <jschmidb@de.ibm.com>
|
|
||||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
||||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
|
||||||
(cherry picked from commit 6222c384958729bc4b5bad61ad38967647cc3248)
|
|
||||||
---
|
|
||||||
zkey/ep11.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/zkey/ep11.c b/zkey/ep11.c
|
|
||||||
index 58dc3c5..8359929 100644
|
|
||||||
--- a/zkey/ep11.c
|
|
||||||
+++ b/zkey/ep11.c
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
* Definitions for the EP11 library
|
|
||||||
*/
|
|
||||||
#define EP11_LIBRARY_NAME "libep11.so"
|
|
||||||
-#define EP11_LIBRARY_VERSION 3
|
|
||||||
+#define EP11_LIBRARY_VERSION 4
|
|
||||||
#define EP11_WEB_PAGE "http://www.ibm.com/security/cryptocards"
|
|
||||||
|
|
||||||
/**
|
|
||||||
--
|
|
||||||
2.39.1
|
|
||||||
|
|
108
s390utils-2.27.0-rhel.patch
Normal file
108
s390utils-2.27.0-rhel.patch
Normal file
@ -0,0 +1,108 @@
|
|||||||
|
From 493af760ed47454f5719f05a6e6316f43a3be98a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stefan Haberland <sth@linux.ibm.com>
|
||||||
|
Date: Mon, 8 May 2023 14:52:54 +0200
|
||||||
|
Subject: [PATCH] zdev: add support for autoquiesce related sysfs attributes
|
||||||
|
|
||||||
|
Autoquiesce is a mechanism that tells Linux to stop issuing I/Os to a
|
||||||
|
specific DASD after certain events.
|
||||||
|
|
||||||
|
Add support for configuring related DASD device attributes
|
||||||
|
that govern the following aspects of autoquiesce:
|
||||||
|
|
||||||
|
aq_mask - Configure which events lead to autoquiesce.
|
||||||
|
aq_requeue - Configure if autoquiesce will requeue all I/O to blocklayer.
|
||||||
|
aq_timeouts - Configure the number of timeouts before autoquiesce.
|
||||||
|
|
||||||
|
Signed-off-by: Stefan Haberland <sth@linux.ibm.com>
|
||||||
|
Reviewed-by: Peter Oberparleiter <oberpar@linux.ibm.com>
|
||||||
|
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||||
|
---
|
||||||
|
zdev/src/dasd.c | 65 +++++++++++++++++++++++++++++++++++++++++++++++++
|
||||||
|
1 file changed, 65 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/zdev/src/dasd.c b/zdev/src/dasd.c
|
||||||
|
index f9fd231..4330229 100644
|
||||||
|
--- a/zdev/src/dasd.c
|
||||||
|
+++ b/zdev/src/dasd.c
|
||||||
|
@@ -344,6 +344,68 @@ static struct attrib dasd_attr_fc_security = {
|
||||||
|
.readonly = 1,
|
||||||
|
};
|
||||||
|
|
||||||
|
+static struct attrib dasd_attr_aq_mask = {
|
||||||
|
+ .name = "aq_mask",
|
||||||
|
+ .title = "Specify autoquiesce triggers",
|
||||||
|
+ .desc =
|
||||||
|
+ "Use the aq_mask attribute to automatically quiesce a device and block\n"
|
||||||
|
+ "new I/O after certain events.\n"
|
||||||
|
+ "\n"
|
||||||
|
+ "The value is a bitmask in decimal or hexadecimal format where each set bit\n"
|
||||||
|
+ "indicates that the associated event shown in the table below triggers an\n"
|
||||||
|
+ "autoquiesce.\n"
|
||||||
|
+ " Bit 0 is not used.\n"
|
||||||
|
+ " 1 - 0x02 - A terminal I/O error occurred\n"
|
||||||
|
+ " 2 - 0x04 - No active channel paths remain for the device\n"
|
||||||
|
+ " 3 - 0x08 - A state change interrupt occurred\n"
|
||||||
|
+ " 4 - 0x10 - The device is PPRC suspended\n"
|
||||||
|
+ " 5 - 0x20 - No space is left on an ESE device\n"
|
||||||
|
+ " 6 - 0x40 – The number of timeouts specified in aq_timeouts is reached\n"
|
||||||
|
+ " 7 - 0x80 - I/O was not started because of an error in the start function\n"
|
||||||
|
+ "\n"
|
||||||
|
+ "For example bits 1,3 and 5 set (0010 1010) lead to an integer value of 42\n"
|
||||||
|
+ "or 0x2A.\n"
|
||||||
|
+ "An integer value of 0 turns off the autoquiesce function.\n",
|
||||||
|
+ .order_cmp = ccw_online_only_order_cmp,
|
||||||
|
+ .check = ccw_online_only_check,
|
||||||
|
+ .defval = "0",
|
||||||
|
+ /*
|
||||||
|
+ * Currently only 8 bits are defined and the max value is 255.
|
||||||
|
+ * This needs to be adjusted if more bits are defined.
|
||||||
|
+ */
|
||||||
|
+ .accept = ACCEPT_ARRAY(ACCEPT_RANGE(0, 255)),
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+static struct attrib dasd_attr_aq_requeue = {
|
||||||
|
+ .name = "aq_requeue",
|
||||||
|
+ .title = "Control I/O requeing during autoquiesce",
|
||||||
|
+ .desc =
|
||||||
|
+ "Use the aq_requeue attribute to control whether outstanding I/O\n"
|
||||||
|
+ "operations to the blocklayer should be automatically requeued after\n"
|
||||||
|
+ "an autoquiesce event.\n"
|
||||||
|
+ "Valid values are 1 for requeuing, or 0 for no requeueing.\n"
|
||||||
|
+ "Requeing the I/O requests to the blocklayer might benefit I/O\n"
|
||||||
|
+ "in case of a copy_pair swap operation.\n",
|
||||||
|
+ .order_cmp = ccw_online_only_order_cmp,
|
||||||
|
+ .check = ccw_online_only_check,
|
||||||
|
+ .defval = "0",
|
||||||
|
+ .accept = ACCEPT_ARRAY(ACCEPT_RANGE(0, 1)),
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+static struct attrib dasd_attr_aq_timeouts = {
|
||||||
|
+ .name = "aq_timeouts",
|
||||||
|
+ .title = "Specify timeout retry threshold",
|
||||||
|
+ .desc =
|
||||||
|
+ "Specify the number of sequential timeout events for an I/O operation\n"
|
||||||
|
+ "before an autoquiesce is triggered on a device.\n"
|
||||||
|
+ "This requires that the corresponding trigger bit 6 is set\n"
|
||||||
|
+ "in the aq_mask attribute.\n",
|
||||||
|
+ .order_cmp = ccw_online_only_order_cmp,
|
||||||
|
+ .check = ccw_online_only_check,
|
||||||
|
+ .defval = "32768",
|
||||||
|
+ .accept = ACCEPT_ARRAY(ACCEPT_RANGE(0, 32768)),
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* DASD subtype methods.
|
||||||
|
*/
|
||||||
|
@@ -725,6 +787,9 @@ struct subtype dasd_subtype_eckd = {
|
||||||
|
&dasd_attr_safe_offline,
|
||||||
|
&dasd_attr_fc_security,
|
||||||
|
&dasd_attr_copy_pair,
|
||||||
|
+ &dasd_attr_aq_mask,
|
||||||
|
+ &dasd_attr_aq_requeue,
|
||||||
|
+ &dasd_attr_aq_timeouts,
|
||||||
|
&internal_attr_early,
|
||||||
|
),
|
||||||
|
.unknown_dev_attribs = 1,
|
||||||
|
--
|
||||||
|
2.39.2
|
||||||
|
|
@ -9,8 +9,8 @@
|
|||||||
|
|
||||||
Name: s390utils
|
Name: s390utils
|
||||||
Summary: Utilities and daemons for IBM z Systems
|
Summary: Utilities and daemons for IBM z Systems
|
||||||
Version: 2.25.0
|
Version: 2.27.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: MIT
|
License: MIT
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
@ -69,9 +69,6 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
# upstream fixes/updates
|
# upstream fixes/updates
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
|
|
||||||
# drop -Werror from genprotimg to allow building with GCC 12
|
|
||||||
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
|
||||||
|
|
||||||
# remove --strip from install
|
# remove --strip from install
|
||||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||||
|
|
||||||
@ -215,6 +212,7 @@ This package provides minimal set of tools needed to system to boot.
|
|||||||
%{_unitdir}/cpi.service
|
%{_unitdir}/cpi.service
|
||||||
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
|
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
|
||||||
/usr/lib/dracut/modules.d/95zdev/
|
/usr/lib/dracut/modules.d/95zdev/
|
||||||
|
/usr/lib/dracut/modules.d/95zdev-kdump/
|
||||||
%{_mandir}/man5/zipl.conf.5*
|
%{_mandir}/man5/zipl.conf.5*
|
||||||
%{_mandir}/man8/chreipl.8*
|
%{_mandir}/man8/chreipl.8*
|
||||||
%{_mandir}/man8/chzdev.8*
|
%{_mandir}/man8/chzdev.8*
|
||||||
@ -340,11 +338,6 @@ s390 base tools. This collection provides the following utilities:
|
|||||||
* tunedasd:
|
* tunedasd:
|
||||||
Adjust tunable parameters on DASD devices.
|
Adjust tunable parameters on DASD devices.
|
||||||
|
|
||||||
* vmconvert:
|
|
||||||
Convert system dumps created by the z/VM VMDUMP command into dumps with
|
|
||||||
LKCD format. These LKCD dumps can then be analyzed with the dump analysis
|
|
||||||
tool lcrash.
|
|
||||||
|
|
||||||
* vmcp:
|
* vmcp:
|
||||||
Allows Linux users to send commands to the z/VM control program (CP).
|
Allows Linux users to send commands to the z/VM control program (CP).
|
||||||
The normal usage is to invoke vmcp with the command you want to
|
The normal usage is to invoke vmcp with the command you want to
|
||||||
@ -478,7 +471,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_bindir}/mk-s390image
|
%{_bindir}/mk-s390image
|
||||||
%{_bindir}/pvattest
|
%{_bindir}/pvattest
|
||||||
%{_bindir}/pvextract-hdr
|
%{_bindir}/pvextract-hdr
|
||||||
%{_bindir}/vmconvert
|
|
||||||
%{_bindir}/zkey
|
%{_bindir}/zkey
|
||||||
%{_bindir}/zkey-cryptsetup
|
%{_bindir}/zkey-cryptsetup
|
||||||
%{_unitdir}/dumpconf.service
|
%{_unitdir}/dumpconf.service
|
||||||
@ -507,7 +499,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
|||||||
%{_mandir}/man1/pvattest-create.1*
|
%{_mandir}/man1/pvattest-create.1*
|
||||||
%{_mandir}/man1/pvattest-perform.1*
|
%{_mandir}/man1/pvattest-perform.1*
|
||||||
%{_mandir}/man1/pvattest-verify.1*
|
%{_mandir}/man1/pvattest-verify.1*
|
||||||
%{_mandir}/man1/vmconvert.1*
|
|
||||||
%{_mandir}/man1/zkey.1*
|
%{_mandir}/man1/zkey.1*
|
||||||
%{_mandir}/man1/zkey-cryptsetup.1*
|
%{_mandir}/man1/zkey-cryptsetup.1*
|
||||||
%{_mandir}/man1/zkey-ekmfweb.1*
|
%{_mandir}/man1/zkey-ekmfweb.1*
|
||||||
@ -907,6 +898,16 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 31 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-1
|
||||||
|
- rebased to 2.27.0 (#2160062)
|
||||||
|
- lszcrypt fails when querying a specific domain (#2177612)
|
||||||
|
- DASD autoquiesce support (#2196517)
|
||||||
|
- zcrypt DD: AP command filtering (#2170360)
|
||||||
|
- vmconvert and zgetdump consolidation (#2173924)
|
||||||
|
- Support for List-Directed dump from ECKD DASD (#2160052)
|
||||||
|
- Support for List-Directed IPL and re-IPL from ECKD DASD (#2160040)
|
||||||
|
- Resolves: #2160062 #2177612 #2196517 #2170360 #2173924 #2160052 #2160040
|
||||||
|
|
||||||
* Thu Feb 02 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-4
|
* Thu Feb 02 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-4
|
||||||
- zkey: Support EP11 host library version 4 (#2165812)
|
- zkey: Support EP11 host library version 4 (#2165812)
|
||||||
- Resolves: #2165812
|
- Resolves: #2165812
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (s390-tools-2.25.0.tar.gz) = 1c766a4bd19c957596c741a80141712acf150591c0ff1a47caf1aa8a17f7153c1441560f05aef78bb3f05bd35c1fef431569cabd7e7d6b003bd74beedb7213d9
|
SHA512 (s390-tools-2.27.0.tar.gz) = 8ec83718639d17fe7b1990f4e492f1e1bdd11e814b7838c921733eeccb212f417141042118eadf1e8db498e3ff2ce0c8d404189e436cefe17d9a3dacea22429f
|
||||||
|
Loading…
Reference in New Issue
Block a user