Import from AlmaLinux stable repository
This commit is contained in:
parent
3d70613991
commit
337d699714
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
SOURCES/cmsfs-1.1.8c.tar.gz
|
||||
SOURCES/s390-tools-2.25.0.tar.gz
|
||||
SOURCES/s390-tools-2.29.0-rust-vendor.tar.xz
|
||||
SOURCES/s390-tools-2.29.0.tar.gz
|
||||
SOURCES/src_vipa-2.1.0.tar.gz
|
||||
|
@ -1,3 +0,0 @@
|
||||
9c9a4e89bddb2b4e6e09ef6fc7c2e6f2ad6316de SOURCES/cmsfs-1.1.8c.tar.gz
|
||||
e8e0d3f651179fd14dc4a40d53a1e4ef6edaae7d SOURCES/s390-tools-2.25.0.tar.gz
|
||||
8ed8592a0a9370ce8422df9231ccb17f6cf49bed SOURCES/src_vipa-2.1.0.tar.gz
|
@ -1,12 +1,12 @@
|
||||
diff -urN cmsfs-1.1.8/cmsfssed.sh cmsfs-1.1.8_/cmsfssed.sh
|
||||
--- cmsfs-1.1.8/cmsfssed.sh 2003-02-28 17:52:59.000000000 -0500
|
||||
+++ cmsfs-1.1.8_/cmsfssed.sh 2004-05-28 16:36:22.000000000 -0400
|
||||
diff -aruN cmsfs-1.1.8c/cmsfssed.sh cmsfs-1.1.8c.alma/cmsfssed.sh
|
||||
--- cmsfs-1.1.8c/cmsfssed.sh 2006-01-29 07:04:32
|
||||
+++ cmsfs-1.1.8c.alma/cmsfssed.sh 2023-11-01 10:57:10
|
||||
@@ -85,7 +85,7 @@
|
||||
DRIVER_SOURCE="cmsfs22x.c"
|
||||
MODULES_DIRECTORY="/lib/modules/`uname -r`/fs"
|
||||
;;
|
||||
- 2.4*|2.5*)
|
||||
+ 2.4*|2.5*|2.6*|3.*|4.*)
|
||||
+ 2.4*|2.5*|2.6*|3.*|4.*|5.*)
|
||||
LINUX_RELEASE="2.4"
|
||||
# ln -s cmsfs24x.c cmsfsvfs.c
|
||||
INCLUDES="-I/lib/modules/`uname -r`/build/include"
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a17c57bf2b7b6d64a509cb5fb02fe46849bc550c Mon Sep 17 00:00:00 2001
|
||||
From b2daaa34776ba6afec879e362378f6f7563590a6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Mon, 20 Jun 2022 17:43:05 +0200
|
||||
Subject: [PATCH 1/2] Revert "zipl/src: Implement sorting bls entries by
|
||||
@ -194,10 +194,10 @@ index 0cea1d4..9352f76 100644
|
||||
return n;
|
||||
|
||||
--
|
||||
2.38.1
|
||||
2.39.2
|
||||
|
||||
|
||||
From 7a51cfc15b870d90bffe1e24a1da922663ffe1d7 Mon Sep 17 00:00:00 2001
|
||||
From 692e70bcfc32a05e30146bd7077c41e0eaceff03 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Mon, 20 Jun 2022 17:46:59 +0200
|
||||
Subject: [PATCH 2/2] blscfg: sort like rpm nvr, not like a single version
|
||||
@ -213,7 +213,7 @@ Signed-off-by: Dan Horák <dan@danny.cz>
|
||||
2 files changed, 95 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/zipl/src/Makefile b/zipl/src/Makefile
|
||||
index 64eabe4..7043005 100644
|
||||
index cab5655..7ec215d 100644
|
||||
--- a/zipl/src/Makefile
|
||||
+++ b/zipl/src/Makefile
|
||||
@@ -9,6 +9,7 @@ ALL_LDFLAGS += -Wl,-z,noexecstack $(NO_PIE_LDFLAGS)
|
||||
@ -223,7 +223,7 @@ index 64eabe4..7043005 100644
|
||||
+ -lrpmio -lrpm
|
||||
|
||||
objects = misc.o error.o scan.o job.o boot.o bootmap.o fs-map.o disk.o \
|
||||
bootmap_header.o envblk.o install.o zipl.o $(rootdir)/zipl/boot/data.o
|
||||
bootmap_header.o envblk.o install.o zipl.o
|
||||
diff --git a/zipl/src/scan.c b/zipl/src/scan.c
|
||||
index 9352f76..3327e2d 100644
|
||||
--- a/zipl/src/scan.c
|
||||
@ -344,5 +344,5 @@ index 9352f76..3327e2d 100644
|
||||
static int
|
||||
scan_append_section_heading(struct scan_token* scan, int* index, char* name);
|
||||
--
|
||||
2.38.1
|
||||
2.39.2
|
||||
|
||||
|
@ -1,205 +0,0 @@
|
||||
From 48324b579e825a30110abac0369e9d544350ead1 Mon Sep 17 00:00:00 2001
|
||||
From: Steffen Eiden <seiden@linux.ibm.com>
|
||||
Date: Wed, 14 Dec 2022 14:25:21 +0100
|
||||
Subject: [PATCH 1/4] zdump: replace atomic refcount with atomic int
|
||||
|
||||
(Atomic) refcounting was introduced in glib2.58.
|
||||
We want to support v2.56 as well, so replace it with int and the atomic
|
||||
operations introduced in glib 2.4.
|
||||
|
||||
Fixes: https://github.com/ibm-s390-linux/s390-tools/issues/146
|
||||
Reviewed-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||
---
|
||||
zdump/pv_utils.c | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/zdump/pv_utils.c b/zdump/pv_utils.c
|
||||
index 6d9f0bb..a39bfc5 100644
|
||||
--- a/zdump/pv_utils.c
|
||||
+++ b/zdump/pv_utils.c
|
||||
@@ -674,7 +674,7 @@ struct _storage_state_mmap {
|
||||
size_t mapped_size;
|
||||
pv_tweak_component_t *tweak_components;
|
||||
size_t num_tweaks;
|
||||
- gatomicrefcount ref_count;
|
||||
+ int ref_count;
|
||||
};
|
||||
|
||||
storage_state_mmap_t *storage_state_mmap_new(const int fd, const size_t file_size, const u64 offset,
|
||||
@@ -733,14 +733,14 @@ storage_state_mmap_t *storage_state_mmap_new(const int fd, const size_t file_siz
|
||||
ret->tweak_components = (pv_tweak_component_t *)(ptr + in_page_offset);
|
||||
ret->num_tweaks = tweak_components_cnt;
|
||||
ret->mapped_size = mmapped_size;
|
||||
- g_atomic_ref_count_init(&ret->ref_count);
|
||||
+ ret->ref_count = 1;
|
||||
return g_steal_pointer(&ret);
|
||||
}
|
||||
|
||||
storage_state_mmap_t *storage_state_mmap_ref(storage_state_mmap_t *storage_state)
|
||||
{
|
||||
g_assert(storage_state);
|
||||
- g_atomic_ref_count_inc(&storage_state->ref_count);
|
||||
+ g_atomic_int_inc(&storage_state->ref_count);
|
||||
return storage_state;
|
||||
}
|
||||
|
||||
@@ -748,7 +748,7 @@ void storage_state_mmap_unref(storage_state_mmap_t *storage_state)
|
||||
{
|
||||
if (!storage_state)
|
||||
return;
|
||||
- if (storage_state->ref_count && !g_atomic_ref_count_dec(&storage_state->ref_count))
|
||||
+ if (storage_state->ref_count && !g_atomic_int_dec_and_test(&storage_state->ref_count))
|
||||
return;
|
||||
if (storage_state->first_page_ptr) {
|
||||
int rc = munmap(storage_state->first_page_ptr, storage_state->mapped_size);
|
||||
--
|
||||
2.39.1
|
||||
|
||||
|
||||
From 4007220d35a9e33186fdfe3a4b5c22cd2eea9bb9 Mon Sep 17 00:00:00 2001
|
||||
From: Steffen Eiden <seiden@linux.ibm.com>
|
||||
Date: Wed, 14 Dec 2022 13:53:29 +0100
|
||||
Subject: [PATCH 2/4] libpv: disallow glib features from after 2.56
|
||||
|
||||
Enforce that the first glib.h include is done via glib-helper.h for libpv
|
||||
so that glib version checks are in place.
|
||||
|
||||
Change zdump and pvattest such that they never include glibstuff before
|
||||
libpv/glib-helper.h
|
||||
|
||||
Reviewed-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||
---
|
||||
include/libpv/glib-helper.h | 6 ++++++
|
||||
pvattest/src/common.h | 2 +-
|
||||
zdump/dfi_pv_elf.c | 1 -
|
||||
3 files changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/include/libpv/glib-helper.h b/include/libpv/glib-helper.h
|
||||
index 5d3df50..9f90b28 100644
|
||||
--- a/include/libpv/glib-helper.h
|
||||
+++ b/include/libpv/glib-helper.h
|
||||
@@ -18,6 +18,12 @@
|
||||
#define GLIB_VERSION_MIN_REQUIRED GLIB_VERSION_2_56
|
||||
#endif
|
||||
|
||||
+#define GLIB_VERSION_MAX_ALLOWED GLIB_VERSION_2_56
|
||||
+
|
||||
+#ifdef __G_LIB_H__
|
||||
+#error "glib.h must be included via libpv/glib-helper.h"
|
||||
+#endif
|
||||
+
|
||||
#include <glib.h>
|
||||
#include <gmodule.h>
|
||||
#include <stdio.h>
|
||||
diff --git a/pvattest/src/common.h b/pvattest/src/common.h
|
||||
index e2e3ef1..43d2ab9 100644
|
||||
--- a/pvattest/src/common.h
|
||||
+++ b/pvattest/src/common.h
|
||||
@@ -11,10 +11,10 @@
|
||||
/* Must be included before any other header */
|
||||
#include "config.h"
|
||||
|
||||
-#include <glib/gi18n.h>
|
||||
#include <stdio.h>
|
||||
|
||||
#include "libpv/glib-helper.h"
|
||||
+#include <glib/gi18n.h>
|
||||
#include "libpv/macros.h"
|
||||
#include "lib/zt_common.h"
|
||||
|
||||
diff --git a/zdump/dfi_pv_elf.c b/zdump/dfi_pv_elf.c
|
||||
index 8d1021e..9d33e8f 100644
|
||||
--- a/zdump/dfi_pv_elf.c
|
||||
+++ b/zdump/dfi_pv_elf.c
|
||||
@@ -21,7 +21,6 @@
|
||||
#include <elf.h>
|
||||
#include <errno.h>
|
||||
|
||||
-#include <glib.h>
|
||||
#include <openssl/bio.h>
|
||||
#include <openssl/crypto.h>
|
||||
|
||||
--
|
||||
2.39.1
|
||||
|
||||
|
||||
From fb01fb45bb6a9e62313e9cdb79ad5ed39471cfe7 Mon Sep 17 00:00:00 2001
|
||||
From: Marc Hartmayer <mhartmay@linux.ibm.com>
|
||||
Date: Mon, 19 Dec 2022 09:51:51 +0000
|
||||
Subject: [PATCH 3/4] zgetdump/Makefile: don't use `.check_dep_zgetdump` as
|
||||
linker input
|
||||
|
||||
The `.check_dep_zgetdump` file is used to cache the result of the
|
||||
dependency checks and should not be used as input for linking or
|
||||
anything else. Let's add it as dependency for the objects file. This
|
||||
shouldn't cause any problems since the Makefile rule for object files is
|
||||
defined in `common.mak` as follows:
|
||||
|
||||
%.o: %.c
|
||||
$(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -c $< -o $@
|
||||
|
||||
Fixes: https://github.com/ibm-s390-linux/s390-tools/issues/147
|
||||
Fixes: 8d8d5e9746a4 ("zdump: Fix Makefile dependencies")
|
||||
Signed-off-by: Marc Hartmayer <mhartmay@linux.ibm.com>
|
||||
Reviewed-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
||||
Signed-off-by: Jan Hoeppner <hoeppner@linux.ibm.com>
|
||||
---
|
||||
zdump/Makefile | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/zdump/Makefile b/zdump/Makefile
|
||||
index ca8aadc..934dc47 100644
|
||||
--- a/zdump/Makefile
|
||||
+++ b/zdump/Makefile
|
||||
@@ -119,7 +119,9 @@ libs = $(rootdir)/libutil/libutil.a $(LIBPV)
|
||||
|
||||
all: $(BUILD_TARGETS)
|
||||
|
||||
-zgetdump: .check_dep_zgetdump $(OBJECTS) $(libs)
|
||||
+$(OBJECTS): .check_dep_zgetdump
|
||||
+
|
||||
+zgetdump: $(OBJECTS) $(libs)
|
||||
|
||||
skip-zgetdump:
|
||||
echo " SKIP zgetdump due to unresolved dependencies"
|
||||
--
|
||||
2.39.1
|
||||
|
||||
|
||||
From 1ad208c17a0edc65e6abd47b68a7d9c206faf2a6 Mon Sep 17 00:00:00 2001
|
||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Date: Fri, 20 Jan 2023 11:04:18 +0100
|
||||
Subject: [PATCH 4/4] zkey: Support EP11 host library version 4 (#2165811)
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Try to load libep11.so.4 if available, but fallback to older
|
||||
library versions if not.
|
||||
|
||||
Reviewed-by: Jörg Schmidbauer <jschmidb@de.ibm.com>
|
||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||
(cherry picked from commit 6222c384958729bc4b5bad61ad38967647cc3248)
|
||||
---
|
||||
zkey/ep11.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/zkey/ep11.c b/zkey/ep11.c
|
||||
index 58dc3c5..8359929 100644
|
||||
--- a/zkey/ep11.c
|
||||
+++ b/zkey/ep11.c
|
||||
@@ -35,7 +35,7 @@
|
||||
* Definitions for the EP11 library
|
||||
*/
|
||||
#define EP11_LIBRARY_NAME "libep11.so"
|
||||
-#define EP11_LIBRARY_VERSION 3
|
||||
+#define EP11_LIBRARY_VERSION 4
|
||||
#define EP11_WEB_PAGE "http://www.ibm.com/security/cryptocards"
|
||||
|
||||
/**
|
||||
--
|
||||
2.39.1
|
||||
|
5719
SOURCES/s390utils-2.29.0-rhel.patch
Normal file
5719
SOURCES/s390utils-2.29.0-rhel.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -3,23 +3,32 @@
|
||||
|
||||
# secure boot support is for RHEL only
|
||||
%if 0%{?rhel} >= 8
|
||||
%global signzipl 1
|
||||
%bcond_without signzipl
|
||||
%else
|
||||
%bcond_with signzipl
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%global with_pandoc 1
|
||||
%bcond_without pandoc
|
||||
%else
|
||||
%bcond_with pandoc
|
||||
%endif
|
||||
%bcond_without rust
|
||||
|
||||
Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Version: 2.25.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.29.0
|
||||
Release: 3%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
#URL: http://www.ibm.com/developerworks/linux/linux390/s390-tools.html
|
||||
URL: https://github.com/ibm-s390-tools/s390-tools
|
||||
Source0: https://github.com/ibm-s390-tools/s390-tools/archive/v%{version}.tar.gz#/s390-tools-%{version}.tar.gz
|
||||
# To create the vendor tarball:
|
||||
# tar xf s390-tools-%%{version}.tar.gz ; pushd s390-tools-%%{version}/rust/pvsecret ; \
|
||||
# rm -f Cargo.lock && cargo vendor && \
|
||||
# tar Jvcf ../../../s390-tools-%%{version}-rust-vendor.tar.xz vendor/ ; popd
|
||||
Source1: s390-tools-%{version}-rust-vendor.tar.xz
|
||||
Source4: http://www.linuxvm.org/Patches/S390/cmsfs-%{cmsfsver}.tar.gz
|
||||
Source5: zfcpconf.sh
|
||||
# http://www.ibm.com/developerworks/linux/linux390/src_vipa-%%{vipaver}.html
|
||||
@ -38,7 +47,7 @@ Source24: 20-zipl-kernel.install
|
||||
Source25: 52-zipl-rescue.install
|
||||
Source26: 91-zipl.install
|
||||
|
||||
%if 0%{?signzipl}
|
||||
%if %{with signzipl}
|
||||
%define pesign_name redhatsecureboot302
|
||||
%endif
|
||||
|
||||
@ -47,7 +56,7 @@ Patch0: s390-tools-zipl-invert-script-options.patch
|
||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||
|
||||
# upstream fixes/updates
|
||||
Patch100: s390utils-%%{version}-rhel.patch
|
||||
Patch100: s390utils-%{version}-rhel.patch
|
||||
|
||||
Patch1000: cmsfs-1.1.8-warnings.patch
|
||||
Patch1001: cmsfs-1.1.8-kernel26.patch
|
||||
@ -56,6 +65,13 @@ Patch1003: cmsfs-1.1.8-args.patch
|
||||
|
||||
Patch2000: src_vipa-2.1.0-deprecate.patch
|
||||
|
||||
# https://fedoraproject.org/wiki/Changes/EncourageI686LeafRemoval
|
||||
ExcludeArch: %{ix86}
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native package structure
|
||||
#
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||
@ -64,8 +80,46 @@ Requires: s390utils-mon_statd = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-iucvterm = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-ziomon = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-cmsfs = %{epoch}:%{version}-%{release}
|
||||
%else
|
||||
#
|
||||
# multiarch package structure
|
||||
#
|
||||
Requires: s390utils-se-data = %{epoch}:%{version}-%{release}
|
||||
%endif
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: glib2-devel
|
||||
%if %{with rust}
|
||||
%if 0%{?rhel}
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: rust-toolset
|
||||
%else
|
||||
BuildRequires: crate(anstream)
|
||||
BuildRequires: crate(anstyle-query)
|
||||
BuildRequires: crate(anyhow)
|
||||
BuildRequires: crate(byteorder)
|
||||
BuildRequires: crate(cfg-if)
|
||||
BuildRequires: crate(clap)
|
||||
BuildRequires: crate(clap_complete)
|
||||
BuildRequires: crate(clap_derive)
|
||||
BuildRequires: crate(colorchoice)
|
||||
BuildRequires: crate(curl)
|
||||
BuildRequires: crate(is-terminal)
|
||||
BuildRequires: crate(libc)
|
||||
BuildRequires: crate(log)
|
||||
BuildRequires: crate(openssl)
|
||||
BuildRequires: crate(openssl-probe)
|
||||
BuildRequires: crate(serde)
|
||||
BuildRequires: crate(serde_derive)
|
||||
BuildRequires: crate(serde_yaml)
|
||||
BuildRequires: crate(strsim)
|
||||
BuildRequires: crate(terminal_size)
|
||||
BuildRequires: crate(thiserror)
|
||||
BuildRequires: crate(zerocopy)
|
||||
BuildRequires: rust-packaging
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%description
|
||||
This is a meta package for installing the default s390-tools sub packages.
|
||||
@ -83,7 +137,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||
|
||||
# upstream fixes/updates
|
||||
%%patch100 -p1
|
||||
%patch100 -p1
|
||||
|
||||
#
|
||||
# cmsfs
|
||||
@ -113,6 +167,17 @@ popd
|
||||
# remove --strip from install
|
||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||
|
||||
%if %{with rust}
|
||||
%if 0%{?rhel}
|
||||
pushd rust
|
||||
%cargo_prep -V 1
|
||||
popd
|
||||
%else
|
||||
%cargo_prep
|
||||
%endif
|
||||
rm -rf ./rust/Cargo.lock
|
||||
%endif
|
||||
|
||||
pushd cmsfs-%{cmsfsver}
|
||||
# cmdfs: fix encoding
|
||||
iconv -f ISO8859-1 -t UTF-8 -o README.new README
|
||||
@ -127,8 +192,11 @@ popd
|
||||
%build
|
||||
make \
|
||||
CFLAGS="%{build_cflags}" CXXFLAGS="%{build_cxxflags}" LDFLAGS="%{build_ldflags}" \
|
||||
%if %{without rust}
|
||||
HAVE_CARGO=0 \
|
||||
%endif
|
||||
HAVE_DRACUT=1 \
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
ENABLE_DOC=1 \
|
||||
%endif
|
||||
NO_PIE_LDFLAGS="" \
|
||||
@ -136,6 +204,10 @@ make \
|
||||
DISTRELEASE=%{release} \
|
||||
V=1
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native specific %%build section
|
||||
#
|
||||
pushd cmsfs-%{cmsfsver}
|
||||
./configure
|
||||
make CC="gcc %{build_cflags} -fno-strict-aliasing %{build_ldflags}"
|
||||
@ -144,12 +216,16 @@ popd
|
||||
pushd src_vipa-%{vipaver}
|
||||
make CC_FLAGS="%{build_cflags} -fPIC" LD_FLAGS="%{build_ldflags} -shared" LIBDIR=%{_libdir}
|
||||
popd
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
make install \
|
||||
%if %{without rust}
|
||||
HAVE_CARGO=0 \
|
||||
%endif
|
||||
HAVE_DRACUT=1 \
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
ENABLE_DOC=1 \
|
||||
%endif
|
||||
DESTDIR=%{buildroot} \
|
||||
@ -158,8 +234,12 @@ make install \
|
||||
DISTRELEASE=%{release} \
|
||||
V=1
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native specific %%install section
|
||||
#
|
||||
# sign the stage3 bootloader
|
||||
%if 0%{?signzipl}
|
||||
%if %{with signzipl}
|
||||
if [ -x /usr/bin/rpm-sign ]; then
|
||||
pushd %{buildroot}/lib/s390-tools/
|
||||
rpm-sign --key "%{pesign_name}" --lkmsign stage3.bin --output stage3.signed
|
||||
@ -229,11 +309,63 @@ install -p -m 644 %{SOURCE17} %{buildroot}%{_udevrulesdir}/81-ccw.rules
|
||||
|
||||
# zipl.conf to be ghosted
|
||||
touch %{buildroot}%{_sysconfdir}/zipl.conf
|
||||
%endif
|
||||
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x/native main %%files section
|
||||
#
|
||||
%files
|
||||
%doc README.md
|
||||
|
||||
%else
|
||||
#
|
||||
# multiarch %%files section
|
||||
#
|
||||
|
||||
%files
|
||||
%doc README.md
|
||||
%license LICENSE
|
||||
%{_bindir}/genprotimg
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvapconfig
|
||||
%endif
|
||||
%{_bindir}/pvattest
|
||||
%{_bindir}/pvextract-hdr
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvsecret
|
||||
%endif
|
||||
%{_mandir}/man1/genprotimg.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvapconfig.1*
|
||||
%endif
|
||||
%{_mandir}/man1/pvattest.1*
|
||||
%{_mandir}/man1/pvattest-create.1*
|
||||
%{_mandir}/man1/pvattest-perform.1*
|
||||
%{_mandir}/man1/pvattest-verify.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvsecret-add.1*
|
||||
%{_mandir}/man1/pvsecret-create-association.1*
|
||||
%{_mandir}/man1/pvsecret-create-meta.1*
|
||||
%{_mandir}/man1/pvsecret-create.1*
|
||||
%{_mandir}/man1/pvsecret-list.1*
|
||||
%{_mandir}/man1/pvsecret-lock.1*
|
||||
%{_mandir}/man1/pvsecret-version.1*
|
||||
%{_mandir}/man1/pvsecret.1*
|
||||
%endif
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
|
||||
#
|
||||
# enf of multi-arch section
|
||||
#
|
||||
%endif
|
||||
|
||||
%ifarch s390x
|
||||
#
|
||||
# s390x specific sub-packages
|
||||
#
|
||||
#
|
||||
# ************************* s390-tools core package *************************
|
||||
#
|
||||
%package core
|
||||
@ -289,6 +421,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
|
||||
%{_unitdir}/cpi.service
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/cpi
|
||||
/usr/lib/dracut/modules.d/95zdev/
|
||||
/usr/lib/dracut/modules.d/95zdev-kdump/
|
||||
%{_mandir}/man5/zipl.conf.5*
|
||||
%{_mandir}/man8/chreipl.8*
|
||||
%{_mandir}/man8/chzdev.8*
|
||||
@ -343,6 +476,7 @@ Requires: ethtool
|
||||
Requires: tar
|
||||
Requires: file
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-se-data = %{epoch}:%{version}-%{release}
|
||||
%{?systemd_requires}
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: ncurses-devel
|
||||
@ -350,7 +484,6 @@ BuildRequires: glibc-static
|
||||
BuildRequires: cryptsetup-devel >= 2.0.3
|
||||
BuildRequires: json-c-devel
|
||||
BuildRequires: rpm-devel
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libxml2-devel
|
||||
|
||||
|
||||
@ -416,11 +549,6 @@ s390 base tools. This collection provides the following utilities:
|
||||
* tunedasd:
|
||||
Adjust tunable parameters on DASD devices.
|
||||
|
||||
* vmconvert:
|
||||
Convert system dumps created by the z/VM VMDUMP command into dumps with
|
||||
LKCD format. These LKCD dumps can then be analyzed with the dump analysis
|
||||
tool lcrash.
|
||||
|
||||
* vmcp:
|
||||
Allows Linux users to send commands to the z/VM control program (CP).
|
||||
The normal usage is to invoke vmcp with the command you want to
|
||||
@ -552,9 +680,14 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_bindir}/dump2tar
|
||||
%{_bindir}/genprotimg
|
||||
%{_bindir}/mk-s390image
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvapconfig
|
||||
%endif
|
||||
%{_bindir}/pvattest
|
||||
%{_bindir}/pvextract-hdr
|
||||
%{_bindir}/vmconvert
|
||||
%if %{with rust}
|
||||
%{_bindir}/pvsecret
|
||||
%endif
|
||||
%{_bindir}/zkey
|
||||
%{_bindir}/zkey-cryptsetup
|
||||
%{_unitdir}/dumpconf.service
|
||||
@ -579,11 +712,23 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_libdir}/zkey/zkey-kmip.so
|
||||
%{_mandir}/man1/dump2tar.1*
|
||||
%{_mandir}/man1/genprotimg.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvapconfig.1*
|
||||
%endif
|
||||
%{_mandir}/man1/pvattest.1*
|
||||
%{_mandir}/man1/pvattest-create.1*
|
||||
%{_mandir}/man1/pvattest-perform.1*
|
||||
%{_mandir}/man1/pvattest-verify.1*
|
||||
%{_mandir}/man1/vmconvert.1*
|
||||
%if %{with rust}
|
||||
%{_mandir}/man1/pvsecret-add.1*
|
||||
%{_mandir}/man1/pvsecret-create-association.1*
|
||||
%{_mandir}/man1/pvsecret-create-meta.1*
|
||||
%{_mandir}/man1/pvsecret-create.1*
|
||||
%{_mandir}/man1/pvsecret-list.1*
|
||||
%{_mandir}/man1/pvsecret-lock.1*
|
||||
%{_mandir}/man1/pvsecret-version.1*
|
||||
%{_mandir}/man1/pvsecret.1*
|
||||
%endif
|
||||
%{_mandir}/man1/zkey.1*
|
||||
%{_mandir}/man1/zkey-cryptsetup.1*
|
||||
%{_mandir}/man1/zkey-ekmfweb.1*
|
||||
@ -634,7 +779,6 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_mandir}/man8/znetconf.8*
|
||||
%{_mandir}/man8/zpcictl.8*
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
%{_datadir}/s390-tools/netboot/
|
||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
|
||||
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/kmip
|
||||
@ -651,6 +795,18 @@ getent group zkeyadm > /dev/null || groupadd -r zkeyadm
|
||||
%{_libdir}/src_vipa.so
|
||||
%{_mandir}/man8/src_vipa.8*
|
||||
|
||||
%package se-data
|
||||
License: MIT
|
||||
Summary: Data for Secure Execution
|
||||
BuildArch: noarch
|
||||
|
||||
%description se-data
|
||||
%{summary}.
|
||||
|
||||
%files se-data
|
||||
%dir %{_datadir}/s390-tools
|
||||
%{_datadir}/s390-tools/genprotimg/
|
||||
|
||||
#
|
||||
# *********************** s390-tools osasnmpd package ***********************
|
||||
#
|
||||
@ -955,7 +1111,7 @@ Summary: Use multipath information for re-IPL path failover
|
||||
BuildRequires: make
|
||||
BuildRequires: bash
|
||||
BuildRequires: coreutils
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
BuildRequires: pandoc
|
||||
%endif
|
||||
BuildRequires: gawk
|
||||
@ -976,7 +1132,7 @@ reconfigures the FCP re-IPL settings to use an operational path.
|
||||
|
||||
%files chreipl-fcp-mpath
|
||||
%doc chreipl-fcp-mpath/README.md
|
||||
%if 0%{?with_pandoc}
|
||||
%if %{with pandoc}
|
||||
%doc chreipl-fcp-mpath/README.html
|
||||
%endif
|
||||
%dir %{_prefix}/lib/chreipl-fcp-mpath/
|
||||
@ -1008,12 +1164,56 @@ User-space development files for the s390/s390x architecture.
|
||||
%{_libdir}/libekmfweb.so
|
||||
%{_libdir}/libkmipclient.so
|
||||
|
||||
#
|
||||
# end of s390x specific sub-packages
|
||||
#
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 29 2024 Dan Horák <dhorak@redhat.com> - 2:2.29.0-3
|
||||
- add s390utils-se-data as a noarch subpackage with Secure Execution data files
|
||||
- Resolves: RHEL-10568
|
||||
|
||||
* Fri Jan 19 2024 Dan Horák <dhorak@redhat.com> - 2:2.29.0-2
|
||||
- SE: Secure guest tool to bind and associate APQNs (RHEL-10575)
|
||||
- Resolves: RHEL-10575
|
||||
|
||||
* Mon Dec 04 2023 Dan Horák <dhorak@redhat.com> - 2:2.29.0-1
|
||||
- rebased to 2.29.0 (RHEL-11409)
|
||||
- KVM: Support AP Bindings in SE Header (RHEL-10573)
|
||||
- KVM: Userspace Tool for IBK Request Generation and Insertion (RHEL-10579)
|
||||
- zkey: support for key type PKEY_TYPE_EP11_AES (RHEL-11441)
|
||||
- vmur: fix handling of option -t (RHEL-11479)
|
||||
- dbginfo.sh: global original Input Field Separator (IFS) (RHEL-16526)
|
||||
- enable multi-arch build (RHEL-10568)
|
||||
- Resolves: RHEL-11409 RHEL-10573 RHEL-10579 RHEL-11441 RHEL-11479 RHEL-16526 RHEL-10568
|
||||
|
||||
* Mon Aug 07 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-3
|
||||
- zdev/dracut: fix kdump build to integrate with site support (#2229178)
|
||||
- Resolves: #2229178
|
||||
|
||||
* Fri Jul 21 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-2
|
||||
- Secure Execution APQN binding and IBK association (#2110510)
|
||||
- Resolves: #2110510
|
||||
|
||||
* Tue Jun 06 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-1.1
|
||||
- rebuild
|
||||
- Related: #2159698
|
||||
|
||||
* Mon Jun 05 2023 Dan Horák <dhorak@redhat.com> - 2:2.27.0-1
|
||||
- rebased to 2.27.0 (#2159698)
|
||||
- lszcrypt fails when querying a specific domain (#2177613)
|
||||
- DASD autoquiesce support (#2196510)
|
||||
- zcrypt DD: AP command filtering (#2170362)
|
||||
- vmconvert and zgetdump consolidation (#2173925)
|
||||
- Support for List-Directed dump from ECKD DASD (#2159694)
|
||||
- Support for List-Directed IPL and re-IPL from ECKD DASD (#2159691)
|
||||
- Resolves: #2159698 #2177613 #2196510 #2170362 #2173925 #2159694 #2159691
|
||||
|
||||
* Fri Feb 03 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-2
|
||||
- zkey: Support EP11 host library version 4 (#2165811)
|
||||
- Resolves: #2165811
|
||||
|
||||
* Tue Dec 13 2022 Dan Horák <dhorak@redhat.com> - 2:2.25.0-1
|
||||
- rebased to 2.25.0 (#2110312)
|
||||
- KVM: Tool to process encrypted Secure Execution guest dumps (#2043851)
|
||||
|
Loading…
Reference in New Issue
Block a user