import s390utils-2.6.0-30.el8

This commit is contained in:
CentOS Sources 2020-07-28 07:59:15 -04:00 committed by Stepan Oksanichenko
parent cc17fcc87f
commit 2d18c03a45
5 changed files with 19676 additions and 87 deletions

View File

@ -24,6 +24,17 @@ get_config_line_by_subchannel()
return 1
}
# borrowed from network-scrips, initscripts along with the get_config_by_subchannel
[ -z "$__sed_discard_ignored_files" ] && __sed_discard_ignored_files='/\(~\|\.bak\|\.old\|\.orig\|\.rpmnew\|\.rpmorig\|\.rpmsave\)$/d'
get_config_by_subchannel ()
{
LANG=C grep -E -i -l \
"^[[:space:]]*SUBCHANNELS=['\"]?([0-9]\.[0-9]\.[a-f0-9]+,){0,2}${1}(,[0-9]\.[0-9]\.[a-f0-9]+){0,2}['\"]?([[:space:]]+#|[[:space:]]*$)" \
/etc/sysconfig/network-scripts/ifcfg-* \
| LC_ALL=C sed -e "$__sed_discard_ignored_files"
}
CHANNEL=${DEVPATH##*/}
if [ $MODE = "dracut" ]; then
@ -49,8 +60,6 @@ if [ $MODE = "dracut" ]; then
elif [ $MODE = "normal" ]; then
NOLOCALE="yes"
. /etc/sysconfig/network-scripts/network-functions
CONFIG_FILE=$(get_config_by_subchannel $CHANNEL)
if [ -n "$CONFIG_FILE" ]; then

View File

@ -1,7 +1,7 @@
[Unit]
Description=Free all devices on startup
DefaultDependencies=no
Before=sysinit.target
Before=sysinit.target systemd-udev-trigger.service
[Service]
Type=oneshot

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,12 @@
diff -up s390-tools-2.2.0/src_vipa-2.1.0/Makefile.orig s390-tools-2.2.0/src_vipa-2.1.0/Makefile
--- s390-tools-2.2.0/src_vipa-2.1.0/Makefile.orig 2020-02-21 13:51:23.502305796 +0100
+++ s390-tools-2.2.0/src_vipa-2.1.0/Makefile 2020-02-21 13:53:51.353817181 +0100
@@ -44,6 +44,8 @@ src_vipa.sh:
echo '#!/bin/bash' > src_vipa.sh
echo 'export LD_LIBRARY_PATH=$(LIBDIR):$$LD_LIBRARY_PATH' >> src_vipa.sh
echo 'export LD_PRELOAD=$(LIBDIR)/src_vipa.so' >> src_vipa.sh
+ echo 'echo "WARNING: The src_vipa (flexible source address selection) feature is DEPRECATED"' >> src_vipa.sh
+ echo 'echo "WARNING: It will be removed in the future."' >> src_vipa.sh
echo 'exec $$@' >> src_vipa.sh
chmod 755 src_vipa.sh

View File

@ -9,7 +9,7 @@ Name: s390utils
Summary: Utilities and daemons for IBM z Systems
Group: System Environment/Base
Version: 2.6.0
Release: 25%{?dist}
Release: 30%{?dist}
Epoch: 2
License: MIT
ExclusiveArch: s390 s390x
@ -53,6 +53,8 @@ Patch1000: cmsfs-1.1.8-warnings.patch
Patch1001: cmsfs-1.1.8-kernel26.patch
Patch1002: cmsfs-1.1.8-use-detected-filesystem-block-size-on-FBA-devices.patch
Patch2000: src_vipa-2.1.0-deprecate.patch
Requires: s390utils-base = %{epoch}:%{version}-%{release}
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
Requires: s390utils-cpuplugd = %{epoch}:%{version}-%{release}
@ -97,6 +99,13 @@ pushd cmsfs-%{cmsfsver}
%patch1002 -p1 -b .use-detected-block-size
popd
#
# src_vipa
#
pushd src_vipa-%{vipaver}
# mark as deprecated
%patch2000 -p2
popd
# remove --strip from install
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
@ -223,7 +232,6 @@ Requires: gawk sed coreutils
Requires: sysfsutils
Requires: sg3_utils
Requires: ethtool
Requires: network-scripts
%{?systemd_requires}
BuildRequires: perl-generators
BuildRequires: ncurses-devel
@ -231,6 +239,7 @@ BuildRequires: libpfm-devel
BuildRequires: glibc-static
BuildRequires: cryptsetup-devel >= 2.0.3
BuildRequires: json-c-devel
BuildRequires: glib2-devel
%description base
@ -356,6 +365,13 @@ s390 base tools. This collection provides the following utilities:
Allows to set the system and sysplex names from the Linux guest to
the HMC/SE using the Control Program Identification feature.
* genprotimg:
Tool for the creation of PV images. The image consists of a concatenation of
a plain text boot loader, the encrypted components for kernel, initrd, and
cmdline, and the integrity-protected PV header, containing metadata necessary for
running the guest in PV mode. Protected VMs (PVM) are KVM VMs, where KVM can't
access the VM's state like guest memory and guest registers anymore.
For more information refer to the following publications:
* "Device Drivers, Features, and Commands" chapter "Useful Linux commands"
* "Using the dump tools"
@ -437,6 +453,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_sbindir}/zpcictl
%{_bindir}/lscpumf
%{_bindir}/dump2tar
%{_bindir}/genprotimg
%{_bindir}/vmconvert
%{_bindir}/zkey
%{_bindir}/zkey-cryptsetup
@ -471,6 +488,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_mandir}/man8/dasdview.8*
%{_mandir}/man8/dumpconf.8*
%{_mandir}/man8/fdasd.8*
%{_mandir}/man8/genprotimg.8.*
%{_mandir}/man8/hyptop.8*
%{_mandir}/man8/lschp.8*
%{_mandir}/man8/lscss.8*
@ -501,6 +519,7 @@ systemctl --no-reload preset device_cio_free.service >/dev/null 2>&1 || :
%{_mandir}/man8/zpcictl.8*
%dir %{_datadir}/s390-tools/
%{_datadir}/s390-tools/cpumf/
%{_datadir}/s390-tools/genprotimg/
%{_datadir}/s390-tools/netboot/
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey
%dir %attr(0770,root,zkeyadm) %{_sysconfdir}/zkey/repository
@ -857,6 +876,39 @@ User-space development files for the s390/s390x architecture.
%changelog
* Mon Jun 22 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-30
- avoid dependency on network-scripts (#1847388)
- Resolves: #1847388
* Thu May 28 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-29
- zkey: Add support for EP11 secure keys (#1723845)
- ipl-tools: Add nvme device support to zipl, lsreipl/chreipl (#1525178)
- zipl: Rebase to 2.13.0 (#1821250)
- ipl_tools: support clear attribute for FCP and CCW re-IPL (#1812983)
- lscpumf: New z15 CPU-MF counters not available (#1821591)
- dbginfo.sh: Extend data collection (#1814323)
- zpcictl: Initiate recover after reset (#1814303)
- zipl: fix secure boot config handling (#1814322)
- zkey: Fix display of clear key size for CCA-AESCIPHER keys (#1808492)
- zkey: Fix display of XTS attribute for validate command (#1808494)
- dasdview: Fix exit status in error cases (#1783288)
- zipl/libc: Fix potential buffer overflow in printf (#1807973)
- src_vipa feature is deprecated (#1780648)
- zdev: report FC Endpoint Security of zfcp device (#1723843)
- Resolves: #1723845 #1525178 #1821250 #1812983 #1821591 #1814323 #1814303 #1814322 #1808492 #1808494 #1783288 #1807973 #1780648 #1723843
* Mon Jan 27 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-28
- zkey: Fix listing of keys on file systems reporting DT_UNKNOWN (#1792957)
- Resolves: #1792957
* Mon Jan 27 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-27
- zkey: Fix display of clear key size for XTS keys (#1794375)
- Resolves: #1794375
* Wed Jan 15 2020 Dan Horák <dhorak@redhat.com> - 2:2.6.0-26
- fix service order after switching to real root file system (#1790790)
- Resolves: #1790790
* Fri Dec 13 2019 Dan Horák <dhorak@redhat.com> - 2:2.6.0-25
- kernel-install: skip BOOT_IMAGE param when copying the cmdline to BLS snippets (#1782321)
- Resolves: #1782321