- zkey: Support EP11 host library version 4 (#2165812)
- Resolves: #2165812
This commit is contained in:
parent
3eb7d4cf52
commit
2b26a7dc9e
@ -0,0 +1,35 @@
|
|||||||
|
From a9fed51fbf159a98fcd4a9dddf4fef243bb433af Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||||
|
Date: Fri, 20 Jan 2023 11:04:18 +0100
|
||||||
|
Subject: [PATCH] zkey: Support EP11 host library version 4 (#2165812)
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Try to load libep11.so.4 if available, but fallback to older
|
||||||
|
library versions if not.
|
||||||
|
|
||||||
|
Reviewed-by: Jörg Schmidbauer <jschmidb@de.ibm.com>
|
||||||
|
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||||
|
Signed-off-by: Steffen Eiden <seiden@linux.ibm.com>
|
||||||
|
(cherry picked from commit 6222c384958729bc4b5bad61ad38967647cc3248)
|
||||||
|
---
|
||||||
|
zkey/ep11.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/zkey/ep11.c b/zkey/ep11.c
|
||||||
|
index 58dc3c5..8359929 100644
|
||||||
|
--- a/zkey/ep11.c
|
||||||
|
+++ b/zkey/ep11.c
|
||||||
|
@@ -35,7 +35,7 @@
|
||||||
|
* Definitions for the EP11 library
|
||||||
|
*/
|
||||||
|
#define EP11_LIBRARY_NAME "libep11.so"
|
||||||
|
-#define EP11_LIBRARY_VERSION 3
|
||||||
|
+#define EP11_LIBRARY_VERSION 4
|
||||||
|
#define EP11_WEB_PAGE "http://www.ibm.com/security/cryptocards"
|
||||||
|
|
||||||
|
/**
|
||||||
|
--
|
||||||
|
2.39.1
|
||||||
|
|
@ -38,7 +38,7 @@ Patch0: s390-tools-zipl-invert-script-options.patch
|
|||||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||||
|
|
||||||
# upstream fixes/updates
|
# upstream fixes/updates
|
||||||
#Patch100: s390utils-%%{version}-rhel.patch
|
Patch100: s390utils-%%{version}-rhel.patch
|
||||||
|
|
||||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
@ -67,7 +67,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
|||||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||||
|
|
||||||
# upstream fixes/updates
|
# upstream fixes/updates
|
||||||
#%%patch100 -p1
|
%patch100 -p1
|
||||||
|
|
||||||
# drop -Werror from genprotimg to allow building with GCC 12
|
# drop -Werror from genprotimg to allow building with GCC 12
|
||||||
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
sed -i.bak -e 's/-Werror//g' genprotimg/src/Makefile genprotimg/boot/Makefile
|
||||||
@ -907,6 +907,10 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 02 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-4
|
||||||
|
- zkey: Support EP11 host library version 4 (#2165812)
|
||||||
|
- Resolves: #2165812
|
||||||
|
|
||||||
* Wed Jan 25 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-3
|
* Wed Jan 25 2023 Dan Horák <dhorak@redhat.com> - 2:2.25.0-3
|
||||||
- revert the last change
|
- revert the last change
|
||||||
- Related: #2161740
|
- Related: #2161740
|
||||||
|
Loading…
Reference in New Issue
Block a user