parent
2e07dac60a
commit
152ca9dfde
41
s390utils-2.17.0-rhel.patch
Normal file
41
s390utils-2.17.0-rhel.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From 2e70a381e8064b9112e30b44a4be0d6c5811a0fd Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Egorenkov <egorenar@linux.ibm.com>
|
||||
Date: Wed, 21 Jul 2021 17:22:29 +0200
|
||||
Subject: [PATCH] hsavmcore: Avoid recompilation of overlay during install step
|
||||
|
||||
overlay.o was being recompiled during the install step because
|
||||
it depended on the target check-dep-fuse which is phony and,
|
||||
therefore, always outdated. The solution is to create an empty file
|
||||
for the target check-dep-fuse after its successful completion. This
|
||||
prevents make from rebuilding overlay.o during installation.
|
||||
|
||||
Fixes: 5a7d2a58 ("hsavmcore: Fix fuse dependency checking")
|
||||
Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com>
|
||||
Suggested-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
---
|
||||
hsavmcore/Makefile | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/hsavmcore/Makefile b/hsavmcore/Makefile
|
||||
index 7c1d4fd..82e6abc 100644
|
||||
--- a/hsavmcore/Makefile
|
||||
+++ b/hsavmcore/Makefile
|
||||
@@ -69,6 +69,7 @@ check-dep-fuse:
|
||||
"fuse.h", \
|
||||
"fuse-devel or libfuse-dev", \
|
||||
"HAVE_FUSE=0")
|
||||
+ touch check-dep-fuse
|
||||
|
||||
install: all
|
||||
$(INSTALL) -g $(GROUP) -o $(OWNER) -m 755 hsavmcore \
|
||||
@@ -81,6 +82,6 @@ install: all
|
||||
endif # HAVE_FUSE
|
||||
|
||||
clean:
|
||||
- rm -f hsavmcore $(objects)
|
||||
+ rm -f hsavmcore $(objects) check-dep-fuse
|
||||
|
||||
.PHONY: all install clean
|
||||
--
|
||||
2.31.1
|
||||
|
@ -6,7 +6,7 @@
|
||||
Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Version: 2.17.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
@ -33,6 +33,9 @@ Source25: 91-zipl.install
|
||||
Patch0: s390-tools-zipl-invert-script-options.patch
|
||||
Patch1: s390-tools-zipl-blscfg-rpm-nvr-sort.patch
|
||||
|
||||
# backported fixes
|
||||
Patch100: s390utils-2.17.0-rhel.patch
|
||||
|
||||
Requires: s390utils-core = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||
@ -59,6 +62,8 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
||||
%patch0 -p1 -b .zipl-invert-script-options
|
||||
%patch1 -p1 -b .blscfg-rpm-nvr-sort
|
||||
|
||||
%patch100 -p1
|
||||
|
||||
# remove --strip from install
|
||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||
|
||||
@ -821,6 +826,10 @@ User-space development files for the s390/s390x architecture.
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 22 2021 Dan Horák <dan[at]danny.cz> - 2:2.17.0-2
|
||||
- fix build
|
||||
- Related: #1869554
|
||||
|
||||
* Thu Jul 15 2021 Dan Horák <dan[at]danny.cz> - 2:2.17.0-1
|
||||
- rebased to 2.17.0 (#1869554)
|
||||
- Resolves: #1869554
|
||||
|
Loading…
Reference in New Issue
Block a user