- fix issues in lib-zfcp-hbaapi with a patch
This commit is contained in:
parent
47e517e16b
commit
03b8fe03dd
36
lib-zfcp-hbaapi-2.0-sgutils.patch
Normal file
36
lib-zfcp-hbaapi-2.0-sgutils.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
diff -Nrup lib-zfcp-hbaapi-2.0.orig/Makefile.am lib-zfcp-hbaapi-2.0/Makefile.am
|
||||||
|
--- lib-zfcp-hbaapi-2.0.orig/Makefile.am 2008-11-21 15:08:13.000000000 +0100
|
||||||
|
+++ lib-zfcp-hbaapi-2.0/Makefile.am 2009-09-25 12:30:07.000000000 +0200
|
||||||
|
@@ -60,7 +60,7 @@ lib_LTLIBRARIES = libzfcphbaapi.la
|
||||||
|
|
||||||
|
libzfcphbaapi_la_SOURCES = vlib.c vlib_callbacks.c vlib_aux.c vlib_sysfs.c \
|
||||||
|
vlib_sg.c
|
||||||
|
-libzfcphbaapi_la_LIBADD = -lsysfs -lsgutils
|
||||||
|
+libzfcphbaapi_la_LIBADD = -lsysfs -lsgutils2
|
||||||
|
libzfcphbaapi_la_LDFLAGS = \
|
||||||
|
-version-info $(LIB_CURRENT):$(LIB_REVISION):$(LIB_AGE) \
|
||||||
|
-lpthread -Wl,-init,_initvlib,-fini,_finivlib \
|
||||||
|
diff -Nrup lib-zfcp-hbaapi-2.0.orig/Makefile.in lib-zfcp-hbaapi-2.0/Makefile.in
|
||||||
|
--- lib-zfcp-hbaapi-2.0.orig/Makefile.in 2008-11-21 15:08:18.000000000 +0100
|
||||||
|
+++ lib-zfcp-hbaapi-2.0/Makefile.in 2009-09-25 13:22:04.000000000 +0200
|
||||||
|
@@ -248,7 +248,7 @@ lib_LTLIBRARIES = libzfcphbaapi.la
|
||||||
|
libzfcphbaapi_la_SOURCES = vlib.c vlib_callbacks.c vlib_aux.c vlib_sysfs.c \
|
||||||
|
vlib_sg.c
|
||||||
|
|
||||||
|
-libzfcphbaapi_la_LIBADD = -lsysfs -lsgutils
|
||||||
|
+libzfcphbaapi_la_LIBADD = -lsysfs -lsgutils2
|
||||||
|
libzfcphbaapi_la_LDFLAGS = \
|
||||||
|
-version-info $(LIB_CURRENT):$(LIB_REVISION):$(LIB_AGE) \
|
||||||
|
-lpthread -Wl,-init,_initvlib,-fini,_finivlib \
|
||||||
|
diff -Nrup lib-zfcp-hbaapi-2.0.orig/vlib_sg.c lib-zfcp-hbaapi-2.0/vlib_sg.c
|
||||||
|
--- lib-zfcp-hbaapi-2.0.orig/vlib_sg.c 2008-11-20 10:23:34.000000000 +0100
|
||||||
|
+++ lib-zfcp-hbaapi-2.0/vlib_sg.c 2009-09-25 13:21:52.000000000 +0200
|
||||||
|
@@ -19,6 +19,8 @@
|
||||||
|
* @brief All calls that use sg_utils library.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <scsi/sg_lib.h>
|
||||||
|
+#include <scsi/sg_cmds.h>
|
||||||
|
#include "vlib.h"
|
||||||
|
|
||||||
|
#define INTERVAL 10000000
|
@ -8,7 +8,7 @@ Name: s390utils
|
|||||||
Summary: Utilities and daemons for IBM System/z
|
Summary: Utilities and daemons for IBM System/z
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Version: 1.8.1
|
Version: 1.8.1
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: GPLv2 and GPLv2+ and CPL
|
License: GPLv2 and GPLv2+ and CPL
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -52,6 +52,8 @@ Patch101: cmsfs-1.1.8-kernel26.patch
|
|||||||
|
|
||||||
Patch200: src_vipa-2.0.4-locations.patch
|
Patch200: src_vipa-2.0.4-locations.patch
|
||||||
|
|
||||||
|
Patch300: lib-zfcp-hbaapi-2.0-sgutils.patch
|
||||||
|
|
||||||
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
Requires: s390utils-base = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
Requires: s390utils-osasnmpd = %{epoch}:%{version}-%{release}
|
||||||
Requires: s390utils-cpuplugd = %{epoch}:%{version}-%{release}
|
Requires: s390utils-cpuplugd = %{epoch}:%{version}-%{release}
|
||||||
@ -145,6 +147,14 @@ pushd src_vipa-%{vipaver}
|
|||||||
%patch200 -p1 -b .locations
|
%patch200 -p1 -b .locations
|
||||||
popd
|
popd
|
||||||
|
|
||||||
|
#
|
||||||
|
# lib-zfcp-hbaapi
|
||||||
|
#
|
||||||
|
pushd lib-zfcp-hbaapi-%{hbaapiver}
|
||||||
|
# fix for newer sg3_utils and missing function declarations
|
||||||
|
%patch300 -p1 -b .sgutils
|
||||||
|
popd
|
||||||
|
|
||||||
# remove --strip from install
|
# remove --strip from install
|
||||||
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
find . -name Makefile | xargs sed -i 's/$(INSTALL) -s/$(INSTALL)/g'
|
||||||
|
|
||||||
@ -162,8 +172,6 @@ popd
|
|||||||
pushd lib-zfcp-hbaapi-%{hbaapiver}
|
pushd lib-zfcp-hbaapi-%{hbaapiver}
|
||||||
# lib-zfcp-hbaapi: fix perms
|
# lib-zfcp-hbaapi: fix perms
|
||||||
chmod a-x *.h AUTHORS README ChangeLog LICENSE
|
chmod a-x *.h AUTHORS README ChangeLog LICENSE
|
||||||
# update sg3_utils library name
|
|
||||||
sed -i 's/-lsgutils/-lsgutils2/g' Makefile.in
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
|
|
||||||
@ -768,6 +776,9 @@ User-space development files for the s390/s390x architecture.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 25 2009 Dan Horák <dan[at]danny.cz> 2:1.8.1-6
|
||||||
|
- fix issues in lib-zfcp-hbaapi with a patch
|
||||||
|
|
||||||
* Thu Sep 24 2009 Dan Horák <dan[at]danny.cz> 2:1.8.1-5
|
* Thu Sep 24 2009 Dan Horák <dan[at]danny.cz> 2:1.8.1-5
|
||||||
- drop support for Fedora < 10
|
- drop support for Fedora < 10
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user