Update to 1.21.0.
This commit is contained in:
parent
99c271af8c
commit
dbb950d592
8
.gitignore
vendored
8
.gitignore
vendored
@ -73,3 +73,11 @@
|
||||
/rust-1.19.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.19.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.19.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rustc-1.21.0-src.tar.xz
|
||||
/rust-1.20.0-aarch64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.20.0-armv7-unknown-linux-gnueabihf.tar.xz
|
||||
/rust-1.20.0-i686-unknown-linux-gnu.tar.xz
|
||||
/rust-1.20.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.20.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.20.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.20.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 253ff9c24f0e11323ae4f173cc620721fb322beb Mon Sep 17 00:00:00 2001
|
||||
From: Ximin Luo <infinity0@pwned.gg>
|
||||
Date: Mon, 17 Jul 2017 22:29:09 +0200
|
||||
Subject: [PATCH] configure: allow distros to disable debuginfo-only-std
|
||||
|
||||
---
|
||||
configure | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index af59d5b0bb88..084f5bfdedbc 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -558,8 +558,8 @@ case "$CFG_RELEASE_CHANNEL" in
|
||||
*-pc-windows-gnu)
|
||||
;;
|
||||
*)
|
||||
- CFG_ENABLE_DEBUGINFO_LINES=1
|
||||
- CFG_ENABLE_DEBUGINFO_ONLY_STD=1
|
||||
+ enable_if_not_disabled debuginfo-lines
|
||||
+ enable_if_not_disabled debuginfo-only-std
|
||||
;;
|
||||
esac
|
||||
|
||||
@@ -570,8 +570,8 @@ case "$CFG_RELEASE_CHANNEL" in
|
||||
*-pc-windows-gnu)
|
||||
;;
|
||||
*)
|
||||
- CFG_ENABLE_DEBUGINFO_LINES=1
|
||||
- CFG_ENABLE_DEBUGINFO_ONLY_STD=1
|
||||
+ enable_if_not_disabled debuginfo-lines
|
||||
+ enable_if_not_disabled debuginfo-only-std
|
||||
;;
|
||||
esac
|
||||
;;
|
||||
--
|
||||
2.13.3
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 6f680d06544edae491d2281d89b0b93efcdd6143 Mon Sep 17 00:00:00 2001
|
||||
From bc3a71ed00af01855b0ae8908ae271b83eca34f6 Mon Sep 17 00:00:00 2001
|
||||
From: bors <bors@rust-lang.org>
|
||||
Date: Sat, 2 Sep 2017 19:46:51 +0000
|
||||
Subject: [PATCH] Auto merge of #44066 - cuviper:powerpc64-extern-abi,
|
||||
@ -35,7 +35,7 @@ formerly-failing tests now pass on powerpc64:
|
||||
6 files changed, 151 insertions(+), 44 deletions(-)
|
||||
|
||||
diff --git a/src/librustc_trans/cabi_powerpc64.rs b/src/librustc_trans/cabi_powerpc64.rs
|
||||
index c4f8d0b4b963..a3780c8cfa92 100644
|
||||
index 5c695387236f..fb5472eb6ae1 100644
|
||||
--- a/src/librustc_trans/cabi_powerpc64.rs
|
||||
+++ b/src/librustc_trans/cabi_powerpc64.rs
|
||||
@@ -14,14 +14,26 @@
|
||||
@ -44,7 +44,7 @@ index c4f8d0b4b963..a3780c8cfa92 100644
|
||||
use context::CrateContext;
|
||||
+use rustc::ty::layout;
|
||||
|
||||
-fn is_homogenous_aggregate<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>, arg: &mut ArgType<'tcx>)
|
||||
-fn is_homogeneous_aggregate<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>, arg: &mut ArgType<'tcx>)
|
||||
+#[derive(Debug, Clone, Copy, PartialEq)]
|
||||
+enum ABI {
|
||||
+ ELFv1, // original ABI used for powerpc64 (big-endian)
|
||||
@ -52,11 +52,11 @@ index c4f8d0b4b963..a3780c8cfa92 100644
|
||||
+}
|
||||
+use self::ABI::*;
|
||||
+
|
||||
+fn is_homogenous_aggregate<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>,
|
||||
+ arg: &mut ArgType<'tcx>,
|
||||
+ abi: ABI)
|
||||
+fn is_homogeneous_aggregate<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>,
|
||||
+ arg: &mut ArgType<'tcx>,
|
||||
+ abi: ABI)
|
||||
-> Option<Uniform> {
|
||||
arg.layout.homogenous_aggregate(ccx).and_then(|unit| {
|
||||
arg.layout.homogeneous_aggregate(ccx).and_then(|unit| {
|
||||
let size = arg.layout.size(ccx);
|
||||
|
||||
- // Ensure we have at most eight uniquely addressable members.
|
||||
@ -68,7 +68,7 @@ index c4f8d0b4b963..a3780c8cfa92 100644
|
||||
return None;
|
||||
}
|
||||
|
||||
@@ -42,21 +54,23 @@ fn is_homogenous_aggregate<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>, arg: &mut Arg
|
||||
@@ -42,21 +54,23 @@ fn is_homogeneous_aggregate<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>, arg: &mut Ar
|
||||
})
|
||||
}
|
||||
|
||||
@ -87,8 +87,8 @@ index c4f8d0b4b963..a3780c8cfa92 100644
|
||||
+ return;
|
||||
}
|
||||
|
||||
- if let Some(uniform) = is_homogenous_aggregate(ccx, ret) {
|
||||
+ if let Some(uniform) = is_homogenous_aggregate(ccx, ret, abi) {
|
||||
- if let Some(uniform) = is_homogeneous_aggregate(ccx, ret) {
|
||||
+ if let Some(uniform) = is_homogeneous_aggregate(ccx, ret, abi) {
|
||||
ret.cast_to(ccx, uniform);
|
||||
return;
|
||||
}
|
||||
@ -107,8 +107,8 @@ index c4f8d0b4b963..a3780c8cfa92 100644
|
||||
return;
|
||||
}
|
||||
|
||||
- if let Some(uniform) = is_homogenous_aggregate(ccx, arg) {
|
||||
+ if let Some(uniform) = is_homogenous_aggregate(ccx, arg, abi) {
|
||||
- if let Some(uniform) = is_homogeneous_aggregate(ccx, arg) {
|
||||
+ if let Some(uniform) = is_homogeneous_aggregate(ccx, arg, abi) {
|
||||
arg.cast_to(ccx, uniform);
|
||||
return;
|
||||
}
|
||||
@ -159,7 +159,7 @@ index c4f8d0b4b963..a3780c8cfa92 100644
|
||||
}
|
||||
}
|
||||
diff --git a/src/librustc_trans/cabi_x86.rs b/src/librustc_trans/cabi_x86.rs
|
||||
index 9f5520dabe33..05932ef2de80 100644
|
||||
index 8b024b8c97fa..49634d6e78ce 100644
|
||||
--- a/src/librustc_trans/cabi_x86.rs
|
||||
+++ b/src/librustc_trans/cabi_x86.rs
|
||||
@@ -11,12 +11,30 @@
|
@ -14,14 +14,14 @@ diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index 746f85a9d59d..05d59e7d5956 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -562,7 +562,7 @@ impl Step for Src {
|
||||
"src/libprofiler_builtins",
|
||||
];
|
||||
let std_src_dirs_exclude = [
|
||||
- "src/compiler-rt/test",
|
||||
+ "src/libcompiler_builtins/compiler-rt/test",
|
||||
"src/jemalloc/test/unit",
|
||||
];
|
||||
@@ -754,7 +754,7 @@ impl Step for Src {
|
||||
"src/libprofiler_builtins",
|
||||
];
|
||||
let std_src_dirs_exclude = [
|
||||
- "src/compiler-rt/test",
|
||||
+ "src/libcompiler_builtins/compiler-rt/test",
|
||||
"src/jemalloc/test/unit",
|
||||
];
|
||||
|
||||
--
|
||||
2.13.5
|
@ -1,7 +1,8 @@
|
||||
From 3ca86983df58daf0242b0618d3beb9ea917193e2 Mon Sep 17 00:00:00 2001
|
||||
From 0f5ee28213a73733e6811b176c89ecececfe9cbc Mon Sep 17 00:00:00 2001
|
||||
From: bors <bors@rust-lang.org>
|
||||
Date: Mon, 11 Sep 2017 12:53:21 +0000
|
||||
Subject: [PATCH] Auto merge of #44440 - cuviper:min_global_align, r=japaric
|
||||
Subject: [PATCH] Auto merge of #44440 - cuviper:min_global_align,
|
||||
r=japaric
|
||||
|
||||
Add `TargetOptions::min_global_align`, with s390x at 16-bit
|
||||
|
||||
@ -27,10 +28,10 @@ r? @eddyb
|
||||
create mode 100644 src/test/run-make/min-global-align/min_global_align.rs
|
||||
|
||||
diff --git a/src/librustc_back/target/mod.rs b/src/librustc_back/target/mod.rs
|
||||
index edbbcf6f0b64..f88a3879d6c0 100644
|
||||
index 130e1b695dbd..301cf3f8c820 100644
|
||||
--- a/src/librustc_back/target/mod.rs
|
||||
+++ b/src/librustc_back/target/mod.rs
|
||||
@@ -414,6 +414,9 @@ pub struct TargetOptions {
|
||||
@@ -425,6 +425,9 @@ pub struct TargetOptions {
|
||||
|
||||
/// Whether or not stack probes (__rust_probestack) are enabled
|
||||
pub stack_probes: bool,
|
||||
@ -40,25 +41,25 @@ index edbbcf6f0b64..f88a3879d6c0 100644
|
||||
}
|
||||
|
||||
impl Default for TargetOptions {
|
||||
@@ -472,6 +475,7 @@ impl Default for TargetOptions {
|
||||
abi_blacklist: vec![],
|
||||
@@ -486,6 +489,7 @@ impl Default for TargetOptions {
|
||||
crt_static_default: false,
|
||||
crt_static_respected: false,
|
||||
stack_probes: false,
|
||||
+ min_global_align: None,
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -695,6 +699,7 @@ impl Target {
|
||||
try!(key!(panic_strategy, PanicStrategy));
|
||||
@@ -724,6 +728,7 @@ impl Target {
|
||||
key!(crt_static_default, bool);
|
||||
key!(crt_static_respected, bool);
|
||||
key!(stack_probes, bool);
|
||||
+ key!(min_global_align, Option<u64>);
|
||||
|
||||
if let Some(array) = obj.find("abi-blacklist").and_then(Json::as_array) {
|
||||
for name in array.iter().filter_map(|abi| abi.as_string()) {
|
||||
@@ -882,6 +887,7 @@ impl ToJson for Target {
|
||||
target_option_val!(panic_strategy);
|
||||
@@ -914,6 +919,7 @@ impl ToJson for Target {
|
||||
target_option_val!(crt_static_default);
|
||||
target_option_val!(crt_static_respected);
|
||||
target_option_val!(stack_probes);
|
||||
+ target_option_val!(min_global_align);
|
||||
|
||||
@ -77,7 +78,7 @@ index 78a6bb7933d9..aad9effacd44 100644
|
||||
Ok(Target {
|
||||
llvm_target: "s390x-unknown-linux-gnu".to_string(),
|
||||
diff --git a/src/librustc_trans/consts.rs b/src/librustc_trans/consts.rs
|
||||
index eac0a0625671..cfb29d848d0f 100644
|
||||
index 310cd6fe9559..f7f9b9386841 100644
|
||||
--- a/src/librustc_trans/consts.rs
|
||||
+++ b/src/librustc_trans/consts.rs
|
||||
@@ -26,6 +26,7 @@ use rustc::ty;
|
||||
@ -88,7 +89,7 @@ index eac0a0625671..cfb29d848d0f 100644
|
||||
use std::ffi::{CStr, CString};
|
||||
use syntax::ast;
|
||||
use syntax::attr;
|
||||
@@ -36,6 +37,25 @@ pub fn ptrcast(val: ValueRef, ty: Type) -> ValueRef {
|
||||
@@ -42,6 +43,25 @@ pub fn bitcast(val: ValueRef, ty: Type) -> ValueRef {
|
||||
}
|
||||
}
|
||||
|
||||
@ -114,7 +115,7 @@ index eac0a0625671..cfb29d848d0f 100644
|
||||
pub fn addr_of_mut(ccx: &CrateContext,
|
||||
cv: ValueRef,
|
||||
align: machine::llalign,
|
||||
@@ -47,7 +67,7 @@ pub fn addr_of_mut(ccx: &CrateContext,
|
||||
@@ -53,7 +73,7 @@ pub fn addr_of_mut(ccx: &CrateContext,
|
||||
bug!("symbol `{}` is already defined", name);
|
||||
});
|
||||
llvm::LLVMSetInitializer(gv, cv);
|
||||
@ -123,7 +124,7 @@ index eac0a0625671..cfb29d848d0f 100644
|
||||
llvm::LLVMRustSetLinkage(gv, llvm::Linkage::InternalLinkage);
|
||||
SetUnnamedAddr(gv, true);
|
||||
gv
|
||||
@@ -251,7 +271,7 @@ pub fn trans_static<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>,
|
||||
@@ -271,7 +291,7 @@ pub fn trans_static<'a, 'tcx>(ccx: &CrateContext<'a, 'tcx>,
|
||||
ccx.statics_to_rauw().borrow_mut().push((g, new_g));
|
||||
new_g
|
||||
};
|
27
rust.spec
27
rust.spec
@ -8,10 +8,10 @@
|
||||
# To bootstrap from scratch, set the channel and date from src/stage0.txt
|
||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||
# or nightly wants some beta-YYYY-MM-DD
|
||||
%global bootstrap_rust 1.19.0
|
||||
%global bootstrap_cargo 0.20.0
|
||||
%global bootstrap_rust 1.20.0
|
||||
%global bootstrap_cargo 0.21.0
|
||||
%global bootstrap_channel %{bootstrap_rust}
|
||||
%global bootstrap_date 2017-07-20
|
||||
%global bootstrap_date 2017-08-31
|
||||
|
||||
# Only the specified arches will use bootstrap binaries.
|
||||
#global bootstrap_arches %%{rust_arches}
|
||||
@ -47,8 +47,8 @@
|
||||
|
||||
|
||||
Name: rust
|
||||
Version: 1.20.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.21.0
|
||||
Release: 1%{?dist}
|
||||
Summary: The Rust Programming Language
|
||||
License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
|
||||
# ^ written as: (rust itself) and (bundled libraries)
|
||||
@ -62,10 +62,9 @@ ExclusiveArch: %{rust_arches}
|
||||
%endif
|
||||
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||
|
||||
Patch1: rust-1.19.0-43297-configure-debuginfo.patch
|
||||
Patch2: rust-1.20.0-44203-exclude-compiler-rt-test.patch
|
||||
Patch3: rust-1.20.0-44066-ppc64-struct-abi.patch
|
||||
Patch4: rust-1.20.0-44440-s390x-global-align.patch
|
||||
Patch1: rust-1.21.0-44203-exclude-compiler-rt-test.patch
|
||||
Patch2: rust-1.21.0-44066-ppc64-struct-abi.patch
|
||||
Patch3: rust-1.21.0-44440-s390x-global-align.patch
|
||||
|
||||
# Get the Rust triple for any arch.
|
||||
%{lua: function rust_triple(arch)
|
||||
@ -311,10 +310,9 @@ sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
|
||||
src/librustc_llvm/lib.rs
|
||||
%endif
|
||||
|
||||
%patch1 -p1 -b .debuginfo
|
||||
%patch2 -p1 -b .compiler-rt
|
||||
%patch3 -p1 -b .ppc64-struct-abi
|
||||
%patch4 -p1 -b .s390x-global-align
|
||||
%patch1 -p1 -b .compiler-rt
|
||||
%patch2 -p1 -b .ppc64-struct-abi
|
||||
%patch3 -p1 -b .s390x-global-align
|
||||
|
||||
# The configure macro will modify some autoconf-related files, which upsets
|
||||
# cargo when it tries to verify checksums in those files. If we just truncate
|
||||
@ -473,6 +471,9 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
|
||||
- Update to 1.21.0.
|
||||
|
||||
* Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
|
||||
- ABI fixes for ppc64 and s390x.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rustc-1.20.0-src.tar.xz) = 1fcf5f279094e9f8b89b2a46f3fbc11c15609a8bda1e51b82899bd475381c8bb6aaa7ce6fe196fc07e0a36e9d9b9dbaa1c4a6281946cd9f13f3e72fb8cbd3bb2
|
||||
SHA512 (rustc-1.21.0-src.tar.xz) = 63b5c247ef7028c59bb246b96cb9917476d6d13cf68b37956e290248a1e53de3e4dbfad1dcae3c5c2cacc73c9dd212c50e45902c7d913fadeaac81db630bc951
|
||||
|
@ -1,8 +1,8 @@
|
||||
SHA512 (rustc-1.20.0-src.tar.xz) = 1fcf5f279094e9f8b89b2a46f3fbc11c15609a8bda1e51b82899bd475381c8bb6aaa7ce6fe196fc07e0a36e9d9b9dbaa1c4a6281946cd9f13f3e72fb8cbd3bb2
|
||||
SHA512 (rust-1.19.0-aarch64-unknown-linux-gnu.tar.xz) = 403ff1e6795c623e022813a9cb6f3c246aeeb5f657f233ff96674b1c2fb8146838003de9322817e15cd3099e8a3a2044e92e64a8dde5b3e8f7255f1616699467
|
||||
SHA512 (rust-1.19.0-armv7-unknown-linux-gnueabihf.tar.xz) = dd358f03f9ff23de2b9932504d35518f6340a9dd32984a7597bcf77435435f6101066efd088f2637e75bfd1939cb363ef71796ea6f5f6583899a51190c2a5b64
|
||||
SHA512 (rust-1.19.0-i686-unknown-linux-gnu.tar.xz) = e04b453fd3d5f72cc24211f1dc8a04813b3d07fe088281926bddc5273ddda7702af71010eba5611b911b7049e5f852087c94516792c0e534b15122c55760f7a3
|
||||
SHA512 (rust-1.19.0-powerpc64le-unknown-linux-gnu.tar.xz) = 9bbdd62d2067d1c81b0cfb205f4c51250afe8699752f212a12ad359d9f7b6a85489a459093ab5d1c516d758f676df6eacef1f8d07a5d43b6c794daf1cde33f1c
|
||||
SHA512 (rust-1.19.0-powerpc64-unknown-linux-gnu.tar.xz) = 6697ec98588d092a65b23565d4d29390182089bcc2fe5c9de75ca9020ac5cdfae6e255f6355a828884c4986197917c45b131b29aafd06a67d4d9a5686f3bf975
|
||||
SHA512 (rust-1.19.0-s390x-unknown-linux-gnu.tar.xz) = 61724b6e647d8c6539cc50b47bbef772a65b4d1b041f8fe2411e947bf08535b3227ffda729c3cdb73613723dfc66d73db08b99c173f4fdb6fe510066e9a47fa0
|
||||
SHA512 (rust-1.19.0-x86_64-unknown-linux-gnu.tar.xz) = 807d1b9845f47d515aac54d06274502fb57a4d8ac9caeeaf53bdfd8ae23cc67a151932a9abaa2c0b3ade7124943df91b42442450cbc2a58d2b545db798b45e5d
|
||||
SHA512 (rustc-1.21.0-src.tar.xz) = 63b5c247ef7028c59bb246b96cb9917476d6d13cf68b37956e290248a1e53de3e4dbfad1dcae3c5c2cacc73c9dd212c50e45902c7d913fadeaac81db630bc951
|
||||
SHA512 (rust-1.20.0-aarch64-unknown-linux-gnu.tar.xz) = 23ac0086fa10c46eb2d607fc70dcb35b9858440b20030c4e688ec7d83e1d2798c46dd931914e2b555b6d846220bc678ea769a5e9b366b8fd12d9e57b4962ca3a
|
||||
SHA512 (rust-1.20.0-armv7-unknown-linux-gnueabihf.tar.xz) = ca041644fd78d399e81a8dad9b5d5b401a2d8426eaf1e4ed02a2c5415b0a1caefadbc9716fefd6fd01aedde4fae15fc0357375d43a803714a88d65643b8ab5d1
|
||||
SHA512 (rust-1.20.0-i686-unknown-linux-gnu.tar.xz) = fdd3e039589feba8a1f3ab2aa0d92bfe87a05d0e1697c5ea981577628e89715d3790a747408cb0d52fc48605c3faf6b59548e6237bdfc0505f8090b23a63a89b
|
||||
SHA512 (rust-1.20.0-powerpc64le-unknown-linux-gnu.tar.xz) = 2ccb9b686bc6e52dfe906ee9c807564b7a87839340b6b3de9862d53182d68044b892f6eea5606a9c6e04538a1aa3d8e2c17c73480bbfe317c1edb294e1b937a4
|
||||
SHA512 (rust-1.20.0-powerpc64-unknown-linux-gnu.tar.xz) = cd25a99e9f4331d458639887db8e3011ca9eb0907bb8a9f948353042658344338b170326c3931f4cca66dde2375611eeaae536f9b08a8f3cc4b75eef9220a8b5
|
||||
SHA512 (rust-1.20.0-s390x-unknown-linux-gnu.tar.xz) = 60e051bc917c46fcec0816f1a7bbaee40a781af3f9061c8d3d257fc380321994737cc95383686032b7264e42b75d0ac71c7727875ec97672e6776329915bffb6
|
||||
SHA512 (rust-1.20.0-x86_64-unknown-linux-gnu.tar.xz) = 5e397b1d3f7ef2ef7f11a7d48ad309f17220751246d5bf3e7301cca1c1a81864be49a7b78e122bb3bc66938971b73c8db443ba9e969880544e61af4061a5d96e
|
||||
|
Loading…
Reference in New Issue
Block a user