Update to 1.45.0.
This commit is contained in:
parent
bd38d989dc
commit
d62a20a4de
8
.gitignore
vendored
8
.gitignore
vendored
@ -279,3 +279,11 @@
|
||||
/rust-1.43.1-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.43.1-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rustc-1.44.1-src.tar.xz
|
||||
/rustc-1.45.0-src.tar.xz
|
||||
/rust-1.44.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.44.0-i686-unknown-linux-gnu.tar.xz
|
||||
/rust-1.44.0-armv7-unknown-linux-gnueabihf.tar.xz
|
||||
/rust-1.44.0-aarch64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.44.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.44.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.44.0-s390x-unknown-linux-gnu.tar.xz
|
||||
|
@ -1,56 +0,0 @@
|
||||
From fbd3fbdb24563a9d8fd3651f6bdc90bbbbd81d3e Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 1 May 2020 16:50:10 -0700
|
||||
Subject: [PATCH] Use a non-existent test path instead of clobbering /dev/null
|
||||
|
||||
---
|
||||
src/test/ui/non-ice-error-on-worker-io-fail.rs | 10 +++++++---
|
||||
src/test/ui/non-ice-error-on-worker-io-fail.stderr | 2 +-
|
||||
2 files changed, 8 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/test/ui/non-ice-error-on-worker-io-fail.rs b/src/test/ui/non-ice-error-on-worker-io-fail.rs
|
||||
index 8af17742850d..30779fc65c0f 100644
|
||||
--- a/src/test/ui/non-ice-error-on-worker-io-fail.rs
|
||||
+++ b/src/test/ui/non-ice-error-on-worker-io-fail.rs
|
||||
@@ -4,8 +4,12 @@
|
||||
//
|
||||
// An attempt to `-o` into a directory we cannot write into should indeed
|
||||
// be an error; but not an ICE.
|
||||
+//
|
||||
+// However, some folks run tests as root, which can write `/dev/` and end
|
||||
+// up clobbering `/dev/null`. Instead we'll use a non-existent path, which
|
||||
+// also used to ICE, but even root can't magically write there.
|
||||
|
||||
-// compile-flags: -o /dev/null
|
||||
+// compile-flags: -o /does-not-exist/output
|
||||
|
||||
// The error-pattern check occurs *before* normalization, and the error patterns
|
||||
// are wildly different between build environments. So this is a cop-out (and we
|
||||
@@ -15,10 +19,10 @@
|
||||
// error-pattern: error
|
||||
|
||||
// On Mac OS X, we get an error like the below
|
||||
-// normalize-stderr-test "failed to write bytecode to /dev/null.non_ice_error_on_worker_io_fail.*" -> "io error modifying /dev/"
|
||||
+// normalize-stderr-test "failed to write bytecode to /does-not-exist/output.non_ice_error_on_worker_io_fail.*" -> "io error modifying /does-not-exist/"
|
||||
|
||||
// On Linux, we get an error like the below
|
||||
-// normalize-stderr-test "couldn't create a temp dir.*" -> "io error modifying /dev/"
|
||||
+// normalize-stderr-test "couldn't create a temp dir.*" -> "io error modifying /does-not-exist/"
|
||||
|
||||
// ignore-tidy-linelength
|
||||
// ignore-windows - this is a unix-specific test
|
||||
diff --git a/src/test/ui/non-ice-error-on-worker-io-fail.stderr b/src/test/ui/non-ice-error-on-worker-io-fail.stderr
|
||||
index f732abc52b71..edadecf273a7 100644
|
||||
--- a/src/test/ui/non-ice-error-on-worker-io-fail.stderr
|
||||
+++ b/src/test/ui/non-ice-error-on-worker-io-fail.stderr
|
||||
@@ -1,6 +1,6 @@
|
||||
warning: ignoring --out-dir flag due to -o flag
|
||||
|
||||
-error: io error modifying /dev/
|
||||
+error: io error modifying /does-not-exist/
|
||||
|
||||
error: aborting due to previous error; 1 warning emitted
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
28
rust.spec
28
rust.spec
@ -9,10 +9,10 @@
|
||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||
# or nightly wants some beta-YYYY-MM-DD
|
||||
# Note that cargo matches the program version here, not its crate version.
|
||||
%global bootstrap_rust 1.43.1
|
||||
%global bootstrap_cargo 1.43.1
|
||||
%global bootstrap_channel 1.43.1
|
||||
%global bootstrap_date 2020-05-07
|
||||
%global bootstrap_rust 1.44.0
|
||||
%global bootstrap_cargo 1.44.0
|
||||
%global bootstrap_channel 1.44.0
|
||||
%global bootstrap_date 2020-06-04
|
||||
|
||||
# Only the specified arches will use bootstrap binaries.
|
||||
#global bootstrap_arches %%{rust_arches}
|
||||
@ -21,7 +21,7 @@
|
||||
%bcond_with llvm_static
|
||||
|
||||
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
||||
# is insufficient. Rust currently requires LLVM 7.0+.
|
||||
# is insufficient. Rust currently requires LLVM 8.0+.
|
||||
%if 0%{?rhel} && !0%{?epel}
|
||||
%bcond_without bundled_llvm
|
||||
%else
|
||||
@ -48,8 +48,8 @@
|
||||
%endif
|
||||
|
||||
Name: rust
|
||||
Version: 1.44.1
|
||||
Release: 2%{?dist}
|
||||
Version: 1.45.0
|
||||
Release: 1%{?dist}
|
||||
Summary: The Rust Programming Language
|
||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||
# ^ written as: (rust itself) and (bundled libraries)
|
||||
@ -63,9 +63,6 @@ ExclusiveArch: %{rust_arches}
|
||||
%endif
|
||||
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||
|
||||
# https://github.com/rust-lang/rust/pull/71782
|
||||
Patch1: rust-pr71782-Use-a-non-existent-test-path.patch
|
||||
|
||||
# Get the Rust triple for any arch.
|
||||
%{lua: function rust_triple(arch)
|
||||
local abi = "gnu"
|
||||
@ -146,7 +143,7 @@ BuildRequires: %{python}
|
||||
|
||||
%if %with bundled_llvm
|
||||
BuildRequires: cmake3 >= 3.4.3
|
||||
Provides: bundled(llvm) = 9.0.1
|
||||
Provides: bundled(llvm) = 10.0.1
|
||||
%else
|
||||
BuildRequires: cmake >= 2.8.11
|
||||
%if 0%{?epel}
|
||||
@ -394,8 +391,6 @@ test -f '%{local_rust_root}/bin/rustc'
|
||||
|
||||
%setup -q -n %{rustc_package}
|
||||
|
||||
%patch1 -p1
|
||||
|
||||
%if "%{python}" == "python3"
|
||||
sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
|
||||
%endif
|
||||
@ -506,6 +501,7 @@ export LIBSSH2_SYS_USE_PKG_CONFIG=1
|
||||
--disable-rpath \
|
||||
%{enable_debuginfo} \
|
||||
--enable-extended \
|
||||
--tools=analysis,cargo,clippy,rls,rustfmt,src \
|
||||
--enable-vendor \
|
||||
--enable-verbose-tests \
|
||||
%{?codegen_units_std} \
|
||||
@ -613,7 +609,6 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
%dir %{rustlibdir}/%{rust_triple}
|
||||
%dir %{rustlibdir}/%{rust_triple}/lib
|
||||
%{rustlibdir}/%{rust_triple}/lib/*.so
|
||||
%exclude %{_bindir}/*miri
|
||||
|
||||
|
||||
%files std-static
|
||||
@ -705,7 +700,10 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 01 2020 Josh Stone <jistone@redhat.com> - 1.44.1-2
|
||||
* Thu Jul 16 2020 Josh Stone <jistone@redhat.com> - 1.45.0-1
|
||||
- Update to 1.45.0.
|
||||
|
||||
* Wed Jul 01 2020 Jeff Law <law@redhat.com> - 1.44.1-2
|
||||
- Disable LTO
|
||||
|
||||
* Thu Jun 18 2020 Josh Stone <jistone@redhat.com> - 1.44.1-1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rustc-1.44.1-src.tar.xz) = 1c17002edae844a710db9b144c17171416330dc565343c65af8a6e112fb61555e2025bb4cf33cac1229d7df689e6ff8858b91ae00552400ccacafaf1de11849b
|
||||
SHA512 (rustc-1.45.0-src.tar.xz) = ff049eb65b36e6c64531d56251ebd446336a782f26504eccf375df1c22fa94b5f18e84660cef423edb815c1b31a1a7c9e57aea4aa0779576f3b0d7e81e19427b
|
||||
|
@ -1,8 +1,8 @@
|
||||
SHA512 (rustc-1.44.1-src.tar.xz) = 1c17002edae844a710db9b144c17171416330dc565343c65af8a6e112fb61555e2025bb4cf33cac1229d7df689e6ff8858b91ae00552400ccacafaf1de11849b
|
||||
SHA512 (rust-1.43.1-aarch64-unknown-linux-gnu.tar.xz) = b54fad5493344d2370bd77110f0ffb0231f41ab8aa9707e9303304957c5d9067dc83089432eb175605b78dc771dfcf7abfcce63d7fecdbb759dd224c17d12da0
|
||||
SHA512 (rust-1.43.1-armv7-unknown-linux-gnueabihf.tar.xz) = 0812b3229dd47f1b5cadb49020e68d28b4267ac0489d0c2e448f21e3b0b6519bbf216ac9b20b747e035033842a6eb3b13a98706f2eddca2c088d9396dcb2c21e
|
||||
SHA512 (rust-1.43.1-i686-unknown-linux-gnu.tar.xz) = c7423bccfb15f3df6043ec1d81203c9db9b3229dedd347cab09d3cc3b183f53aa0707f59964efccd63418e1c6ad21e7ee7dcc1495eda8c4ecb55ee8e6b3ac034
|
||||
SHA512 (rust-1.43.1-powerpc64le-unknown-linux-gnu.tar.xz) = da447ec44ebf998290a73420437c8d434a6c196cfe1c3331a9adf40abf7acd97a231e352a8626bbfa961da8e0c4f450aa59d573254257f72cce4068eeb8112a1
|
||||
SHA512 (rust-1.43.1-powerpc64-unknown-linux-gnu.tar.xz) = 695591807892c8f08801cd145ebc6a91ee4222000210baaaa0d6c8acf1ac6a96f4bf2566871def04d15a9965b7e3ea4287e37d7851fb14010518694d8ede75e6
|
||||
SHA512 (rust-1.43.1-s390x-unknown-linux-gnu.tar.xz) = f087e50a91b1cc4a12bf15aea1cefbda9b89518febcecc0d56ea7d0a6a682be06cff7777d0a0b4812e96f3fb3295e7799bf200c1599c88cb7083a78d5002f14a
|
||||
SHA512 (rust-1.43.1-x86_64-unknown-linux-gnu.tar.xz) = 2fc573ca2826d9f03044f746ae4d7715b4e31b9ac933289607aa3449a538bb4dfd519540576a1d0d286c0d754a7ba6ce38beef6aded1090d3af3091b6ba2a9ee
|
||||
SHA512 (rustc-1.45.0-src.tar.xz) = ff049eb65b36e6c64531d56251ebd446336a782f26504eccf375df1c22fa94b5f18e84660cef423edb815c1b31a1a7c9e57aea4aa0779576f3b0d7e81e19427b
|
||||
SHA512 (rust-1.44.0-x86_64-unknown-linux-gnu.tar.xz) = 25c762e07e178ffc1b96b4a113e437541d6dc18bd81fb9933af676e99ca391c6cdd8d420caabcfca1b3ddb987a84ff9eb1d0bdb3cca486e71925555f51ecaa4c
|
||||
SHA512 (rust-1.44.0-i686-unknown-linux-gnu.tar.xz) = 85ee1d7cd4581d9cdc18f0cfe89b0c78c32039f658b85c5f6a60ac8047864234bdff955e02d6e15ae40dd98e8e27cb3d83fab978dba6373f9e487cfd2ba0b594
|
||||
SHA512 (rust-1.44.0-armv7-unknown-linux-gnueabihf.tar.xz) = 59fd1f0dc058118a838c4c3c66dd5a5c2acb1b05ebf4525188846577cb22c4b46a57605d6a9cede5fbd34c0b5c638434a186d1ce3693ace6be8105c265b59b7b
|
||||
SHA512 (rust-1.44.0-aarch64-unknown-linux-gnu.tar.xz) = c853a585bd76730a9ed1e95c12baf2939928fd3c5ba7cc0f95c03ec472c0012f01d0b7d7c37e21dfdcc1d1eca4c7e392709a2585e42bc759b636e95b4ab870d0
|
||||
SHA512 (rust-1.44.0-powerpc64-unknown-linux-gnu.tar.xz) = dff9aa248cd0efd1b28c6254c040cd30356ce973a3ed525530db783d6f7ebcdd32568bfa5c68c2aba0bb312ee74f03d1c91361e69830fe79ddd4d31e73fc2865
|
||||
SHA512 (rust-1.44.0-powerpc64le-unknown-linux-gnu.tar.xz) = d74802fc29641d08b5e5d526e91258c71d914daf0f33abea71ad7d300da4ae39d457b9d4e95b0b0811ec8ed5e60e7d0292e8e928f3079189e07887ce115bd466
|
||||
SHA512 (rust-1.44.0-s390x-unknown-linux-gnu.tar.xz) = 39fac45e0c1e8786275ba30ed13d13334c7f0fc03d653a3e0a3e174d18e244d9e4bb99614ed1465e7a21befb2542ed4d3a54d4ea2702da449b1e6a7770a43970
|
||||
|
Loading…
Reference in New Issue
Block a user