Update to 1.53.0.
This commit is contained in:
parent
ebd24b3917
commit
d498bc15d8
7
.gitignore
vendored
7
.gitignore
vendored
@ -343,3 +343,10 @@
|
|||||||
/rust-1.51.0-s390x-unknown-linux-gnu.tar.xz
|
/rust-1.51.0-s390x-unknown-linux-gnu.tar.xz
|
||||||
/rust-1.51.0-x86_64-unknown-linux-gnu.tar.xz
|
/rust-1.51.0-x86_64-unknown-linux-gnu.tar.xz
|
||||||
/rustc-1.52.1-src.tar.xz
|
/rustc-1.52.1-src.tar.xz
|
||||||
|
/rustc-1.53.0-src.tar.xz
|
||||||
|
/rust-1.52.0-aarch64-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.52.0-armv7-unknown-linux-gnueabihf.tar.xz
|
||||||
|
/rust-1.52.0-i686-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.52.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.52.0-s390x-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.52.0-x86_64-unknown-linux-gnu.tar.xz
|
||||||
|
@ -1,17 +1,17 @@
|
|||||||
From 1a6307bbf7972aa2ce89a213bad6f26b6325a59c Mon Sep 17 00:00:00 2001
|
From 3582a262d27fd5a2f8705bad6018241eaca8aadd Mon Sep 17 00:00:00 2001
|
||||||
From: Ivan Mironov <mironov.ivan@gmail.com>
|
From: Ivan Mironov <mironov.ivan@gmail.com>
|
||||||
Date: Sun, 8 Dec 2019 17:23:08 +0500
|
Date: Sun, 8 Dec 2019 17:23:08 +0500
|
||||||
Subject: [PATCH] Use lld provided by system for wasm
|
Subject: [PATCH] Use lld provided by system for wasm
|
||||||
|
|
||||||
---
|
---
|
||||||
compiler/rustc_target/src/spec/wasm32_base.rs | 3 +--
|
compiler/rustc_target/src/spec/wasm_base.rs | 3 +--
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/compiler/rustc_target/src/spec/wasm32_base.rs b/compiler/rustc_target/src/spec/wasm32_base.rs
|
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||||
index bfef3d37228f..0ecb29248fe2 100644
|
index b208eb92f8ff..94a701a11c8b 100644
|
||||||
--- a/compiler/rustc_target/src/spec/wasm32_base.rs
|
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/wasm32_base.rs
|
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||||
@@ -97,8 +97,7 @@ pub fn options() -> TargetOptions {
|
@@ -98,8 +98,7 @@ pub fn options() -> TargetOptions {
|
||||||
// arguments just yet
|
// arguments just yet
|
||||||
limit_rdylib_exports: false,
|
limit_rdylib_exports: false,
|
||||||
|
|
||||||
|
23
rust.spec
23
rust.spec
@ -9,10 +9,10 @@
|
|||||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||||
# or nightly wants some beta-YYYY-MM-DD
|
# or nightly wants some beta-YYYY-MM-DD
|
||||||
# Note that cargo matches the program version here, not its crate version.
|
# Note that cargo matches the program version here, not its crate version.
|
||||||
%global bootstrap_rust 1.51.0
|
%global bootstrap_rust 1.52.0
|
||||||
%global bootstrap_cargo 1.51.0
|
%global bootstrap_cargo 1.52.0
|
||||||
%global bootstrap_channel 1.51.0
|
%global bootstrap_channel 1.52.0
|
||||||
%global bootstrap_date 2021-03-25
|
%global bootstrap_date 2021-05-06
|
||||||
|
|
||||||
# Only the specified arches will use bootstrap binaries.
|
# Only the specified arches will use bootstrap binaries.
|
||||||
#global bootstrap_arches %%{rust_arches}
|
#global bootstrap_arches %%{rust_arches}
|
||||||
@ -30,7 +30,7 @@
|
|||||||
%bcond_with llvm_static
|
%bcond_with llvm_static
|
||||||
|
|
||||||
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
||||||
# is insufficient. Rust currently requires LLVM 9.0+.
|
# is insufficient. Rust currently requires LLVM 10.0+.
|
||||||
%bcond_with bundled_llvm
|
%bcond_with bundled_llvm
|
||||||
|
|
||||||
# Requires stable libgit2 1.1
|
# Requires stable libgit2 1.1
|
||||||
@ -61,8 +61,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: rust
|
Name: rust
|
||||||
Version: 1.52.1
|
Version: 1.53.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Rust Programming Language
|
Summary: The Rust Programming Language
|
||||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||||
# ^ written as: (rust itself) and (bundled libraries)
|
# ^ written as: (rust itself) and (bundled libraries)
|
||||||
@ -90,7 +90,7 @@ Patch100: rustc-1.48.0-disable-libssh2.patch
|
|||||||
|
|
||||||
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
||||||
# will try to build it statically -- instead we turn off the feature.
|
# will try to build it statically -- instead we turn off the feature.
|
||||||
Patch101: rustc-1.51.0-disable-http2.patch
|
Patch101: rustc-1.53.0-disable-http2.patch
|
||||||
|
|
||||||
# kernel rh1410097 causes too-small stacks for PIE.
|
# kernel rh1410097 causes too-small stacks for PIE.
|
||||||
# (affects RHEL6 kernels when building for RHEL7)
|
# (affects RHEL6 kernels when building for RHEL7)
|
||||||
@ -181,7 +181,7 @@ Provides: bundled(llvm) = 12.0.0
|
|||||||
%else
|
%else
|
||||||
BuildRequires: cmake >= 2.8.11
|
BuildRequires: cmake >= 2.8.11
|
||||||
%if 0%{?epel} == 7
|
%if 0%{?epel} == 7
|
||||||
%global llvm llvm9.0
|
%global llvm llvm11.0
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?fedora} == 34
|
%if 0%{?fedora} == 34
|
||||||
# aarch64 is hanging with LLVM 12-rc1, but it's fine with 12-final on rawhide.
|
# aarch64 is hanging with LLVM 12-rc1, but it's fine with 12-final on rawhide.
|
||||||
@ -194,7 +194,7 @@ BuildRequires: cmake >= 2.8.11
|
|||||||
%global llvm llvm
|
%global llvm llvm
|
||||||
%global llvm_root %{_prefix}
|
%global llvm_root %{_prefix}
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: %{llvm}-devel >= 9.0
|
BuildRequires: %{llvm}-devel >= 10.0
|
||||||
%if %with llvm_static
|
%if %with llvm_static
|
||||||
BuildRequires: %{llvm}-static
|
BuildRequires: %{llvm}-static
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
@ -809,6 +809,9 @@ end}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 17 2021 Josh Stone <jistone@redhat.com> - 1.53.0-1
|
||||||
|
- Update to 1.53.0.
|
||||||
|
|
||||||
* Wed Jun 02 2021 Josh Stone <jistone@redhat.com> - 1.52.1-2
|
* Wed Jun 02 2021 Josh Stone <jistone@redhat.com> - 1.52.1-2
|
||||||
- Set rust.codegen-units-std=1 for all targets again.
|
- Set rust.codegen-units-std=1 for all targets again.
|
||||||
- Add rust-std-static-wasm32-unknown-unknown.
|
- Add rust-std-static-wasm32-unknown-unknown.
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- rustc-beta-src/Cargo.lock.orig 2021-03-09 10:30:08.626424998 -0800
|
--- rustc-beta-src/Cargo.lock.orig 2021-06-04 15:56:04.141227630 -0700
|
||||||
+++ rustc-beta-src/Cargo.lock 2021-03-09 10:32:38.096207704 -0800
|
+++ rustc-beta-src/Cargo.lock 2021-06-04 16:03:04.461396826 -0700
|
||||||
@@ -899,7 +899,6 @@
|
@@ -885,7 +885,6 @@
|
||||||
dependencies = [
|
dependencies = [
|
||||||
"cc",
|
"cc",
|
||||||
"libc",
|
"libc",
|
||||||
@ -8,8 +8,8 @@
|
|||||||
"libz-sys",
|
"libz-sys",
|
||||||
"openssl-sys",
|
"openssl-sys",
|
||||||
"pkg-config",
|
"pkg-config",
|
||||||
@@ -1860,16 +1859,6 @@
|
@@ -1904,16 +1903,6 @@
|
||||||
]
|
checksum = "7fc7aa29613bd6a620df431842069224d8bc9011086b1db4c0e0cd47fa03ec9a"
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
-name = "libnghttp2-sys"
|
-name = "libnghttp2-sys"
|
||||||
@ -25,20 +25,20 @@
|
|||||||
name = "libz-sys"
|
name = "libz-sys"
|
||||||
version = "1.1.2"
|
version = "1.1.2"
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||||
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2021-03-05 08:34:15.000000000 -0800
|
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2021-06-04 15:56:04.143227587 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2021-03-09 10:32:38.096207704 -0800
|
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2021-06-04 15:57:56.931857927 -0700
|
||||||
@@ -25,7 +25,7 @@
|
@@ -25,7 +25,7 @@
|
||||||
|
cargo-util = { path = "crates/cargo-util", version = "0.1.0" }
|
||||||
crates-io = { path = "crates/crates-io", version = "0.33.0" }
|
crates-io = { path = "crates/crates-io", version = "0.33.0" }
|
||||||
crossbeam-utils = "0.8"
|
crossbeam-utils = "0.8"
|
||||||
crypto-hash = "0.3.1"
|
|
||||||
-curl = { version = "0.4.23", features = ["http2"] }
|
-curl = { version = "0.4.23", features = ["http2"] }
|
||||||
+curl = { version = "0.4.23", features = [] }
|
+curl = { version = "0.4.23", features = [] }
|
||||||
curl-sys = "0.4.22"
|
curl-sys = "0.4.22"
|
||||||
env_logger = "0.8.1"
|
env_logger = "0.8.1"
|
||||||
pretty_env_logger = { version = "0.4", optional = true }
|
pretty_env_logger = { version = "0.4", optional = true }
|
||||||
--- rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs.orig 2021-03-05 08:34:15.000000000 -0800
|
--- rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs.orig 2021-05-22 15:22:31.000000000 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs 2021-03-09 10:32:38.096207704 -0800
|
+++ rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs 2021-06-04 16:00:03.903190293 -0700
|
||||||
@@ -412,14 +412,8 @@
|
@@ -416,14 +416,8 @@
|
||||||
// Also note that pipelining is disabled as curl authors have indicated
|
// Also note that pipelining is disabled as curl authors have indicated
|
||||||
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
||||||
// proxies.
|
// proxies.
|
||||||
@ -46,7 +46,7 @@
|
|||||||
- let multiplexing = config.http_config()?.multiplexing.unwrap_or(true);
|
- let multiplexing = config.http_config()?.multiplexing.unwrap_or(true);
|
||||||
- multi
|
- multi
|
||||||
- .pipelining(false, multiplexing)
|
- .pipelining(false, multiplexing)
|
||||||
- .chain_err(|| "failed to enable multiplexing/pipelining in curl")?;
|
- .with_context(|| "failed to enable multiplexing/pipelining in curl")?;
|
||||||
-
|
-
|
||||||
- // let's not flood crates.io with connections
|
- // let's not flood crates.io with connections
|
||||||
- multi.set_max_host_connections(2)?;
|
- multi.set_max_host_connections(2)?;
|
||||||
@ -55,7 +55,7 @@
|
|||||||
|
|
||||||
Ok(PackageSet {
|
Ok(PackageSet {
|
||||||
packages: package_ids
|
packages: package_ids
|
||||||
@@ -592,7 +586,7 @@
|
@@ -596,7 +590,7 @@
|
||||||
macro_rules! try_old_curl {
|
macro_rules! try_old_curl {
|
||||||
($e:expr, $msg:expr) => {
|
($e:expr, $msg:expr) => {
|
||||||
let result = $e;
|
let result = $e;
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (rustc-1.52.1-src.tar.xz) = 55f5053ce40d4eba4663052817aef6a6275139ca229c89cd1ec44711458b412720203301d8c7975aac5720a91fcaf21847f8184f641cbb0004f722520283c73c
|
SHA512 (rustc-1.53.0-src.tar.xz) = 70485cf7a0f7fc36ee31644e546374079dc387a85b44e5e793707fd0a4d7ca05d311291e78b86db955485d8f21c47ff9e1908acc4da68ba04929287213a40c24
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
SHA512 (rustc-1.52.1-src.tar.xz) = 55f5053ce40d4eba4663052817aef6a6275139ca229c89cd1ec44711458b412720203301d8c7975aac5720a91fcaf21847f8184f641cbb0004f722520283c73c
|
SHA512 (rustc-1.53.0-src.tar.xz) = 70485cf7a0f7fc36ee31644e546374079dc387a85b44e5e793707fd0a4d7ca05d311291e78b86db955485d8f21c47ff9e1908acc4da68ba04929287213a40c24
|
||||||
SHA512 (rust-1.51.0-aarch64-unknown-linux-gnu.tar.xz) = 2af31290e1065a4611f34e6cc8c62ee494c222becfb21ec6707059c119069b0adf0eec23e56bad4a3cc8690b2556309ec58cbd9003a959983689cc46c7c63361
|
SHA512 (rust-1.52.0-aarch64-unknown-linux-gnu.tar.xz) = 7a26e14be6b27c7084c7c85b312341ab991c2df91ea53128f14707a4c725dd03ba7df30b9e9fcef39a509ab4f5d5feb028b99d6d9ffcc059996ed29b83eb90b9
|
||||||
SHA512 (rust-1.51.0-armv7-unknown-linux-gnueabihf.tar.xz) = c602dcc7fd1343b310f5e3074bf63f2428ca7c15cdce8999fa4655de5a4bda5a13255fc12bee3d0632f6cb93220a883fb36d24061dca6795d23afa9f8fdae57f
|
SHA512 (rust-1.52.0-armv7-unknown-linux-gnueabihf.tar.xz) = 100b9abdc3dc7852f880eea205056a7a6b78af39fc3b7019ebcac712d5eee3c053f0508a6dc1f9da13074ca476e9fb33514bb83098d3b41964e878c0fc6498d4
|
||||||
SHA512 (rust-1.51.0-i686-unknown-linux-gnu.tar.xz) = 05d08e44827dcba8197667deb9a7f3584465085ce1b79a38deb138849a07c716646a70f1cc2cee02b41c45ec7c3a3b7800a3fae62ebe04d6f72f017a5d722bab
|
SHA512 (rust-1.52.0-i686-unknown-linux-gnu.tar.xz) = 10fcf9e891ae8bc6e83b5e71c83b34773c18b024c9e9b580cfae714b4e135d313ba5434fc28c2dffa3db2e50669b3acd07e6874de0cfab89b343db92bfbdff80
|
||||||
SHA512 (rust-1.51.0-powerpc64le-unknown-linux-gnu.tar.xz) = b53a741d1d75637fb31ddb0364e1f91427c3818ca145f819b906d13c32c638ae77fbaa567a6220b6bf69f38cc00d2b95615778a86f4acadd63efe2e62b1b01ef
|
SHA512 (rust-1.52.0-powerpc64le-unknown-linux-gnu.tar.xz) = 916a3338c850cf804535e25aebc0fdcf6cea8fe9e5df9fed11fbf03ae81fb8220321dc41edd7133f287dfee0dbf19730ff8b020f32322850329865db76bab95e
|
||||||
SHA512 (rust-1.51.0-s390x-unknown-linux-gnu.tar.xz) = a72ad31c6306f939c4f963133ddc0b3fabc9e506bdff5e318f5275658b7271a675a51d208d306d94fb01739cbcf0f62f018fc7490ca6db54b301852202749d16
|
SHA512 (rust-1.52.0-s390x-unknown-linux-gnu.tar.xz) = 6a91adf7c1947b63db0bf02b4aa4a36fbbfcc5b40d9c18175e4c5efe785b8a17ff21a887476cf76f7e3d3854f2cc362b5d2dc8243493291a4d19a705276e6355
|
||||||
SHA512 (rust-1.51.0-x86_64-unknown-linux-gnu.tar.xz) = 9f95045119bcd5ef7be54f5b5bdc9ebc6bd6c48437d90762a1cfbc03281882f81087e1877eecae9573ba5e7cd7c11ef5fed979034c57f45b6547cbfeb11eef6d
|
SHA512 (rust-1.52.0-x86_64-unknown-linux-gnu.tar.xz) = 27a8db421ae62af92e2c34dcc1fdd617bf7e8de2c68205773a3037be496ccbf21f5549dd18377a9730102e7915519824231218fef9a09abe9d116441d6ce28d2
|
||||||
|
Loading…
Reference in New Issue
Block a user