Update to 1.41.0.
This commit is contained in:
parent
d39c26097c
commit
b2dedbd4bd
8
.gitignore
vendored
8
.gitignore
vendored
@ -244,3 +244,11 @@
|
||||
/rust-1.39.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.39.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.39.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rustc-1.41.0-src.tar.xz
|
||||
/rust-1.40.0-aarch64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.40.0-armv7-unknown-linux-gnueabihf.tar.xz
|
||||
/rust-1.40.0-i686-unknown-linux-gnu.tar.xz
|
||||
/rust-1.40.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.40.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.40.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.40.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
|
@ -1,32 +0,0 @@
|
||||
From f6832adadb84364ce0c81fa02910b3706f441abc Mon Sep 17 00:00:00 2001
|
||||
From: Mark Rousskov <mark.simulacrum@gmail.com>
|
||||
Date: Wed, 6 Nov 2019 15:17:02 -0500
|
||||
Subject: [PATCH] Compiletest bump to stage0 bootstrap libtest
|
||||
|
||||
---
|
||||
src/tools/compiletest/src/main.rs | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/tools/compiletest/src/main.rs b/src/tools/compiletest/src/main.rs
|
||||
index 34435819a2c4..b115539b4af3 100644
|
||||
--- a/src/tools/compiletest/src/main.rs
|
||||
+++ b/src/tools/compiletest/src/main.rs
|
||||
@@ -568,6 +568,7 @@ pub fn test_opts(config: &Config) -> test::TestOpts {
|
||||
skip: vec![],
|
||||
list: false,
|
||||
options: test::Options::new(),
|
||||
+ time_options: None,
|
||||
}
|
||||
}
|
||||
|
||||
@@ -703,6 +704,7 @@ pub fn make_test(config: &Config, testpaths: &TestPaths) -> Vec<test::TestDescAn
|
||||
ignore,
|
||||
should_panic,
|
||||
allow_fail: false,
|
||||
+ test_type: test::TestType::Unknown,
|
||||
},
|
||||
testfn: make_test_closure(config, early_props.ignore, testpaths, revision),
|
||||
}
|
||||
--
|
||||
2.24.1
|
||||
|
24
0001-Fix-compiletest-fallout-from-stage0-bump.patch
Normal file
24
0001-Fix-compiletest-fallout-from-stage0-bump.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From 241d2e765dc7401e642812e43b75dbc3950f2c98 Mon Sep 17 00:00:00 2001
|
||||
From: Mark Rousskov <mark.simulacrum@gmail.com>
|
||||
Date: Wed, 18 Dec 2019 13:28:14 -0500
|
||||
Subject: [PATCH] Fix compiletest fallout from stage0 bump
|
||||
|
||||
---
|
||||
src/tools/compiletest/src/main.rs | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/tools/compiletest/src/main.rs b/src/tools/compiletest/src/main.rs
|
||||
index 15f8abd75d59..32965bbb292d 100644
|
||||
--- a/src/tools/compiletest/src/main.rs
|
||||
+++ b/src/tools/compiletest/src/main.rs
|
||||
@@ -569,6 +569,7 @@ pub fn test_opts(config: &Config) -> test::TestOpts {
|
||||
list: false,
|
||||
options: test::Options::new(),
|
||||
time_options: None,
|
||||
+ force_run_in_process: false,
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.24.1
|
||||
|
@ -29,4 +29,4 @@ index 6deedd0b5ea3..9f63038c3623 100644
|
||||
+ || llvm_util::get_major_version() < 8;
|
||||
}
|
||||
|
||||
// Describes the members of an enum value: An enum is described as a union of
|
||||
// FIXME(eddyb) maybe precompute this? Right now it's computed once
|
||||
|
@ -1,39 +0,0 @@
|
||||
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
|
||||
index 2748903f2d47..10d02d6db829 100644
|
||||
--- a/src/bootstrap/builder.rs
|
||||
+++ b/src/bootstrap/builder.rs
|
||||
@@ -1231,7 +1231,8 @@ impl<'a> Builder<'a> {
|
||||
cargo.arg("--frozen");
|
||||
}
|
||||
|
||||
- cargo.env("RUSTC_INSTALL_BINDIR", &self.config.bindir);
|
||||
+ // Try to use a sysroot-relative bindir, in case it was configured absolutely.
|
||||
+ cargo.env("RUSTC_INSTALL_BINDIR", self.config.bindir_relative());
|
||||
|
||||
self.ci_env.force_coloring_in_ci(&mut cargo);
|
||||
|
||||
diff --git a/src/bootstrap/config.rs b/src/bootstrap/config.rs
|
||||
index d1bdfa0a7676..0c03b95c7b25 100644
|
||||
--- a/src/bootstrap/config.rs
|
||||
+++ b/src/bootstrap/config.rs
|
||||
@@ -647,6 +647,20 @@ impl Config {
|
||||
config
|
||||
}
|
||||
|
||||
+ /// Try to find the relative path of `bindir`, otherwise return it in full.
|
||||
+ pub fn bindir_relative(&self) -> &Path {
|
||||
+ let bindir = &self.bindir;
|
||||
+ if bindir.is_absolute() {
|
||||
+ // Try to make it relative to the prefix.
|
||||
+ if let Some(prefix) = &self.prefix {
|
||||
+ if let Ok(stripped) = bindir.strip_prefix(prefix) {
|
||||
+ return stripped;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+ bindir
|
||||
+ }
|
||||
+
|
||||
/// Try to find the relative path of `libdir`.
|
||||
pub fn libdir_relative(&self) -> Option<&Path> {
|
||||
let libdir = self.libdir.as_ref()?;
|
35
rust.spec
35
rust.spec
@ -9,10 +9,10 @@
|
||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||
# or nightly wants some beta-YYYY-MM-DD
|
||||
# Note that cargo matches the program version here, not its crate version.
|
||||
%global bootstrap_rust 1.39.0
|
||||
%global bootstrap_cargo 1.39.0
|
||||
%global bootstrap_channel 1.39.0
|
||||
%global bootstrap_date 2019-11-07
|
||||
%global bootstrap_rust 1.40.0
|
||||
%global bootstrap_cargo 1.40.0
|
||||
%global bootstrap_channel 1.40.0
|
||||
%global bootstrap_date 2019-12-19
|
||||
|
||||
# Only the specified arches will use bootstrap binaries.
|
||||
#global bootstrap_arches %%{rust_arches}
|
||||
@ -21,7 +21,7 @@
|
||||
%bcond_with llvm_static
|
||||
|
||||
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
||||
# is insufficient. Rust currently requires LLVM 6.0+.
|
||||
# is insufficient. Rust currently requires LLVM 7.0+.
|
||||
%if 0%{?rhel} && !0%{?epel}
|
||||
%bcond_without bundled_llvm
|
||||
%else
|
||||
@ -48,8 +48,8 @@
|
||||
%endif
|
||||
|
||||
Name: rust
|
||||
Version: 1.40.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.41.0
|
||||
Release: 1%{?dist}
|
||||
Summary: The Rust Programming Language
|
||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||
# ^ written as: (rust itself) and (bundled libraries)
|
||||
@ -67,19 +67,15 @@ Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||
# We do have the necessary fix in our LLVM 7.
|
||||
Patch1: rust-pr57840-llvm7-debuginfo-variants.patch
|
||||
|
||||
# Fix the bindir used by rustdoc to find rustc
|
||||
# https://github.com/rust-lang/rust/pull/66317
|
||||
Patch2: rust-pr66317-bindir-relative.patch
|
||||
|
||||
# Fix compiletest with newer (local-rebuild) libtest
|
||||
# https://github.com/rust-lang/rust/pull/66156/commits/f6832adadb84364ce0c81fa02910b3706f441abc
|
||||
Patch3: 0001-Compiletest-bump-to-stage0-bootstrap-libtest.patch
|
||||
# https://github.com/rust-lang/rust/commit/241d2e765dc7401e642812e43b75dbc3950f2c98
|
||||
Patch2: 0001-Fix-compiletest-fallout-from-stage0-bump.patch
|
||||
# https://github.com/rust-lang/rust/pull/68019
|
||||
Patch4: rust-pr68019-in-tree-compiletest.patch
|
||||
Patch3: rust-pr68019-in-tree-compiletest.patch
|
||||
|
||||
# Fix ARM unwinding for foreign-exceptions
|
||||
# https://github.com/rust-lang/rust/pull/67779
|
||||
Patch5: 0001-Update-the-barrier-cache-during-ARM-EHABI-unwinding.patch
|
||||
Patch4: 0001-Update-the-barrier-cache-during-ARM-EHABI-unwinding.patch
|
||||
|
||||
# Get the Rust triple for any arch.
|
||||
%{lua: function rust_triple(arch)
|
||||
@ -161,7 +157,7 @@ BuildRequires: %{python}
|
||||
|
||||
%if %with bundled_llvm
|
||||
BuildRequires: cmake3 >= 3.4.3
|
||||
Provides: bundled(llvm) = 8.0.0
|
||||
Provides: bundled(llvm) = 9.0.0
|
||||
%else
|
||||
BuildRequires: cmake >= 2.8.11
|
||||
%if 0%{?epel}
|
||||
@ -173,7 +169,7 @@ BuildRequires: cmake >= 2.8.11
|
||||
%global llvm llvm
|
||||
%global llvm_root %{_prefix}
|
||||
%endif
|
||||
BuildRequires: %{llvm}-devel >= 6.0
|
||||
BuildRequires: %{llvm}-devel >= 7.0
|
||||
%if %with llvm_static
|
||||
BuildRequires: %{llvm}-static
|
||||
BuildRequires: libffi-devel
|
||||
@ -414,7 +410,6 @@ test -f '%{local_rust_root}/bin/rustc'
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%if "%{python}" == "python3"
|
||||
sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
|
||||
@ -628,7 +623,6 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
%dir %{rustlibdir}/%{rust_triple}
|
||||
%dir %{rustlibdir}/%{rust_triple}/lib
|
||||
%{rustlibdir}/%{rust_triple}/lib/*.so
|
||||
%{rustlibdir}/%{rust_triple}/codegen-backends/
|
||||
%exclude %{_bindir}/*miri
|
||||
|
||||
|
||||
@ -721,6 +715,9 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 30 2020 Josh Stone <jistone@redhat.com> - 1.41.0-1
|
||||
- Update to 1.41.0.
|
||||
|
||||
* Thu Jan 16 2020 Josh Stone <jistone@redhat.com> - 1.40.0-3
|
||||
- Build compiletest with in-tree libtest
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rustc-1.40.0-src.tar.xz) = b5ac3079acefb62d3c985b77f624d7fb68de23a59396fed9ccb292db61641c064f3146ee54d3cf59067b17ebfaadd14a6b2b466def60316bb5b13ba3aef01e1f
|
||||
SHA512 (rustc-1.41.0-src.tar.xz) = 0e30fe53b77860085bea0f1f60315eb835b00dd796c5d1b98ed44fe6fc27336dfb064908c86e1669a9cbe81c9ca1495e1c259a8a268bef23b23805a719cef0dd
|
||||
|
@ -1,8 +1,8 @@
|
||||
SHA512 (rustc-1.40.0-src.tar.xz) = b5ac3079acefb62d3c985b77f624d7fb68de23a59396fed9ccb292db61641c064f3146ee54d3cf59067b17ebfaadd14a6b2b466def60316bb5b13ba3aef01e1f
|
||||
SHA512 (rust-1.39.0-aarch64-unknown-linux-gnu.tar.xz) = ad37a8454acb8985a5c2b42d7f8bc4212651a16fb5af6b4314dd97faa47de79893f2f74b516af89cd7e77ef3db64247c4764585eb0a17ac328c9cba5e5b9c407
|
||||
SHA512 (rust-1.39.0-armv7-unknown-linux-gnueabihf.tar.xz) = db2b001a5587e2d5c8cdcb53c974f2332e76f58e362cba55fc971d7244754f1fa0b7e708ad7e73e7250652b442f06929dc1e8981536d7d76850b45ade275d406
|
||||
SHA512 (rust-1.39.0-i686-unknown-linux-gnu.tar.xz) = 930546e79c0b1105eb0604ae33ccdbd8b00b56e56d069f19f0d802093a052fd3f940eaf1390cdecd79833b0c70457ebfee2ce3b9674fff72df1367076584394a
|
||||
SHA512 (rust-1.39.0-powerpc64le-unknown-linux-gnu.tar.xz) = e15585150370514e580e171faa749218aeef04ce0493f5ad3928a0cb6cd0bddbf7c75ba8ed0783a2c954bbd7166e0445b4c33be4ab48479b0104f032b3d4b0af
|
||||
SHA512 (rust-1.39.0-powerpc64-unknown-linux-gnu.tar.xz) = ff99ad6b120631346af8afac092f8b620e50fb8e118ef1e0ff5668103c01f4b9f082fae72e31a767be35d0647fd9fecc7e6b7b215bb1906e06b20bf3e2685619
|
||||
SHA512 (rust-1.39.0-s390x-unknown-linux-gnu.tar.xz) = d2b588f802d4fbe153dbd88cb745d34d1f5434cb3134cc9e091ebfb336a48b4c886cd80311cf92b5e1c6a16374302853a67e8a0576b02a89dbcf61d27919a045
|
||||
SHA512 (rust-1.39.0-x86_64-unknown-linux-gnu.tar.xz) = 02ca6c821877379d8bd0bcc38281a87e6f86bdbae1270da19e41336cc3a812d9c11c1e976655c192c39153f92cda90ddbd7b4b0bcb4f6787d6d354d2be827a8a
|
||||
SHA512 (rustc-1.41.0-src.tar.xz) = 0e30fe53b77860085bea0f1f60315eb835b00dd796c5d1b98ed44fe6fc27336dfb064908c86e1669a9cbe81c9ca1495e1c259a8a268bef23b23805a719cef0dd
|
||||
SHA512 (rust-1.40.0-aarch64-unknown-linux-gnu.tar.xz) = f601e4251e08a6d66edb0489b6ab840b57622b506547e81036e6dfe08eb71005a22a2777a0b8b2d07a6f88286d58f513482b863116311a6f43c7284769af6e7f
|
||||
SHA512 (rust-1.40.0-armv7-unknown-linux-gnueabihf.tar.xz) = d3345946c5a3d5cb3d7fca4d3200710704d64547ebfa4ab11c45ea1a18ca3c49b429783d499845f31dcb150abe2f6836fe203fd9d7aa53e0475b940da5549492
|
||||
SHA512 (rust-1.40.0-i686-unknown-linux-gnu.tar.xz) = d727149afbbc3b2709360dd6080ff301e781aaa94459c1348d3e35382bc9c7ad65c4d70f9bfc7b44ac92ddaf89e3aab92b75b9d184eba86916da25bd629592b6
|
||||
SHA512 (rust-1.40.0-powerpc64le-unknown-linux-gnu.tar.xz) = 8b82f3bacc503aa23cfa7a6cd6232e34b734becffbbe02df9f766878d526d24d7409d8c104f39fa791c0f7a8b3fa61f6b8a528e89e8ab94d6a131b2d0ac11f0f
|
||||
SHA512 (rust-1.40.0-powerpc64-unknown-linux-gnu.tar.xz) = eae2e0ba3a6a9ba07945112c17962ca3c77737fa187759e674e78f626777da85a5ee6107168fe2866b5beb1ecf2e655652cb7d9b51867b247d76e174dfb103ce
|
||||
SHA512 (rust-1.40.0-s390x-unknown-linux-gnu.tar.xz) = e71d3a1d85975653b6d972a4854c9e53be7f2d093a601145261c97f7917f869399fbc6322a04f63b782a5a28b91c3be40041a8c77367d19dec8d0e857cbbef14
|
||||
SHA512 (rust-1.40.0-x86_64-unknown-linux-gnu.tar.xz) = 11a2ad1d8b9e91cbe9ee6a1954d46ac75eeaa83f0c2425a8ad70d191727b02e86ead33d6464222effca6f5134c31a165801a854aa57bdb5f12944d605de3c1d1
|
||||
|
Loading…
Reference in New Issue
Block a user