Update to 1.47.0.
This commit is contained in:
parent
aacb4980d2
commit
aac4471f40
8
.gitignore
vendored
8
.gitignore
vendored
@ -297,3 +297,11 @@
|
||||
/rust-1.45.2-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.45.2-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.45.2-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rustc-1.47.0-src.tar.xz
|
||||
/rust-1.46.0-aarch64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.46.0-armv7-unknown-linux-gnueabihf.tar.xz
|
||||
/rust-1.46.0-i686-unknown-linux-gnu.tar.xz
|
||||
/rust-1.46.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.46.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.46.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.46.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
|
@ -1,29 +0,0 @@
|
||||
From 02fc16aece46abcd23d2ade2d969497f07fe26ab Mon Sep 17 00:00:00 2001
|
||||
From: Alex Crichton <alex@alexcrichton.com>
|
||||
Date: Fri, 7 Aug 2020 12:50:25 -0700
|
||||
Subject: [PATCH] Fix jobserver_exists test on single-cpu systems
|
||||
|
||||
Closes #8595
|
||||
---
|
||||
tests/testsuite/jobserver.rs | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/testsuite/jobserver.rs b/tests/testsuite/jobserver.rs
|
||||
index 9e91c956cd75..16518ee2c614 100644
|
||||
--- a/tests/testsuite/jobserver.rs
|
||||
+++ b/tests/testsuite/jobserver.rs
|
||||
@@ -51,7 +51,10 @@ fn jobserver_exists() {
|
||||
.file("src/lib.rs", "")
|
||||
.build();
|
||||
|
||||
- p.cargo("build").run();
|
||||
+ // Explicitly use `-j2` to ensure that there's eventually going to be a
|
||||
+ // token to read from `valdiate` above, since running the build script
|
||||
+ // itself consumes a token.
|
||||
+ p.cargo("build -j2").run();
|
||||
}
|
||||
|
||||
#[cargo_test]
|
||||
--
|
||||
2.26.2
|
||||
|
28
0001-use-NativeEndian-in-symbolize-gimli-Context.patch
Normal file
28
0001-use-NativeEndian-in-symbolize-gimli-Context.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 6f8efee8c936de65bc31610eea30abd5461a5dd1 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Thu, 8 Oct 2020 15:53:49 -0700
|
||||
Subject: [PATCH] use NativeEndian in symbolize::gimli::Context
|
||||
|
||||
`Object` uses `NativeEndian`, so the `Context` should too.
|
||||
|
||||
Cc: https://github.com/rust-lang/rust/issues/77410
|
||||
---
|
||||
src/symbolize/gimli.rs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/symbolize/gimli.rs b/src/symbolize/gimli.rs
|
||||
index 58ed8bafca3d..273ff43f1c8c 100644
|
||||
--- a/src/symbolize/gimli.rs
|
||||
+++ b/src/symbolize/gimli.rs
|
||||
@@ -5,7 +5,7 @@
|
||||
//! intended to wholesale replace the `libbacktrace.rs` implementation.
|
||||
|
||||
use self::gimli::read::EndianSlice;
|
||||
-use self::gimli::LittleEndian as Endian;
|
||||
+use self::gimli::NativeEndian as Endian;
|
||||
use self::mmap::Mmap;
|
||||
use self::stash::Stash;
|
||||
use super::BytesOrWideString;
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,133 +0,0 @@
|
||||
From 2c9deaabf99dab9998f6ddbbe496d19ff7ce31f0 Mon Sep 17 00:00:00 2001
|
||||
From: Fabio Valentini <decathorpe@gmail.com>
|
||||
Date: Fri, 28 Aug 2020 21:56:45 +0200
|
||||
Subject: [PATCH 2/2] Fix LTO with doctests
|
||||
|
||||
---
|
||||
.../src/cargo/core/compiler/context/mod.rs | 3 +-
|
||||
.../cargo/src/cargo/core/compiler/mod.rs | 59 +++++----------
|
||||
src/tools/cargo/src/cargo/core/profiles.rs | 7 +-
|
||||
src/tools/cargo/tests/testsuite/lto.rs | 71 ++++++++++++++++---
|
||||
4 files changed, 85 insertions(+), 55 deletions(-)
|
||||
|
||||
diff --git a/src/tools/cargo/src/cargo/core/compiler/context/mod.rs b/src/tools/cargo/src/cargo/core/compiler/context/mod.rs
|
||||
index 52b954dd1..82831f423 100644
|
||||
--- a/src/tools/cargo/src/cargo/core/compiler/context/mod.rs
|
||||
+++ b/src/tools/cargo/src/cargo/core/compiler/context/mod.rs
|
||||
@@ -210,7 +210,8 @@ impl<'a, 'cfg> Context<'a, 'cfg> {
|
||||
// Collect information for `rustdoc --test`.
|
||||
if unit.mode.is_doc_test() {
|
||||
let mut unstable_opts = false;
|
||||
- let args = compiler::extern_args(&self, unit, &mut unstable_opts)?;
|
||||
+ let mut args = compiler::extern_args(&self, unit, &mut unstable_opts)?;
|
||||
+ args.extend(compiler::lto_args(&self, unit));
|
||||
self.compilation.to_doc_test.push(compilation::Doctest {
|
||||
unit: unit.clone(),
|
||||
args,
|
||||
diff --git a/src/tools/cargo/src/cargo/core/compiler/mod.rs b/src/tools/cargo/src/cargo/core/compiler/mod.rs
|
||||
index 9399c5042..47d2b9bb4 100644
|
||||
--- a/src/tools/cargo/src/cargo/core/compiler/mod.rs
|
||||
+++ b/src/tools/cargo/src/cargo/core/compiler/mod.rs
|
||||
@@ -783,49 +783,9 @@ fn build_base_args(
|
||||
cmd.arg("-C").arg(format!("panic={}", panic));
|
||||
}
|
||||
|
||||
- match cx.lto[unit] {
|
||||
- lto::Lto::Run(None) => {
|
||||
- cmd.arg("-C").arg("lto");
|
||||
- }
|
||||
- lto::Lto::Run(Some(s)) => {
|
||||
- cmd.arg("-C").arg(format!("lto={}", s));
|
||||
- }
|
||||
- lto::Lto::Off => {
|
||||
- cmd.arg("-C").arg("lto=off");
|
||||
- }
|
||||
- lto::Lto::ObjectAndBitcode => {} // this is rustc's default
|
||||
- lto::Lto::OnlyBitcode => {
|
||||
- // Note that this compiler flag, like the one below, is just an
|
||||
- // optimization in terms of build time. If we don't pass it then
|
||||
- // both object code and bitcode will show up. This is lagely just
|
||||
- // compat until the feature lands on stable and we can remove the
|
||||
- // conditional branch.
|
||||
- if cx
|
||||
- .bcx
|
||||
- .target_data
|
||||
- .info(CompileKind::Host)
|
||||
- .supports_embed_bitcode
|
||||
- .unwrap()
|
||||
- {
|
||||
- cmd.arg("-Clinker-plugin-lto");
|
||||
- }
|
||||
- }
|
||||
- lto::Lto::OnlyObject => {
|
||||
- if cx
|
||||
- .bcx
|
||||
- .target_data
|
||||
- .info(CompileKind::Host)
|
||||
- .supports_embed_bitcode
|
||||
- .unwrap()
|
||||
- {
|
||||
- cmd.arg("-Cembed-bitcode=no");
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
+ cmd.args(<o_args(cx, unit));
|
||||
|
||||
if let Some(n) = codegen_units {
|
||||
- // There are some restrictions with LTO and codegen-units, so we
|
||||
- // only add codegen units when LTO is not used.
|
||||
cmd.arg("-C").arg(&format!("codegen-units={}", n));
|
||||
}
|
||||
|
||||
@@ -952,6 +912,23 @@ fn build_base_args(
|
||||
Ok(())
|
||||
}
|
||||
|
||||
+fn lto_args(cx: &Context<'_, '_>, unit: &Unit) -> Vec<OsString> {
|
||||
+ let mut result = Vec::new();
|
||||
+ let mut push = |arg: &str| {
|
||||
+ result.push(OsString::from("-C"));
|
||||
+ result.push(OsString::from(arg));
|
||||
+ };
|
||||
+ match cx.lto[unit] {
|
||||
+ lto::Lto::Run(None) => push("lto"),
|
||||
+ lto::Lto::Run(Some(s)) => push(&format!("lto={}", s)),
|
||||
+ lto::Lto::Off => push("lto=off"),
|
||||
+ lto::Lto::ObjectAndBitcode => {} // this is rustc's default
|
||||
+ lto::Lto::OnlyBitcode => push("linker-plugin-lto"),
|
||||
+ lto::Lto::OnlyObject => push("embed-bitcode=no"),
|
||||
+ }
|
||||
+ result
|
||||
+}
|
||||
+
|
||||
fn build_deps_args(
|
||||
cmd: &mut ProcessBuilder,
|
||||
cx: &mut Context<'_, '_>,
|
||||
diff --git a/src/tools/cargo/src/cargo/core/profiles.rs b/src/tools/cargo/src/cargo/core/profiles.rs
|
||||
index 6a28bd261..ca0c2e417 100644
|
||||
--- a/src/tools/cargo/src/cargo/core/profiles.rs
|
||||
+++ b/src/tools/cargo/src/cargo/core/profiles.rs
|
||||
@@ -302,7 +302,7 @@ impl Profiles {
|
||||
};
|
||||
|
||||
match mode {
|
||||
- CompileMode::Test | CompileMode::Bench => {
|
||||
+ CompileMode::Test | CompileMode::Bench | CompileMode::Doctest => {
|
||||
if release {
|
||||
(
|
||||
InternedString::new("bench"),
|
||||
@@ -315,10 +315,7 @@ impl Profiles {
|
||||
)
|
||||
}
|
||||
}
|
||||
- CompileMode::Build
|
||||
- | CompileMode::Check { .. }
|
||||
- | CompileMode::Doctest
|
||||
- | CompileMode::RunCustomBuild => {
|
||||
+ CompileMode::Build | CompileMode::Check { .. } | CompileMode::RunCustomBuild => {
|
||||
// Note: `RunCustomBuild` doesn't normally use this code path.
|
||||
// `build_unit_profiles` normally ensures that it selects the
|
||||
// ancestor's profile. However, `cargo clean -p` can hit this
|
||||
--
|
||||
2.26.2
|
||||
|
78
rust.spec
78
rust.spec
@ -9,10 +9,10 @@
|
||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||
# or nightly wants some beta-YYYY-MM-DD
|
||||
# Note that cargo matches the program version here, not its crate version.
|
||||
%global bootstrap_rust 1.45.2
|
||||
%global bootstrap_cargo 1.45.2
|
||||
%global bootstrap_channel 1.45.2
|
||||
%global bootstrap_date 2020-08-03
|
||||
%global bootstrap_rust 1.46.0
|
||||
%global bootstrap_cargo 1.46.0
|
||||
%global bootstrap_channel 1.46.0
|
||||
%global bootstrap_date 2020-08-27
|
||||
|
||||
# Only the specified arches will use bootstrap binaries.
|
||||
#global bootstrap_arches %%{rust_arches}
|
||||
@ -52,8 +52,8 @@
|
||||
%endif
|
||||
|
||||
Name: rust
|
||||
Version: 1.46.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.47.0
|
||||
Release: 1%{?dist}
|
||||
Summary: The Rust Programming Language
|
||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||
# ^ written as: (rust itself) and (bundled libraries)
|
||||
@ -67,19 +67,17 @@ ExclusiveArch: %{rust_arches}
|
||||
%endif
|
||||
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||
|
||||
# https://github.com/rust-lang/cargo/pull/8598
|
||||
Patch1: 0001-Fix-jobserver_exists-test-on-single-cpu-systems.patch
|
||||
# https://github.com/rust-lang/cargo/pull/8657 (backported)
|
||||
Patch2: 0002-Fix-LTO-with-doctests.patch
|
||||
# https://github.com/rust-lang/backtrace-rs/pull/373
|
||||
Patch1: 0001-use-NativeEndian-in-symbolize-gimli-Context.patch
|
||||
|
||||
### RHEL-specific patches below ###
|
||||
|
||||
# Disable cargo->libgit2->libssh2 on RHEL, as it's not approved for FIPS (rhbz1732949)
|
||||
Patch100: rustc-1.42.0-disable-libssh2.patch
|
||||
Patch100: rustc-1.47.0-disable-libssh2.patch
|
||||
|
||||
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
||||
# will try to build it statically -- instead we turn off the feature.
|
||||
Patch101: rustc-1.45.0-disable-http2.patch
|
||||
Patch101: rustc-1.47.0-disable-http2.patch
|
||||
|
||||
# kernel rh1410097 causes too-small stacks for PIE.
|
||||
# (affects RHEL6 kernels when building for RHEL7)
|
||||
@ -166,7 +164,7 @@ BuildRequires: %{python}
|
||||
|
||||
%if %with bundled_llvm
|
||||
BuildRequires: cmake3 >= 3.4.3
|
||||
Provides: bundled(llvm) = 10.0.1
|
||||
Provides: bundled(llvm) = 11.0.0
|
||||
%else
|
||||
BuildRequires: cmake >= 2.8.11
|
||||
%if 0%{?epel} == 7
|
||||
@ -191,9 +189,6 @@ BuildRequires: procps-ng
|
||||
# debuginfo-gdb tests need gdb
|
||||
BuildRequires: gdb
|
||||
|
||||
# TODO: work on unbundling these!
|
||||
Provides: bundled(libbacktrace) = 1.0.20200219
|
||||
|
||||
# Virtual provides for folks who attempt "dnf install rustc"
|
||||
Provides: rustc = %{version}-%{release}
|
||||
Provides: rustc%{?_isa} = %{version}-%{release}
|
||||
@ -410,8 +405,7 @@ test -f '%{local_rust_root}/bin/rustc'
|
||||
|
||||
%setup -q -n %{rustc_package}
|
||||
|
||||
%patch1 -p1 -d src/tools/cargo
|
||||
%patch2 -p1
|
||||
%patch1 -p1 -d library/backtrace
|
||||
|
||||
%if %with disabled_libssh2
|
||||
%patch100 -p1
|
||||
@ -456,9 +450,6 @@ rm -rf vendor/libssh2-sys/
|
||||
# This only affects the transient rust-installer, but let it use our dynamic xz-libs
|
||||
sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
|
||||
|
||||
# rename bundled license for packaging
|
||||
cp -a vendor/backtrace-sys/src/libbacktrace/LICENSE{,-libbacktrace}
|
||||
|
||||
%if %{with bundled_llvm} && 0%{?epel} == 7
|
||||
mkdir -p cmake-bin
|
||||
ln -s /usr/bin/cmake3 cmake-bin/cmake
|
||||
@ -482,6 +473,20 @@ find vendor -name .cargo-checksum.json \
|
||||
# it's a shebang and make them executable. Then brp-mangle-shebangs gets upset...
|
||||
find -name '*.rs' -type f -perm /111 -exec chmod -v -x '{}' '+'
|
||||
|
||||
# Set up shared environment variables for build/install/check
|
||||
%global rust_env RUSTFLAGS="%{rustflags}"
|
||||
%if 0%{?cmake_path:1}
|
||||
%global rust_env %{rust_env} PATH="%{cmake_path}:$PATH"
|
||||
%endif
|
||||
%if %without bundled_libgit2
|
||||
# convince libgit2-sys to use the distro libgit2
|
||||
%global rust_env %{rust_env} LIBGIT2_SYS_USE_PKG_CONFIG=1
|
||||
%endif
|
||||
%if %without bundled_libssh2
|
||||
# convince libssh2-sys to use the distro libssh2
|
||||
%global rust_env %{rust_env} LIBSSH2_SYS_USE_PKG_CONFIG=1
|
||||
%endif
|
||||
|
||||
|
||||
%build
|
||||
# This package fails to build with LTO due to undefined symbols. LTO
|
||||
@ -490,18 +495,7 @@ find -name '*.rs' -type f -perm /111 -exec chmod -v -x '{}' '+'
|
||||
# Disable LTO
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
%if %without bundled_libgit2
|
||||
# convince libgit2-sys to use the distro libgit2
|
||||
export LIBGIT2_SYS_USE_PKG_CONFIG=1
|
||||
%endif
|
||||
|
||||
%if %without bundled_libssh2
|
||||
# convince libssh2-sys to use the distro libssh2
|
||||
export LIBSSH2_SYS_USE_PKG_CONFIG=1
|
||||
%endif
|
||||
|
||||
%{?cmake_path:export PATH=%{cmake_path}:$PATH}
|
||||
%{?rustflags:export RUSTFLAGS="%{rustflags}"}
|
||||
export %{rust_env}
|
||||
|
||||
# We're going to override --libdir when configuring to get rustlib into a
|
||||
# common path, but we'll fix the shared libraries during install.
|
||||
@ -555,12 +549,11 @@ fi
|
||||
--release-channel=%{channel}
|
||||
|
||||
%{python} ./x.py build -j "$ncpus" --stage 2
|
||||
%{python} ./x.py doc
|
||||
%{python} ./x.py doc --stage 2
|
||||
|
||||
|
||||
%install
|
||||
%{?cmake_path:export PATH=%{cmake_path}:$PATH}
|
||||
%{?rustflags:export RUSTFLAGS="%{rustflags}"}
|
||||
export %{rust_env}
|
||||
|
||||
DESTDIR=%{buildroot} %{python} ./x.py install
|
||||
|
||||
@ -624,13 +617,12 @@ ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
|
||||
|
||||
%if %without lldb
|
||||
rm -f %{buildroot}%{_bindir}/rust-lldb
|
||||
rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
rm -f %{buildroot}%{rustlibdir}/etc/lldb_*
|
||||
%endif
|
||||
|
||||
|
||||
%check
|
||||
%{?cmake_path:export PATH=%{cmake_path}:$PATH}
|
||||
%{?rustflags:export RUSTFLAGS="%{rustflags}"}
|
||||
export %{rust_env}
|
||||
|
||||
# The results are not stable on koji, so mask errors and just log it.
|
||||
%{python} ./x.py test --no-fail-fast || :
|
||||
@ -645,7 +637,6 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
|
||||
%files
|
||||
%license COPYRIGHT LICENSE-APACHE LICENSE-MIT
|
||||
%license vendor/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
|
||||
%doc README.md
|
||||
%{_bindir}/rustc
|
||||
%{_bindir}/rustdoc
|
||||
@ -673,14 +664,14 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
|
||||
%files gdb
|
||||
%{_bindir}/rust-gdb
|
||||
%{rustlibdir}/etc/gdb_*.py*
|
||||
%{rustlibdir}/etc/gdb_*
|
||||
%exclude %{_bindir}/rust-gdbgui
|
||||
|
||||
|
||||
%if %with lldb
|
||||
%files lldb
|
||||
%{_bindir}/rust-lldb
|
||||
%{rustlibdir}/etc/lldb_*.py*
|
||||
%{rustlibdir}/etc/lldb_*
|
||||
%endif
|
||||
|
||||
|
||||
@ -747,6 +738,9 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 08 2020 Josh Stone <jistone@redhat.com> - 1.47.0-1
|
||||
- Update to 1.47.0.
|
||||
|
||||
* Fri Aug 28 2020 Fabio Valentini <decathorpe@gmail.com> - 1.46.0-2
|
||||
- Fix LTO with doctests (backported cargo PR#8657).
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- rustc-1.45.0-src/Cargo.lock.orig 2020-07-13 09:27:24.000000000 -0700
|
||||
+++ rustc-1.45.0-src/Cargo.lock 2020-07-16 12:12:32.253903599 -0700
|
||||
@@ -896,7 +896,6 @@
|
||||
--- rustc-1.47.0-src/Cargo.lock.orig 2020-10-08 12:21:40.516837553 -0700
|
||||
+++ rustc-1.47.0-src/Cargo.lock 2020-10-08 12:23:25.327581933 -0700
|
||||
@@ -837,7 +837,6 @@
|
||||
dependencies = [
|
||||
"cc",
|
||||
"libc",
|
||||
@ -8,14 +8,14 @@
|
||||
"libz-sys",
|
||||
"openssl-sys",
|
||||
"pkg-config",
|
||||
@@ -1875,16 +1874,6 @@
|
||||
@@ -1642,16 +1641,6 @@
|
||||
]
|
||||
|
||||
[[package]]
|
||||
-name = "libnghttp2-sys"
|
||||
-version = "0.1.2"
|
||||
-version = "0.1.4+1.41.0"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "02254d44f4435dd79e695f2c2b83cd06a47919adea30216ceaf0c57ca0a72463"
|
||||
-checksum = "03624ec6df166e79e139a2310ca213283d6b3c30810c54844f307086d4488df1"
|
||||
-dependencies = [
|
||||
- "cc",
|
||||
- "libc",
|
||||
@ -23,10 +23,10 @@
|
||||
-
|
||||
-[[package]]
|
||||
name = "libz-sys"
|
||||
version = "1.0.25"
|
||||
version = "1.0.27"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
--- rustc-1.45.0-src/src/tools/cargo/Cargo.toml.orig 2020-07-13 09:27:49.000000000 -0700
|
||||
+++ rustc-1.45.0-src/src/tools/cargo/Cargo.toml 2020-07-16 12:12:32.253903599 -0700
|
||||
--- rustc-1.47.0-src/src/tools/cargo/Cargo.toml.orig 2020-10-07 01:04:03.000000000 -0700
|
||||
+++ rustc-1.47.0-src/src/tools/cargo/Cargo.toml 2020-10-08 12:22:17.830034534 -0700
|
||||
@@ -25,7 +25,7 @@
|
||||
crates-io = { path = "crates/crates-io", version = "0.31.1" }
|
||||
crossbeam-utils = "0.7"
|
||||
@ -36,9 +36,9 @@
|
||||
curl-sys = "0.4.22"
|
||||
env_logger = "0.7.0"
|
||||
pretty_env_logger = { version = "0.4", optional = true }
|
||||
--- rustc-1.45.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-07-13 09:27:49.000000000 -0700
|
||||
+++ rustc-1.45.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-07-16 12:12:32.253903599 -0700
|
||||
@@ -393,14 +393,8 @@
|
||||
--- rustc-1.47.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-10-07 01:04:03.000000000 -0700
|
||||
+++ rustc-1.47.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-10-08 12:23:11.246884961 -0700
|
||||
@@ -396,14 +396,8 @@
|
||||
// Also note that pipelining is disabled as curl authors have indicated
|
||||
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
||||
// proxies.
|
||||
@ -55,7 +55,7 @@
|
||||
|
||||
Ok(PackageSet {
|
||||
packages: package_ids
|
||||
@@ -563,7 +557,7 @@
|
||||
@@ -566,7 +560,7 @@
|
||||
macro_rules! try_old_curl {
|
||||
($e:expr, $msg:expr) => {
|
||||
let result = $e;
|
@ -1,6 +1,6 @@
|
||||
--- rustc-1.42.0-src/Cargo.lock.orig 2020-03-09 15:11:17.000000000 -0700
|
||||
+++ rustc-1.42.0-src/Cargo.lock 2020-04-02 16:39:22.268896227 -0700
|
||||
@@ -1796,7 +1796,6 @@
|
||||
--- rustc-1.47.0-src/Cargo.lock.orig 2020-10-07 00:53:22.000000000 -0700
|
||||
+++ rustc-1.47.0-src/Cargo.lock 2020-10-08 12:15:07.361298619 -0700
|
||||
@@ -1636,7 +1636,6 @@
|
||||
dependencies = [
|
||||
"cc",
|
||||
"libc",
|
||||
@ -8,14 +8,14 @@
|
||||
"libz-sys",
|
||||
"openssl-sys",
|
||||
"pkg-config",
|
||||
@@ -1813,20 +1812,6 @@
|
||||
@@ -1653,20 +1652,6 @@
|
||||
]
|
||||
|
||||
[[package]]
|
||||
-name = "libssh2-sys"
|
||||
-version = "0.2.14"
|
||||
-version = "0.2.18"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "36aa6e813339d3a063292b77091dfbbb6152ff9006a459895fa5bebed7d34f10"
|
||||
-checksum = "eafa907407504b0e683786d4aba47acf250f114d37357d56608333fd167dd0fc"
|
||||
-dependencies = [
|
||||
- "cc",
|
||||
- "libc",
|
||||
@ -27,11 +27,11 @@
|
||||
-
|
||||
-[[package]]
|
||||
name = "libz-sys"
|
||||
version = "1.0.25"
|
||||
version = "1.0.27"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
--- rustc-1.42.0-src/vendor/git2/Cargo.toml.orig 2020-03-09 17:00:19.000000000 -0700
|
||||
+++ rustc-1.42.0-src/vendor/git2/Cargo.toml 2020-04-02 16:38:46.163664007 -0700
|
||||
@@ -55,7 +55,7 @@
|
||||
--- rustc-1.47.0-src/vendor/git2/Cargo.toml.orig 2020-10-07 02:33:31.000000000 -0700
|
||||
+++ rustc-1.47.0-src/vendor/git2/Cargo.toml 2020-10-08 12:13:37.697228272 -0700
|
||||
@@ -49,7 +49,7 @@
|
||||
version = "0.1.39"
|
||||
|
||||
[features]
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rustc-1.46.0-src.tar.xz) = 099857f1d295043587a4e2a65ef3e6a90e12c8b6958e98535a1656c113c553f9a9b621aba8a19cf21bd8d2c79d27cbfa4b8e6fabbcb3cbfee23b545be7b450b4
|
||||
SHA512 (rustc-1.47.0-src.tar.xz) = 6ba83c0158f8130ddeae7e070417a2121d8a548c8fe97e28bce116d84048636c75aaee78e0c92cd43a50f5679a1223fc226cc8c5ba9bbd1465e84c5c6034d5c9
|
||||
|
@ -1,8 +1,8 @@
|
||||
SHA512 (rustc-1.46.0-src.tar.xz) = 099857f1d295043587a4e2a65ef3e6a90e12c8b6958e98535a1656c113c553f9a9b621aba8a19cf21bd8d2c79d27cbfa4b8e6fabbcb3cbfee23b545be7b450b4
|
||||
SHA512 (rust-1.45.2-aarch64-unknown-linux-gnu.tar.xz) = b4b3fb198bf85192563fb8b6017cf07f92b9c26d6e590efa9476aa878871839315db935e3353c664e635a229f17b0979bcfd31488e29e02ce0dc266d252b9e41
|
||||
SHA512 (rust-1.45.2-armv7-unknown-linux-gnueabihf.tar.xz) = dbf36643e87fc31cda5c0d5fc8b1589ce80531a94379060106ce81d525cd77c36ac6f89d5ae05d8872020baf31e5391422ed58c01ec6f801428d67e2e10896fb
|
||||
SHA512 (rust-1.45.2-i686-unknown-linux-gnu.tar.xz) = afe81d38d8692e5792e111c3b2c83da4dffa99c9a8a89b5f1e10a6e449e49d4dd19d68c96d7b2f5013054d141bf4b1a08da1c2b877c7bbe87f81c19232020ecb
|
||||
SHA512 (rust-1.45.2-powerpc64le-unknown-linux-gnu.tar.xz) = 6cb169efae4c847ba204fa24c1f40b4320e53928ab8966727971a5bc7a565eaa6142f40904cec93927543b25450db23d816c20653f53d3aa36ac616fe85ee6ba
|
||||
SHA512 (rust-1.45.2-powerpc64-unknown-linux-gnu.tar.xz) = fbf909e5f9135d5216dbbc1be0d1e3159000c58b83bcdeb9839a12f5a9ff56261a61edfab93cd21800a90ff56bb9eff8a1ad83c60fa54bf0cf4b149219dbe914
|
||||
SHA512 (rust-1.45.2-s390x-unknown-linux-gnu.tar.xz) = 7727cfbeed29e8a1e79398392332b25b5498900f593f3d08414c70b44da0cd06dca0791a361956c47c3367e6572d59d885085d3cd99fd4a9c28c431a158ddbfd
|
||||
SHA512 (rust-1.45.2-x86_64-unknown-linux-gnu.tar.xz) = dfd3ce0cc42ae82a2d13866c5c94c304b031e253a1485ccc1d6ecd62cc05018b01ac7b2183297bc45ada286b5e91d1344aa3d8417694ab834f8265c7838b4fd2
|
||||
SHA512 (rustc-1.47.0-src.tar.xz) = 6ba83c0158f8130ddeae7e070417a2121d8a548c8fe97e28bce116d84048636c75aaee78e0c92cd43a50f5679a1223fc226cc8c5ba9bbd1465e84c5c6034d5c9
|
||||
SHA512 (rust-1.46.0-aarch64-unknown-linux-gnu.tar.xz) = 53e5d8afadaa9505286dce4acbb911126d17bc7bf45ea4685070ff07be7f6c7860e543a7686eeac695e7e3e127ca38ba2f09b73467fbf5f92d0b2195467c51f2
|
||||
SHA512 (rust-1.46.0-armv7-unknown-linux-gnueabihf.tar.xz) = c7e320fd5169c99bf8a12fb5bf1c5fb19a05d14f75ce655e4b64cad3456594ef09be1da7ac34a09b5d84da0c857d1a6e5a0695b5ff04cda491ea92fea15d28dc
|
||||
SHA512 (rust-1.46.0-i686-unknown-linux-gnu.tar.xz) = b01e9b06c9de50e43bc6b5e1a5e6cc49dab1cf28b9cf0a8b974d2630c7ed4c6a5df6f321c872e11eb622c42f1d8cfaec77c1b67254a84365464fe3415acfa07f
|
||||
SHA512 (rust-1.46.0-powerpc64le-unknown-linux-gnu.tar.xz) = 986f0bf7995f35836b73fb7045cf43ae5efe0c2543c75c66cdcc0f8c1dd3513def3c291e021241e328142deaca690ce113526ffc870c4412a7841f244258a43e
|
||||
SHA512 (rust-1.46.0-powerpc64-unknown-linux-gnu.tar.xz) = 40f9423d838cab74b9920372e728c4ca7057005d83af587387dd2b164a0bf93de65cebc035320bce25f80914c63ce65b84218b9a776b0b905428e4cba0821b8b
|
||||
SHA512 (rust-1.46.0-s390x-unknown-linux-gnu.tar.xz) = b6146695225ff6d0516e7bb6bc4620599356bb89b14f429a09d9d7f8715a94e8e218402346d5c9a10eeb54c0bdc40fb179289216b0cb4edd5bdf886f6b69aab4
|
||||
SHA512 (rust-1.46.0-x86_64-unknown-linux-gnu.tar.xz) = 95f5adc2d2137010c7e5ac8a0fc70485250b4f9a909cb8b164b35fffff76ab88e9b09d305bfac37324ed080c5fc7643001d2abec5454ca911dc3513f1af52c88
|
||||
|
Loading…
Reference in New Issue
Block a user