Update to 1.58.1.
This commit is contained in:
parent
26168805e8
commit
820e900bd0
1
.gitignore
vendored
1
.gitignore
vendored
@ -390,3 +390,4 @@
|
|||||||
/rust-1.57.0-powerpc64le-unknown-linux-gnu.tar.xz
|
/rust-1.57.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||||
/rust-1.57.0-s390x-unknown-linux-gnu.tar.xz
|
/rust-1.57.0-s390x-unknown-linux-gnu.tar.xz
|
||||||
/rust-1.57.0-x86_64-unknown-linux-gnu.tar.xz
|
/rust-1.57.0-x86_64-unknown-linux-gnu.tar.xz
|
||||||
|
/rustc-1.58.1-src.tar.xz
|
||||||
|
11
rust.spec
11
rust.spec
@ -78,7 +78,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: rust
|
Name: rust
|
||||||
Version: 1.58.0
|
Version: 1.58.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Rust Programming Language
|
Summary: The Rust Programming Language
|
||||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||||
@ -109,7 +109,7 @@ Patch101: rustc-1.58.0-disable-http2.patch
|
|||||||
|
|
||||||
# kernel rh1410097 causes too-small stacks for PIE.
|
# kernel rh1410097 causes too-small stacks for PIE.
|
||||||
# (affects RHEL6 kernels when building for RHEL7)
|
# (affects RHEL6 kernels when building for RHEL7)
|
||||||
Patch102: rustc-1.57.0-no-default-pie.patch
|
Patch102: rustc-1.58.0-no-default-pie.patch
|
||||||
|
|
||||||
|
|
||||||
# Get the Rust triple for any arch.
|
# Get the Rust triple for any arch.
|
||||||
@ -507,7 +507,7 @@ useful as a reference for code completion tools in various editors.
|
|||||||
|
|
||||||
%package analysis
|
%package analysis
|
||||||
Summary: Compiler analysis data for the Rust standard library
|
Summary: Compiler analysis data for the Rust standard library
|
||||||
Requires: rust-std-static%{?_isa} = %{version}-%{release}
|
Requires: %{name}-std-static%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
%description analysis
|
%description analysis
|
||||||
This package contains analysis data files produced with rustc's -Zsave-analysis
|
This package contains analysis data files produced with rustc's -Zsave-analysis
|
||||||
@ -639,7 +639,7 @@ fi
|
|||||||
--set target.%{rust_triple}.cc=%{__cc}
|
--set target.%{rust_triple}.cc=%{__cc}
|
||||||
--set target.%{rust_triple}.cxx=%{__cxx}
|
--set target.%{rust_triple}.cxx=%{__cxx}
|
||||||
--set target.%{rust_triple}.ar=%{__ar}
|
--set target.%{rust_triple}.ar=%{__ar}
|
||||||
--set target.%{rust_triple}.ranlib=/usr/bin/ranlib
|
--set target.%{rust_triple}.ranlib=%{__ranlib}
|
||||||
}
|
}
|
||||||
|
|
||||||
%if %defined mingw_targets
|
%if %defined mingw_targets
|
||||||
@ -970,6 +970,9 @@ end}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 20 2022 Josh Stone <jistone@redhat.com> - 1.58.1-1
|
||||||
|
- Update to 1.58.1.
|
||||||
|
|
||||||
* Thu Jan 13 2022 Josh Stone <jistone@redhat.com> - 1.58.0-1
|
* Thu Jan 13 2022 Josh Stone <jistone@redhat.com> - 1.58.0-1
|
||||||
- Update to 1.58.0.
|
- Update to 1.58.0.
|
||||||
|
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
--- rustc-beta-src/compiler/rustc_codegen_ssa/src/back/link.rs.orig 2021-11-29 10:41:02.380100917 -0800
|
|
||||||
+++ rustc-beta-src/compiler/rustc_codegen_ssa/src/back/link.rs 2021-11-29 10:53:31.014783112 -0800
|
|
||||||
@@ -1485,15 +1485,14 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
fn link_output_kind(sess: &Session, crate_type: CrateType) -> LinkOutputKind {
|
|
||||||
- let kind = match (crate_type, sess.crt_static(Some(crate_type)), sess.relocation_model()) {
|
|
||||||
+ // Only use PIE if explicity specified.
|
|
||||||
+ let explicit_pic =
|
|
||||||
+ matches!(sess.opts.cg.relocation_model, Some(RelocModel::Pic | RelocModel::Pie));
|
|
||||||
+ let kind = match (crate_type, sess.crt_static(Some(crate_type)), explicit_pic) {
|
|
||||||
(CrateType::Executable, _, _) if sess.is_wasi_reactor() => LinkOutputKind::WasiReactorExe,
|
|
||||||
- (CrateType::Executable, false, RelocModel::Pic | RelocModel::Pie) => {
|
|
||||||
- LinkOutputKind::DynamicPicExe
|
|
||||||
- }
|
|
||||||
+ (CrateType::Executable, false, true) => LinkOutputKind::DynamicPicExe,
|
|
||||||
(CrateType::Executable, false, _) => LinkOutputKind::DynamicNoPicExe,
|
|
||||||
- (CrateType::Executable, true, RelocModel::Pic | RelocModel::Pie) => {
|
|
||||||
- LinkOutputKind::StaticPicExe
|
|
||||||
- }
|
|
||||||
+ (CrateType::Executable, true, true) => LinkOutputKind::StaticPicExe,
|
|
||||||
(CrateType::Executable, true, _) => LinkOutputKind::StaticNoPicExe,
|
|
||||||
(_, true, _) => LinkOutputKind::StaticDylib,
|
|
||||||
(_, false, _) => LinkOutputKind::DynamicDylib,
|
|
44
rustc-1.58.0-no-default-pie.patch
Normal file
44
rustc-1.58.0-no-default-pie.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff --git a/compiler/rustc_codegen_ssa/src/back/link.rs b/compiler/rustc_codegen_ssa/src/back/link.rs
|
||||||
|
index 638b2a7b5a9f..79d4ecf4cb91 100644
|
||||||
|
--- a/compiler/rustc_codegen_ssa/src/back/link.rs
|
||||||
|
+++ b/compiler/rustc_codegen_ssa/src/back/link.rs
|
||||||
|
@@ -763,7 +763,7 @@ fn link_natively<'a, B: ArchiveBuilder<'a>>(
|
||||||
|
&& cmd.get_args().iter().any(|e| e.to_string_lossy() == "-no-pie")
|
||||||
|
{
|
||||||
|
info!("linker output: {:?}", out);
|
||||||
|
- warn!("Linker does not support -no-pie command line option. Retrying without.");
|
||||||
|
+ info!("Linker does not support -no-pie command line option. Retrying without.");
|
||||||
|
for arg in cmd.take_args() {
|
||||||
|
if arg.to_string_lossy() != "-no-pie" {
|
||||||
|
cmd.arg(arg);
|
||||||
|
@@ -782,7 +782,7 @@ fn link_natively<'a, B: ArchiveBuilder<'a>>(
|
||||||
|
&& cmd.get_args().iter().any(|e| e.to_string_lossy() == "-static-pie")
|
||||||
|
{
|
||||||
|
info!("linker output: {:?}", out);
|
||||||
|
- warn!(
|
||||||
|
+ info!(
|
||||||
|
"Linker does not support -static-pie command line option. Retrying with -static instead."
|
||||||
|
);
|
||||||
|
// Mirror `add_(pre,post)_link_objects` to replace CRT objects.
|
||||||
|
@@ -1507,15 +1507,14 @@ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
|
||||||
|
}
|
||||||
|
|
||||||
|
fn link_output_kind(sess: &Session, crate_type: CrateType) -> LinkOutputKind {
|
||||||
|
- let kind = match (crate_type, sess.crt_static(Some(crate_type)), sess.relocation_model()) {
|
||||||
|
+ // Only use PIE if explicitly specified.
|
||||||
|
+ let explicit_pic =
|
||||||
|
+ matches!(sess.opts.cg.relocation_model, Some(RelocModel::Pic | RelocModel::Pie));
|
||||||
|
+ let kind = match (crate_type, sess.crt_static(Some(crate_type)), explicit_pic) {
|
||||||
|
(CrateType::Executable, _, _) if sess.is_wasi_reactor() => LinkOutputKind::WasiReactorExe,
|
||||||
|
- (CrateType::Executable, false, RelocModel::Pic | RelocModel::Pie) => {
|
||||||
|
- LinkOutputKind::DynamicPicExe
|
||||||
|
- }
|
||||||
|
+ (CrateType::Executable, false, true) => LinkOutputKind::DynamicPicExe,
|
||||||
|
(CrateType::Executable, false, _) => LinkOutputKind::DynamicNoPicExe,
|
||||||
|
- (CrateType::Executable, true, RelocModel::Pic | RelocModel::Pie) => {
|
||||||
|
- LinkOutputKind::StaticPicExe
|
||||||
|
- }
|
||||||
|
+ (CrateType::Executable, true, true) => LinkOutputKind::StaticPicExe,
|
||||||
|
(CrateType::Executable, true, _) => LinkOutputKind::StaticNoPicExe,
|
||||||
|
(_, true, _) => LinkOutputKind::StaticDylib,
|
||||||
|
(_, false, _) => LinkOutputKind::DynamicDylib,
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (rustc-1.58.0-src.tar.xz) = 70104f4d3b474dcb9935200ef0503f29cb15f10d38ba8630e1dadbb384924dd9137fced647794699efe83ac88083e4ae5f45712f0e1c8bc0a6f8c23eecdb0aeb
|
SHA512 (rustc-1.58.1-src.tar.xz) = eff3279d2e519343cea542a9ae2daab592e44f35af344e33ff43ed55fc7c824511790d1991dd36a603d12465de8c3688e7194c2b9557f288c587ffa04738c2ce
|
||||||
SHA512 (wasi-libc-ad5133410f66b93a2381db5b542aad5e0964db96.tar.gz) = 04cb3a25fef7949bf77f262bd939102f5b36e2ae85f28cdbfcd8a8984425fba54fae68049b777974bdbad96882fab383b44203e8f19a776d8a56a55475c4aab6
|
SHA512 (wasi-libc-ad5133410f66b93a2381db5b542aad5e0964db96.tar.gz) = 04cb3a25fef7949bf77f262bd939102f5b36e2ae85f28cdbfcd8a8984425fba54fae68049b777974bdbad96882fab383b44203e8f19a776d8a56a55475c4aab6
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
SHA512 (rustc-1.58.0-src.tar.xz) = 70104f4d3b474dcb9935200ef0503f29cb15f10d38ba8630e1dadbb384924dd9137fced647794699efe83ac88083e4ae5f45712f0e1c8bc0a6f8c23eecdb0aeb
|
SHA512 (rustc-1.58.1-src.tar.xz) = eff3279d2e519343cea542a9ae2daab592e44f35af344e33ff43ed55fc7c824511790d1991dd36a603d12465de8c3688e7194c2b9557f288c587ffa04738c2ce
|
||||||
SHA512 (wasi-libc-ad5133410f66b93a2381db5b542aad5e0964db96.tar.gz) = 04cb3a25fef7949bf77f262bd939102f5b36e2ae85f28cdbfcd8a8984425fba54fae68049b777974bdbad96882fab383b44203e8f19a776d8a56a55475c4aab6
|
SHA512 (wasi-libc-ad5133410f66b93a2381db5b542aad5e0964db96.tar.gz) = 04cb3a25fef7949bf77f262bd939102f5b36e2ae85f28cdbfcd8a8984425fba54fae68049b777974bdbad96882fab383b44203e8f19a776d8a56a55475c4aab6
|
||||||
SHA512 (rust-1.57.0-aarch64-unknown-linux-gnu.tar.xz) = 71d32e1ed3fc4a2eaf3594112b3b43ab82bd28b35e547542f6c1ed006175d7cf805be373a4da8b962762962dd32fe951c8ca7c0a424addad5d4e828441d5386c
|
SHA512 (rust-1.57.0-aarch64-unknown-linux-gnu.tar.xz) = 71d32e1ed3fc4a2eaf3594112b3b43ab82bd28b35e547542f6c1ed006175d7cf805be373a4da8b962762962dd32fe951c8ca7c0a424addad5d4e828441d5386c
|
||||||
SHA512 (rust-1.57.0-armv7-unknown-linux-gnueabihf.tar.xz) = 667d8f6fb56408782c7a9e0c5086013d0350d6161d52ca4cd948ea39a02ebdf657dd45cb0a135ade8bc1e856c0962040969416fa1762e3bb55a03574fff3b1d1
|
SHA512 (rust-1.57.0-armv7-unknown-linux-gnueabihf.tar.xz) = 667d8f6fb56408782c7a9e0c5086013d0350d6161d52ca4cd948ea39a02ebdf657dd45cb0a135ade8bc1e856c0962040969416fa1762e3bb55a03574fff3b1d1
|
||||||
|
Loading…
Reference in New Issue
Block a user