Update to 1.26.0.
This commit is contained in:
parent
8ccb982681
commit
72ac66629d
8
.gitignore
vendored
8
.gitignore
vendored
@ -114,3 +114,11 @@
|
||||
/rust-1.24.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.24.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.24.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rustc-1.26.0-src.tar.xz
|
||||
/rust-1.25.0-aarch64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.25.0-armv7-unknown-linux-gnueabihf.tar.xz
|
||||
/rust-1.25.0-i686-unknown-linux-gnu.tar.xz
|
||||
/rust-1.25.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.25.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.25.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.25.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
|
@ -1,54 +0,0 @@
|
||||
From b404ec4b4880db7f6aea23ebf778869dfd6ecf99 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Thu, 29 Mar 2018 10:25:32 -0700
|
||||
Subject: [PATCH] Ignore stack-probes tests on powerpc/s390x too
|
||||
|
||||
We only support stack probes on x86 and x86_64.
|
||||
Other arches are already ignored.
|
||||
---
|
||||
src/test/codegen/stack-probes.rs | 1 +
|
||||
src/test/run-pass/stack-probes-lto.rs | 2 ++
|
||||
src/test/run-pass/stack-probes.rs | 2 ++
|
||||
3 files changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/test/codegen/stack-probes.rs b/src/test/codegen/stack-probes.rs
|
||||
index af400ff3bcbd..51ebc42a0dd6 100644
|
||||
--- a/src/test/codegen/stack-probes.rs
|
||||
+++ b/src/test/codegen/stack-probes.rs
|
||||
@@ -11,6 +11,7 @@
|
||||
// ignore-arm
|
||||
// ignore-aarch64
|
||||
// ignore-powerpc
|
||||
+// ignore-s390x
|
||||
// ignore-aarch64
|
||||
// ignore-wasm
|
||||
// ignore-emscripten
|
||||
diff --git a/src/test/run-pass/stack-probes-lto.rs b/src/test/run-pass/stack-probes-lto.rs
|
||||
index e7fa3bc0a75c..d1cb75909c15 100644
|
||||
--- a/src/test/run-pass/stack-probes-lto.rs
|
||||
+++ b/src/test/run-pass/stack-probes-lto.rs
|
||||
@@ -10,6 +10,8 @@
|
||||
|
||||
// ignore-arm
|
||||
// ignore-aarch64
|
||||
+// ignore-powerpc
|
||||
+// ignore-s390x
|
||||
// ignore-wasm
|
||||
// ignore-cloudabi no processes
|
||||
// ignore-emscripten no processes
|
||||
diff --git a/src/test/run-pass/stack-probes.rs b/src/test/run-pass/stack-probes.rs
|
||||
index 67b3962ee5fb..78c5782be383 100644
|
||||
--- a/src/test/run-pass/stack-probes.rs
|
||||
+++ b/src/test/run-pass/stack-probes.rs
|
||||
@@ -10,6 +10,8 @@
|
||||
|
||||
// ignore-arm
|
||||
// ignore-aarch64
|
||||
+// ignore-powerpc
|
||||
+// ignore-s390x
|
||||
// ignore-wasm
|
||||
// ignore-cloudabi no processes
|
||||
// ignore-emscripten no processes
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,4 +1,4 @@
|
||||
From f89f1b496c0c3b96aa8e41bef882131008dac6c3 Mon Sep 17 00:00:00 2001
|
||||
From cc2906cb26304301709557a88ac4a3334b88616b Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 13 Apr 2018 16:52:54 -0700
|
||||
Subject: [PATCH 1/3] rustbuild: allow building tools with debuginfo
|
||||
@ -19,7 +19,7 @@ a concern in regular use.
|
||||
5 files changed, 19 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
|
||||
index 70376c120f..fcd995b703 100644
|
||||
index 7a62405f0596..73d4188d6954 100644
|
||||
--- a/CONTRIBUTING.md
|
||||
+++ b/CONTRIBUTING.md
|
||||
@@ -121,6 +121,7 @@ configuration used in the build process. Some options to note:
|
||||
@ -31,10 +31,10 @@ index 70376c120f..fcd995b703 100644
|
||||
- `optimize = false` - Disable optimizations to speed up compilation of stage1 rust, but makes the stage1 compiler x100 slower.
|
||||
|
||||
diff --git a/config.toml.example b/config.toml.example
|
||||
index f153562a53..64e2f1b424 100644
|
||||
index 68bc7dfe720f..bd18a604a9c8 100644
|
||||
--- a/config.toml.example
|
||||
+++ b/config.toml.example
|
||||
@@ -259,6 +259,10 @@
|
||||
@@ -262,6 +262,10 @@
|
||||
# standard library.
|
||||
#debuginfo-only-std = false
|
||||
|
||||
@ -46,10 +46,10 @@ index f153562a53..64e2f1b424 100644
|
||||
#use-jemalloc = true
|
||||
|
||||
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
|
||||
index fcb78c479f..584c0cbe75 100644
|
||||
index 7ff64af91967..ae19c66d6070 100644
|
||||
--- a/src/bootstrap/builder.rs
|
||||
+++ b/src/bootstrap/builder.rs
|
||||
@@ -603,10 +603,14 @@ impl<'a> Builder<'a> {
|
||||
@@ -622,10 +622,14 @@ impl<'a> Builder<'a> {
|
||||
cargo.env("RUSTDOC_LIBDIR", self.rustc_libdir(self.compiler(2, self.build.build)));
|
||||
}
|
||||
|
||||
@ -69,10 +69,10 @@ index fcb78c479f..584c0cbe75 100644
|
||||
cargo.env("RUSTC_DEBUGINFO_LINES", self.config.rust_debuginfo_lines.to_string());
|
||||
cargo.env("RUSTC_FORCE_UNSTABLE", "1");
|
||||
diff --git a/src/bootstrap/config.rs b/src/bootstrap/config.rs
|
||||
index f3810ac869..ac64e6e8e3 100644
|
||||
index 239316d45c49..95d138b9fab2 100644
|
||||
--- a/src/bootstrap/config.rs
|
||||
+++ b/src/bootstrap/config.rs
|
||||
@@ -88,6 +88,7 @@ pub struct Config {
|
||||
@@ -94,6 +94,7 @@ pub struct Config {
|
||||
pub rust_debuginfo: bool,
|
||||
pub rust_debuginfo_lines: bool,
|
||||
pub rust_debuginfo_only_std: bool,
|
||||
@ -80,7 +80,7 @@ index f3810ac869..ac64e6e8e3 100644
|
||||
pub rust_rpath: bool,
|
||||
pub rustc_parallel_queries: bool,
|
||||
pub rustc_default_linker: Option<String>,
|
||||
@@ -271,6 +272,7 @@ struct Rust {
|
||||
@@ -282,6 +283,7 @@ struct Rust {
|
||||
debuginfo: Option<bool>,
|
||||
debuginfo_lines: Option<bool>,
|
||||
debuginfo_only_std: Option<bool>,
|
||||
@ -88,7 +88,7 @@ index f3810ac869..ac64e6e8e3 100644
|
||||
experimental_parallel_queries: Option<bool>,
|
||||
debug_jemalloc: Option<bool>,
|
||||
use_jemalloc: Option<bool>,
|
||||
@@ -425,6 +427,7 @@ impl Config {
|
||||
@@ -462,6 +464,7 @@ impl Config {
|
||||
let mut llvm_assertions = None;
|
||||
let mut debuginfo_lines = None;
|
||||
let mut debuginfo_only_std = None;
|
||||
@ -96,7 +96,7 @@ index f3810ac869..ac64e6e8e3 100644
|
||||
let mut debug = None;
|
||||
let mut debug_jemalloc = None;
|
||||
let mut debuginfo = None;
|
||||
@@ -462,6 +465,7 @@ impl Config {
|
||||
@@ -499,6 +502,7 @@ impl Config {
|
||||
debuginfo = rust.debuginfo;
|
||||
debuginfo_lines = rust.debuginfo_lines;
|
||||
debuginfo_only_std = rust.debuginfo_only_std;
|
||||
@ -104,8 +104,8 @@ index f3810ac869..ac64e6e8e3 100644
|
||||
optimize = rust.optimize;
|
||||
ignore_git = rust.ignore_git;
|
||||
debug_jemalloc = rust.debug_jemalloc;
|
||||
@@ -553,6 +557,7 @@ impl Config {
|
||||
config.rust_thinlto = thinlto.unwrap_or(true);
|
||||
@@ -582,6 +586,7 @@ impl Config {
|
||||
};
|
||||
config.rust_debuginfo_lines = debuginfo_lines.unwrap_or(default);
|
||||
config.rust_debuginfo_only_std = debuginfo_only_std.unwrap_or(default);
|
||||
+ config.rust_debuginfo_tools = debuginfo_tools.unwrap_or(default);
|
||||
@ -113,10 +113,10 @@ index f3810ac869..ac64e6e8e3 100644
|
||||
let default = debug == Some(true);
|
||||
config.debug_jemalloc = debug_jemalloc.unwrap_or(default);
|
||||
diff --git a/src/bootstrap/configure.py b/src/bootstrap/configure.py
|
||||
index 99a3ee4e4c..689dd905fb 100755
|
||||
index b06968d313ba..a0123da6d8ff 100755
|
||||
--- a/src/bootstrap/configure.py
|
||||
+++ b/src/bootstrap/configure.py
|
||||
@@ -78,6 +78,7 @@ def v(*args):
|
||||
@@ -79,6 +79,7 @@ o("llvm-release-debuginfo", "llvm.release-debuginfo", "build LLVM with debugger
|
||||
o("debuginfo", "rust.debuginfo", "build with debugger metadata")
|
||||
o("debuginfo-lines", "rust.debuginfo-lines", "build with line number debugger metadata")
|
||||
o("debuginfo-only-std", "rust.debuginfo-only-std", "build only libstd with debugging information")
|
||||
@ -125,10 +125,10 @@ index 99a3ee4e4c..689dd905fb 100755
|
||||
v("save-toolstates", "rust.save-toolstates", "save build and test status of external tools into this file")
|
||||
|
||||
--
|
||||
2.14.3
|
||||
2.17.0
|
||||
|
||||
|
||||
From f0a43d3a9a4c28ea45d6bed430b1d9d561944e16 Mon Sep 17 00:00:00 2001
|
||||
From bc7403d067b3e2a154df1ef088377cb2a75f429c Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 13 Apr 2018 21:57:53 -0700
|
||||
Subject: [PATCH 2/3] Avoid specific claims about debuginfo size
|
||||
@ -139,10 +139,10 @@ Subject: [PATCH 2/3] Avoid specific claims about debuginfo size
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/config.toml.example b/config.toml.example
|
||||
index 64e2f1b424..46be1ecab7 100644
|
||||
index bd18a604a9c8..effe00843810 100644
|
||||
--- a/config.toml.example
|
||||
+++ b/config.toml.example
|
||||
@@ -260,7 +260,7 @@
|
||||
@@ -263,7 +263,7 @@
|
||||
#debuginfo-only-std = false
|
||||
|
||||
# Enable debuginfo for the extended tools: cargo, rls, rustfmt
|
||||
@ -152,10 +152,10 @@ index 64e2f1b424..46be1ecab7 100644
|
||||
|
||||
# Whether or not jemalloc is built and enabled
|
||||
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
|
||||
index 584c0cbe75..627a695884 100644
|
||||
index ae19c66d6070..6874efa5a4c7 100644
|
||||
--- a/src/bootstrap/builder.rs
|
||||
+++ b/src/bootstrap/builder.rs
|
||||
@@ -605,7 +605,7 @@ impl<'a> Builder<'a> {
|
||||
@@ -624,7 +624,7 @@ impl<'a> Builder<'a> {
|
||||
|
||||
if mode == Mode::Tool {
|
||||
// Tools like cargo and rls don't get debuginfo by default right now, but this can be
|
||||
@ -165,10 +165,10 @@ index 584c0cbe75..627a695884 100644
|
||||
cargo.env("RUSTC_DEBUGINFO", self.config.rust_debuginfo.to_string());
|
||||
cargo.env("RUSTC_DEBUGINFO_LINES", self.config.rust_debuginfo_lines.to_string());
|
||||
--
|
||||
2.14.3
|
||||
2.17.0
|
||||
|
||||
|
||||
From 7ddb573a2ea41ad3c35f927b7b90fd545a6ab9da Mon Sep 17 00:00:00 2001
|
||||
From 93734e9c46e30acc9a51f19c56511ce8516b6855 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 13 Apr 2018 21:58:21 -0700
|
||||
Subject: [PATCH 3/3] Make debuginfo-tools always default false
|
||||
@ -178,11 +178,11 @@ Subject: [PATCH 3/3] Make debuginfo-tools always default false
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/config.rs b/src/bootstrap/config.rs
|
||||
index ac64e6e8e3..06443ae6cd 100644
|
||||
index 95d138b9fab2..1b4b2c5fb2a5 100644
|
||||
--- a/src/bootstrap/config.rs
|
||||
+++ b/src/bootstrap/config.rs
|
||||
@@ -557,7 +557,7 @@ impl Config {
|
||||
config.rust_thinlto = thinlto.unwrap_or(true);
|
||||
@@ -586,7 +586,7 @@ impl Config {
|
||||
};
|
||||
config.rust_debuginfo_lines = debuginfo_lines.unwrap_or(default);
|
||||
config.rust_debuginfo_only_std = debuginfo_only_std.unwrap_or(default);
|
||||
- config.rust_debuginfo_tools = debuginfo_tools.unwrap_or(default);
|
||||
@ -191,5 +191,5 @@ index ac64e6e8e3..06443ae6cd 100644
|
||||
let default = debug == Some(true);
|
||||
config.debug_jemalloc = debug_jemalloc.unwrap_or(default);
|
||||
--
|
||||
2.14.3
|
||||
2.17.0
|
||||
|
||||
|
33
rust.spec
33
rust.spec
@ -8,10 +8,10 @@
|
||||
# To bootstrap from scratch, set the channel and date from src/stage0.txt
|
||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||
# or nightly wants some beta-YYYY-MM-DD
|
||||
%global bootstrap_rust 1.24.0
|
||||
%global bootstrap_cargo 0.25.0
|
||||
%global bootstrap_rust 1.25.0
|
||||
%global bootstrap_cargo 0.26.0
|
||||
%global bootstrap_channel %{bootstrap_rust}
|
||||
%global bootstrap_date 2018-02-15
|
||||
%global bootstrap_date 2018-03-29
|
||||
|
||||
# Only the specified arches will use bootstrap binaries.
|
||||
#global bootstrap_arches %%{rust_arches}
|
||||
@ -47,16 +47,16 @@
|
||||
%endif
|
||||
|
||||
# Some sub-packages are versioned independently of the rust compiler and runtime itself.
|
||||
%global rustc_version 1.25.0
|
||||
%global cargo_version 0.26.0
|
||||
%global rustfmt_version 0.3.8
|
||||
%global rls_version 0.125.1
|
||||
%global rustc_version 1.26.0
|
||||
%global cargo_version %{rustc_version}
|
||||
%global rustfmt_version 0.4.1
|
||||
%global rls_version 0.126.0
|
||||
|
||||
Name: rust
|
||||
Version: %{rustc_version}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: The Rust Programming Language
|
||||
License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
|
||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||
# ^ written as: (rust itself) and (bundled libraries)
|
||||
URL: https://www.rust-lang.org
|
||||
ExclusiveArch: %{rust_arches}
|
||||
@ -68,11 +68,9 @@ ExclusiveArch: %{rust_arches}
|
||||
%endif
|
||||
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||
|
||||
# https://github.com/rust-lang/rust/pull/49484
|
||||
Patch1: 0001-Ignore-stack-probes-tests-on-powerpc-s390x-too.patch
|
||||
|
||||
# rustbuild: allow building tools with debuginfo
|
||||
# https://github.com/rust-lang/rust/pull/49959
|
||||
Patch2: pull-49959.patch
|
||||
Patch1: pull-49959.patch
|
||||
|
||||
# Get the Rust triple for any arch.
|
||||
%{lua: function rust_triple(arch)
|
||||
@ -172,7 +170,6 @@ BuildRequires: procps-ng
|
||||
BuildRequires: gdb
|
||||
|
||||
# TODO: work on unbundling these!
|
||||
Provides: bundled(hoedown) = 3.0.7
|
||||
Provides: bundled(jquery) = 2.1.4
|
||||
Provides: bundled(libbacktrace) = 6.1.0
|
||||
Provides: bundled(miniz) = 1.16~beta+r1
|
||||
@ -374,8 +371,7 @@ test -f '%{local_rust_root}/bin/rustc'
|
||||
|
||||
%setup -q -n %{rustc_package}
|
||||
|
||||
%patch1 -p1 -b .ignore-ibm
|
||||
%patch2 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%if "%{python}" == "python3"
|
||||
sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
|
||||
@ -392,7 +388,6 @@ rm -rf src/llvm/
|
||||
rm -rf src/llvm-emscripten/
|
||||
|
||||
# extract bundled licenses for packaging
|
||||
cp src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
|
||||
sed -e '/*\//q' src/libbacktrace/backtrace.h \
|
||||
>src/libbacktrace/LICENSE-libbacktrace
|
||||
|
||||
@ -558,7 +553,6 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
%files
|
||||
%license COPYRIGHT LICENSE-APACHE LICENSE-MIT
|
||||
%license src/libbacktrace/LICENSE-libbacktrace
|
||||
%license src/rt/hoedown/LICENSE-hoedown
|
||||
%doc README.md
|
||||
%{_bindir}/rustc
|
||||
%{_bindir}/rustdoc
|
||||
@ -648,6 +642,9 @@ rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 10 2018 Josh Stone <jistone@redhat.com> - 1.26.0-1
|
||||
- Update to 1.26.0.
|
||||
|
||||
* Mon Apr 16 2018 Dan Callaghan <dcallagh@redhat.com> - 1.25.0-3
|
||||
- Add cargo, rls, and analysis
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rustc-1.25.0-src.tar.xz) = 45baaaa47d8b6433f61b1a6f2637d8f4fe013b534a8a94365025dfcf786815c95111b9bd3beb2544ba8587fb4c8b38431765c4d68bc9c19285da4ccf7c7eeda2
|
||||
SHA512 (rustc-1.26.0-src.tar.xz) = 563b910ecf4b2a0d798a1201177f733333e64efad49e5aceec5adc66a8c6903df391c9afc0fdd8284348c08082e0c4de1e5cb68efe6797594de43ca93e4ad7a2
|
||||
|
@ -1,8 +1,8 @@
|
||||
SHA512 (rustc-1.25.0-src.tar.xz) = 45baaaa47d8b6433f61b1a6f2637d8f4fe013b534a8a94365025dfcf786815c95111b9bd3beb2544ba8587fb4c8b38431765c4d68bc9c19285da4ccf7c7eeda2
|
||||
SHA512 (rust-1.24.0-aarch64-unknown-linux-gnu.tar.xz) = c8be9bd2929d5a9ac96524bdbbc3b137c703a54d6bdf19a8abee69fcb2cf7d11693a79c520571da021fb0c059de5f759f6c0336d4e42f278584c0ec3783983ce
|
||||
SHA512 (rust-1.24.0-armv7-unknown-linux-gnueabihf.tar.xz) = 57383893b1015377857509f9d485629fc181408089c577b725e52577e5cc44a69f557c8311324473008d879e7917105077045591e72c7d09b4b57bcf020fd39d
|
||||
SHA512 (rust-1.24.0-i686-unknown-linux-gnu.tar.xz) = d7e4ae046bea9c8fd5709fc316965bd0422afc1b7cf2b35bebc8899524bb5e12c1e685dc395e96f43957ab9b6ab3039fa0c0306751b6f1771bd6550d559e66a8
|
||||
SHA512 (rust-1.24.0-powerpc64le-unknown-linux-gnu.tar.xz) = f1a6ad1b66ce4e928a7f7aed8476fedc9ef93ef8520aa34781a5e7e8e2ab2ac3b13fc325d37bd30bc9cc3dc709b2286436b6c68eae1748c434860b51643afa1b
|
||||
SHA512 (rust-1.24.0-powerpc64-unknown-linux-gnu.tar.xz) = 0a2fbe4017c2c69e5fc2b35591f40fa45cf03be93ed0c03c56fb10d76dd78f7a86c40552afb60e360aa05447faf278e2988a9a0056a21950ba05daad1bf070a1
|
||||
SHA512 (rust-1.24.0-s390x-unknown-linux-gnu.tar.xz) = 252342cad4d41f7f972aec7a96e2ed0c8044af9a8c02bfdb36e47b591fad33df4234c141b7532e62f33d7f57af2191cbfb88606e2c59e927b08e41d9f0f8d2a5
|
||||
SHA512 (rust-1.24.0-x86_64-unknown-linux-gnu.tar.xz) = 876e5d66b5531a5dd1c42b8b2f073bc463a6dead348d5857f43b0047a4f6b101d26c7b29d6bbe1c1ea64cb6ca8c36d0159ff4dc75418e4216e7e585b169276ff
|
||||
SHA512 (rustc-1.26.0-src.tar.xz) = 563b910ecf4b2a0d798a1201177f733333e64efad49e5aceec5adc66a8c6903df391c9afc0fdd8284348c08082e0c4de1e5cb68efe6797594de43ca93e4ad7a2
|
||||
SHA512 (rust-1.25.0-aarch64-unknown-linux-gnu.tar.xz) = 404ecd4dc1e49fba41d7ade947877f621aa762e43eb5a8f604823fe297e8023f095cd449610240ed235723baaac96064eb38445794e27708edcdbca998d939e3
|
||||
SHA512 (rust-1.25.0-armv7-unknown-linux-gnueabihf.tar.xz) = 63bf72c6011f9ccb052496d09d1ecc37d5c2ec8260ade2ef9b7bca6fb0dc8b77f5d27eb77c1136cef6f986f2fec90577399b0f9c57e757838904ab4030f93f6d
|
||||
SHA512 (rust-1.25.0-i686-unknown-linux-gnu.tar.xz) = 75ad5cb5e00fabc24aaa46236cc6f2193a7543fd0944c0717c11a56d9c420d20463ad683558d86f5d42abacfb89d15f9cabf404c912a5e24a28e6716c8003e8f
|
||||
SHA512 (rust-1.25.0-powerpc64le-unknown-linux-gnu.tar.xz) = f4a37b82a8cd2a9a50d6cc7db0b09513829388e72ab13e8b6d633a166c9f15fd3692d06131e8546636e9e6a8b7dae93345d063f88d64ab876da582d7156ebdee
|
||||
SHA512 (rust-1.25.0-powerpc64-unknown-linux-gnu.tar.xz) = 853c7a009c2b5a80d625bad024faa92193041461213761a9d4bdf33d5bb958c4f81b966cb8af1a5abbde6d393650f74c6a18a5ba9f709bce04d0da4f0e15ee7a
|
||||
SHA512 (rust-1.25.0-s390x-unknown-linux-gnu.tar.xz) = 864919cf590377f47c6fb11dec3f0b9999ca5db3c002d3f253efbb7ad268e5f0a7d6f590411fed14c2068f08fb100ae76c33a5165f689d98b0798e227cf22632
|
||||
SHA512 (rust-1.25.0-x86_64-unknown-linux-gnu.tar.xz) = aea93ff64f620a1dd6b48d07ec3dcbc126b2f5c17b4697c096ec8cd02a3c7dfec7ae7d5df70a55eceb372897ad12f3d01c67d5aaea0167a80270931c61323f78
|
||||
|
Loading…
Reference in New Issue
Block a user