Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/rust.git#3aadadbd4b2429a45fd1ae02261c8d37bff90eae
This commit is contained in:
parent
b323553c25
commit
65b9d39200
8
.gitignore
vendored
8
.gitignore
vendored
@ -313,3 +313,11 @@
|
|||||||
/rust-1.47.0-powerpc64-unknown-linux-gnu.tar.xz
|
/rust-1.47.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||||
/rust-1.47.0-s390x-unknown-linux-gnu.tar.xz
|
/rust-1.47.0-s390x-unknown-linux-gnu.tar.xz
|
||||||
/rust-1.47.0-x86_64-unknown-linux-gnu.tar.xz
|
/rust-1.47.0-x86_64-unknown-linux-gnu.tar.xz
|
||||||
|
/rustc-1.49.0-src.tar.xz
|
||||||
|
/rust-1.48.0-aarch64-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.48.0-armv7-unknown-linux-gnueabihf.tar.xz
|
||||||
|
/rust-1.48.0-i686-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.48.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.48.0-powerpc64-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.48.0-s390x-unknown-linux-gnu.tar.xz
|
||||||
|
/rust-1.48.0-x86_64-unknown-linux-gnu.tar.xz
|
||||||
|
@ -1,46 +0,0 @@
|
|||||||
From f200c1e7afdd04b42c01c0108735e5b14ca07d93 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Stone <jistone@redhat.com>
|
|
||||||
Date: Fri, 9 Oct 2020 20:12:26 -0700
|
|
||||||
Subject: [PATCH] doc: disambiguate stat in MetadataExt::as_raw_stat
|
|
||||||
|
|
||||||
A few architectures in `os::linux::raw` import `libc::stat`, rather than
|
|
||||||
defining that type directly. However, that also imports the _function_
|
|
||||||
called `stat`, which makes this doc link ambiguous:
|
|
||||||
|
|
||||||
error: `crate::os::linux::raw::stat` is both a struct and a function
|
|
||||||
--> library/std/src/os/linux/fs.rs:21:19
|
|
||||||
|
|
|
||||||
21 | /// [`stat`]: crate::os::linux::raw::stat
|
|
||||||
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^ ambiguous link
|
|
||||||
|
|
|
||||||
= note: `-D broken-intra-doc-links` implied by `-D warnings`
|
|
||||||
help: to link to the struct, prefix with the item type
|
|
||||||
|
|
|
||||||
21 | /// [`stat`]: struct@crate::os::linux::raw::stat
|
|
||||||
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
|
|
||||||
help: to link to the function, add parentheses
|
|
||||||
|
|
|
||||||
21 | /// [`stat`]: crate::os::linux::raw::stat()
|
|
||||||
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
|
|
||||||
|
|
||||||
We want the `struct`, so it's now prefixed accordingly.
|
|
||||||
---
|
|
||||||
library/std/src/os/linux/fs.rs | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/library/std/src/os/linux/fs.rs b/library/std/src/os/linux/fs.rs
|
|
||||||
index ff23c3d67e3b..9b7af97616c9 100644
|
|
||||||
--- a/library/std/src/os/linux/fs.rs
|
|
||||||
+++ b/library/std/src/os/linux/fs.rs
|
|
||||||
@@ -20,7 +20,7 @@ pub trait MetadataExt {
|
|
||||||
/// Unix platforms. The `os::unix::fs::MetadataExt` trait contains the
|
|
||||||
/// cross-Unix abstractions contained within the raw stat.
|
|
||||||
///
|
|
||||||
- /// [`stat`]: crate::os::linux::raw::stat
|
|
||||||
+ /// [`stat`]: struct@crate::os::linux::raw::stat
|
|
||||||
///
|
|
||||||
/// # Examples
|
|
||||||
///
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
From 6f8efee8c936de65bc31610eea30abd5461a5dd1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Stone <jistone@redhat.com>
|
|
||||||
Date: Thu, 8 Oct 2020 15:53:49 -0700
|
|
||||||
Subject: [PATCH] use NativeEndian in symbolize::gimli::Context
|
|
||||||
|
|
||||||
`Object` uses `NativeEndian`, so the `Context` should too.
|
|
||||||
|
|
||||||
Cc: https://github.com/rust-lang/rust/issues/77410
|
|
||||||
---
|
|
||||||
src/symbolize/gimli.rs | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/symbolize/gimli.rs b/src/symbolize/gimli.rs
|
|
||||||
index 58ed8bafca3d..273ff43f1c8c 100644
|
|
||||||
--- a/src/symbolize/gimli.rs
|
|
||||||
+++ b/src/symbolize/gimli.rs
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
//! intended to wholesale replace the `libbacktrace.rs` implementation.
|
|
||||||
|
|
||||||
use self::gimli::read::EndianSlice;
|
|
||||||
-use self::gimli::LittleEndian as Endian;
|
|
||||||
+use self::gimli::NativeEndian as Endian;
|
|
||||||
use self::mmap::Mmap;
|
|
||||||
use self::stash::Stash;
|
|
||||||
use super::BytesOrWideString;
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
30
rust.spec
30
rust.spec
@ -9,10 +9,10 @@
|
|||||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||||
# or nightly wants some beta-YYYY-MM-DD
|
# or nightly wants some beta-YYYY-MM-DD
|
||||||
# Note that cargo matches the program version here, not its crate version.
|
# Note that cargo matches the program version here, not its crate version.
|
||||||
%global bootstrap_rust 1.47.0
|
%global bootstrap_rust 1.48.0
|
||||||
%global bootstrap_cargo 1.47.0
|
%global bootstrap_cargo 1.48.0
|
||||||
%global bootstrap_channel 1.47.0
|
%global bootstrap_channel 1.48.0
|
||||||
%global bootstrap_date 2020-10-08
|
%global bootstrap_date 2020-11-19
|
||||||
|
|
||||||
# Only the specified arches will use bootstrap binaries.
|
# Only the specified arches will use bootstrap binaries.
|
||||||
#global bootstrap_arches %%{rust_arches}
|
#global bootstrap_arches %%{rust_arches}
|
||||||
@ -52,8 +52,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: rust
|
Name: rust
|
||||||
Version: 1.48.0
|
Version: 1.49.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Rust Programming Language
|
Summary: The Rust Programming Language
|
||||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||||
# ^ written as: (rust itself) and (bundled libraries)
|
# ^ written as: (rust itself) and (bundled libraries)
|
||||||
@ -67,12 +67,6 @@ ExclusiveArch: %{rust_arches}
|
|||||||
%endif
|
%endif
|
||||||
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||||
|
|
||||||
# https://github.com/rust-lang/backtrace-rs/pull/373
|
|
||||||
Patch1: 0001-use-NativeEndian-in-symbolize-gimli-Context.patch
|
|
||||||
|
|
||||||
# https://github.com/rust-lang/rust/pull/77777
|
|
||||||
Patch2: 0001-doc-disambiguate-stat-in-MetadataExt-as_raw_stat.patch
|
|
||||||
|
|
||||||
### RHEL-specific patches below ###
|
### RHEL-specific patches below ###
|
||||||
|
|
||||||
# Disable cargo->libgit2->libssh2 on RHEL, as it's not approved for FIPS (rhbz1732949)
|
# Disable cargo->libgit2->libssh2 on RHEL, as it's not approved for FIPS (rhbz1732949)
|
||||||
@ -80,7 +74,7 @@ Patch100: rustc-1.48.0-disable-libssh2.patch
|
|||||||
|
|
||||||
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
||||||
# will try to build it statically -- instead we turn off the feature.
|
# will try to build it statically -- instead we turn off the feature.
|
||||||
Patch101: rustc-1.48.0-disable-http2.patch
|
Patch101: rustc-1.49.0-disable-http2.patch
|
||||||
|
|
||||||
# kernel rh1410097 causes too-small stacks for PIE.
|
# kernel rh1410097 causes too-small stacks for PIE.
|
||||||
# (affects RHEL6 kernels when building for RHEL7)
|
# (affects RHEL6 kernels when building for RHEL7)
|
||||||
@ -179,7 +173,7 @@ BuildRequires: cmake >= 2.8.11
|
|||||||
%global llvm llvm
|
%global llvm llvm
|
||||||
%global llvm_root %{_prefix}
|
%global llvm_root %{_prefix}
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: %{llvm}-devel >= 8.0
|
BuildRequires: %{llvm}-devel >= 9.0
|
||||||
%if %with llvm_static
|
%if %with llvm_static
|
||||||
BuildRequires: %{llvm}-static
|
BuildRequires: %{llvm}-static
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
@ -402,9 +396,6 @@ test -f '%{local_rust_root}/bin/rustc'
|
|||||||
|
|
||||||
%setup -q -n %{rustc_package}
|
%setup -q -n %{rustc_package}
|
||||||
|
|
||||||
%patch1 -p1 -d library/backtrace
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%if %with disabled_libssh2
|
%if %with disabled_libssh2
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
%endif
|
%endif
|
||||||
@ -729,10 +720,13 @@ export %{rust_env}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 05 2021 Josh Stone <jistone@redhat.com> - 1.49.0-1
|
||||||
|
- Update to 1.49.0.
|
||||||
|
|
||||||
* Tue Dec 29 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.48.0-3
|
* Tue Dec 29 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.48.0-3
|
||||||
- De-bootstrap
|
- De-bootstrap
|
||||||
|
|
||||||
* Mon Dec 28 19:00:26 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.48.0-2
|
* Mon Dec 28 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.48.0-2
|
||||||
- Rebuild for libgit2 1.1.x
|
- Rebuild for libgit2 1.1.x
|
||||||
|
|
||||||
* Thu Nov 19 2020 Josh Stone <jistone@redhat.com> - 1.48.0-1
|
* Thu Nov 19 2020 Josh Stone <jistone@redhat.com> - 1.48.0-1
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- rustc-1.48.0-src/Cargo.lock.orig 2020-11-16 09:36:19.889728111 -0800
|
--- rustc-1.49.0-src/Cargo.lock.orig 2021-01-05 12:45:10.456414612 -0800
|
||||||
+++ rustc-1.48.0-src/Cargo.lock 2020-11-16 09:36:19.890728089 -0800
|
+++ rustc-1.49.0-src/Cargo.lock 2021-01-05 12:45:10.458414575 -0800
|
||||||
@@ -849,7 +849,6 @@
|
@@ -882,7 +882,6 @@
|
||||||
dependencies = [
|
dependencies = [
|
||||||
"cc",
|
"cc",
|
||||||
"libc",
|
"libc",
|
||||||
@ -8,7 +8,7 @@
|
|||||||
"libz-sys",
|
"libz-sys",
|
||||||
"openssl-sys",
|
"openssl-sys",
|
||||||
"pkg-config",
|
"pkg-config",
|
||||||
@@ -1682,16 +1681,6 @@
|
@@ -1728,16 +1727,6 @@
|
||||||
]
|
]
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
@ -25,20 +25,20 @@
|
|||||||
name = "libz-sys"
|
name = "libz-sys"
|
||||||
version = "1.1.2"
|
version = "1.1.2"
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||||
--- rustc-1.48.0-src/src/tools/cargo/Cargo.toml.orig 2020-11-16 06:02:09.000000000 -0800
|
--- rustc-1.49.0-src/src/tools/cargo/Cargo.toml.orig 2021-01-05 12:45:10.458414575 -0800
|
||||||
+++ rustc-1.48.0-src/src/tools/cargo/Cargo.toml 2020-11-16 09:36:19.890728089 -0800
|
+++ rustc-1.49.0-src/src/tools/cargo/Cargo.toml 2021-01-05 12:47:25.966928554 -0800
|
||||||
@@ -25,7 +25,7 @@
|
@@ -25,7 +25,7 @@
|
||||||
crates-io = { path = "crates/crates-io", version = "0.31.1" }
|
crates-io = { path = "crates/crates-io", version = "0.31.1" }
|
||||||
crossbeam-utils = "0.7"
|
crossbeam-utils = "0.8"
|
||||||
crypto-hash = "0.3.1"
|
crypto-hash = "0.3.1"
|
||||||
-curl = { version = "0.4.23", features = ["http2"] }
|
-curl = { version = "0.4.23", features = ["http2"] }
|
||||||
+curl = { version = "0.4.23", features = [] }
|
+curl = { version = "0.4.23", features = [] }
|
||||||
curl-sys = "0.4.22"
|
curl-sys = "0.4.22"
|
||||||
env_logger = "0.7.0"
|
env_logger = "0.8.1"
|
||||||
pretty_env_logger = { version = "0.4", optional = true }
|
pretty_env_logger = { version = "0.4", optional = true }
|
||||||
--- rustc-1.48.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-11-16 06:02:09.000000000 -0800
|
--- rustc-1.49.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-12-28 19:03:25.000000000 -0800
|
||||||
+++ rustc-1.48.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-11-16 09:36:19.890728089 -0800
|
+++ rustc-1.49.0-src/src/tools/cargo/src/cargo/core/package.rs 2021-01-05 12:45:10.458414575 -0800
|
||||||
@@ -396,14 +396,8 @@
|
@@ -408,14 +408,8 @@
|
||||||
// Also note that pipelining is disabled as curl authors have indicated
|
// Also note that pipelining is disabled as curl authors have indicated
|
||||||
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
||||||
// proxies.
|
// proxies.
|
||||||
@ -55,7 +55,7 @@
|
|||||||
|
|
||||||
Ok(PackageSet {
|
Ok(PackageSet {
|
||||||
packages: package_ids
|
packages: package_ids
|
||||||
@@ -566,7 +560,7 @@
|
@@ -584,7 +578,7 @@
|
||||||
macro_rules! try_old_curl {
|
macro_rules! try_old_curl {
|
||||||
($e:expr, $msg:expr) => {
|
($e:expr, $msg:expr) => {
|
||||||
let result = $e;
|
let result = $e;
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (rustc-1.48.0-src.tar.xz) = 4e12baa6893238a8d336ec9ebe891477d18676f271b32763474fa7a6a8b58fb3187dd4e2aa95bce482989b692cc2e1360221669d6811eec71b326f22a1756c23
|
SHA512 (rustc-1.49.0-src.tar.xz) = fd8bc67ec0a73d3b6bf9c1fabb7ea981ef817644b4e6ced982fa90b12eae9b55de074634a670bdfb38bfee6588603e818ddcbcc2f2a05f83057c061b4194b4b7
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
SHA512 (rustc-1.48.0-src.tar.xz) = 4e12baa6893238a8d336ec9ebe891477d18676f271b32763474fa7a6a8b58fb3187dd4e2aa95bce482989b692cc2e1360221669d6811eec71b326f22a1756c23
|
SHA512 (rustc-1.49.0-src.tar.xz) = fd8bc67ec0a73d3b6bf9c1fabb7ea981ef817644b4e6ced982fa90b12eae9b55de074634a670bdfb38bfee6588603e818ddcbcc2f2a05f83057c061b4194b4b7
|
||||||
SHA512 (rust-1.47.0-aarch64-unknown-linux-gnu.tar.xz) = 7df7045df341f03508f1ad795a9117b39c1f4c4cc778c7fd9d78c42e7da662ce244d018084ac9e80d9409cf8b3b5d1ccc25ef4cb71a2b8727398d30a4e962e19
|
SHA512 (rust-1.48.0-aarch64-unknown-linux-gnu.tar.xz) = 6ebbd936b1bc2ccf30b62dbbbc6f3986fb57738d89e33a23d58bab09be57a445c17df7912866add91cc108ef7547d229a08c6206db2d2fb00d72887ff6a0894d
|
||||||
SHA512 (rust-1.47.0-armv7-unknown-linux-gnueabihf.tar.xz) = b207ab7c478dce6db4018527888f539938c8e77b5ceccb460b9d52ffee13a2329d225d03a605b60729cae6254129245bdd69730aebb6ec91dd0c83005cf25253
|
SHA512 (rust-1.48.0-armv7-unknown-linux-gnueabihf.tar.xz) = 9763b0c5bc5dc7b265b86636ed32947aab98bd9b5732c4b298ade93e9a09bab82ad37fc7ca2d7c97dfd87634756b3c55015d47696c0a6ed2cb44be03659bcf55
|
||||||
SHA512 (rust-1.47.0-i686-unknown-linux-gnu.tar.xz) = 551204b4edfc1500aa83108c88b845997bb6befba0dd3401e9ae5294ab27960421f1b3130159946b996171c1d46f7532afa0c3ae767a9318985db0bb7c88dba0
|
SHA512 (rust-1.48.0-i686-unknown-linux-gnu.tar.xz) = b8b3c5407304a333fc6c10ad70363589a88673640dda7b5fde8971097e679f56a8c733da31b2183044ae2ce30700db923cc3c3cb8c590d785df680b60b199451
|
||||||
SHA512 (rust-1.47.0-powerpc64le-unknown-linux-gnu.tar.xz) = d5c6580861786545f0540cc9591884fb9f2036061bdd451d17cf8bfb427008d365cacd14e5054028c72b83d1d5eb347ab74478a882cbbd7fcc75a7421657561c
|
SHA512 (rust-1.48.0-powerpc64le-unknown-linux-gnu.tar.xz) = 7ddd2b0599872012f8613ccab456622cb05a0a43587b7d389e8b7fdf9381f0387763726d892da931233c89e8e3ce45c2b303ed00b1cce1f91c88d8f88d6b148d
|
||||||
SHA512 (rust-1.47.0-powerpc64-unknown-linux-gnu.tar.xz) = 46fa1c042aebb06db4185fed6ef3bc7772f2a13f2290a20f5499757aae2a05dc984026315be7b5813aac172f52f50565e56aa074d32f6271858590a9ceb9e1c7
|
SHA512 (rust-1.48.0-powerpc64-unknown-linux-gnu.tar.xz) = f79e1f984cc3c4dce08599418be2885666e0b6f73e639b10e97ffff4b900606d880c0596b6c2ab7c5f999cfc364d22b2ca6ab88db6ba38b8b227670b222fe23b
|
||||||
SHA512 (rust-1.47.0-s390x-unknown-linux-gnu.tar.xz) = dd5877b6ff5c310ca6aa23c1cc621e6b0675d4c46f5a06b2a0b107641b604a1a2101109ba8e286267bab1158768c601d5d9a922a8da72486c91755ef465720c0
|
SHA512 (rust-1.48.0-s390x-unknown-linux-gnu.tar.xz) = b2b1565f3b1cc0c3bf4aa06aba1da7df775c6e29c892ca7727d0e549f175b632080433be2586e799c5636231de6c678f0228dedee8358fbf167016a1f7d25389
|
||||||
SHA512 (rust-1.47.0-x86_64-unknown-linux-gnu.tar.xz) = f695986ab8e67636b0e92ca7ea223984121e3c22788434a6f1062690e7932f6b30c0c302160fef96831f821acedaf8a909bd3d00a9aa873c7200d2b8fa39013f
|
SHA512 (rust-1.48.0-x86_64-unknown-linux-gnu.tar.xz) = 0784e156e70c47386abfa88ecfeb62b1109364459b1fee225de0749c30379c4eb443ff3ff7faa7dc1a6ff373bc6eb43997007f937889cb35daf940a74641753b
|
||||||
|
Loading…
Reference in New Issue
Block a user