Update to 1.63.0.
Related: rhbz#2123902
This commit is contained in:
parent
4cce58fc28
commit
55ada7b79f
1
.gitignore
vendored
1
.gitignore
vendored
@ -389,3 +389,4 @@
|
|||||||
/wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz
|
/wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz
|
||||||
/rustc-1.62.0-src.tar.xz
|
/rustc-1.62.0-src.tar.xz
|
||||||
/rustc-1.62.1-src.tar.xz
|
/rustc-1.62.1-src.tar.xz
|
||||||
|
/rustc-1.63.0-src.tar.xz
|
||||||
|
17
rust.spec
17
rust.spec
@ -8,9 +8,9 @@
|
|||||||
# To bootstrap from scratch, set the channel and date from src/stage0.json
|
# To bootstrap from scratch, set the channel and date from src/stage0.json
|
||||||
# e.g. 1.59.0 wants rustc: 1.58.0-2022-01-13
|
# e.g. 1.59.0 wants rustc: 1.58.0-2022-01-13
|
||||||
# or nightly wants some beta-YYYY-MM-DD
|
# or nightly wants some beta-YYYY-MM-DD
|
||||||
%global bootstrap_version 1.61.0
|
%global bootstrap_version 1.62.0
|
||||||
%global bootstrap_channel 1.61.0
|
%global bootstrap_channel 1.62.0
|
||||||
%global bootstrap_date 2022-05-19
|
%global bootstrap_date 2022-06-30
|
||||||
|
|
||||||
# Only the specified arches will use bootstrap binaries.
|
# Only the specified arches will use bootstrap binaries.
|
||||||
# NOTE: Those binaries used to be uploaded with every new release, but that was
|
# NOTE: Those binaries used to be uploaded with every new release, but that was
|
||||||
@ -46,7 +46,7 @@
|
|||||||
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
||||||
# is insufficient. Rust currently requires LLVM 12.0+.
|
# is insufficient. Rust currently requires LLVM 12.0+.
|
||||||
%global min_llvm_version 12.0.0
|
%global min_llvm_version 12.0.0
|
||||||
%global bundled_llvm_version 14.0.4
|
%global bundled_llvm_version 14.0.5
|
||||||
%bcond_with bundled_llvm
|
%bcond_with bundled_llvm
|
||||||
|
|
||||||
# Requires stable libgit2 1.4, and not the next minor soname change.
|
# Requires stable libgit2 1.4, and not the next minor soname change.
|
||||||
@ -83,7 +83,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: rust
|
Name: rust
|
||||||
Version: 1.62.1
|
Version: 1.63.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Rust Programming Language
|
Summary: The Rust Programming Language
|
||||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||||
@ -116,7 +116,7 @@ Patch100: rustc-1.59.0-disable-libssh2.patch
|
|||||||
|
|
||||||
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
||||||
# will try to build it statically -- instead we turn off the feature.
|
# will try to build it statically -- instead we turn off the feature.
|
||||||
Patch101: rustc-1.62.0-disable-http2.patch
|
Patch101: rustc-1.63.0-disable-http2.patch
|
||||||
|
|
||||||
# kernel rh1410097 causes too-small stacks for PIE.
|
# kernel rh1410097 causes too-small stacks for PIE.
|
||||||
# (affects RHEL6 kernels when building for RHEL7)
|
# (affects RHEL6 kernels when building for RHEL7)
|
||||||
@ -630,7 +630,7 @@ ln -s /usr/bin/cmake3 cmake-bin/cmake
|
|||||||
# Static linking to distro LLVM needs to add -lffi
|
# Static linking to distro LLVM needs to add -lffi
|
||||||
# https://github.com/rust-lang/rust/issues/34486
|
# https://github.com/rust-lang/rust/issues/34486
|
||||||
sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
|
sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
|
||||||
src/librustc_llvm/lib.rs
|
compiler/rustc_llvm/src/lib.rs
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# The configure macro will modify some autoconf-related files, which upsets
|
# The configure macro will modify some autoconf-related files, which upsets
|
||||||
@ -1032,6 +1032,9 @@ end}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 07 2022 Josh Stone <jistone@redhat.com> - 1.63.0-1
|
||||||
|
- Update to 1.63.0.
|
||||||
|
|
||||||
* Tue Jul 19 2022 Josh Stone <jistone@redhat.com> - 1.62.1-1
|
* Tue Jul 19 2022 Josh Stone <jistone@redhat.com> - 1.62.1-1
|
||||||
- Update to 1.62.1.
|
- Update to 1.62.1.
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- rustc-beta-src/Cargo.lock.orig 2022-06-22 14:03:26.309745526 -0700
|
--- rustc-1.63.0-src/Cargo.lock.orig 2022-08-10 12:25:16.512185135 -0700
|
||||||
+++ rustc-beta-src/Cargo.lock 2022-06-22 14:03:26.310745506 -0700
|
+++ rustc-1.63.0-src/Cargo.lock 2022-08-10 12:25:16.513185114 -0700
|
||||||
@@ -990,7 +990,6 @@
|
@@ -1054,7 +1054,6 @@
|
||||||
dependencies = [
|
dependencies = [
|
||||||
"cc",
|
"cc",
|
||||||
"libc",
|
"libc",
|
||||||
@ -8,7 +8,7 @@
|
|||||||
"libz-sys",
|
"libz-sys",
|
||||||
"openssl-sys",
|
"openssl-sys",
|
||||||
"pkg-config",
|
"pkg-config",
|
||||||
@@ -2101,16 +2100,6 @@
|
@@ -2160,16 +2159,6 @@
|
||||||
checksum = "7fc7aa29613bd6a620df431842069224d8bc9011086b1db4c0e0cd47fa03ec9a"
|
checksum = "7fc7aa29613bd6a620df431842069224d8bc9011086b1db4c0e0cd47fa03ec9a"
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
@ -25,20 +25,20 @@
|
|||||||
name = "libz-sys"
|
name = "libz-sys"
|
||||||
version = "1.1.3"
|
version = "1.1.3"
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||||
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2022-06-22 14:03:26.310745506 -0700
|
--- rustc-1.63.0-src/src/tools/cargo/Cargo.toml.orig 2022-08-10 12:25:16.514185093 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2022-06-22 14:04:22.058596881 -0700
|
+++ rustc-1.63.0-src/src/tools/cargo/Cargo.toml 2022-08-10 12:25:51.441455282 -0700
|
||||||
@@ -22,7 +22,7 @@
|
@@ -22,7 +22,7 @@
|
||||||
cargo-util = { path = "crates/cargo-util", version = "0.1.3" }
|
cargo-util = { path = "crates/cargo-util", version = "0.2.1" }
|
||||||
crates-io = { path = "crates/crates-io", version = "0.34.0" }
|
crates-io = { path = "crates/crates-io", version = "0.34.0" }
|
||||||
crossbeam-utils = "0.8"
|
crossbeam-utils = "0.8"
|
||||||
-curl = { version = "0.4.41", features = ["http2"] }
|
-curl = { version = "0.4.43", features = ["http2"] }
|
||||||
+curl = { version = "0.4.41", features = [] }
|
+curl = { version = "0.4.43", features = [] }
|
||||||
curl-sys = "0.4.50"
|
curl-sys = "0.4.55"
|
||||||
env_logger = "0.9.0"
|
env_logger = "0.9.0"
|
||||||
pretty_env_logger = { version = "0.4", optional = true }
|
pretty_env_logger = { version = "0.4", optional = true }
|
||||||
--- rustc-beta-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs.orig 2022-06-13 07:34:54.000000000 -0700
|
--- rustc-1.63.0-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs.orig 2022-08-08 15:47:35.000000000 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs 2022-06-22 14:03:26.311745485 -0700
|
+++ rustc-1.63.0-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs 2022-08-10 12:25:16.514185093 -0700
|
||||||
@@ -183,16 +183,8 @@
|
@@ -192,16 +192,8 @@
|
||||||
}
|
}
|
||||||
self.fetch_started = true;
|
self.fetch_started = true;
|
||||||
|
|
||||||
@ -57,8 +57,8 @@
|
|||||||
|
|
||||||
self.config
|
self.config
|
||||||
.shell()
|
.shell()
|
||||||
--- rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs.orig 2022-06-13 07:34:54.000000000 -0700
|
--- rustc-1.63.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2022-08-08 15:47:35.000000000 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs 2022-06-22 14:03:26.311745485 -0700
|
+++ rustc-1.63.0-src/src/tools/cargo/src/cargo/core/package.rs 2022-08-10 12:25:16.514185093 -0700
|
||||||
@@ -403,16 +403,9 @@
|
@@ -403,16 +403,9 @@
|
||||||
sources: SourceMap<'cfg>,
|
sources: SourceMap<'cfg>,
|
||||||
config: &'cfg Config,
|
config: &'cfg Config,
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (rustc-1.62.1-src.tar.xz) = 6f7fa855acdf20525e907a6fc8c7aa8b206603e3bcbd532d3bdce165380f0019f45dba2b2b06d20b541381accf67ca0d256fbddfcb1642a2e60e1237807d5410
|
SHA512 (rustc-1.63.0-src.tar.xz) = 0dd3cd1546bd9c1438afe0c4694e1ed80507f6b437674682c0474e13f83457e9ced4560ddeee58602e01837140f9e34a9e24c6828643dd6f613e07755af6997c
|
||||||
SHA512 (wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz) = 5b6af0f7133d31c2c068606737eff957126a3045e09c1e95bd2650e0c5637d4797d7036b9beb167829d38d58f6d4199852832f61b0c8836f05e945cd0cf68132
|
SHA512 (wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz) = 5b6af0f7133d31c2c068606737eff957126a3045e09c1e95bd2650e0c5637d4797d7036b9beb167829d38d58f6d4199852832f61b0c8836f05e945cd0cf68132
|
||||||
|
Loading…
Reference in New Issue
Block a user