import rust-1.49.0-1.module+el8.4.0+9446+1a463e08
This commit is contained in:
parent
957838d1cc
commit
2a05617f78
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/rustc-1.47.0-src.tar.xz
|
SOURCES/rustc-1.49.0-src.tar.xz
|
||||||
|
@ -1 +1 @@
|
|||||||
7c74bea0e1db296aa0cf8c6e0b6fb1d392b62c0c SOURCES/rustc-1.47.0-src.tar.xz
|
f6f4d4e41694935511097c3913d9f720d5e606f8 SOURCES/rustc-1.49.0-src.tar.xz
|
||||||
|
@ -1,46 +0,0 @@
|
|||||||
From f200c1e7afdd04b42c01c0108735e5b14ca07d93 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Stone <jistone@redhat.com>
|
|
||||||
Date: Fri, 9 Oct 2020 20:12:26 -0700
|
|
||||||
Subject: [PATCH] doc: disambiguate stat in MetadataExt::as_raw_stat
|
|
||||||
|
|
||||||
A few architectures in `os::linux::raw` import `libc::stat`, rather than
|
|
||||||
defining that type directly. However, that also imports the _function_
|
|
||||||
called `stat`, which makes this doc link ambiguous:
|
|
||||||
|
|
||||||
error: `crate::os::linux::raw::stat` is both a struct and a function
|
|
||||||
--> library/std/src/os/linux/fs.rs:21:19
|
|
||||||
|
|
|
||||||
21 | /// [`stat`]: crate::os::linux::raw::stat
|
|
||||||
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^ ambiguous link
|
|
||||||
|
|
|
||||||
= note: `-D broken-intra-doc-links` implied by `-D warnings`
|
|
||||||
help: to link to the struct, prefix with the item type
|
|
||||||
|
|
|
||||||
21 | /// [`stat`]: struct@crate::os::linux::raw::stat
|
|
||||||
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
|
|
||||||
help: to link to the function, add parentheses
|
|
||||||
|
|
|
||||||
21 | /// [`stat`]: crate::os::linux::raw::stat()
|
|
||||||
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
|
|
||||||
|
|
||||||
We want the `struct`, so it's now prefixed accordingly.
|
|
||||||
---
|
|
||||||
library/std/src/os/linux/fs.rs | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/library/std/src/os/linux/fs.rs b/library/std/src/os/linux/fs.rs
|
|
||||||
index ff23c3d67e3b..9b7af97616c9 100644
|
|
||||||
--- a/library/std/src/os/linux/fs.rs
|
|
||||||
+++ b/library/std/src/os/linux/fs.rs
|
|
||||||
@@ -20,7 +20,7 @@ pub trait MetadataExt {
|
|
||||||
/// Unix platforms. The `os::unix::fs::MetadataExt` trait contains the
|
|
||||||
/// cross-Unix abstractions contained within the raw stat.
|
|
||||||
///
|
|
||||||
- /// [`stat`]: crate::os::linux::raw::stat
|
|
||||||
+ /// [`stat`]: struct@crate::os::linux::raw::stat
|
|
||||||
///
|
|
||||||
/// # Examples
|
|
||||||
///
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
From 6f8efee8c936de65bc31610eea30abd5461a5dd1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Stone <jistone@redhat.com>
|
|
||||||
Date: Thu, 8 Oct 2020 15:53:49 -0700
|
|
||||||
Subject: [PATCH] use NativeEndian in symbolize::gimli::Context
|
|
||||||
|
|
||||||
`Object` uses `NativeEndian`, so the `Context` should too.
|
|
||||||
|
|
||||||
Cc: https://github.com/rust-lang/rust/issues/77410
|
|
||||||
---
|
|
||||||
src/symbolize/gimli.rs | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/symbolize/gimli.rs b/src/symbolize/gimli.rs
|
|
||||||
index 58ed8bafca3d..273ff43f1c8c 100644
|
|
||||||
--- a/src/symbolize/gimli.rs
|
|
||||||
+++ b/src/symbolize/gimli.rs
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
//! intended to wholesale replace the `libbacktrace.rs` implementation.
|
|
||||||
|
|
||||||
use self::gimli::read::EndianSlice;
|
|
||||||
-use self::gimli::LittleEndian as Endian;
|
|
||||||
+use self::gimli::NativeEndian as Endian;
|
|
||||||
use self::mmap::Mmap;
|
|
||||||
use self::stash::Stash;
|
|
||||||
use super::BytesOrWideString;
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
--- rustc-1.47.0-src/Cargo.lock.orig 2020-10-07 00:53:22.000000000 -0700
|
--- rustc-1.48.0-src/Cargo.lock.orig 2020-11-16 06:01:53.000000000 -0800
|
||||||
+++ rustc-1.47.0-src/Cargo.lock 2020-10-08 12:15:07.361298619 -0700
|
+++ rustc-1.48.0-src/Cargo.lock 2020-11-16 09:27:44.425104404 -0800
|
||||||
@@ -1636,7 +1636,6 @@
|
@@ -1676,7 +1676,6 @@
|
||||||
dependencies = [
|
dependencies = [
|
||||||
"cc",
|
"cc",
|
||||||
"libc",
|
"libc",
|
||||||
@ -8,14 +8,14 @@
|
|||||||
"libz-sys",
|
"libz-sys",
|
||||||
"openssl-sys",
|
"openssl-sys",
|
||||||
"pkg-config",
|
"pkg-config",
|
||||||
@@ -1653,20 +1652,6 @@
|
@@ -1693,20 +1692,6 @@
|
||||||
]
|
]
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
-name = "libssh2-sys"
|
-name = "libssh2-sys"
|
||||||
-version = "0.2.18"
|
-version = "0.2.19"
|
||||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||||
-checksum = "eafa907407504b0e683786d4aba47acf250f114d37357d56608333fd167dd0fc"
|
-checksum = "ca46220853ba1c512fc82826d0834d87b06bcd3c2a42241b7de72f3d2fe17056"
|
||||||
-dependencies = [
|
-dependencies = [
|
||||||
- "cc",
|
- "cc",
|
||||||
- "libc",
|
- "libc",
|
||||||
@ -27,10 +27,10 @@
|
|||||||
-
|
-
|
||||||
-[[package]]
|
-[[package]]
|
||||||
name = "libz-sys"
|
name = "libz-sys"
|
||||||
version = "1.0.27"
|
version = "1.1.2"
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||||
--- rustc-1.47.0-src/vendor/git2/Cargo.toml.orig 2020-10-07 02:33:31.000000000 -0700
|
--- rustc-1.48.0-src/vendor/git2/Cargo.toml.orig 2020-11-16 06:27:49.000000000 -0800
|
||||||
+++ rustc-1.47.0-src/vendor/git2/Cargo.toml 2020-10-08 12:13:37.697228272 -0700
|
+++ rustc-1.48.0-src/vendor/git2/Cargo.toml 2020-11-16 09:27:44.425104404 -0800
|
||||||
@@ -49,7 +49,7 @@
|
@@ -49,7 +49,7 @@
|
||||||
version = "0.1.39"
|
version = "0.1.39"
|
||||||
|
|
@ -1,8 +1,6 @@
|
|||||||
diff --git a/src/librustc_codegen_ssa/back/link.rs b/src/librustc_codegen_ssa/back/link.rs
|
--- rustc-1.48.0-src/compiler/rustc_codegen_ssa/src/back/link.rs.orig 2020-11-16 06:01:53.000000000 -0800
|
||||||
index dcce1d45298c..5c11f7276f26 100644
|
+++ rustc-1.48.0-src/compiler/rustc_codegen_ssa/src/back/link.rs 2020-11-16 09:37:15.779516797 -0800
|
||||||
--- a/src/librustc_codegen_ssa/back/link.rs
|
@@ -1185,10 +1185,12 @@
|
||||||
+++ b/src/librustc_codegen_ssa/back/link.rs
|
|
||||||
@@ -1184,10 +1184,12 @@ fn exec_linker(
|
|
||||||
}
|
}
|
||||||
|
|
||||||
fn link_output_kind(sess: &Session, crate_type: CrateType) -> LinkOutputKind {
|
fn link_output_kind(sess: &Session, crate_type: CrateType) -> LinkOutputKind {
|
@ -1,6 +1,6 @@
|
|||||||
--- rustc-1.47.0-src/Cargo.lock.orig 2020-10-08 12:21:40.516837553 -0700
|
--- rustc-1.49.0-src/Cargo.lock.orig 2021-01-05 12:45:10.456414612 -0800
|
||||||
+++ rustc-1.47.0-src/Cargo.lock 2020-10-08 12:23:25.327581933 -0700
|
+++ rustc-1.49.0-src/Cargo.lock 2021-01-05 12:45:10.458414575 -0800
|
||||||
@@ -837,7 +837,6 @@
|
@@ -882,7 +882,6 @@
|
||||||
dependencies = [
|
dependencies = [
|
||||||
"cc",
|
"cc",
|
||||||
"libc",
|
"libc",
|
||||||
@ -8,7 +8,7 @@
|
|||||||
"libz-sys",
|
"libz-sys",
|
||||||
"openssl-sys",
|
"openssl-sys",
|
||||||
"pkg-config",
|
"pkg-config",
|
||||||
@@ -1642,16 +1641,6 @@
|
@@ -1728,16 +1727,6 @@
|
||||||
]
|
]
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
@ -23,22 +23,22 @@
|
|||||||
-
|
-
|
||||||
-[[package]]
|
-[[package]]
|
||||||
name = "libz-sys"
|
name = "libz-sys"
|
||||||
version = "1.0.27"
|
version = "1.1.2"
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||||
--- rustc-1.47.0-src/src/tools/cargo/Cargo.toml.orig 2020-10-07 01:04:03.000000000 -0700
|
--- rustc-1.49.0-src/src/tools/cargo/Cargo.toml.orig 2021-01-05 12:45:10.458414575 -0800
|
||||||
+++ rustc-1.47.0-src/src/tools/cargo/Cargo.toml 2020-10-08 12:22:17.830034534 -0700
|
+++ rustc-1.49.0-src/src/tools/cargo/Cargo.toml 2021-01-05 12:47:25.966928554 -0800
|
||||||
@@ -25,7 +25,7 @@
|
@@ -25,7 +25,7 @@
|
||||||
crates-io = { path = "crates/crates-io", version = "0.31.1" }
|
crates-io = { path = "crates/crates-io", version = "0.31.1" }
|
||||||
crossbeam-utils = "0.7"
|
crossbeam-utils = "0.8"
|
||||||
crypto-hash = "0.3.1"
|
crypto-hash = "0.3.1"
|
||||||
-curl = { version = "0.4.23", features = ["http2"] }
|
-curl = { version = "0.4.23", features = ["http2"] }
|
||||||
+curl = { version = "0.4.23", features = [] }
|
+curl = { version = "0.4.23", features = [] }
|
||||||
curl-sys = "0.4.22"
|
curl-sys = "0.4.22"
|
||||||
env_logger = "0.7.0"
|
env_logger = "0.8.1"
|
||||||
pretty_env_logger = { version = "0.4", optional = true }
|
pretty_env_logger = { version = "0.4", optional = true }
|
||||||
--- rustc-1.47.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-10-07 01:04:03.000000000 -0700
|
--- rustc-1.49.0-src/src/tools/cargo/src/cargo/core/package.rs.orig 2020-12-28 19:03:25.000000000 -0800
|
||||||
+++ rustc-1.47.0-src/src/tools/cargo/src/cargo/core/package.rs 2020-10-08 12:23:11.246884961 -0700
|
+++ rustc-1.49.0-src/src/tools/cargo/src/cargo/core/package.rs 2021-01-05 12:45:10.458414575 -0800
|
||||||
@@ -396,14 +396,8 @@
|
@@ -408,14 +408,8 @@
|
||||||
// Also note that pipelining is disabled as curl authors have indicated
|
// Also note that pipelining is disabled as curl authors have indicated
|
||||||
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
// that it's buggy, and we've empirically seen that it's buggy with HTTP
|
||||||
// proxies.
|
// proxies.
|
||||||
@ -55,7 +55,7 @@
|
|||||||
|
|
||||||
Ok(PackageSet {
|
Ok(PackageSet {
|
||||||
packages: package_ids
|
packages: package_ids
|
||||||
@@ -566,7 +560,7 @@
|
@@ -584,7 +578,7 @@
|
||||||
macro_rules! try_old_curl {
|
macro_rules! try_old_curl {
|
||||||
($e:expr, $msg:expr) => {
|
($e:expr, $msg:expr) => {
|
||||||
let result = $e;
|
let result = $e;
|
@ -1,5 +1,5 @@
|
|||||||
# Only x86_64 and i686 are Tier 1 platforms at this time.
|
# Only x86_64 and i686 are Tier 1 platforms at this time.
|
||||||
# https://forge.rust-lang.org/platform-support.html
|
# https://doc.rust-lang.org/nightly/rustc/platform-support.html
|
||||||
#global rust_arches x86_64 i686 armv7hl aarch64 ppc64 ppc64le s390x
|
#global rust_arches x86_64 i686 armv7hl aarch64 ppc64 ppc64le s390x
|
||||||
%global rust_arches x86_64 i686 aarch64 ppc64le s390x
|
%global rust_arches x86_64 i686 aarch64 ppc64le s390x
|
||||||
|
|
||||||
@ -10,10 +10,10 @@
|
|||||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||||
# or nightly wants some beta-YYYY-MM-DD
|
# or nightly wants some beta-YYYY-MM-DD
|
||||||
# Note that cargo matches the program version here, not its crate version.
|
# Note that cargo matches the program version here, not its crate version.
|
||||||
%global bootstrap_rust 1.46.0
|
%global bootstrap_rust 1.48.0
|
||||||
%global bootstrap_cargo 1.46.0
|
%global bootstrap_cargo 1.48.0
|
||||||
%global bootstrap_channel 1.46.0
|
%global bootstrap_channel 1.48.0
|
||||||
%global bootstrap_date 2020-08-27
|
%global bootstrap_date 2020-11-19
|
||||||
|
|
||||||
# Only the specified arches will use bootstrap binaries.
|
# Only the specified arches will use bootstrap binaries.
|
||||||
#global bootstrap_arches %%{rust_arches}
|
#global bootstrap_arches %%{rust_arches}
|
||||||
@ -53,7 +53,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: rust
|
Name: rust
|
||||||
Version: 1.47.0
|
Version: 1.49.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Rust Programming Language
|
Summary: The Rust Programming Language
|
||||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||||
@ -68,24 +68,18 @@ ExclusiveArch: %{rust_arches}
|
|||||||
%endif
|
%endif
|
||||||
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||||
|
|
||||||
# https://github.com/rust-lang/backtrace-rs/pull/373
|
|
||||||
Patch1: 0001-use-NativeEndian-in-symbolize-gimli-Context.patch
|
|
||||||
|
|
||||||
# https://github.com/rust-lang/rust/pull/77777
|
|
||||||
Patch2: 0001-doc-disambiguate-stat-in-MetadataExt-as_raw_stat.patch
|
|
||||||
|
|
||||||
### RHEL-specific patches below ###
|
### RHEL-specific patches below ###
|
||||||
|
|
||||||
# Disable cargo->libgit2->libssh2 on RHEL, as it's not approved for FIPS (rhbz1732949)
|
# Disable cargo->libgit2->libssh2 on RHEL, as it's not approved for FIPS (rhbz1732949)
|
||||||
Patch100: rustc-1.47.0-disable-libssh2.patch
|
Patch100: rustc-1.48.0-disable-libssh2.patch
|
||||||
|
|
||||||
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
||||||
# will try to build it statically -- instead we turn off the feature.
|
# will try to build it statically -- instead we turn off the feature.
|
||||||
Patch101: rustc-1.47.0-disable-http2.patch
|
Patch101: rustc-1.49.0-disable-http2.patch
|
||||||
|
|
||||||
# kernel rh1410097 causes too-small stacks for PIE.
|
# kernel rh1410097 causes too-small stacks for PIE.
|
||||||
# (affects RHEL6 kernels when building for RHEL7)
|
# (affects RHEL6 kernels when building for RHEL7)
|
||||||
Patch102: rustc-1.45.0-no-default-pie.patch
|
Patch102: rustc-1.48.0-no-default-pie.patch
|
||||||
|
|
||||||
|
|
||||||
# Get the Rust triple for any arch.
|
# Get the Rust triple for any arch.
|
||||||
@ -158,7 +152,7 @@ BuildRequires: pkgconfig(zlib)
|
|||||||
BuildRequires: pkgconfig(libgit2) >= 1.0.0
|
BuildRequires: pkgconfig(libgit2) >= 1.0.0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{without disabled_libssh2} && %{without bundled_libssh2}
|
%if %{without disabled_libssh2}
|
||||||
# needs libssh2_userauth_publickey_frommemory
|
# needs libssh2_userauth_publickey_frommemory
|
||||||
BuildRequires: pkgconfig(libssh2) >= 1.6.0
|
BuildRequires: pkgconfig(libssh2) >= 1.6.0
|
||||||
%endif
|
%endif
|
||||||
@ -180,7 +174,7 @@ BuildRequires: cmake >= 2.8.11
|
|||||||
%global llvm llvm
|
%global llvm llvm
|
||||||
%global llvm_root %{_prefix}
|
%global llvm_root %{_prefix}
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: %{llvm}-devel >= 8.0
|
BuildRequires: %{llvm}-devel >= 9.0
|
||||||
%if %with llvm_static
|
%if %with llvm_static
|
||||||
BuildRequires: %{llvm}-static
|
BuildRequires: %{llvm}-static
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
@ -298,10 +292,7 @@ its standard library.
|
|||||||
%package -n cargo
|
%package -n cargo
|
||||||
Summary: Rust's package manager and build tool
|
Summary: Rust's package manager and build tool
|
||||||
%if %with bundled_libgit2
|
%if %with bundled_libgit2
|
||||||
Provides: bundled(libgit2) = 1.0.0
|
Provides: bundled(libgit2) = 1.1.0
|
||||||
%endif
|
|
||||||
%if %with bundled_libssh2
|
|
||||||
Provides: bundled(libssh2) = 1.9.0~dev
|
|
||||||
%endif
|
%endif
|
||||||
# For tests:
|
# For tests:
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
@ -344,10 +335,7 @@ A tool for formatting Rust code according to style guidelines.
|
|||||||
%package -n rls
|
%package -n rls
|
||||||
Summary: Rust Language Server for IDE integration
|
Summary: Rust Language Server for IDE integration
|
||||||
%if %with bundled_libgit2
|
%if %with bundled_libgit2
|
||||||
Provides: bundled(libgit2) = 1.0.0
|
Provides: bundled(libgit2) = 1.1.0
|
||||||
%endif
|
|
||||||
%if %with bundled_libssh2
|
|
||||||
Provides: bundled(libssh2) = 1.9.0~dev
|
|
||||||
%endif
|
%endif
|
||||||
Requires: rust-analysis
|
Requires: rust-analysis
|
||||||
# /usr/bin/rls is dynamically linked against internal rustc libs
|
# /usr/bin/rls is dynamically linked against internal rustc libs
|
||||||
@ -409,9 +397,6 @@ test -f '%{local_rust_root}/bin/rustc'
|
|||||||
|
|
||||||
%setup -q -n %{rustc_package}
|
%setup -q -n %{rustc_package}
|
||||||
|
|
||||||
%patch1 -p1 -d library/backtrace
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%if %with disabled_libssh2
|
%if %with disabled_libssh2
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
%endif
|
%endif
|
||||||
@ -422,7 +407,7 @@ rm -rf vendor/libnghttp2-sys/
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||||
%patch102 -p1 -b .no-pie
|
%patch102 -p1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if "%{python}" != "python3"
|
%if "%{python}" != "python3"
|
||||||
@ -432,12 +417,15 @@ sed -i.try-python -e '/^try python3 /i try "%{python}" "$@"' ./configure
|
|||||||
|
|
||||||
%if %without bundled_llvm
|
%if %without bundled_llvm
|
||||||
rm -rf src/llvm-project/
|
rm -rf src/llvm-project/
|
||||||
|
mkdir -p src/llvm-project/libunwind/
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Remove other unused vendored libraries
|
# Remove other unused vendored libraries
|
||||||
rm -rf vendor/curl-sys/curl/
|
rm -rf vendor/curl-sys/curl/
|
||||||
rm -rf vendor/jemalloc-sys/jemalloc/
|
rm -rf vendor/jemalloc-sys/jemalloc/
|
||||||
|
rm -rf vendor/libssh2-sys/libssh2/
|
||||||
rm -rf vendor/libz-sys/src/zlib/
|
rm -rf vendor/libz-sys/src/zlib/
|
||||||
|
rm -rf vendor/libz-sys/src/zlib-ng/
|
||||||
rm -rf vendor/lzma-sys/xz-*/
|
rm -rf vendor/lzma-sys/xz-*/
|
||||||
rm -rf vendor/openssl-src/openssl/
|
rm -rf vendor/openssl-src/openssl/
|
||||||
|
|
||||||
@ -445,9 +433,6 @@ rm -rf vendor/openssl-src/openssl/
|
|||||||
rm -rf vendor/libgit2-sys/libgit2/
|
rm -rf vendor/libgit2-sys/libgit2/
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %without bundled_libssh2
|
|
||||||
rm -rf vendor/libssh2-sys/libssh2/
|
|
||||||
%endif
|
|
||||||
%if %with disabled_libssh2
|
%if %with disabled_libssh2
|
||||||
rm -rf vendor/libssh2-sys/
|
rm -rf vendor/libssh2-sys/
|
||||||
%endif
|
%endif
|
||||||
@ -487,7 +472,7 @@ find -name '*.rs' -type f -perm /111 -exec chmod -v -x '{}' '+'
|
|||||||
# convince libgit2-sys to use the distro libgit2
|
# convince libgit2-sys to use the distro libgit2
|
||||||
%global rust_env %{rust_env} LIBGIT2_SYS_USE_PKG_CONFIG=1
|
%global rust_env %{rust_env} LIBGIT2_SYS_USE_PKG_CONFIG=1
|
||||||
%endif
|
%endif
|
||||||
%if %without bundled_libssh2
|
%if %without disabled_libssh2
|
||||||
# convince libssh2-sys to use the distro libssh2
|
# convince libssh2-sys to use the distro libssh2
|
||||||
%global rust_env %{rust_env} LIBSSH2_SYS_USE_PKG_CONFIG=1
|
%global rust_env %{rust_env} LIBSSH2_SYS_USE_PKG_CONFIG=1
|
||||||
%endif
|
%endif
|
||||||
@ -681,7 +666,6 @@ export %{rust_env}
|
|||||||
%{_docdir}/%{name}/html/*/
|
%{_docdir}/%{name}/html/*/
|
||||||
%{_docdir}/%{name}/html/*.html
|
%{_docdir}/%{name}/html/*.html
|
||||||
%{_docdir}/%{name}/html/*.css
|
%{_docdir}/%{name}/html/*.css
|
||||||
%{_docdir}/%{name}/html/*.ico
|
|
||||||
%{_docdir}/%{name}/html/*.js
|
%{_docdir}/%{name}/html/*.js
|
||||||
%{_docdir}/%{name}/html/*.png
|
%{_docdir}/%{name}/html/*.png
|
||||||
%{_docdir}/%{name}/html/*.svg
|
%{_docdir}/%{name}/html/*.svg
|
||||||
@ -737,6 +721,12 @@ export %{rust_env}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 13 2021 Josh Stone <jistone@redhat.com> - 1.49.0-1
|
||||||
|
- Update to 1.49.0.
|
||||||
|
|
||||||
|
* Tue Jan 12 2021 Josh Stone <jistone@redhat.com> - 1.48.0-1
|
||||||
|
- Update to 1.48.0.
|
||||||
|
|
||||||
* Thu Oct 22 2020 Josh Stone <jistone@redhat.com> - 1.47.0-1
|
* Thu Oct 22 2020 Josh Stone <jistone@redhat.com> - 1.47.0-1
|
||||||
- Update to 1.47.0.
|
- Update to 1.47.0.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user