Update to 1.62.0.
Resolves: rhbz#2075337
This commit is contained in:
parent
510485acbb
commit
24b9a1b8a7
1
.gitignore
vendored
1
.gitignore
vendored
@ -387,3 +387,4 @@
|
|||||||
/rustc-1.60.0-src.tar.xz
|
/rustc-1.60.0-src.tar.xz
|
||||||
/rustc-1.61.0-src.tar.xz
|
/rustc-1.61.0-src.tar.xz
|
||||||
/wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz
|
/wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz
|
||||||
|
/rustc-1.62.0-src.tar.xz
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From beb4e16f055aa7925194fd2c360105a6d55f10f6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Lo=C3=AFc=20BRANSTETT?= <lolo.branstett@numericable.fr>
|
|
||||||
Date: Wed, 27 Apr 2022 19:11:56 +0200
|
|
||||||
Subject: [PATCH] Add missing `target_feature` to the list of well known cfg
|
|
||||||
names
|
|
||||||
|
|
||||||
---
|
|
||||||
compiler/rustc_session/src/config.rs | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
|
||||||
index 12c5c4445d46..330201dd8fef 100644
|
|
||||||
--- a/compiler/rustc_session/src/config.rs
|
|
||||||
+++ b/compiler/rustc_session/src/config.rs
|
|
||||||
@@ -1038,6 +1038,7 @@ fn fill_well_known_names(&mut self) {
|
|
||||||
sym::target_has_atomic_load_store,
|
|
||||||
sym::target_has_atomic,
|
|
||||||
sym::target_has_atomic_equal_alignment,
|
|
||||||
+ sym::target_feature,
|
|
||||||
sym::panic,
|
|
||||||
sym::sanitize,
|
|
||||||
sym::debug_assertions,
|
|
||||||
@@ -1081,6 +1082,10 @@ fn fill_well_known_values(&mut self) {
|
|
||||||
.into_iter()
|
|
||||||
.map(|sanitizer| Symbol::intern(sanitizer.as_str().unwrap()));
|
|
||||||
|
|
||||||
+ // Unknown possible values:
|
|
||||||
+ // - `feature`
|
|
||||||
+ // - `target_feature`
|
|
||||||
+
|
|
||||||
// No-values
|
|
||||||
for name in [
|
|
||||||
sym::doc,
|
|
||||||
--
|
|
||||||
2.36.1
|
|
||||||
|
|
25
rust.spec
25
rust.spec
@ -8,9 +8,9 @@
|
|||||||
# To bootstrap from scratch, set the channel and date from src/stage0.json
|
# To bootstrap from scratch, set the channel and date from src/stage0.json
|
||||||
# e.g. 1.59.0 wants rustc: 1.58.0-2022-01-13
|
# e.g. 1.59.0 wants rustc: 1.58.0-2022-01-13
|
||||||
# or nightly wants some beta-YYYY-MM-DD
|
# or nightly wants some beta-YYYY-MM-DD
|
||||||
%global bootstrap_version 1.60.0
|
%global bootstrap_version 1.61.0
|
||||||
%global bootstrap_channel 1.60.0
|
%global bootstrap_channel 1.61.0
|
||||||
%global bootstrap_date 2022-04-07
|
%global bootstrap_date 2022-05-19
|
||||||
|
|
||||||
# Only the specified arches will use bootstrap binaries.
|
# Only the specified arches will use bootstrap binaries.
|
||||||
# NOTE: Those binaries used to be uploaded with every new release, but that was
|
# NOTE: Those binaries used to be uploaded with every new release, but that was
|
||||||
@ -46,7 +46,7 @@
|
|||||||
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
|
||||||
# is insufficient. Rust currently requires LLVM 12.0+.
|
# is insufficient. Rust currently requires LLVM 12.0+.
|
||||||
%global min_llvm_version 12.0.0
|
%global min_llvm_version 12.0.0
|
||||||
%global bundled_llvm_version 14.0.0
|
%global bundled_llvm_version 14.0.4
|
||||||
%bcond_with bundled_llvm
|
%bcond_with bundled_llvm
|
||||||
|
|
||||||
# Requires stable libgit2 1.4, and not the next minor soname change.
|
# Requires stable libgit2 1.4, and not the next minor soname change.
|
||||||
@ -83,7 +83,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: rust
|
Name: rust
|
||||||
Version: 1.61.0
|
Version: 1.62.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Rust Programming Language
|
Summary: The Rust Programming Language
|
||||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||||
@ -106,13 +106,6 @@ Patch1: 0001-Use-lld-provided-by-system-for-wasm.patch
|
|||||||
# Set a substitute-path in rust-gdb for standard library sources.
|
# Set a substitute-path in rust-gdb for standard library sources.
|
||||||
Patch2: rustc-1.61.0-rust-gdb-substitute-path.patch
|
Patch2: rustc-1.61.0-rust-gdb-substitute-path.patch
|
||||||
|
|
||||||
# Infer the type that compiletest uses for TestDesc ignore_message
|
|
||||||
Patch3: rustc-1.61.0-fix-compiletest-ignore_message.patch
|
|
||||||
|
|
||||||
# Add missing target_feature to the list of well known cfg names
|
|
||||||
# https://github.com/rust-lang/rust/pull/96483
|
|
||||||
Patch4: 0001-Add-missing-target_feature-to-the-list-of-well-known.patch
|
|
||||||
|
|
||||||
### RHEL-specific patches below ###
|
### RHEL-specific patches below ###
|
||||||
|
|
||||||
# Simple rpm macros for rust-toolset (as opposed to full rust-packaging)
|
# Simple rpm macros for rust-toolset (as opposed to full rust-packaging)
|
||||||
@ -123,7 +116,7 @@ Patch100: rustc-1.59.0-disable-libssh2.patch
|
|||||||
|
|
||||||
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
# libcurl on RHEL7 doesn't have http2, but since cargo requests it, curl-sys
|
||||||
# will try to build it statically -- instead we turn off the feature.
|
# will try to build it statically -- instead we turn off the feature.
|
||||||
Patch101: rustc-1.61.0-disable-http2.patch
|
Patch101: rustc-1.62.0-disable-http2.patch
|
||||||
|
|
||||||
# kernel rh1410097 causes too-small stacks for PIE.
|
# kernel rh1410097 causes too-small stacks for PIE.
|
||||||
# (affects RHEL6 kernels when building for RHEL7)
|
# (affects RHEL6 kernels when building for RHEL7)
|
||||||
@ -578,8 +571,6 @@ test -f '%{local_rust_root}/bin/rustc'
|
|||||||
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
%if %with disabled_libssh2
|
%if %with disabled_libssh2
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
@ -979,7 +970,6 @@ end}
|
|||||||
%{_docdir}/%{name}/html/*.js
|
%{_docdir}/%{name}/html/*.js
|
||||||
%{_docdir}/%{name}/html/*.png
|
%{_docdir}/%{name}/html/*.png
|
||||||
%{_docdir}/%{name}/html/*.svg
|
%{_docdir}/%{name}/html/*.svg
|
||||||
%{_docdir}/%{name}/html/*.woff
|
|
||||||
%{_docdir}/%{name}/html/*.woff2
|
%{_docdir}/%{name}/html/*.woff2
|
||||||
%license %{_docdir}/%{name}/html/*.txt
|
%license %{_docdir}/%{name}/html/*.txt
|
||||||
%license %{_docdir}/%{name}/html/*.md
|
%license %{_docdir}/%{name}/html/*.md
|
||||||
@ -1039,6 +1029,9 @@ end}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 30 2022 Josh Stone <jistone@redhat.com> - 1.62.0-1
|
||||||
|
- Update to 1.62.0.
|
||||||
|
|
||||||
* Fri Jun 03 2022 Josh Stone <jistone@redhat.com> - 1.61.0-1
|
* Fri Jun 03 2022 Josh Stone <jistone@redhat.com> - 1.61.0-1
|
||||||
- Update to 1.61.0.
|
- Update to 1.61.0.
|
||||||
- Add rust-toolset as a subpackage.
|
- Add rust-toolset as a subpackage.
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/tools/compiletest/src/header.rs b/src/tools/compiletest/src/header.rs
|
|
||||||
index 1bdea33dffaf..1c21d5e87b68 100644
|
|
||||||
--- a/src/tools/compiletest/src/header.rs
|
|
||||||
+++ b/src/tools/compiletest/src/header.rs
|
|
||||||
@@ -807,7 +807,7 @@ pub fn make_test_description<R: Read>(
|
|
||||||
) -> test::TestDesc {
|
|
||||||
let mut ignore = false;
|
|
||||||
#[cfg(not(bootstrap))]
|
|
||||||
- let ignore_message: Option<String> = None;
|
|
||||||
+ let ignore_message = None;
|
|
||||||
let mut should_fail = false;
|
|
||||||
|
|
||||||
let rustc_has_profiler_support = env::var_os("RUSTC_PROFILER_SUPPORT").is_some();
|
|
@ -1,6 +1,6 @@
|
|||||||
--- rustc-beta-src/Cargo.lock.orig 2022-04-28 15:34:11.668960640 -0700
|
--- rustc-beta-src/Cargo.lock.orig 2022-06-22 14:03:26.309745526 -0700
|
||||||
+++ rustc-beta-src/Cargo.lock 2022-04-28 15:35:24.542419588 -0700
|
+++ rustc-beta-src/Cargo.lock 2022-06-22 14:03:26.310745506 -0700
|
||||||
@@ -951,7 +951,6 @@
|
@@ -990,7 +990,6 @@
|
||||||
dependencies = [
|
dependencies = [
|
||||||
"cc",
|
"cc",
|
||||||
"libc",
|
"libc",
|
||||||
@ -8,7 +8,7 @@
|
|||||||
"libz-sys",
|
"libz-sys",
|
||||||
"openssl-sys",
|
"openssl-sys",
|
||||||
"pkg-config",
|
"pkg-config",
|
||||||
@@ -2002,16 +2001,6 @@
|
@@ -2101,16 +2100,6 @@
|
||||||
checksum = "7fc7aa29613bd6a620df431842069224d8bc9011086b1db4c0e0cd47fa03ec9a"
|
checksum = "7fc7aa29613bd6a620df431842069224d8bc9011086b1db4c0e0cd47fa03ec9a"
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
@ -25,10 +25,10 @@
|
|||||||
name = "libz-sys"
|
name = "libz-sys"
|
||||||
version = "1.1.3"
|
version = "1.1.3"
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||||
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2022-04-24 17:43:07.000000000 -0700
|
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2022-06-22 14:03:26.310745506 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2022-04-28 15:34:11.670960598 -0700
|
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2022-06-22 14:04:22.058596881 -0700
|
||||||
@@ -22,7 +22,7 @@
|
@@ -22,7 +22,7 @@
|
||||||
cargo-util = { path = "crates/cargo-util", version = "0.1.2" }
|
cargo-util = { path = "crates/cargo-util", version = "0.1.3" }
|
||||||
crates-io = { path = "crates/crates-io", version = "0.34.0" }
|
crates-io = { path = "crates/crates-io", version = "0.34.0" }
|
||||||
crossbeam-utils = "0.8"
|
crossbeam-utils = "0.8"
|
||||||
-curl = { version = "0.4.41", features = ["http2"] }
|
-curl = { version = "0.4.41", features = ["http2"] }
|
||||||
@ -36,8 +36,8 @@
|
|||||||
curl-sys = "0.4.50"
|
curl-sys = "0.4.50"
|
||||||
env_logger = "0.9.0"
|
env_logger = "0.9.0"
|
||||||
pretty_env_logger = { version = "0.4", optional = true }
|
pretty_env_logger = { version = "0.4", optional = true }
|
||||||
--- rustc-beta-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs.orig 2022-04-24 17:43:07.000000000 -0700
|
--- rustc-beta-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs.orig 2022-06-13 07:34:54.000000000 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs 2022-04-28 15:34:11.670960598 -0700
|
+++ rustc-beta-src/src/tools/cargo/src/cargo/sources/registry/http_remote.rs 2022-06-22 14:03:26.311745485 -0700
|
||||||
@@ -183,16 +183,8 @@
|
@@ -183,16 +183,8 @@
|
||||||
}
|
}
|
||||||
self.fetch_started = true;
|
self.fetch_started = true;
|
||||||
@ -57,8 +57,8 @@
|
|||||||
|
|
||||||
self.config
|
self.config
|
||||||
.shell()
|
.shell()
|
||||||
--- rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs.orig 2022-04-24 17:43:07.000000000 -0700
|
--- rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs.orig 2022-06-13 07:34:54.000000000 -0700
|
||||||
+++ rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs 2022-04-28 15:34:11.670960598 -0700
|
+++ rustc-beta-src/src/tools/cargo/src/cargo/core/package.rs 2022-06-22 14:03:26.311745485 -0700
|
||||||
@@ -403,16 +403,9 @@
|
@@ -403,16 +403,9 @@
|
||||||
sources: SourceMap<'cfg>,
|
sources: SourceMap<'cfg>,
|
||||||
config: &'cfg Config,
|
config: &'cfg Config,
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (rustc-1.61.0-src.tar.xz) = 9bbdcc1c37f7b889be0c8d195963b4c3b65267a63ea309315eda12bd3b2cd36e0060301805dfc7da440c0a8702d085ccb0bf763155b27035a078769333637fb3
|
SHA512 (rustc-1.62.0-src.tar.xz) = 02872a8409b0490fa9fa7a70756cbf103643694df6b2e2aea32ad8b70032a3162c7751cd92d78291587ee0120daeb9bc1ae5ec6136c7eb6eb584d8be3032dd3d
|
||||||
SHA512 (wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz) = 5b6af0f7133d31c2c068606737eff957126a3045e09c1e95bd2650e0c5637d4797d7036b9beb167829d38d58f6d4199852832f61b0c8836f05e945cd0cf68132
|
SHA512 (wasi-libc-9886d3d6200fcc3726329966860fc058707406cd.tar.gz) = 5b6af0f7133d31c2c068606737eff957126a3045e09c1e95bd2650e0c5637d4797d7036b9beb167829d38d58f6d4199852832f61b0c8836f05e945cd0cf68132
|
||||||
|
Loading…
Reference in New Issue
Block a user