47 lines
1.4 KiB
Diff
47 lines
1.4 KiB
Diff
From 5628c8f28940e30a40e4a5c006e738ad7b9991b6 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Tue, 26 Oct 2021 16:11:53 +0200
|
|
Subject: [PATCH 2/2] make: print executed commands
|
|
|
|
The initial version of the Makefile used @ everywhere, but this hides
|
|
errors. If anything, the user should use "make --silent" if they want
|
|
to hide the commands.
|
|
---
|
|
Makefile | 12 ++++++------
|
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index a15b95f483..0df1eaad64 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -18,23 +18,23 @@ export SYSTEMD_UTIL_DIR
|
|
build: program systemd-service man
|
|
|
|
program:
|
|
- @$(CARGO) build --release $(CARGOFLAGS)
|
|
+ $(CARGO) build --release $(CARGOFLAGS)
|
|
|
|
systemd-service:
|
|
@test -n "$(SYSTEMD_SYSTEM_GENERATOR_DIR)"
|
|
- @sed -e 's,@SYSTEMD_SYSTEM_GENERATOR_DIR@,$(SYSTEMD_SYSTEM_GENERATOR_DIR),' \
|
|
+ sed -e 's,@SYSTEMD_SYSTEM_GENERATOR_DIR@,$(SYSTEMD_SYSTEM_GENERATOR_DIR),' \
|
|
< units/systemd-zram-setup@.service.in \
|
|
> units/systemd-zram-setup@.service
|
|
|
|
man:
|
|
- @$(RONN) --organization="zram-generator developers" man/*.md
|
|
+ $(RONN) --organization="zram-generator developers" man/*.md
|
|
|
|
check: program
|
|
- @$(CARGO) test --release $(CARGOFLAGS)
|
|
+ $(CARGO) test --release $(CARGOFLAGS)
|
|
|
|
clean:
|
|
- @$(CARGO) clean
|
|
- @rm -f units/systemd-zram-setup@.service
|
|
+ $(CARGO) clean
|
|
+ rm -f units/systemd-zram-setup@.service
|
|
|
|
install: build
|
|
@test -n "$(SYSTEMD_SYSTEM_GENERATOR_DIR)"
|