rust-zram-generator/0002-make-print-executed-commands.patch
Zbigniew Jędrzejewski-Szmek 2227078dc4 Fix broken systemd-makefs path
2021-10-26 18:23:29 +02:00

47 lines
1.5 KiB
Diff

From 87f3f12d27f7a81891f9a6942de22a6084e9bc1a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Tue, 26 Oct 2021 16:11:53 +0200
Subject: [PATCH 2/5] make: print executed commands
The initial version of the Makefile used @ everywhere, but this can hide
errors in the executed commands. The user should instead use "make --silent" if
they want to hide the commands.
---
Makefile | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/Makefile b/Makefile
index 49baab926f..ff3d4e80d9 100644
--- a/Makefile
+++ b/Makefile
@@ -19,23 +19,23 @@ build: program systemd-service man
program:
@test -n "$(SYSTEMD_UTIL_DIR)"
- @$(CARGO) build --release $(CARGOFLAGS)
+ $(CARGO) build --release $(CARGOFLAGS)
systemd-service:
@test -n "$(SYSTEMD_SYSTEM_GENERATOR_DIR)"
- @sed -e 's,@SYSTEMD_SYSTEM_GENERATOR_DIR@,$(SYSTEMD_SYSTEM_GENERATOR_DIR),' \
+ sed -e 's,@SYSTEMD_SYSTEM_GENERATOR_DIR@,$(SYSTEMD_SYSTEM_GENERATOR_DIR),' \
< units/systemd-zram-setup@.service.in \
> units/systemd-zram-setup@.service
man:
- @$(RONN) --organization="zram-generator developers" man/*.md
+ $(RONN) --organization="zram-generator developers" man/*.md
check: program
- @$(CARGO) test --release $(CARGOFLAGS)
+ $(CARGO) test --release $(CARGOFLAGS)
clean:
- @$(CARGO) clean
- @rm -f units/systemd-zram-setup@.service
+ $(CARGO) clean
+ rm -f units/systemd-zram-setup@.service
install: build
@test -n "$(SYSTEMD_SYSTEM_GENERATOR_DIR)"