Adapt to new packaging
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
46bdab198d
commit
611c1e5938
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
|||||||
|
/zram-generator-0.1.1.crate
|
@ -5,39 +5,45 @@
|
|||||||
|
|
||||||
Name: rust-%{crate}
|
Name: rust-%{crate}
|
||||||
Version: 0.1.1
|
Version: 0.1.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Systemd unit generator for zram devices
|
Summary: Systemd unit generator for zram devices
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: https://github.com/systemd/zram-generator
|
URL: https://crates.io/crates/zram-generator
|
||||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Update dependencies, https://github.com/systemd/zram-generator/commit/6f2b69c4a38b6da92fc4509b7d055423b8440238
|
||||||
|
Patch0: zram-generator-fix-metadata.diff
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
BuildRequires: rust-packaging
|
BuildRequires: rust-packaging
|
||||||
# [dependencies]
|
BuildRequires: (crate(failure/default) >= 0.1.2 with crate(failure/default) < 0.2.0)
|
||||||
BuildRequires: (crate(failure) >= 0.1.0 with crate(failure) < 0.2.0)
|
BuildRequires: (crate(failure_derive/default) >= 0.1.0 with crate(failure_derive/default) < 0.2.0)
|
||||||
BuildRequires: (crate(failure_derive) >= 0.1.0 with crate(failure_derive) < 0.2.0)
|
BuildRequires: (crate(rust-ini/default) >= 0.12.0 with crate(rust-ini/default) < 0.13.0)
|
||||||
BuildRequires: (crate(rust-ini) >= 0.12.0 with crate(rust-ini) < 1.0.0)
|
|
||||||
|
|
||||||
BuildRequires: systemd
|
%global _description \
|
||||||
|
This is a systemd unit generator that creates a unit file to create a\
|
||||||
Patch0: bump-versions.diff
|
zram device. To activate, copy\
|
||||||
|
/usr/share/doc/rust-zram-generator/zram-generator.conf.example to\
|
||||||
%description
|
|
||||||
This is a systemd unit generator that creates a unit file to create a
|
|
||||||
zram device. To activate, copy
|
|
||||||
/usr/share/doc/rust-zram-generator/zram-generator.conf.example to
|
|
||||||
/etc/systemd/zram-generator.conf and possibly edit to adjust the limits.
|
/etc/systemd/zram-generator.conf and possibly edit to adjust the limits.
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
%package -n %{crate}
|
%package -n %{crate}
|
||||||
Summary: %{summary}
|
Summary: %{summary}
|
||||||
|
|
||||||
%description -n %{crate}
|
%description -n %{crate}
|
||||||
%{summary}.
|
%{summary}.
|
||||||
|
|
||||||
|
%files -n %{crate}
|
||||||
|
%license LICENSE
|
||||||
|
%doc zram-generator.conf.example
|
||||||
|
%doc README.md TODO
|
||||||
|
%{_systemdgeneratordir}/zram-generator
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -n %{crate}-%{version} -p1
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
%cargo_prep
|
%cargo_prep
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -54,13 +60,10 @@ mv -v %{buildroot}%{_bindir}/zram-generator %{buildroot}%{_systemdgeneratordir}/
|
|||||||
%cargo_test
|
%cargo_test
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%files -n %{crate}
|
|
||||||
%license LICENSE
|
|
||||||
%doc zram-generator.conf.example
|
|
||||||
%doc README.md TODO
|
|
||||||
%{_systemdgeneratordir}/zram-generator
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Mar 09 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.1-3
|
||||||
|
- Adapt to new packaging
|
||||||
|
|
||||||
* Fri Mar 1 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.1.1-2
|
* Fri Mar 1 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.1.1-2
|
||||||
- Add crude patch to fix build (#1676154)
|
- Add crude patch to fix build (#1676154)
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -0,0 +1 @@
|
|||||||
|
SHA512 (zram-generator-0.1.1.crate) = b48638b4821fe914a2aa910fbabd060ea4f14a71a2db4010bbd3d3c9e50a64350f4a6e37223b035bdc45983fc10426693ebacda8979b9297ec3e7817ff78ac57
|
Binary file not shown.
@ -1,5 +1,5 @@
|
|||||||
--- zram-generator-0.1.1/Cargo.toml~ 1970-01-01 01:00:00.000000000 +0100
|
--- zram-generator-0.1.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
+++ zram-generator-0.1.1/Cargo.toml 2019-03-01 16:48:14.223492246 +0100
|
+++ zram-generator-0.1.1/Cargo.toml 2019-03-09T14:58:31.909576+01:00
|
||||||
@@ -18,10 +18,10 @@
|
@@ -18,10 +18,10 @@
|
||||||
homepage = "https://github.com/systemd/zram-generator"
|
homepage = "https://github.com/systemd/zram-generator"
|
||||||
license = "MIT"
|
license = "MIT"
|
Loading…
Reference in New Issue
Block a user