78 lines
1.6 KiB
Diff
78 lines
1.6 KiB
Diff
--- sequoia-sq-0.37.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ sequoia-sq-0.37.0/Cargo.toml 2024-06-15T16:34:04.061673+00:00
|
|
@@ -44,6 +44,12 @@
|
|
]
|
|
license = "LGPL-2.0-or-later"
|
|
repository = "https://gitlab.com/sequoia-pgp/sequoia-sq"
|
|
+exclude = [
|
|
+ "/deny.toml",
|
|
+ "/Dockerfile",
|
|
+ "/sq.subplot",
|
|
+ "/sq-subplot.md",
|
|
+]
|
|
|
|
[profile.release]
|
|
debug = true
|
|
@@ -76,10 +82,6 @@
|
|
[dependencies.dirs]
|
|
version = "5"
|
|
|
|
-[dependencies.dot-writer]
|
|
-version = "0.1.3"
|
|
-optional = true
|
|
-
|
|
[dependencies.humantime]
|
|
version = "2"
|
|
|
|
@@ -155,9 +157,6 @@
|
|
[dev-dependencies.dircpy]
|
|
version = "0.3"
|
|
|
|
-[dev-dependencies.fehler]
|
|
-version = "1.0.0"
|
|
-
|
|
[dev-dependencies.libc]
|
|
version = "0.2"
|
|
|
|
@@ -166,9 +165,6 @@
|
|
|
|
[dev-dependencies.regex]
|
|
version = "1"
|
|
-
|
|
-[dev-dependencies.subplotlib]
|
|
-version = ">=0.7, <0.10"
|
|
|
|
[build-dependencies.anyhow]
|
|
version = "1.0.18"
|
|
@@ -217,10 +213,6 @@
|
|
version = "1.0.137"
|
|
features = ["derive"]
|
|
|
|
-[build-dependencies.subplot-build]
|
|
-version = ">=0.7, <0.10"
|
|
-optional = true
|
|
-
|
|
[build-dependencies.terminal_size]
|
|
version = ">=0.2.6, <0.4"
|
|
|
|
@@ -228,17 +220,12 @@
|
|
version = ">=0.15, <0.17"
|
|
|
|
[features]
|
|
-crypto-botan = ["sequoia-openpgp/crypto-botan"]
|
|
-crypto-botan2 = ["sequoia-openpgp/crypto-botan2"]
|
|
-crypto-cng = ["sequoia-openpgp/crypto-cng"]
|
|
crypto-nettle = ["sequoia-openpgp/crypto-nettle"]
|
|
crypto-openssl = ["sequoia-openpgp/crypto-openssl"]
|
|
crypto-rust = ["sequoia-openpgp/crypto-rust"]
|
|
default = [
|
|
- "crypto-nettle",
|
|
- "dot-writer",
|
|
-]
|
|
-subplot = ["subplot-build"]
|
|
+ "crypto-openssl",
|
|
+]
|
|
|
|
[badges.gitlab]
|
|
repository = "sequoia-pgp/sequoia-sq"
|