81 lines
1.6 KiB
Diff
81 lines
1.6 KiB
Diff
--- sequoia-sq-1.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ sequoia-sq-1.1.0/Cargo.toml 2025-01-01T19:12:41.953963+00:00
|
|
@@ -44,6 +44,12 @@
|
|
]
|
|
license = "LGPL-2.0-or-later"
|
|
repository = "https://gitlab.com/sequoia-pgp/sequoia-sq"
|
|
+exclude = [
|
|
+ "/deny.toml",
|
|
+ "/Dockerfile",
|
|
+ "/sq.subplot",
|
|
+ "/sq-subplot.md",
|
|
+]
|
|
|
|
[profile.dev.package.aes]
|
|
opt-level = 2
|
|
@@ -134,11 +140,6 @@
|
|
path = "src/main.rs"
|
|
bench = false
|
|
|
|
-[[test]]
|
|
-name = "sq-subplot"
|
|
-path = "tests/sq-subplot.rs"
|
|
-required-features = ["subplot"]
|
|
-
|
|
[dependencies.aho-corasick]
|
|
version = "1"
|
|
|
|
@@ -162,10 +163,6 @@
|
|
"wrap_help",
|
|
]
|
|
|
|
-[dependencies.culpa]
|
|
-version = "1"
|
|
-optional = true
|
|
-
|
|
[dependencies.dirs]
|
|
version = "5"
|
|
|
|
@@ -243,10 +240,6 @@
|
|
[dependencies.serde]
|
|
version = "1.0.137"
|
|
features = ["derive"]
|
|
-
|
|
-[dependencies.subplotlib]
|
|
-version = ">=0.11, <0.13"
|
|
-optional = true
|
|
|
|
[dependencies.tempfile]
|
|
version = "3.1"
|
|
@@ -341,10 +334,6 @@
|
|
version = "1.0.137"
|
|
features = ["derive"]
|
|
|
|
-[build-dependencies.subplot-build]
|
|
-version = ">=0.11, <0.13"
|
|
-optional = true
|
|
-
|
|
[build-dependencies.terminal_size]
|
|
version = ">=0.2.6, <0.5"
|
|
|
|
@@ -355,18 +344,10 @@
|
|
version = "1"
|
|
|
|
[features]
|
|
-crypto-botan = ["sequoia-openpgp/crypto-botan"]
|
|
-crypto-botan2 = ["sequoia-openpgp/crypto-botan2"]
|
|
-crypto-cng = ["sequoia-openpgp/crypto-cng"]
|
|
crypto-nettle = ["sequoia-openpgp/crypto-nettle"]
|
|
crypto-openssl = ["sequoia-openpgp/crypto-openssl"]
|
|
crypto-rust = ["sequoia-openpgp/crypto-rust"]
|
|
-default = ["crypto-nettle"]
|
|
-subplot = [
|
|
- "culpa",
|
|
- "subplot-build",
|
|
- "subplotlib",
|
|
-]
|
|
+default = ["crypto-openssl"]
|
|
|
|
[badges.gitlab]
|
|
repository = "sequoia-pgp/sequoia-sq"
|