Update to 1.3.0

Resolves: RHEL-84033
This commit is contained in:
Jakub Jelen 2025-03-19 13:57:03 +01:00
parent 5d0f4a5bb2
commit 97f54e6bab
5 changed files with 82 additions and 59 deletions

2
.gitignore vendored
View File

@ -3,3 +3,5 @@
/capnproto-c++-1.0.1.tar.gz
/sequoia-sq-1.1.0.crate
/rust-sequoia-sq-1.1.0-vendor.tar.xz
/sequoia-sq-1.3.0.crate
/rust-sequoia-sq-1.3.0-vendor.tar.xz

View File

@ -15,7 +15,7 @@
%endif
Name: rust-sequoia-sq
Version: 1.1.0
Version: 1.3.0
Release: %autorelease
Summary: Command-line frontends for Sequoia
@ -33,7 +33,8 @@ Source0: %{crates_source}
# --platform aarch64-unknown-linux-gnu \
# --platform i686-unknown-linux-gnu \
# --platform s390x-unknown-linux-gnu \
# --all-features=true
# --all-features
# tar -cJf ../rust-%%{crate}-%%{version}-vendor.tar.xz vendor
Source1: %{name}-%{version}-vendor.tar.xz
Source2: capnproto-c++-1.0.1.tar.gz
# Manually created patch for downstream crate metadata changes
@ -75,6 +76,7 @@ Summary: %{summary}
# Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# BSD-2-Clause OR Apache-2.0 OR MIT
# BSD-3-Clause
# BSL-1.0
# LGPL-2.0-or-later
# MIT
@ -84,7 +86,22 @@ Summary: %{summary}
# MPL-2.0
# Unlicense OR MIT
# Zlib OR Apache-2.0 OR MIT
License: LGPL-2.0-or-later AND Apache-2.0 AND BSL-1.0 AND BSD-3-Clause AND MIT AND MPL-2.0 AND Unicode-DFS-2016 AND (0BSD OR MIT OR Apache-2.0) AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR ISC OR MIT) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (BSD-2-Clause OR Apache-2.0 OR MIT) AND (MIT OR Apache-2.0 OR Zlib) AND (Unlicense OR MIT)
License: %{shrink:
LGPL-2.0-or-later AND
Apache-2.0 AND
BSL-1.0 AND
BSD-3-Clause AND
MIT AND
MPL-2.0 AND
Unicode-DFS-2016 AND
(0BSD OR MIT OR Apache-2.0) AND
(Apache-2.0 OR BSL-1.0) AND
(Apache-2.0 OR ISC OR MIT) AND
(Apache-2.0 OR MIT) AND
(Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND
(MIT OR Apache-2.0 OR Zlib) AND
(Unlicense OR MIT)
}
# LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description}

View File

@ -11,11 +11,15 @@ extra-files = [
"%{fish_completions_dir}/sq.fish",
"%{zsh_completions_dir}/_sq",
]
doc-files.exclude = [
"sq-subplot.md",
]
[scripts]
prep.post = [
"# drop broken integration tests",
"rm -vr subplot/",
"rm -v tests/sq-subplot.rs",
]
install.post = [
"# install manual pages",

View File

@ -1,6 +1,6 @@
--- sequoia-sq-1.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-sq-1.1.0/Cargo.toml 2025-01-01T19:12:41.953963+00:00
@@ -44,6 +44,12 @@
--- sequoia-sq-1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-sq-1.3.0/Cargo.toml 2025-03-08T12:37:34.404402+00:00
@@ -49,6 +49,12 @@
]
license = "LGPL-2.0-or-later"
repository = "https://gitlab.com/sequoia-pgp/sequoia-sq"
@ -11,55 +11,10 @@
+ "/sq-subplot.md",
+]
[profile.dev.package.aes]
opt-level = 2
@@ -134,11 +140,6 @@
path = "src/main.rs"
bench = false
-[[test]]
-name = "sq-subplot"
-path = "tests/sq-subplot.rs"
-required-features = ["subplot"]
-
[dependencies.aho-corasick]
version = "1"
@@ -162,10 +163,6 @@
"wrap_help",
]
-[dependencies.culpa]
-version = "1"
-optional = true
-
[dependencies.dirs]
version = "5"
@@ -243,10 +240,6 @@
[dependencies.serde]
version = "1.0.137"
features = ["derive"]
-
-[dependencies.subplotlib]
-version = ">=0.11, <0.13"
-optional = true
[dependencies.tempfile]
version = "3.1"
@@ -341,10 +334,6 @@
version = "1.0.137"
features = ["derive"]
-[build-dependencies.subplot-build]
-version = ">=0.11, <0.13"
-optional = true
-
[build-dependencies.terminal_size]
version = ">=0.2.6, <0.5"
@@ -355,18 +344,10 @@
version = "1"
[badges.gitlab]
repository = "sequoia-pgp/sequoia-sq"
@@ -57,18 +63,10 @@
status = "actively-developed"
[features]
-crypto-botan = ["sequoia-openpgp/crypto-botan"]
@ -76,5 +31,50 @@
-]
+default = ["crypto-openssl"]
[badges.gitlab]
repository = "sequoia-pgp/sequoia-sq"
[[bin]]
name = "sq"
@@ -79,11 +77,6 @@
name = "integration"
path = "tests/integration.rs"
-[[test]]
-name = "sq-subplot"
-path = "tests/sq-subplot.rs"
-required-features = ["subplot"]
-
[dependencies.aho-corasick]
version = "1"
@@ -111,10 +104,6 @@
version = "0.7"
default-features = false
-[dependencies.culpa]
-version = "1"
-optional = true
-
[dependencies.dirs]
version = "5"
@@ -192,10 +181,6 @@
[dependencies.serde]
version = "1.0.137"
features = ["derive"]
-
-[dependencies.subplotlib]
-version = ">=0.11, <0.13"
-optional = true
[dependencies.tempfile]
version = "3.1"
@@ -298,10 +283,6 @@
version = "1.0.137"
features = ["derive"]
-[build-dependencies.subplot-build]
-version = ">=0.11, <0.13"
-optional = true
-
[build-dependencies.terminal_size]
version = ">=0.2.6, <0.5"

View File

@ -1,3 +1,3 @@
SHA512 (sequoia-sq-1.1.0.crate) = 69b13ecf20c2ada478be69ef87a6d784efbf4108941503f2c00c18961831e95585f770c12801e9239fb4e0440552005335a9093439125ed2a4c9c4b8ea96ce74
SHA512 (rust-sequoia-sq-1.1.0-vendor.tar.xz) = 2eb426d9b25ed115fefad01e3bde962e900c72181eb0d4f28307c3027c8e94d5826146a17aae4060b2f22585c1cc598760d62c1a9859c12c66c4621a6a1e8377
SHA512 (sequoia-sq-1.3.0.crate) = b4e6822aa717a790278a6e4f5afe287214e5777bdfac42882629834ef6b10ae20ac37086823aa01edc69f4a5f094f429671849871e64027473cfb5f297133082
SHA512 (rust-sequoia-sq-1.3.0-vendor.tar.xz) = 2af724ef29cb9fc5faf4e0488b29285d74b3bbc23288536fc1aeeaba705beb483ab90dd941ff0b7881cf6b9da146e411f5541d675a2053eedb03386747e4d2cf
SHA512 (capnproto-c++-1.0.1.tar.gz) = c60291f433eea15a51e480e1679a4b9b3b5e67edebc445e371a7a32fce6ec5a7e4b440b17b2adc0565519ec369e3dae8ea727ae790a082a53ecd0d245b5275a9