rust-coreos-installer/mbrman-0.5.0.patch
2022-10-14 01:39:45 -04:00

20 lines
734 B
Diff

--- coreos-installer-0.16.1/Cargo.toml.old 2022-10-14 01:32:13.064282069 -0400
+++ coreos-installer-0.16.1/Cargo.toml 2022-10-14 01:32:44.416313454 -0400
@@ -199,4 +199,3 @@ rdcore = []
[target."cfg(target_arch = \"s390x\")".dependencies.mbrman]
-version = ">= 0.3, < 0.5"
-default-features = false
+version = ">= 0.5, < 0.6"
--- a/src/s390x/fba.rs
+++ b/src/s390x/fba.rs
@@ -39,7 +39,7 @@ pub(crate) fn fba_make_partitions(
length: blocks * bytes_per_block as u64,
});
mbr[idx + 1] = MBRPartitionEntry {
- boot: false,
+ boot: mbrman::BOOT_INACTIVE,
first_chs: CHS::empty(),
sys: 0x83, // MBR_LINUX_DATA_PARTITION
last_chs: CHS::empty(),