Refresh for latest Rust package template; update license tag for SPDX

This commit is contained in:
Fabio Valentini 2023-05-19 12:55:14 +02:00
parent b73e5367b5
commit c20c53f9ce
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF
3 changed files with 47 additions and 35 deletions

View File

@ -1,9 +0,0 @@
diff -ur a/Cargo.toml b/Cargo.toml
--- a/Cargo.toml 1969-12-31 19:00:01.000000000 -0500
+++ b/Cargo.toml 2023-03-20 20:44:02.135392305 -0400
@@ -132,4 +132,4 @@
version = ">= 2.3, < 4"
[dev-dependencies.mockito]
-version = ">= 0.29, < 0.32"
+version = "1"

View File

@ -0,0 +1,8 @@
--- afterburn-5.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ afterburn-5.4.0/Cargo.toml 2023-05-18T13:18:10.533797+00:00
@@ -132,4 +132,4 @@
version = ">= 2.3, < 4"
[dev-dependencies.mockito]
-version = ">= 0.29, < 0.32"
+version = "1"

View File

@ -1,34 +1,33 @@
# Generated by rust2rpm 15
# Generated by rust2rpm 24
%bcond_without check
%global __cargo_skip_build 0
%global dracutmodulesdir %(pkg-config --variable=dracutmodulesdir dracut || echo '/usr/lib/dracut/modules.d')
%global crate afterburn
Name: rust-%{crate}
Name: rust-afterburn
Version: 5.4.0
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Simple cloud provider agent
# Upstream license specification: Apache-2.0
License: ASL 2.0
License: Apache-2.0
URL: https://crates.io/crates/afterburn
Source0: %{crates_source}
# not used on Fedora
Source1: https://github.com/coreos/%{crate}/releases/download/v%{version}/%{crate}-%{version}-vendor.tar.gz
# Manually created patch for downstream crate metadata changes
# * bump mockito dev-dependency to v1
Patch: afterburn-fix-metadata.diff
# Use rust-mockito 1.0 API
# Based on https://github.com/coreos/afterburn/pull/894, fixing merge conflicts
Patch0: 0001-providers-packet-use-stored-client-for-boot-checkin.patch
Patch1: 0002-providers-microsoft-use-stored-client-for-all-fetche.patch
Patch2: 0003-providers-microsoft-import-crate-retry.patch
Patch3: 0004-retry-client-move-URL-parsing-into-helper-function.patch
Patch4: 0005-providers-move-endpoint-mocking-into-retry-Client.patch
Patch5: 0006-Update-mockito-to-1.0.patch
Patch6: 0007-Bump-mockito-version.patch
Patch: 0001-providers-packet-use-stored-client-for-boot-checkin.patch
Patch: 0002-providers-microsoft-use-stored-client-for-all-fetche.patch
Patch: 0003-providers-microsoft-import-crate-retry.patch
Patch: 0004-retry-client-move-URL-parsing-into-helper-function.patch
Patch: 0005-providers-move-endpoint-mocking-into-retry-Client.patch
Patch: 0006-Update-mockito-to-1.0.patch
ExclusiveArch: %{rust_arches}
%if 0%{?rhel} && !0%{?eln}
BuildRequires: rust-toolset
BuildRequires: openssl-devel
@ -37,36 +36,45 @@ BuildRequires: openssl-devel
# does not work without it.
BuildRequires: glibc-devel
%else
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 23
%endif
BuildRequires: systemd
%global _description %{expand:
Simple cloud provider agent.}
A simple cloud provider agent.}
%description %{_description}
%package -n %{crate}
Summary: %{summary}
# (Apache-2.0 OR MIT) AND BSD-3-Clause
# 0BSD
# ASL 2.0
# ASL 2.0 or Boost
# ASL 2.0 or MIT
# BSD
# Apache-2.0
# Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# BSD-3-Clause
# MIT
# MIT or ASL 2.0
# MIT or ASL 2.0 or zlib
# MPLv2.0 or MIT or ASL 2.0
# Unlicense or MIT
# zlib or ASL 2.0 or MIT
License: ASL 2.0 and MIT and BSD and 0BSD
# MIT OR Apache-2.0
# MIT OR Apache-2.0 OR Zlib
# MPL-2.0 OR MIT OR Apache-2.0
# Unlicense OR MIT
# Zlib OR Apache-2.0 OR MIT
License: Apache-2.0 AND 0BSD AND BSD-3-Clause AND MIT AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (MIT OR Apache-2.0 OR Zlib) AND (MPL-2.0 OR MIT OR Apache-2.0) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown
%{?systemd_requires}
%description -n %{crate} %{_description}
%files -n %{crate}
%license COPYRIGHT
%license LICENSE
%license NOTICE
%license LICENSE.dependencies
%doc README.md
%doc code-of-conduct.md
%{_bindir}/afterburn
%{_unitdir}/afterburn.service
%{_unitdir}/afterburn-checkin.service
@ -135,6 +143,8 @@ sed -e 's,@DEFAULT_INSTANCE@,core,' < \
%build
%cargo_build
%{?cargo_license_summary}
%{?cargo_license} > LICENSE.dependencies
%install
%if 0%{?rhel} && !0%{?eln}
@ -153,6 +163,9 @@ cp -a dracut/* %{buildroot}%{dracutmodulesdir}
%endif
%changelog
* Fri May 19 2023 Fabio Valentini <decathorpe@gmail.com> - 5.4.0-4
- Refresh for latest Rust package template; update license tag for SPDX
* Wed May 03 2023 Fabio Valentini <decathorpe@gmail.com> - 5.4.0-3
- Rebuild for tokio, h2, and openssl crate security updates