Update to 5.2.0-1 (from Fedora 35)
Resolves: rhbz#2038284
This commit is contained in:
parent
520daf056c
commit
6e7561e90a
3
.gitignore
vendored
3
.gitignore
vendored
@ -12,3 +12,6 @@
|
||||
/afterburn-4.5.1.crate
|
||||
/afterburn-4.5.3.crate
|
||||
/afterburn-4.6.0.crate
|
||||
/afterburn-5.1.0.crate
|
||||
/afterburn-5.2.0.crate
|
||||
/afterburn-5.2.0-vendor.tar.gz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- afterburn-4.6.0/Cargo.toml 2020-12-09T22:20:24+00:00
|
||||
+++ afterburn-4.6.0/Cargo.toml 2020-12-10T01:03:45.202554+00:00
|
||||
@@ -67,7 +67,7 @@
|
||||
version = "0.3"
|
||||
|
||||
[dependencies.nix]
|
||||
-version = "0.19"
|
||||
+version = "0.18"
|
||||
|
||||
[dependencies.openssh-keys]
|
||||
version = "0.4"
|
@ -7,20 +7,27 @@
|
||||
%global crate afterburn
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 4.6.0
|
||||
Release: 3%{?dist}
|
||||
Version: 5.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Simple cloud provider agent
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/afterburn
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
Patch0: afterburn-fix-metadata.diff
|
||||
Source0: %{crates_source}
|
||||
Source1: https://github.com/coreos/%{crate}/releases/download/v%{version}/%{crate}-%{version}-vendor.tar.gz
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
%if 0%{?rhel} && !0%{?eln}
|
||||
BuildRequires: rust-toolset
|
||||
BuildRequires: openssl-devel
|
||||
# This is needed because the cc crate, which is
|
||||
# used for linking final build results of crates,
|
||||
# does not work without it.
|
||||
BuildRequires: glibc-devel
|
||||
%else
|
||||
BuildRequires: rust-packaging
|
||||
%endif
|
||||
BuildRequires: systemd
|
||||
|
||||
%global _description %{expand:
|
||||
@ -87,24 +94,42 @@ to run in the initramfs on boot.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%if 0%{?rhel} && !0%{?eln}
|
||||
tar xvf %{SOURCE1}
|
||||
mkdir -p .cargo
|
||||
cat >.cargo/config << EOF
|
||||
[source.crates-io]
|
||||
replace-with = "vendored-sources"
|
||||
|
||||
[source.vendored-sources]
|
||||
directory = "vendor"
|
||||
EOF
|
||||
%else
|
||||
%cargo_prep
|
||||
%endif
|
||||
# afterburn-sshkeys@.service is by default enabled for the 'core' user in
|
||||
# Fedora CoreOS.
|
||||
# Based on https://github.com/coreos/afterburn/blob/master/Makefile.
|
||||
sed -e 's,@DEFAULT_INSTANCE@,core,' < \
|
||||
systemd/afterburn-sshkeys@.service.in > \
|
||||
systemd/afterburn-sshkeys@.service
|
||||
%cargo_prep
|
||||
|
||||
%if !0%{?rhel} || 0%{?eln}
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
%endif
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%if 0%{?rhel} && !0%{?eln}
|
||||
%make_install INSTALL="install -p -c"
|
||||
%else
|
||||
%cargo_install
|
||||
install -Dpm0644 -t %{buildroot}%{_unitdir} \
|
||||
systemd/*.service systemd/*.target
|
||||
%endif
|
||||
mkdir -p %{buildroot}%{dracutmodulesdir}
|
||||
cp -a dracut/* %{buildroot}%{dracutmodulesdir}
|
||||
|
||||
@ -114,6 +139,27 @@ cp -a dracut/* %{buildroot}%{dracutmodulesdir}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jan 14 2022 Benjamin Gilbert <bgilbert@redhat.com> - 5.2.0-1
|
||||
- Update to 5.2.0
|
||||
|
||||
* Fri Sep 24 2021 Sohan Kunkerkar <skunkerk@redhat.com> - 5.1.0-3
|
||||
- Vendor rust dependencies on el9
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 5.1.0-2
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
* Tue Aug 10 2021 Sohan Kunkerkar <skunkerk@redhat.com> - 5.1.0-1
|
||||
- Update to 5.1.0
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Fri Apr 09 2021 Sohan Kunkerkar <skunkerk@redhat.com> - 5.0.0-1
|
||||
- Update to 5.0.0
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.6.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Dec 28 13:26:51 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 4.6.0-3
|
||||
- Rebuild
|
||||
|
||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
||||
SHA512 (afterburn-4.6.0.crate) = a23d0902173818bb4f3b57dafe974214b4f5dc8e9b63e523b2d951b42d02f7b9495915e9b16dcd216d7e5fe28954e2f5ced5c3b5c8d84a3a1594ae96ad0d7189
|
||||
SHA512 (afterburn-5.2.0.crate) = f988eec2dd5f677d75a09eede3974ac7161ccd7b691908d3af560aa035cdbd93ee0e4f6f86f3a747882ce7d0c88a84a263a9d59afb0205d24f0041e6d53e41de
|
||||
SHA512 (afterburn-5.2.0-vendor.tar.gz) = bfba2ecccc85fd57acd3f457018504398147da7c6b1019c6f618c4a21eeeb2791418dd36c5d7b5cd4f903ad7c9cf2dcfa5f40d413a67927b2538a4a4b51c9c84
|
||||
|
Loading…
Reference in New Issue
Block a user