Update to 4.5.3
This commit is contained in:
parent
1bd8d3c01c
commit
0044c8e4f0
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
|||||||
/afterburn-4.4.2.crate
|
/afterburn-4.4.2.crate
|
||||||
/afterburn-4.5.0.crate
|
/afterburn-4.5.0.crate
|
||||||
/afterburn-4.5.1.crate
|
/afterburn-4.5.1.crate
|
||||||
|
/afterburn-4.5.3.crate
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From b6f82c63b26bc0e9447b7f58829ddf9cce9e21ca Mon Sep 17 00:00:00 2001
|
|
||||||
From: Luca BRUNO <luca.bruno@coreos.com>
|
|
||||||
Date: Mon, 28 Sep 2020 16:11:31 +0000
|
|
||||||
Subject: [PATCH] sshkeys: activate service on OpenStack
|
|
||||||
|
|
||||||
This adds triggering condition to SSH-keys service units on OpenStack.
|
|
||||||
---
|
|
||||||
systemd/afterburn-sshkeys@.service.in | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/systemd/afterburn-sshkeys@.service.in b/systemd/afterburn-sshkeys@.service.in
|
|
||||||
index 741ca25..bee9b4a 100644
|
|
||||||
--- a/systemd/afterburn-sshkeys@.service.in
|
|
||||||
+++ b/systemd/afterburn-sshkeys@.service.in
|
|
||||||
@@ -11,9 +11,10 @@ ConditionKernelCommandLine=|ignition.platform.id=azure
|
|
||||||
ConditionKernelCommandLine=|ignition.platform.id=digitalocean
|
|
||||||
ConditionKernelCommandLine=|ignition.platform.id=exoscale
|
|
||||||
ConditionKernelCommandLine=|ignition.platform.id=gcp
|
|
||||||
+ConditionKernelCommandLine=|ignition.platform.id=ibmcloud
|
|
||||||
+ConditionKernelCommandLine=|ignition.platform.id=openstack
|
|
||||||
ConditionKernelCommandLine=|ignition.platform.id=packet
|
|
||||||
ConditionKernelCommandLine=|ignition.platform.id=vultr
|
|
||||||
-ConditionKernelCommandLine=|ignition.platform.id=ibmcloud
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Type=oneshot
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
@ -1,20 +1,29 @@
|
|||||||
--- afterburn-4.5.1/Cargo.toml 2020-09-02T15:13:41+00:00
|
--- afterburn-4.5.3/Cargo.toml 2020-10-22T01:47:33+00:00
|
||||||
+++ afterburn-4.5.1/Cargo.toml 2020-09-03T21:56:58.741161+00:00
|
+++ afterburn-4.5.3/Cargo.toml 2020-10-22T19:48:06.040912+00:00
|
||||||
@@ -58,7 +58,7 @@
|
@@ -33,7 +33,7 @@
|
||||||
version = "^0.2.1"
|
name = "afterburn"
|
||||||
|
path = "src/main.rs"
|
||||||
|
[dependencies.base64]
|
||||||
|
-version = "0.13"
|
||||||
|
+version = "0.12"
|
||||||
|
|
||||||
[dependencies.mailparse]
|
[dependencies.byteorder]
|
||||||
-version = "^0.13"
|
version = "1.3"
|
||||||
+version = "^0.12"
|
|
||||||
|
|
||||||
[dependencies.maplit]
|
|
||||||
version = "^1.0"
|
|
||||||
@@ -67,7 +67,7 @@
|
@@ -67,7 +67,7 @@
|
||||||
version = "^0.3"
|
version = "0.3"
|
||||||
|
|
||||||
[dependencies.nix]
|
[dependencies.nix]
|
||||||
-version = "^0.18"
|
-version = "0.19"
|
||||||
+version = "^0.17"
|
+version = "0.18"
|
||||||
|
|
||||||
[dependencies.openssh-keys]
|
[dependencies.openssh-keys]
|
||||||
version = "^0.4"
|
version = "0.4"
|
||||||
|
@@ -122,7 +122,7 @@
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
[dependencies.users]
|
||||||
|
-version = "0.11"
|
||||||
|
+version = "0.10"
|
||||||
|
|
||||||
|
[dependencies.vmw_backdoor]
|
||||||
|
version = "0.2"
|
||||||
|
@ -7,8 +7,8 @@
|
|||||||
%global crate afterburn
|
%global crate afterburn
|
||||||
|
|
||||||
Name: rust-%{crate}
|
Name: rust-%{crate}
|
||||||
Version: 4.5.1
|
Version: 4.5.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Simple cloud provider agent
|
Summary: Simple cloud provider agent
|
||||||
|
|
||||||
# Upstream license specification: Apache-2.0
|
# Upstream license specification: Apache-2.0
|
||||||
@ -17,8 +17,6 @@ URL: https://crates.io/crates/afterburn
|
|||||||
Source: %{crates_source}
|
Source: %{crates_source}
|
||||||
# Initial patched metadata
|
# Initial patched metadata
|
||||||
Patch0: afterburn-fix-metadata.diff
|
Patch0: afterburn-fix-metadata.diff
|
||||||
# https://github.com/coreos/afterburn/pull/493
|
|
||||||
Patch1: 0001-sshkeys-activate-service-on-OpenStack.patch
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
@ -116,6 +114,9 @@ cp -a dracut/* %{buildroot}%{dracutmodulesdir}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 22 2020 Dusty Mabe <dusty@dustymabe.com> - 4.5.3-1
|
||||||
|
- Update to 4.5.3
|
||||||
|
|
||||||
* Wed Oct 14 2020 Dusty Mabe <dusty@dustymabe.com> - 4.5.1-3
|
* Wed Oct 14 2020 Dusty Mabe <dusty@dustymabe.com> - 4.5.1-3
|
||||||
- Backport patch to get afterburn sshkeys working on openstack.
|
- Backport patch to get afterburn sshkeys working on openstack.
|
||||||
- https://github.com/coreos/afterburn/pull/493
|
- https://github.com/coreos/afterburn/pull/493
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (afterburn-4.5.1.crate) = 6aa685c0365dc1b0261f9963ebc707e1848182401221533a3118200d400cc6656c43bd8aa11e1659d8e1f7fd447a4d430bbf9667834aa555722c8e73a6f19584
|
SHA512 (afterburn-4.5.3.crate) = 902948fef187fb4a283ef993ac94a3450ed4115a7c70abfd07ac9b7b5ee6b4771018d55c5236962caaa1b170f24679c45fa5959261c2a144d01a7bade1d04014
|
||||||
|
Loading…
Reference in New Issue
Block a user