runc/trimpath.patch
Peter Hunt 7453b7073d Patch: revert https://github.com/opencontainers/runc/pull/2773
as it breaks builds

Signed-off-by: Peter Hunt <pehunt@redhat.com>
2021-04-05 12:39:32 -04:00

17 lines
844 B
Diff

diff --git a/Makefile b/Makefile
index e13d8f1d..605d7109 100644
--- a/Makefile
+++ b/Makefile
@@ -23,9 +23,9 @@ ifeq ($(shell $(GO) env GOOS),linux)
GO_BUILDMODE := "-buildmode=pie"
endif
endif
-GO_BUILD := $(GO) build -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
+GO_BUILD := $(GO) build $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
-ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
-GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
+GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
-ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
.DEFAULT: runc