runc/trimpath.patch
Peter Hunt c7e494a93c bump to v1.0.0-rc95
Signed-off-by: Peter Hunt <pehunt@redhat.com>
2021-05-19 14:41:40 -04:00

17 lines
817 B
Diff

diff --git a/Makefile b/Makefile
index aff6d531..9a0ed3aa 100644
--- a/Makefile
+++ b/Makefile
@@ -25,9 +25,9 @@ ifeq ($(shell $(GO) env GOOS),linux)
endif
endif
endif
-GO_BUILD := $(GO) build -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
+GO_BUILD := $(GO) build $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
-ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
-GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
+GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
-ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
.DEFAULT: runc