runc-2:1.0.2-2

- use correct v1.0.2 tarball, move trimpath patch in-rpm-spec

Signed-off-by: Lokesh Mandvekar <lsm5@fedoraproject.org>
This commit is contained in:
Lokesh Mandvekar 2021-09-10 09:56:29 -04:00
parent e12878de57
commit d5e03a13ea
4 changed files with 11 additions and 24 deletions

1
.gitignore vendored
View File

@ -352,3 +352,4 @@
/v1.0.0-rc95.tar.gz /v1.0.0-rc95.tar.gz
/v1.0.0.tar.gz /v1.0.0.tar.gz
/v1.0.1.tar.gz /v1.0.1.tar.gz
/v1.0.2.tar.gz

View File

@ -29,20 +29,18 @@
%global git0 https://github.com/opencontainers/runc %global git0 https://github.com/opencontainers/runc
# Used for comparing with latest upstream tag # Used for comparing with latest upstream tag
# to decide whether to autobuild (non-rawhide only) # to decide whether to autobuild
%define built_tag v1.0.1 %global built_tag v1.0.2
%define built_tag_strip %(b=%{built_tag}; echo ${b:1}) %global built_tag_strip %(b=%{built_tag}; echo ${b:1})
%define download_url %{git0}/archive/%{built_tag}.tar.gz
Name: %{repo} Name: %{repo}
Epoch: 2 Epoch: 2
Version: 1.0.2 Version: 1.0.2
Release: 1%{?dist} Release: 2%{?dist}
Summary: CLI for running Open Containers Summary: CLI for running Open Containers
License: ASL 2.0 License: ASL 2.0
URL: %{git0} URL: %{git0}
Source0: %{download_url} Source0: %{git0}/archive/%{built_tag}.tar.gz
Patch1: trimpath.patch
# e.g. el6 has ppc64 arch without gcc-go, so EA tag is required # e.g. el6 has ppc64 arch without gcc-go, so EA tag is required
#ExclusiveArch: %%{?go_arches:%%{go_arches}}%%{!?go_arches:%%{ix86} x86_64 %%{arm}} #ExclusiveArch: %%{?go_arches:%%{go_arches}}%%{!?go_arches:%%{ix86} x86_64 %%{arm}}
@ -187,6 +185,7 @@ providing packages with %{import_path} prefix.
%prep %prep
%autosetup -Sgit -n %{name}-%{built_tag_strip} %autosetup -Sgit -n %{name}-%{built_tag_strip}
sed -i 's/ -trimpath//g' Makefile
%build %build
mkdir -p GOPATH mkdir -p GOPATH
@ -309,6 +308,9 @@ export GOPATH=%{buildroot}/%{gopath}:$(pwd)/Godeps/_workspace:%{gopath}
%endif %endif
%changelog %changelog
* Fri Sep 10 2021 Lokesh Mandvekar <lsm5@fedoraproject.org> - 2:1.0.2-2
- use correct v1.0.2 tarball, move trimpath patch in-rpm-spec
* Fri Sep 10 2021 RH Container Bot <rhcontainerbot@fedoraproject.org> - 2:1.0.2-1 * Fri Sep 10 2021 RH Container Bot <rhcontainerbot@fedoraproject.org> - 2:1.0.2-1
- autobuilt v1.0.2 - autobuilt v1.0.2

View File

@ -1 +1 @@
SHA512 (v1.0.1.tar.gz) = c5db1016f438cd4883d1f9b36414e9c8b1fe9dfcb53dfebd1130cea3cb9bf78615a765715f4dd587cf8cc603b69951a5871adc33870cfeef2e63521d1ceccf39 SHA512 (v1.0.2.tar.gz) = 434abd6d7ad2508c2272b627d8aeeb28ecd8461899bff463e7d2c7abbc0f0cbb2e0bafbfe81fc534fad506b1acb4bda3e05639ecd908bc9d0d2e9356f1e56e26

View File

@ -1,16 +0,0 @@
diff --git a/Makefile b/Makefile
index aff6d531..9a0ed3aa 100644
--- a/Makefile
+++ b/Makefile
@@ -25,9 +25,9 @@ ifeq ($(shell $(GO) env GOOS),linux)
endif
endif
endif
-GO_BUILD := $(GO) build -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
+GO_BUILD := $(GO) build $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
-ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
-GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
+GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
-ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
.DEFAULT: runc