202 lines
5.3 KiB
RPMSpec
202 lines
5.3 KiB
RPMSpec
%global gem_name rspec-support
|
|
|
|
%global mainver 3.7.1
|
|
%undefine prever
|
|
|
|
%global mainrel 2
|
|
%global prerpmver %(echo "%{?prever}" | sed -e 's|\\.||g')
|
|
|
|
%global need_bootstrap_set 0
|
|
|
|
%undefine __brp_mangle_shebangs
|
|
|
|
Name: rubygem-%{gem_name}
|
|
Version: %{mainver}
|
|
Release: %{?prever:0.}%{mainrel}%{?prever:.%{prerpmver}}%{?dist}
|
|
|
|
Summary: Common functionality to Rspec series
|
|
Group: Development/Languages
|
|
License: MIT
|
|
URL: https://github.com/rspec/rspec-support
|
|
Source0: https://rubygems.org/gems/%{gem_name}-%{mainver}%{?prever}.gem
|
|
# %%{SOURCE2} %%{name} %%{version}
|
|
Source1: rubygem-%{gem_name}-%{version}-full.tar.gz
|
|
Source2: rspec-related-create-full-tarball.sh
|
|
# tweak regex for search path
|
|
Patch0: rubygem-rspec-support-3.2.1-callerfilter-searchpath-regex.patch
|
|
|
|
#BuildRequires: ruby(release)
|
|
BuildRequires: rubygems-devel
|
|
%if 0%{?need_bootstrap_set} < 1
|
|
BuildRequires: rubygem(rspec)
|
|
BuildRequires: rubygem(rake)
|
|
BuildRequires: rubygem(thread_order)
|
|
BuildRequires: rubygem(bigdecimal)
|
|
BuildRequires: git
|
|
%endif
|
|
|
|
BuildArch: noarch
|
|
|
|
%description
|
|
`RSpec::Support` provides common functionality to `RSpec::Core`,
|
|
`RSpec::Expectations` and `RSpec::Mocks`. It is considered
|
|
suitable for internal use only at this time.
|
|
|
|
%package doc
|
|
Summary: Documentation for %{name}
|
|
Group: Documentation
|
|
Requires: %{name} = %{version}-%{release}
|
|
BuildArch: noarch
|
|
|
|
%description doc
|
|
Documentation for %{name}
|
|
|
|
%global version_orig %{version}
|
|
%global version %{version_orig}%{?prever}
|
|
|
|
%prep
|
|
%setup -q -T -n %{gem_name}-%{version} -b 1
|
|
gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
|
|
|
|
%patch0 -p1
|
|
|
|
%build
|
|
gem build %{gem_name}.gemspec
|
|
%gem_install
|
|
|
|
%install
|
|
mkdir -p %{buildroot}%{gem_dir}
|
|
cp -pa .%{gem_dir}/* \
|
|
%{buildroot}%{gem_dir}/
|
|
|
|
%if 0%{?need_bootstrap_set} < 1
|
|
%check
|
|
LANG=en_US.UTF-8
|
|
|
|
# Test failure needs investigation...
|
|
FAILFILE=()
|
|
FAILTEST=()
|
|
%if 0
|
|
FAILFILE+=("spec/rspec/support/differ_spec.rb")
|
|
FAILTEST+=("copes with encoded strings")
|
|
%endif
|
|
|
|
for ((i = 0; i < ${#FAILFILE[@]}; i++)) {
|
|
sed -i \
|
|
-e "\@${FAILTEST[$i]}@s|do$|, :broken => true do|" \
|
|
${FAILFILE[$i]}
|
|
}
|
|
|
|
ruby -rrubygems -Ilib/ -S rspec spec/ || \
|
|
ruby -rrubygems -Ilib/ -S rspec --tag ~broken
|
|
%endif
|
|
|
|
%files
|
|
%dir %{gem_instdir}
|
|
%license %{gem_instdir}/LICENSE.md
|
|
%doc %{gem_instdir}/Changelog.md
|
|
%doc %{gem_instdir}/README.md
|
|
|
|
%{gem_libdir}
|
|
%exclude %{gem_cache}
|
|
%{gem_spec}
|
|
|
|
%files doc
|
|
%doc %{gem_docdir}
|
|
|
|
%changelog
|
|
* Thu Jul 12 2018 Jun Aruga <jaruga@redhat.com> - 3.7.1-2
|
|
- Fix FTBFS by adding build dependency for RHEL.
|
|
|
|
* Fri Feb 9 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.1-1
|
|
- 3.7.1
|
|
|
|
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-1
|
|
- Enable tests again
|
|
|
|
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-0.1
|
|
- 3.7.0
|
|
- Once disable tests
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.0-1.1
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-1
|
|
- Enable tests again
|
|
|
|
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-0.1
|
|
- 3.6.0
|
|
- Once disable tests
|
|
|
|
* Tue Feb 21 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-3
|
|
- Always use full tar.gz for installed files and
|
|
keep using gem file for gem spec (ref: bug 1425220)
|
|
|
|
* Fri Feb 03 2017 Jun Aruga <jaruga@redhat.com> - 3.5.0-2
|
|
- Fix for Ruby 2.4.0 compatibility.
|
|
|
|
* Sun Jul 24 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-1
|
|
- Enable tests again
|
|
|
|
* Sat Jul 23 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-0.1
|
|
- 3.5.0
|
|
- Once disable tests
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.1-2.1
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.1-2
|
|
- Enable tests again
|
|
|
|
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.1-1
|
|
- 3.4.1
|
|
- Once disable tests
|
|
|
|
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.0-2
|
|
- Enable tests again
|
|
|
|
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.0-1
|
|
- 3.3.0
|
|
- Once disable tests
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-1.1
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Wed Feb 25 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.2-1
|
|
- 3.2.2
|
|
|
|
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.1-2
|
|
- Enable tests again
|
|
|
|
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.1-1
|
|
- 3.2.1
|
|
- Once disable tests
|
|
|
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-3
|
|
- Enable tests again
|
|
|
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-2
|
|
- Retry
|
|
|
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-1
|
|
- 3.1.2
|
|
- Once disable tests
|
|
|
|
* Fri Aug 15 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.4-1
|
|
- 3.0.4
|
|
|
|
* Thu Aug 14 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.3-1
|
|
- 3.0.3
|
|
|
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-0.4.beta2.1
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
|
|
* Tue Mar 18 2014 Mamoru TASAKA <mtasaka@tbz.t-com.ne.jp> - 3.0.0-0.4.beta1
|
|
- 3.0.0 beta 2
|
|
|
|
* Mon Feb 10 2014 Mamoru TASAKA <mtasaka@tbz.t-com.ne.jp> - 3.0.0-0.2.beta1
|
|
- Modify Provides EVR
|
|
|
|
* Mon Feb 03 2014 Mamoru TASAKA <mtasaka@tbz.t-com.ne.jp> - 3.0.0-0.1.beta1
|
|
- Initial package
|