import rubygem-rspec-support-3.10.2-1.el9.2
This commit is contained in:
commit
dca87fd0a5
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/rspec-support-3.10.2.gem
|
||||||
|
SOURCES/rubygem-rspec-support-3.10.2-full.tar.gz
|
2
.rubygem-rspec-support.metadata
Normal file
2
.rubygem-rspec-support.metadata
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
c783cdaebf6dd4c4d434d6be9dbd63f31f8339b7 SOURCES/rspec-support-3.10.2.gem
|
||||||
|
f421fba20fcc2cff677795aa98a7a49f23c67ac0 SOURCES/rubygem-rspec-support-3.10.2-full.tar.gz
|
27
SOURCES/rspec-related-create-full-tarball.sh
Normal file
27
SOURCES/rspec-related-create-full-tarball.sh
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
if [ $# -lt 2 ]
|
||||||
|
then
|
||||||
|
echo "$0 <name> <version>"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
set -x
|
||||||
|
set -e
|
||||||
|
|
||||||
|
CURRDIR=$(pwd)
|
||||||
|
|
||||||
|
TMPDIRPATH=$(mktemp -d /var/tmp/rspec-tar-XXXXXX)
|
||||||
|
pushd $TMPDIRPATH
|
||||||
|
|
||||||
|
git clone https://github.com/rspec/$1.git
|
||||||
|
pushd $1
|
||||||
|
git reset --hard v$2
|
||||||
|
popd
|
||||||
|
|
||||||
|
ln -sf $1 $1-$2
|
||||||
|
tar czf ${CURRDIR}/rubygem-$1-$2-full.tar.gz $1-$2/./
|
||||||
|
|
||||||
|
popd
|
||||||
|
|
||||||
|
rm -rf $TMPDIRPATH
|
@ -0,0 +1,11 @@
|
|||||||
|
--- rspec-support-3.2.1/spec/rspec/support/caller_filter_spec.rb.regex 2015-02-09 09:09:58.000000000 +0900
|
||||||
|
+++ rspec-support-3.2.1/spec/rspec/support/caller_filter_spec.rb 2015-02-09 09:19:58.589718748 +0900
|
||||||
|
@@ -15,7 +15,7 @@
|
||||||
|
describe "the filtering regex" do
|
||||||
|
def ruby_files_in_lib(lib)
|
||||||
|
# http://rubular.com/r/HYpUMftlG2
|
||||||
|
- path = $LOAD_PATH.find { |p| p.match(/\/rspec-#{lib}(-[a-f0-9]+)?\/lib/) }
|
||||||
|
+ path = $LOAD_PATH.find { |p| p.match(/\/rspec-#{lib}(-[a-f0-9\.]+)?\/lib/) }
|
||||||
|
|
||||||
|
Dir["#{path}/**/*.rb"].sort.tap do |files|
|
||||||
|
# Just a sanity check...
|
268
SPECS/rubygem-rspec-support.spec
Normal file
268
SPECS/rubygem-rspec-support.spec
Normal file
@ -0,0 +1,268 @@
|
|||||||
|
%global gem_name rspec-support
|
||||||
|
|
||||||
|
%global mainver 3.10.2
|
||||||
|
%undefine prever
|
||||||
|
|
||||||
|
%global mainrel 1
|
||||||
|
%global prerpmver %(echo "%{?prever}" | sed -e 's|\\.||g')
|
||||||
|
|
||||||
|
%global need_bootstrap_set 0
|
||||||
|
|
||||||
|
%undefine __brp_mangle_shebangs
|
||||||
|
|
||||||
|
Name: rubygem-%{gem_name}
|
||||||
|
Version: %{mainver}
|
||||||
|
Release: %{?prever:0.}%{mainrel}%{?prever:.%{prerpmver}}%{?dist}.2
|
||||||
|
|
||||||
|
Summary: Common functionality to Rspec series
|
||||||
|
License: MIT
|
||||||
|
URL: https://github.com/rspec/rspec-support
|
||||||
|
Source0: https://rubygems.org/gems/%{gem_name}-%{mainver}%{?prever}.gem
|
||||||
|
# %%{SOURCE2} %%{name} %%{version}
|
||||||
|
Source1: rubygem-%{gem_name}-%{version}-full.tar.gz
|
||||||
|
Source2: rspec-related-create-full-tarball.sh
|
||||||
|
# tweak regex for search path
|
||||||
|
Patch100: rubygem-rspec-support-3.2.1-callerfilter-searchpath-regex.patch
|
||||||
|
|
||||||
|
#BuildRequires: ruby(release)
|
||||||
|
BuildRequires: rubygems-devel
|
||||||
|
%if 0%{?need_bootstrap_set} < 1
|
||||||
|
BuildRequires: rubygem(rspec)
|
||||||
|
BuildRequires: rubygem(thread_order)
|
||||||
|
BuildRequires: rubygem(bigdecimal)
|
||||||
|
BuildRequires: git
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
`RSpec::Support` provides common functionality to `RSpec::Core`,
|
||||||
|
`RSpec::Expectations` and `RSpec::Mocks`. It is considered
|
||||||
|
suitable for internal use only at this time.
|
||||||
|
|
||||||
|
%package doc
|
||||||
|
Summary: Documentation for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
Documentation for %{name}
|
||||||
|
|
||||||
|
%global version_orig %{version}
|
||||||
|
%global version %{version_orig}%{?prever}
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -T -n %{gem_name}-%{version} -b 1
|
||||||
|
gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
|
||||||
|
|
||||||
|
%patch100 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
gem build %{gem_name}.gemspec
|
||||||
|
%gem_install
|
||||||
|
|
||||||
|
%install
|
||||||
|
mkdir -p %{buildroot}%{gem_dir}
|
||||||
|
cp -pa .%{gem_dir}/* \
|
||||||
|
%{buildroot}%{gem_dir}/
|
||||||
|
|
||||||
|
%if 0%{?need_bootstrap_set} < 1
|
||||||
|
%check
|
||||||
|
# UTF-8 is needed
|
||||||
|
LANG=C.UTF-8
|
||||||
|
|
||||||
|
# Test failure needs investigation...
|
||||||
|
FAILFILE=()
|
||||||
|
FAILTEST=()
|
||||||
|
%if 0
|
||||||
|
FAILFILE+=("spec/rspec/support/differ_spec.rb")
|
||||||
|
FAILTEST+=("copes with encoded strings")
|
||||||
|
%endif
|
||||||
|
|
||||||
|
for ((i = 0; i < ${#FAILFILE[@]}; i++)) {
|
||||||
|
sed -i \
|
||||||
|
-e "\@${FAILTEST[$i]}@s|do$|, :broken => true do|" \
|
||||||
|
${FAILFILE[$i]}
|
||||||
|
}
|
||||||
|
|
||||||
|
ruby -rrubygems -Ilib/ -S rspec spec/ || \
|
||||||
|
ruby -rrubygems -Ilib/ -S rspec --tag ~broken
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files
|
||||||
|
%dir %{gem_instdir}
|
||||||
|
%license %{gem_instdir}/LICENSE.md
|
||||||
|
%doc %{gem_instdir}/Changelog.md
|
||||||
|
%doc %{gem_instdir}/README.md
|
||||||
|
|
||||||
|
%{gem_libdir}
|
||||||
|
%exclude %{gem_cache}
|
||||||
|
%{gem_spec}
|
||||||
|
|
||||||
|
%files doc
|
||||||
|
%doc %{gem_docdir}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 3.10.2-1.2
|
||||||
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
|
Related: rhbz#1991688
|
||||||
|
|
||||||
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 3.10.2-1.1
|
||||||
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
* Mon Feb 1 2021 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.10.2-1
|
||||||
|
- 3.10.2
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.10.1-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 29 2020 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.10.1-1
|
||||||
|
- 3.10.1
|
||||||
|
|
||||||
|
* Fri Dec 11 2020 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.10.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Fri Dec 11 2020 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.10.0-0.1
|
||||||
|
- 3.10.0
|
||||||
|
- Once disable test for bootstrap
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.9.3-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun May 3 2020 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.9.3-1
|
||||||
|
- 3.9.3
|
||||||
|
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.9.2-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 30 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.9.2-1
|
||||||
|
- 3.9.2
|
||||||
|
|
||||||
|
* Mon Dec 30 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.9.1-1
|
||||||
|
- 3.9.1
|
||||||
|
|
||||||
|
* Tue Dec 10 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.9.0-2
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Tue Dec 10 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.9.0-0.1
|
||||||
|
- 3.9.0
|
||||||
|
- Once disable test for bootstrap
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.2-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 21 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.8.2-1
|
||||||
|
- 3.8.2
|
||||||
|
|
||||||
|
* Tue Feb 5 2019 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.8.0-2
|
||||||
|
- Backport upstream patch for ruby 2.6 changes
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.0-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 13 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.8.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Wed Dec 12 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.8.0-0.1
|
||||||
|
- 3.8.0
|
||||||
|
- Once disable test for bootstrap
|
||||||
|
|
||||||
|
* Sun Nov 18 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 3.7.1-1.2
|
||||||
|
- Use C.UTF-8 locale
|
||||||
|
See https://fedoraproject.org/wiki/Changes/Remove_glibc-langpacks-all_from_buildroot
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.1-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 9 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.1-1
|
||||||
|
- 3.7.1
|
||||||
|
|
||||||
|
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Mon Nov 13 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.7.0-0.1
|
||||||
|
- 3.7.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.0-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Sat May 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.6.0-0.1
|
||||||
|
- 3.6.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Tue Feb 21 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-3
|
||||||
|
- Always use full tar.gz for installed files and
|
||||||
|
keep using gem file for gem spec (ref: bug 1425220)
|
||||||
|
|
||||||
|
* Fri Feb 03 2017 Jun Aruga <jaruga@redhat.com> - 3.5.0-2
|
||||||
|
- Fix for Ruby 2.4.0 compatibility.
|
||||||
|
|
||||||
|
* Sun Jul 24 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-1
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Sat Jul 23 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.5.0-0.1
|
||||||
|
- 3.5.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.1-2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.1-2
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Tue Dec 8 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.4.1-1
|
||||||
|
- 3.4.1
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.0-2
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Sun Aug 2 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.3.0-1
|
||||||
|
- 3.3.0
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 25 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.2-1
|
||||||
|
- 3.2.2
|
||||||
|
|
||||||
|
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.1-2
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Mon Feb 9 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.2.1-1
|
||||||
|
- 3.2.1
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-3
|
||||||
|
- Enable tests again
|
||||||
|
|
||||||
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-2
|
||||||
|
- Retry
|
||||||
|
|
||||||
|
* Mon Nov 10 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.1.2-1
|
||||||
|
- 3.1.2
|
||||||
|
- Once disable tests
|
||||||
|
|
||||||
|
* Fri Aug 15 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.4-1
|
||||||
|
- 3.0.4
|
||||||
|
|
||||||
|
* Thu Aug 14 2014 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.3-1
|
||||||
|
- 3.0.3
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-0.4.beta2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Mar 18 2014 Mamoru TASAKA <mtasaka@tbz.t-com.ne.jp> - 3.0.0-0.4.beta1
|
||||||
|
- 3.0.0 beta 2
|
||||||
|
|
||||||
|
* Mon Feb 10 2014 Mamoru TASAKA <mtasaka@tbz.t-com.ne.jp> - 3.0.0-0.2.beta1
|
||||||
|
- Modify Provides EVR
|
||||||
|
|
||||||
|
* Mon Feb 03 2014 Mamoru TASAKA <mtasaka@tbz.t-com.ne.jp> - 3.0.0-0.1.beta1
|
||||||
|
- Initial package
|
Loading…
Reference in New Issue
Block a user